1.6 won't read a DVD; 1.5.1 worked fine

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
New User
Posts: 1
Joined: Sun Jan 22, 2023 6:45 am

1.6 won't read a DVD; 1.5.1 worked fine

Post by Gary42 »

Description of problem or question:

I am unable to read and convert a DVD using 1.6.0. 1.5.1 worked fine. I attempted to read a DVD that was successful previously, and it also failed. AFAIK, nothing has changed on my system other than updating to 1.6.0.
Is there a place I can download 1.5.1 to test that version again? (Unfortunately I didn't keep my 1.5.1 download.)

I am able to drag & drop the individual .VOB files into the input window and convert those one at a time.

Steps to reproduce the problem (If Applicable):

Select the DVD drive as input. Fails at this point with "No valid source or titles found."

HandBrake version (e.g., 1.0.0):


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Windows 10 Home

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

HandBrake 1.6.0 (2022122800)
OS: Microsoft Windows NT 10.0.19045.0
CPU: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Ram: 24482 MB, 
GPU Information:
  Radeon RX 580 Series - 31.0.12027.7000
  Intel(R) HD Graphics 3000 -
Screen: 1920x1200
Temp Dir: C:\Users\****\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake\
Data Dir: C:\Users\****\AppData\Roaming\HandBrake

[22:52:08] hb_init: starting libhb thread

 # Starting Scan ...

[22:52:08] CPU: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
[22:52:08]  - Intel microarchitecture Sandy Bridge
[22:52:08]  - logical processor count: 8
[22:52:08] Intel Quick Sync Video support: no
[22:52:08] hb_scan: path=D:\, title_index=0
src/libbluray/disc/disc.c:437: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:437: error opening file BDMV\BACKUP\index.bdmv
[22:52:08] bd: not a bd - trying as a stream/file instead
libdvdread: Could not open input:
libdvdread: Can't open D:\ for reading
libdvdnav: vm: failed to open/read the DVD
[22:52:08] dvd: not a dvd - trying as a stream/file instead
[22:52:08] hb_stream_open: open D:\ failed
[22:52:08] scan: unrecognized file type
[22:52:08] libhb: scan thread found 0 valid title(s)

 # Scan Finished ...
Posts: 13
Joined: Sat Feb 05, 2022 12:01 pm

Re: 1.6 won't read a DVD; 1.5.1 worked fine

Post by el-nebu »

HandBrake is no ripping tool. Try to rip your dvd with any kind of ripping tool and after that, you can use HandBrake for transcoding.
Veteran User
Posts: 4556
Joined: Tue Aug 27, 2013 6:39 am

Re: 1.6 won't read a DVD; 1.5.1 worked fine

Post by Woodstock »

As mentioned, handbrake has not included ripping stuff for a dozen years now, because it was part of a different project. It can USE ripping code if found, but it doesn't include it. Even when it's found, it doesn't always work or provide "perfect reads".

There are a number of tools that will do the ripping. I use MakeMKV, but others use AnyDVD.
Posts: 6
Joined: Sat Jul 16, 2022 9:34 am

Re: 1.6 won't read a DVD; 1.5.1 worked fine

Post by Legendarion »

This will probably solve your problem: viewtopic.php?t=42699
Post Reply