Subtitle, not able to record on clip

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
sorin88
Posts: 3
Joined: Tue Jan 25, 2022 1:13 am

Subtitle, not able to record on clip

Post by sorin88 »

Subtitle, not able to record on clip:




Hi folks, I am trying to record subtitle on a video clip, but there is no success at all and nothing is burned into clip. I have used other version of handBrake as well. I also have observed all the requirements for processing but no chance, I appreciate any help.

HandBrake version 1.0.7

I use windows 8.1:

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

HandBrake 1.0.7 (2017040900) - 64bit
OS: Microsoft Windows NT 6.3.9600.0 - 64bit
CPU: Intel(R) Pentium(R) CPU  J2900  @ 2.41GHz
Ram: 8074 MB, 
GPU Information:
  Intel(R) HD Graphics - 10.18.10.3355
Screen: 1920x1080
Temp Dir: C:\Users\User\AppData\Local\Temp\
Install Dir: F:\250-1-vista\Program Files\HandBrake-oldV\HandBrake
Data Dir: C:\Users\User\AppData\Roaming\HandBrake Team\HandBrake\1.0.7.0

-------------------------------------------


# Starting Encode ...

[20:20:50] hb_init: starting libhb thread
[20:20:51] 1 job(s) to process
[20:20:51] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 160,
        "DRC": 0.0,
        "Encoder": 65536,
        "Gain": 0.0,
        "Mixdown": 1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "File": "F:\\2000-3\\APPZ TEST\\047-subtitle problem now\\test by handbrake\

\with sub\\sample2.mp4",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 4,
        "Settings": {
          "mode": "7"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "240",
          "width": "320"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "2",
          "rate": "27000000/900000"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 1
    },
    "Title": 1,
    "Path": "F:\\2000-3\\APPZ TEST\\047-subtitle problem now\\test by handbrake

\\sample.avi"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": true,
      "Forced": false
    },
    "SubtitleList": [
      {
        "Burn": true,
        "Default": false,
        "Forced": false,
        "ID": 0,
        "Offset": 0,
        "Track": -1,
        "SRT": {
          "Codeset": "UTF-8",
          "Filename": "F:\\2000-3\\APPZ TEST\\047-subtitle problem now\\test by 

handbrake\\sample.srt",
          "Language": "eng"
        }
      }
    ]
  },
  "Video": {
    "Encoder": 65536,
    "Level": "4.0",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "fast",
    "Profile": "main",
    "Quality": 22.0,
    "OpenCL": false,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[20:20:51] CPU: Intel(R) Pentium(R) CPU  J2900  @ 2.41GHz
[20:20:51]  - Intel microarchitecture Silvermont
[20:20:51]  - logical processor count: 4
[20:20:51] Intel Quick Sync Video support: yes
[20:20:51]  - Intel Media SDK hardware: API 1.7 (minimum: 1.3)
[20:20:51]  - H.264 encoder: yes
[20:20:51]     - preferred implementation: hardware (any)
[20:20:51]     - capabilities (hardware):  standard feature set
[20:20:51]  - H.265 encoder: no
[20:20:51] hb_scan: path=F:\2000-3\APPZ TEST\047-subtitle problem now\test 

by handbrake\sample.avi, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:274: failed opening UDF image F:\2000-3\APPZ TEST

\047-subtitle problem now\test by handbrake\sample.avi
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[20:20:51] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[20:20:51] dvd: not a dvd - trying as a stream/file instead
Input #0, avi, from 'F:\2000-3\APPZ TEST\047-subtitle problem now\test by 

handbrake\sample.avi':
  Metadata:
    encoder         : VirtualDubMod 1.5.10.2 (build 2540/release)
  Duration: 00:00:07.07, start: 0.000000, bitrate: 979 kb/s
    Stream #0:0: Video: mpeg4 (Simple Profile) [DIVX / 0x58564944]
      yuv420p, 320x240
      24.92 fps, 24.88 tbn
    Stream #0:1: Audio: pcm_s16le [[1][0][0][0] / 0x0001]
      11025 Hz, 1 channels, s16, 176 kb/s
[20:20:51] scan: decoding previews for title 1
[20:20:51] scan: audio 0x1: pcm_s16le, rate=11025Hz, bitrate=176400 Unknown 

(pcm_s16le) (1.0 ch)
[20:20:51] scan: 10 previews, 320x240, 24.881 fps, autocrop = 0/0/0/0, aspect 

4:3, PAR 1:1
[20:20:51] libhb: scan thread found 1 valid title(s)
[20:20:51] Skipping subtitle scan.  No suitable subtitle tracks.
[20:20:51] starting job
[20:20:51] decomb filter thread started for segment 0
[20:20:51] decomb filter thread started for segment 1
[20:20:51] decomb filter thread started for segment 2
[20:20:51] decomb filter thread started for segment 3
[20:20:51] decomb check thread started for segment 0
[20:20:51] decomb check thread started for segment 1
[20:20:51] decomb check thread started for segment 2
[20:20:51] decomb check thread started for segment 3
[20:20:51] mask filter thread started for segment 0
[20:20:51] mask filter thread started for segment 1
[20:20:51] mask filter thread started for segment 2
[20:20:51] mask filter thread started for segment 3
[20:20:51] mask erode thread started for segment 0
[20:20:51] mask erode thread started for segment 1
[20:20:51] mask erode thread started for segment 2
[20:20:51] mask erode thread started for segment 3
[20:20:51] mask dilate thread started for segment 0
[20:20:51] mask dilate thread started for segment 1
[20:20:51] mask dilate thread started for segment 2
[20:20:51] mask dilate thread started for segment 3
[20:20:51] yadif thread started for segment 0
[20:20:51] yadif thread started for segment 1
[20:20:51] yadif thread started for segment 2
[20:20:51] yadif thread started for segment 3
[20:20:51] [ass] Shaper: FriBidi 0.19.7 (SIMPLE) HarfBuzz-ng 1.3.0 (COMPLEX)
[20:20:51] [ass] Using font provider directwrite
[20:20:51] work: sanitizing track 1 bitrate 160 to 64 Kbps
[20:20:51] work: track 1, dithering not supported by codec
[20:20:51] work: only 1 chapter, disabling chapter markers
[20:20:51] job configuration:
[20:20:51]  * source
[20:20:51]    + F:\2000-3\APPZ TEST\047-subtitle problem now\test by 

handbrake\sample.avi
[20:20:51]    + title 1, chapter(s) 1 to 1
[20:20:51]    + container: avi
[20:20:51]    + data rate: 979 kbps
[20:20:51]  * destination
[20:20:51]    + F:\2000-3\APPZ TEST\047-subtitle problem now\test by 

handbrake\with sub\sample2.mp4
[20:20:51]    + container: MPEG-4 (libavformat)
[20:20:51]  * video track
[20:20:51]    + decoder: mpeg4
[20:20:51]    + filters
[20:20:51]      + Comb Detect (mode=3:spatial-metric=2:motion-

thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-

height=16)
[20:20:51]      + Decomb (mode=39)
[20:20:51]      + Framerate Shaper (mode=2:rate=27000000/900000)
[20:20:51]        + frame rate: 24.881 fps -> peak rate limited to 30.000 fps
[20:20:51]      + Subtitle renderer ()
[20:20:51]      + Crop and Scale (width=320:height=240:crop-top=0:crop-

bottom=0:crop-left=0:crop-right=0)
[20:20:51]        + source: 320 * 240, crop (0/0/0/0): 320 * 240, scale: 320 * 240
[20:20:51]    + Output geometry
[20:20:51]      + storage dimensions: 320 x 240
[20:20:51]      + pixel aspect ratio: 1 : 1
[20:20:51]      + display dimensions: 320 x 240
[20:20:51]    + encoder: H.264 (libx264)
[20:20:51]      + preset:  fast
[20:20:51]      + profile: main
[20:20:51]      + level:   4.0
[20:20:51]      + quality: 22.00 (RF)
[20:20:51]  * subtitle track 1, English (track 0, id 0xff) Text [SRT] -> 

Render/Burn-in, offset: 0, charset: UTF-8
[20:20:51]  * audio track 1
[20:20:51]    + decoder: Unknown (pcm_s16le) (1.0 ch) (track 1, id 0x1)
[20:20:51]      + bitrate: 176 kbps, samplerate: 11025 Hz
[20:20:51]    + mixdown: Mono
[20:20:51]    + encoder: AAC (libavcodec)
[20:20:51]      + bitrate: 64 kbps, samplerate: 11025 Hz
[20:20:51] sync: expecting 175 video frames
[20:20:51] encx264: encoding at constant RF 22.000000
[20:20:51] encx264: unparsed options: level=4.0:rc-

lookahead=30:ref=2:8x8dct=0:weightp=1:subme=6:vbv-bufsize=25000:vbv-

maxrate=20000
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
x264 [info]: profile Main, level 4.0
[20:20:51] sync: first pts video is 0
[20:20:51] sync: "Chapter 1" (1) at frame 1 time 0
[20:20:51] sync: first pts audio 0x1 is 0
[20:20:51] sync: first pts subtitle 0xff is 0
[20:20:51] sync: subtitle 0xff duration <= 0, PTS 0
[20:20:51] reader: done. 1 scr changes
[20:20:52] work: average encoding speed for job is 0.000000 fps
[20:20:52] comb detect: heavy 1 | light 9 | uncombed 166 | total 176
[20:20:52] decomb: deinterlaced 1 | blended 9 | unfiltered 166 | total 176
[20:20:52] vfr: 176 frames output, 0 dropped and 0 duped for CFR/PFR
[20:20:52] vfr: lost time: 0 (0 frames)
[20:20:52] vfr: gained time: 0 (0 frames) (0 not accounted for)
[20:20:53] pcm_s16le-decoder done: 170 frames, 0 decoder errors
[20:20:53] mpeg4-decoder done: 176 frames, 0 decoder errors
[20:20:53] sync: got 176 frames, 175 expected
[20:20:53] sync: framerate min 24.882 fps, max 24.882 fps, avg 24.881 fps
x264 [info]: frame I:4     Avg QP:20.84  size: 10013
x264 [info]: frame P:167   Avg QP:23.48  size:  2240
x264 [info]: frame B:5     Avg QP:26.70  size:  1107
x264 [info]: consecutive B-frames: 95.5%  2.3%  0.0%  2.3%
x264 [info]: mb I  I16..4: 29.2%  0.0% 70.8%
x264 [info]: mb P  I16..4:  0.3%  0.0%  0.2%  P16..4: 66.8% 17.7% 10.2%  

0.0%  0.0%    skip: 4.9%
x264 [info]: mb B  I16..4:  2.7%  0.0%  0.0%  B16..8: 36.7%  9.7%  0.2%  

direct:32.3%  skip:18.4%  L0:45.9% L1:41.5% BI:12.6%
x264 [info]: coded y,uvDC,uvAC intra: 83.4% 99.5% 88.3% inter: 35.6% 79.4% 

38.1%
x264 [info]: i16 v,h,dc,p: 19% 32% 34% 15%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 28% 22% 16%  5%  7%  6%  6%  6%  

5%
x264 [info]: i8c dc,h,v,p: 46% 23% 23%  9%
x264 [info]: Weighted P-Frames: Y:0.0% UV:0.0%
x264 [info]: ref P L0: 86.3% 13.7%
x264 [info]: ref B L0: 86.5% 13.5%
x264 [info]: ref B L1: 97.4%  2.6%
x264 [info]: kb/s:474.53
[20:20:53] mux: track 0, 176 frames, 419474 bytes, 474.40 kbps, fifo 256
[20:20:53] mux: track 1, 77 frames, 51704 bytes, 58.47 kbps, fifo 128
[20:20:53] libhb: work result = 0

# Encode Completed ...


Woodstock
Veteran User
Posts: 4443
Joined: Tue Aug 27, 2013 6:39 am

Re: Subtitle, not able to record on clip

Post by Woodstock »

Turn off the subtitle scan, and just select the subtitle you want.

Code: Select all

[20:20:51] sync: "Chapter 1" (1) at frame 1 time 0
[20:20:51] sync: first pts audio 0x1 is 0
[20:20:51] sync: first pts subtitle 0xff is 0
[20:20:51] sync: subtitle 0xff duration <= 0, PTS 0
Verify that your subtitle file is UTF-8; if it isn't, it will cause errors during the read. As it is, the duration of the subtitle is less than zero, so it won't be displayed.
sorin88
Posts: 3
Joined: Tue Jan 25, 2022 1:13 am

Re: Subtitle, not able to record on clip

Post by sorin88 »

Thank you Woodstock, I turned off subtitle scan, it was UTF-8, but not a chance
sorin88
Posts: 3
Joined: Tue Jan 25, 2022 1:13 am

Re: Subtitle, not able to record on clip

Post by sorin88 »

Thank you very much Woodstock, for second time I tried was a great success
Post Reply