.NET Core Desktop Runtime - Please Read

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
User avatar
HandBrake
Moderator
Posts: 145
Joined: Fri Jul 25, 2008 10:40 pm

.NET Core Desktop Runtime - Please Read

Post by HandBrake »

Hi Everyone.

Just a quick note to say that HandBrake 1.5.1 uses

"Microsoft .NET 6 Desktop Runtime" x64 for Intel/AMD systems or arm64 if using an ARM device
Download: https://dotnet.microsoft.com/download/d ... .0/runtime

When downloading, please make sure to download the correct version. See the highlighted download link in the image below!
net6.png
net6.png (94.18 KiB) Viewed 8780 times


Update 1:

HandBrake 1.5.1 fixes an issue where the Windows UI required BOTH .NET 5 and 6.
HandBrake 1.5.1 ONLY requires .NET 6 Desktop Runtime.

Update 2:

If you are absolutely sure you have installed the *DESKTOP* framework version 6.0.x, check the "DOTNET_ROOT" environment variable and see what it's set to. We've had reports from a user that it was pinned to version 5, thus preventing HandBrake from starting. Type "Edit Env" into the start menu and you'll see the Windows options for managing environment variables.

Update 3:

In Command Prompt, you can use "dotnet --info" to find out what versions of .NET core are installed




Thanks
User avatar
HandBrake
Moderator
Posts: 145
Joined: Fri Jul 25, 2008 10:40 pm

Re: .NET Core Desktop Runtime - Please Read

Post by HandBrake »

Posted Removed -> No longer relevant.
Nickalf
Posts: 3
Joined: Mon Jan 10, 2022 2:24 am

Re: .NET Core Desktop Runtime - Please Read

Post by Nickalf »

I just updated and now it asks to install .NET which I did (v5 as well as v6) but it will not run and keeps asking me to install .NET
Please help, as I need to convert a file for tonight..

Thanks,
Nick...
Win 10 v20H2 on Dell Inspiron 5570
Nickalf
Posts: 3
Joined: Mon Jan 10, 2022 2:24 am

Re: .NET Core Desktop Runtime - Please Read

Post by Nickalf »

I don't see a way to Attach files - Do I paste the Activity Logs here ??

Don't want to do anything wrong,
Nick...
User avatar
s55
HandBrake Team
Posts: 10168
Joined: Sun Dec 24, 2006 1:05 pm

Re: .NET Core Desktop Runtime - Please Read

Post by s55 »

Pay close attention to what your downloading. See the highlighted screenshot above.

If it's asking you, it's because you've not installed the correct one.
User avatar
s55
HandBrake Team
Posts: 10168
Joined: Sun Dec 24, 2006 1:05 pm

Re: .NET Core Desktop Runtime - Please Read

Post by s55 »

HandBrake 1.5.1 has now been released without the dependency on .NET 5
Nickalf
Posts: 3
Joined: Mon Jan 10, 2022 2:24 am

Re: .NET Core Desktop Runtime - Please Read

Post by Nickalf »

Thanks for the comeback s55,
I did your first suggestion D/Led .NET v6.0.1 and, even after a re-boot, still got the same result.
D/Led the HB v1.5.1 version - same result.

Is my only option, at this point, to uninstall HB completely loosing all my configuration preferences ?

Nick...
User avatar
s55
HandBrake Team
Posts: 10168
Joined: Sun Dec 24, 2006 1:05 pm

Re: .NET Core Desktop Runtime - Please Read

Post by s55 »

Which one did you download?

I updated the screenshot above earlier to make it even clearer which one to download.
troubleshooter
Posts: 2
Joined: Tue Jan 11, 2022 9:33 pm

Re: .NET Core Desktop Runtime - Please Read

Post by troubleshooter »

I had the same problem (even with version 1.5.1) and this is what I did to fix it:
  1. Uninstalled Handbrake 1.5.0 and installed 1.5.1
  2. I had both the x86 and x64 versions of Microsoft Windows Desktop Runtime - 6.0.1 installed
  3. Uninstalled x86 version of Microsoft Windows Desktop Runtime - 6.0.1
  4. Opened the uninstaller for x64 version of Microsoft Windows Desktop Runtime - 6.0.1 but when asked to choose between Uninstall or Repair, chose Repair
  5. Launched Handbrake 1.5.1 successfully
Ben5478285
New User
Posts: 1
Joined: Tue Jan 18, 2022 2:07 am

Re: .NET Core Desktop Runtime - Please Read

Post by Ben5478285 »

troubleshooter wrote: Tue Jan 11, 2022 9:44 pm I had the same problem (even with version 1.5.1) and this is what I did to fix it:
  1. Uninstalled Handbrake 1.5.0 and installed 1.5.1
  2. I had both the x86 and x64 versions of Microsoft Windows Desktop Runtime - 6.0.1 installed
  3. Uninstalled x86 version of Microsoft Windows Desktop Runtime - 6.0.1
  4. Opened the uninstaller for x64 version of Microsoft Windows Desktop Runtime - 6.0.1 but when asked to choose between Uninstall or Repair, chose Repair
  5. Launched Handbrake 1.5.1 successfully
I'm having the same problem upgrading from c. 1.33 to 1.5.1. Even though I had the correct x64 version of Microsoft Windows Desktop Runtime - 6.0.1 installed (and that's the version the error message takes me to to download it), I was still getting the error starting up Handbrake.

My solution followed the same process as troubleshooter, except I also went and installed Microsoft Windows Desktop Runtime - 6.0.0. After I installed that, I was able to successfully launch Handbrake.
George
Posts: 6
Joined: Sat Jan 08, 2022 11:45 am

Re: .NET Core Desktop Runtime - Please Read

Post by George »

The explanation of troubleshooter works fine for me. Thank you!!!
RobvanWely
Posts: 2
Joined: Sat Jan 22, 2022 12:44 am

Re: .NET Core Desktop Runtime - Please Read

Post by RobvanWely »

I just installed Handbrake and dotnet-runtime-6.0.1-win-x64.exe .
When trying to launch Handbrake it keeps telling me I must install dotnet-runtime-6.0.1-win-x64
I followed the troubleshooter instructions, apart only in that I didn't have Handbrake 1.5.0 to start with.
When trying to launch Handbrake it keeps telling me I must install dotnet-runtime-6.0.1-win-x64
Feels like a carrousel...
rollin_eng
Veteran User
Posts: 4346
Joined: Wed May 04, 2011 11:06 pm

Re: .NET Core Desktop Runtime - Please Read

Post by rollin_eng »

RobvanWely wrote: Sat Jan 22, 2022 1:02 am I just installed Handbrake and dotnet-runtime-6.0.1-win-x64.exe .
When trying to launch Handbrake it keeps telling me I must install dotnet-runtime-6.0.1-win-x64
I followed the troubleshooter instructions, apart only in that I didn't have Handbrake 1.5.0 to start with.
When trying to launch Handbrake it keeps telling me I must install dotnet-runtime-6.0.1-win-x64
Feels like a carrousel...
Are you sure it’s the desktop runtime.
RobvanWely
Posts: 2
Joined: Sat Jan 22, 2022 12:44 am

Re: .NET Core Desktop Runtime - Please Read

Post by RobvanWely »

When Handbrake doesn't launch, it says I need the .NET Core Desktop Runtime and shows the link for downloading that...
Peter Pan
Posts: 1
Joined: Sat Jan 22, 2022 7:14 pm

Re: .NET Core Desktop Runtime - Please Read

Post by Peter Pan »

Hi,

I have the same problem. Why can't a Readme.txt be added with the link to the right Net Framework? Was the same problem with the .Net5.04 with the last version. It makes it very difficult for the user.

Peter
mduell
Veteran User
Posts: 7682
Joined: Sat Apr 21, 2007 8:54 pm

Re: .NET Core Desktop Runtime - Please Read

Post by mduell »

Dirkmaster
Posts: 2
Joined: Fri Jan 28, 2022 11:09 pm

Re: .NET Core Desktop Runtime - Please Read

Post by Dirkmaster »

I followed the above troubleshooting instructions, and it did NOT work. I still get the popup telling me I have to install .Net Runtime. I have installed, uninstalled and reinstalled the Runtime 3x. I didn't have an environment variable for .Net. I can create one if you think that will help. What is the verbage for the value of DotNet_Root?
rollin_eng
Veteran User
Posts: 4346
Joined: Wed May 04, 2011 11:06 pm

Re: .NET Core Desktop Runtime - Please Read

Post by rollin_eng »

Dirkmaster wrote: Fri Jan 28, 2022 11:14 pm I followed the above troubleshooting instructions, and it did NOT work. I still get the popup telling me I have to install .Net Runtime. I have installed, uninstalled and reinstalled the Runtime 3x. I didn't have an environment variable for .Net. I can create one if you think that will help. What is the verbage for the value of DotNet_Root?
Are you sure it’s the desktop runtime.
Dirkmaster
Posts: 2
Joined: Fri Jan 28, 2022 11:09 pm

Re: .NET Core Desktop Runtime - Please Read

Post by Dirkmaster »

Yes, I am. But a reboot seems to have cleared up the issue.
rollin_eng
Veteran User
Posts: 4346
Joined: Wed May 04, 2011 11:06 pm

Re: .NET Core Desktop Runtime - Please Read

Post by rollin_eng »

Dirkmaster wrote: Sat Jan 29, 2022 5:44 pm Yes, I am. But a reboot seems to have cleared up the issue.
Good to know.
hter
Posts: 3
Joined: Thu Feb 03, 2022 4:10 pm

Re: .NET Core Desktop Runtime - Please Read

Post by hter »

I have not been able to install version 1.5.1 even after attempting to update .net files (it was already up to date).
To edit environment variables is a step too much for me.
Though also requiring .net 6.0 runtime according to the description I have succesfully been able to install from the archives a working version of Handbrake 1.4.2!
rollin_eng
Veteran User
Posts: 4346
Joined: Wed May 04, 2011 11:06 pm

Re: .NET Core Desktop Runtime - Please Read

Post by rollin_eng »

hter wrote: Thu Feb 03, 2022 4:30 pm I have not been able to install version 1.5.1 even after attempting to update .net files (it was already up to date).
To edit environment variables is a step too much for me.
Though also requiring .net 6.0 runtime according to the description I have succesfully been able to install from the archives a working version of Handbrake 1.4.2!
Are you sure you installed the desktop runtime?
hter
Posts: 3
Joined: Thu Feb 03, 2022 4:10 pm

Re: .NET Core Desktop Runtime - Please Read

Post by hter »

rollin_eng wrote: Thu Feb 03, 2022 6:37 pm
hter wrote: Thu Feb 03, 2022 4:30 pm I have not been able to install version 1.5.1 even after attempting to update .net files (it was already up to date).
To edit environment variables is a step too much for me.
Though also requiring .net 6.0 runtime according to the description I have succesfully been able to install from the archives a working version of Handbrake 1.4.2!
Are you sure you installed the desktop runtime?
Yes I did
hter
Posts: 3
Joined: Thu Feb 03, 2022 4:10 pm

Re: .NET Core Desktop Runtime - Please Read

Post by hter »

hter wrote: Fri Feb 04, 2022 7:30 am
rollin_eng wrote: Thu Feb 03, 2022 6:37 pm
hter wrote: Thu Feb 03, 2022 4:30 pm I have not been able to install version 1.5.1 even after attempting to update .net files (it was already up to date).
To edit environment variables is a step too much for me.
Though also requiring .net 6.0 runtime according to the description I have succesfully been able to install from the archives a working version of Handbrake 1.4.2!
Are you sure you installed the desktop runtime?
Yes I did
I restarted my pc and reinstalled desktop runtime as well as handbrake 1.51 (thus removing 1.4.2). Now there is no problem to open handbrake and my problem is solved! Thanks for your attention.
depirro
New User
Posts: 1
Joined: Mon Feb 21, 2022 8:41 pm

Re: .NET Core Desktop Runtime - Please Read

Post by depirro »

I've installed 'HandBrake-1.5.1-x86_64-Win_GUI' and 'windowsdesktop-runtime-6.0.2-win-x64' as instructed but I'm still unable to open & use Handbrake. I'm currently using Windows 10 version. Can you help? Thanks!
Post Reply