How to stop having -x number added to output file name?

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
NickSteel
Posts: 6
Joined: Sat Jun 15, 2019 5:18 pm

How to stop having -x number added to output file name?

Post by NickSteel »

Description of problem or question:
How to stop having -x number added to output file name?




Steps to reproduce the problem (If Applicable):




HandBrake version (e.g., 1.0.0):
HandBrake 1.3.2 (2020050300)

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
OS: Microsoft Windows NT 10.0.18363.0

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

HandBrake 1.3.2 (2020050300)
OS: Microsoft Windows NT 10.0.18363.0
CPU: Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Ram: 16079 MB, 
GPU Information:
  Intel(R) HD Graphics 4000 - 10.18.10.5069
Screen: 1366x768
Temp Dir: C:\Users\X230\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\X230\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[08:14:34] base preset: DVDx
[08:14:34] hb_init: starting libhb thread
[08:14:34] Starting work at: Sat May 16 08:14:34 2020
[08:14:34] 1 job(s) to process
[08:14:34] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 160,
        "DRC": 0.0,
        "Encoder": "av_aac",
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      },
      {
        "Bitrate": 640,
        "DRC": 0.0,
        "Encoder": "ac3",
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      "copy:aac",
      "copy:ac3",
      "copy:dtshd",
      "copy:dts",
      "copy:eac3",
      "copy:flac",
      "copy:mp3",
      "copy:truehd"
    ],
    "FallbackEncoder": "ac3"
  },
  "Destination": {
    "ChapterList": [],
    "ChapterMarkers": false,
    "AlignAVStart": true,
    "File": "G:\\TV Series\\Star Trek Voyager\\0524 Warhead-1.mp4",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": "av_mp4"
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 4,
        "Settings": {
          "mode": "7"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 8,
        "Settings": {
          "cb-spatial": "2",
          "cb-temporal": "3",
          "cr-spatial": "2",
          "cr-temporal": "3",
          "y-spatial": "3",
          "y-temporal": "2"
        }
      },
      {
        "ID": 12,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "2",
          "height": "768",
          "width": "1360"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 32784,
    "Den": 32555
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 1
    },
    "Title": 1,
    "Path": "C:\\Users\\X230\\Desktop\\Work\\0524 Warhead.mp4"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": false,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": "x264",
    "Level": "3.1",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "ref=5:bframes=5",
    "Preset": "veryslow",
    "Profile": "high",
    "Quality": 21.0,
    "Tune": "film",
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[08:14:34] CPU: Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
[08:14:34]  - Intel microarchitecture Ivy Bridge
[08:14:34]  - logical processor count: 4
[08:14:34] Intel Quick Sync Video support: yes
[08:14:34]  - Intel Media SDK hardware: API 1.11 (minimum: 1.3)
[08:14:34]  - H.264 encoder: yes
[08:14:34]     - preferred implementation: hardware (any) via D3D11
[08:14:34]     - capabilities (hardware):  vsinfo opt1 opt2+extbrc+ib_adapt+nmpslice
[08:14:34]  - H.265 encoder: no
[08:14:34] hb_scan: path=C:\Users\X230\Desktop\Work\0524 Warhead.mp4, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image C:\Users\X230\Desktop\Work\0524 Warhead.mp4
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
src/libbluray/bluray.c:2585: nav_get_title_list(C:\Users\X230\Desktop\Work\0524 Warhead.mp4\) failed
[08:14:34] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[08:14:34] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'C:\Users\X230\Desktop\Work\0524 Warhead.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : VideoReDo (Lavf57.71.100)
  Duration: 00:45:24.57, start: 0.000000, bitrate: 14550 kb/s
    Chapter #0:0: start 0.000000, end 2724.564000
    Metadata:
      title           : Chapter 1
    Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1366x768 [SAR 1:1 DAR 683:384], 14407 kb/s, 30 fps, 30 tbr, 90k tbn, 60 tbc (default)
    Metadata:
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 129 kb/s (default)
    Metadata:
      handler_name    : SoundHandler
    Stream #0:2(eng): Data: bin_data (txet / 0x74657874)
    Metadata:
      handler_name    : SubtitleHandler
[08:14:34] scan: decoding previews for title 1
[08:14:34] scan: audio 0x1: aac, rate=44100Hz, bitrate=129320 Unknown (AAC LC) (2.0 ch) (129 kbps)
[08:14:34] scan: 10 previews, 1366x768, 30.000 fps, autocrop = 2/0/0/0, aspect 16:9, PAR 1:1
[08:14:34] scan: supported video decoders: avcodec qsv
[08:14:34] libhb: scan thread found 1 valid title(s)
[08:14:34] Starting Task: Encoding Pass
[08:14:34] job configuration:
[08:14:34]  * source
[08:14:34]    + C:\Users\X230\Desktop\Work\0524 Warhead.mp4
[08:14:34]    + title 1, chapter(s) 1 to 1
[08:14:34]    + container: mov,mp4,m4a,3gp,3g2,mj2
[08:14:34]    + data rate: 14550 kbps
[08:14:34]  * destination
[08:14:34]    + G:\TV Series\Star Trek Voyager\0524 Warhead-1.mp4
[08:14:34]    + container: MPEG-4 (libavformat)
[08:14:34]      + align initial A/V stream timestamps
[08:14:34]  * video track
[08:14:34]    + decoder: h264
[08:14:34]      + bitrate 14407 kbps
[08:14:34]    + filters
[08:14:34]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[08:14:34]      + Decomb (mode=39)
[08:14:34]      + Framerate Shaper (mode=1)
[08:14:34]        + frame rate: 30.000 fps -> constant 30.000 fps
[08:14:34]      + Denoise (hqdn3d) (y-spatial=3:cb-spatial=2:cr-spatial=2:y-temporal=2:cb-temporal=3:cr-temporal=3)
[08:14:34]      + Crop and Scale (width=1360:height=768:crop-top=2:crop-bottom=0:crop-left=0:crop-right=0)
[08:14:34]        + source: 1366 * 768, crop (2/0/0/0): 1366 * 766, scale: 1360 * 768
[08:14:34]    + Output geometry
[08:14:34]      + storage dimensions: 1360 x 768
[08:14:34]      + pixel aspect ratio: 32784 : 32555
[08:14:34]      + display dimensions: 1369 x 768
[08:14:34]    + encoder: H.264 (libx264)
[08:14:34]      + preset:  veryslow
[08:14:34]      + tune:    film
[08:14:34]      + options: ref=5:bframes=5
[08:14:34]      + profile: high
[08:14:34]      + level:   3.1
[08:14:34]      + quality: 21.00 (RF)
[08:14:34]      + color profile: 1-1-1
[08:14:34]  * audio track 1
[08:14:34]    + decoder: Unknown (AAC LC) (2.0 ch) (129 kbps) (track 1, id 0x1)
[08:14:34]      + bitrate: 129 kbps, samplerate: 44100 Hz
[08:14:34]    + mixdown: Stereo
[08:14:34]    + dither: none
[08:14:34]    + encoder: AAC (libavcodec)
[08:14:34]      + bitrate: 160 kbps, samplerate: 44100 Hz
[08:14:34]  * audio track 2
[08:14:34]    + decoder: Unknown (AAC LC) (2.0 ch) (129 kbps) (track 1, id 0x1)
[08:14:34]      + bitrate: 129 kbps, samplerate: 44100 Hz
[08:14:34]    + mixdown: Stereo
[08:14:34]    + dither: none
[08:14:34]    + encoder: AC3 (libavcodec)
[08:14:34]      + bitrate: 640 kbps, samplerate: 44100 Hz
[08:14:34] sync: expecting 81737 video frames
[08:14:34] encx264: min-keyint: 30, keyint: 300
[08:14:34] encx264: encoding at constant RF 21.000000
[08:14:34] apply_h264_level [warning]: frame size (1360x768, 4080 macroblocks) too high for level 3.1 (max. 3600 macroblocks)
[08:14:34] encx264: unparsed options: ref=4:bframes=5:level=3.1:b-adapt=2:direct=auto:deblock=-1,-1:analyse=all:me=umh:merange=24:subme=10:trellis=2:psy-rd=1,0.15:vbv-bufsize=17500:vbv-maxrate=17500:rc-lookahead=60
x264 [info]: using SAR=32784/32555
x264 [warning]: frame MB size (85x48) > level limit (3600)
x264 [warning]: MB rate (122400) > level limit (108000)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
x264 [info]: profile High, level 3.1, 4:2:0, 8-bit
[08:14:34] sync: first pts video is 0
[08:14:34] sync: "Chapter 1" (1) at frame 1 time 0
[08:14:34] sync: first pts audio 0x1 is 0
[08:14:34] sync: first pts audio 0x1 is 0
.

User avatar
s55
HandBrake Team
Posts: 9754
Joined: Sun Dec 24, 2006 1:05 pm

Re: How to stop having -x number added to output file name?

Post by s55 »

Tools -> Preferences -> Output Files -> File Format (Text box)

NickSteel
Posts: 6
Joined: Sat Jun 15, 2019 5:18 pm

Re: How to stop having -x number added to output file name?

Post by NickSteel »

Thanks!
Tools -> Preferences -> Output Files -> File Format ({source} )

Post Reply