Subtitles not transferring

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Videoman
New User
Posts: 1
Joined: Mon Apr 27, 2020 5:12 pm

Subtitles not transferring

Post by Videoman »

Description of problem or question:
I upgraded to Handbrake 1.3.1. I now find that subtitles are not transferring when processing either a dvd or a TS file. I have tried all the different settings in the Selection Behavior.
The subtitle function used to work fine in previous versions of Handbrake. In fact I did not have to do anything to the settings (in the Selection Behavior) befofe other than choose the subtitle track.
I wonder if anyone else has had this problem and how to fix it?

Thanks


Steps to reproduce the problem (If Applicable):




HandBrake version (e.g., 1.0.0):

1.3.1


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):


macOS 10.14.6 Mojave

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

[10:24:00] libhb: work result = 0
[10:24:00] macgui: PreviewCore work done
[10:25:14] macgui: QueueCore scanning specifically for title: 1
[10:25:14] CPU: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
[10:25:14]  - Intel microarchitecture Kaby Lake
[10:25:14]  - logical processor count: 8
[10:25:14] hb_scan: path=/Volumes/Film Library 02/FILMS 2/RED_DESERT_990816, title_index=1
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2585: nav_get_title_list(/Volumes/Film Library 02/FILMS 2/RED_DESERT_990816/) failed
[10:25:14] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Couldn't find device name.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: vm: dvd_read_name failed
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdread: Couldn't find device name.
[10:25:14] scan: DVD has 1 title(s)
[10:25:14] scan: scanning title 1
[10:25:14] scan: duration is 01:56:26 (6986033 ms)
[10:25:14] pgc_id: 1, pgn: 1: pgc: 0x7fe9c960b110
[10:25:14] scan: checking audio 1
[10:25:14] scan: id=0x80bd, lang=Unknown (AC3), 3cc=und ext=0
[10:25:14] scan: checking subtitle 1
[10:25:14] scan: id=0x20bd, lang=Unknown (4:3) [VOBSUB], 3cc=und ext=0
[10:25:14] scan: title 1 has 16 chapters
[10:25:14] scan: chap 1, 185533 ms
[10:25:14] scan: chap 2, 297467 ms
[10:25:14] scan: chap 3, 412734 ms
[10:25:14] scan: chap 4, 258000 ms
[10:25:14] scan: chap 5, 569633 ms
[10:25:14] scan: chap 6, 504367 ms
[10:25:14] scan: chap 7, 429767 ms
[10:25:14] scan: chap 8, 496600 ms
[10:25:14] scan: chap 9, 526633 ms
[10:25:14] scan: chap 10, 579000 ms
[10:25:14] scan: chap 11, 499500 ms
[10:25:14] scan: chap 12, 649367 ms
[10:25:14] scan: chap 13, 933333 ms
[10:25:14] scan: chap 14, 181233 ms
[10:25:14] scan: chap 15, 338233 ms
[10:25:14] scan: chap 16, 124633 ms
[10:25:14] scan: aspect = 4:3
[10:25:14] scan: decoding previews for title 1
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
[10:25:14] scan: title angle(s) 1
[10:25:14] scan: audio 0x80bd: ac3, rate=48000Hz, bitrate=192000 Unknown (AC3) (1.0 ch) (192 kbps)
[10:25:14] scan: 10 previews, 720x480, 23.976 fps, autocrop = 64/62/4/2, aspect 4:3, PAR 8:9
[10:25:14] libhb: scan thread found 1 valid title(s)
[10:25:14] macgui: QueueCore scan done
[10:25:14] Starting work at: Mon Apr 27 10:25:14 2020

[10:25:14] 1 job(s) to process
[10:25:14] macgui: QueueCore started encoding RED_DESERT.m4v
[10:25:14] macgui: QueueCore with preset Fast 1080p30
[10:25:14] Starting Task: Encoding Pass
[10:25:14] job configuration:
[10:25:14]  * source
[10:25:14]    + /Volumes/Film Library 02/FILMS 2/RED_DESERT_990816
[10:25:14]    + title 1, chapter(s) 1 to 16
[10:25:14]  * destination
[10:25:14]    + /Volumes/Berkeley Films Music/Film Rips/Film Rips 02/RED_DESERT.m4v
[10:25:14]    + container: MPEG-4 (libavformat)
[10:25:14]      + align initial A/V stream timestamps
[10:25:14]      + chapter markers
[10:25:14]  * video track
[10:25:14]    + decoder: mpeg2video
[10:25:14]      + bitrate 200 kbps
[10:25:14]    + filters
[10:25:14]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[10:25:14]      + Decomb (mode=39)
[10:25:14]      + Framerate Shaper (mode=2:rate=27000000/900000)
[10:25:14]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[10:25:14]      + Subtitle renderer ()
[10:25:14]      + Crop and Scale (width=714:height=354:crop-top=64:crop-bottom=62:crop-left=4:crop-right=2)
[10:25:14]        + source: 720 * 480, crop (64/62/4/2): 714 * 354, scale: 714 * 354
[10:25:14]    + Output geometry
[10:25:14]      + storage dimensions: 714 x 354
[10:25:14]      + pixel aspect ratio: 8 : 9
[10:25:14]      + display dimensions: 634 x 354
[10:25:14]    + encoder: H.264 (libx264)
[10:25:14]      + preset:  fast
[10:25:14]      + profile: main
[10:25:14]      + level:   4.0
[10:25:14]      + quality: 22.00 (RF)
[10:25:14]      + color profile: 6-1-6
[10:25:14]  * subtitle track 1, Unknown (4:3) [VOBSUB] (track 0, id 0x20bd, Picture) -> Render/Burn-in, Forced Only
[10:25:14]  * audio track 1
[10:25:14]    + decoder: Unknown (AC3) (1.0 ch) (192 kbps) (track 1, id 0x80bd)
[10:25:14]      + bitrate: 192 kbps, samplerate: 48000 Hz
[10:25:14]    + mixdown: Mono
[10:25:14]    + dither: triangular
[10:25:14]    + encoder: AAC (Apple AudioToolbox)
[10:25:14]      + bitrate: 160 kbps, samplerate: 48000 Hz
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Couldn't find device name.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: vm: dvd_read_name failed
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdread: Couldn't find device name.
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
[10:25:14] sync: expecting 167497 video frames
[10:25:14] encx264: min-keyint: 24, keyint: 240
[10:25:14] encx264: encoding at constant RF 22.000000
[10:25:14] encx264: unparsed options: level=4.0:ref=2:8x8dct=0:weightp=1:subme=6:vbv-bufsize=25000:vbv-maxrate=20000:rc-lookahead=30
x264 [info]: using SAR=8/9
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile Main, level 4.0, 4:2:0, 8-bit
[10:25:14] sync: first pts video is 0
[10:25:14] sync: first pts audio 0x80bd is 0
[10:25:14] sync: "Chapter 1" (1) at frame 2 time 3753
[10:25:14] 1.451444s: Video -> Film
[10:25:24] macgui: QueueCore encode canceled
[10:25:24] work: average encoding speed for job is 248.236954 fps
[10:25:24] comb detect: heavy 86 | light 1139 | uncombed 1291 | total 2516
[10:25:24] decomb: deinterlaced 86 | blended 1137 | unfiltered 1288 | total 2511
[10:25:24] vfr: 2507 frames output, 0 dropped and 0 duped for CFR/PFR
[10:25:24] vfr: lost time: 0 (0 frames)
[10:25:24] vfr: gained time: 0 (0 frames) (0 not accounted for)
[10:25:24] ac3-decoder done: 3338 frames, 0 decoder errors
[10:25:24] mpeg2video-decoder done: 2579 frames, 0 decoder errors
[10:25:24] sync: got 2528 frames, 167497 expected
[10:25:24] sync: framerate min 23.976 fps, max 29.970 fps, avg 24.045 fps
x264 [info]: frame I:22    Avg QP:16.23  size: 10241
x264 [info]: frame P:828   Avg QP:22.04  size:  3690
x264 [info]: frame B:1609  Avg QP:24.11  size:  1773
x264 [info]: consecutive B-frames: 12.2%  1.1%  1.6% 85.2%
x264 [info]: mb I  I16..4: 63.8%  0.0% 36.2%
x264 [info]: mb P  I16..4:  5.6%  0.0%  1.2%  P16..4: 44.8%  7.7%  5.9%  0.0%  0.0%    skip:34.7%
x264 [info]: mb B  I16..4:  8.5%  0.0%  0.1%  B16..8: 24.1%  4.1%  0.1%  direct:18.4%  skip:44.6%  L0:48.2% L1:41.5% BI:10.3%
x264 [info]: coded y,uvDC,uvAC intra: 36.1% 67.5% 23.9% inter: 9.0% 42.9% 1.0%
x264 [info]: i16 v,h,dc,p: 25% 36% 19% 20%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 21% 28% 25%  4%  5%  4%  5%  3%  5%
x264 [info]: i8c dc,h,v,p: 47% 34% 15%  3%
x264 [info]: Weighted P-Frames: Y:37.3% UV:31.8%
x264 [info]: ref P L0: 62.2% 37.8%
x264 [info]: ref B L0: 64.5% 35.5%
x264 [info]: ref B L1: 86.8% 13.2%
x264 [info]: kb/s:479.89
[10:25:24] mux: track 0, 2456 frames, 6124262 bytes, 465.96 kbps, fifo 4096
[10:25:24] mux: track 1, 4929 frames, 2153077 bytes, 163.82 kbps, fifo 8192
[10:25:24] Finished work at: Mon Apr 27 10:25:24 2020

[10:25:24] libhb: work result = 1
[10:25:25] macgui: Queue manually stopped
[10:25:24] macgui: QueueCore work canceled
[10:26:34] hb_init: starting libhb thread
[10:26:34] macgui: PreviewCore started encoding preview_temp.m4v
[10:26:34] macgui: PreviewCore with preset Apple 1080p30 Surround
[10:26:34] Starting work at: Mon Apr 27 10:26:34 2020

[10:26:34] 1 job(s) to process
[10:26:34] Starting Task: Encoding Pass
[10:26:34] job configuration:
[10:26:34]  * source
[10:26:34]    + /Volumes/Film Library 02/FILMS 2/RED_DESERT_990816
[10:26:34]    + title 1, start 00:00:0.00 stop 00:00:15.00
[10:26:34]  * destination
[10:26:34]    + /Users/rogergarcia/Library/Containers/fr.handbrake.HandBrake/Data/Library/Application Support/HandBrake//Previews/17449/preview_temp.m4v
[10:26:34]    + container: MPEG-4 (libavformat)
[10:26:34]      + chapter markers
[10:26:34]  * video track
[10:26:34]    + decoder: mpeg2video
[10:26:34]      + bitrate 200 kbps
[10:26:34]    + filters
[10:26:34]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[10:26:34]      + Decomb (mode=39)
[10:26:34]      + Framerate Shaper (mode=2:rate=27000000/900000)
[10:26:34]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[10:26:34]      + Subtitle renderer ()
[10:26:34]      + Crop and Scale (width=714:height=354:crop-top=64:crop-bottom=62:crop-left=4:crop-right=2)
[10:26:34]        + source: 720 * 480, crop (64/62/4/2): 714 * 354, scale: 714 * 354
[10:26:34]    + Output geometry
[10:26:34]      + storage dimensions: 714 x 354
[10:26:34]      + pixel aspect ratio: 8 : 9
[10:26:34]      + display dimensions: 634 x 354
[10:26:34]    + encoder: H.264 (libx264)
[10:26:34]      + preset:  medium
[10:26:34]      + profile: high
[10:26:34]      + level:   4.0
[10:26:34]      + quality: 22.00 (RF)
[10:26:34]      + color profile: 6-1-6
[10:26:34]  * subtitle track 1, Unknown (4:3) [VOBSUB] (track 0, id 0x20bd, Picture) -> Render/Burn-in, Forced Only
[10:26:34]  * audio track 1
[10:26:34]    + decoder: Unknown (AC3) (1.0 ch) (192 kbps) (track 1, id 0x80bd)
[10:26:34]      + bitrate: 192 kbps, samplerate: 48000 Hz
[10:26:34]    + mixdown: Mono
[10:26:34]    + dither: triangular
[10:26:34]    + encoder: AAC (Apple AudioToolbox)
[10:26:34]      + bitrate: 160 kbps, samplerate: 48000 Hz
[10:26:34]  * audio track 2
[10:26:34]    + decoder: Unknown (AC3) (1.0 ch) (192 kbps) (track 1, id 0x80bd)
[10:26:34]      + bitrate: 192 kbps, samplerate: 48000 Hz
[10:26:34]    + AC3 Passthru
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Couldn't find device name.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: vm: dvd_read_name failed
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdread: Couldn't find device name.
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
[10:26:34] sync: expecting 383 video frames
[10:26:34] encx264: min-keyint: 24, keyint: 240
[10:26:34] encx264: encoding at constant RF 22.000000
[10:26:34] encx264: unparsed options: level=4.0:vbv-bufsize=31250:vbv-maxrate=25000
x264 [info]: using SAR=8/9
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile High, level 4.0, 4:2:0, 8-bit
[10:26:34] sync: first pts audio 0x80bd is 0
[10:26:34] sync: first pts audio 0x80bd is 0
[10:26:34] sync: first pts video is 28461
[10:26:34] sync: "Chapter 5" (5) at frame 1 time 28461
[10:26:36] sync: reached audio 0x80bd pts 1350720, exiting early
[10:26:36] sync: reached audio 0x80bd pts 1350720, exiting early
[10:26:36] sync: reached video pts 1353534, exiting early
[10:26:37] work: average encoding speed for job is 0.000000 fps
[10:26:37] comb detect: heavy 0 | light 12 | uncombed 341 | total 353
[10:26:37] decomb: deinterlaced 0 | blended 12 | unfiltered 341 | total 353
[10:26:37] vfr: 353 frames output, 0 dropped and 0 duped for CFR/PFR
[10:26:37] vfr: lost time: 0 (0 frames)
[10:26:37] vfr: gained time: 0 (0 frames) (0 not accounted for)
[10:26:37] ac3-decoder done: 692 frames, 0 decoder errors
[10:26:37] ac3-decoder done: 692 frames, 0 decoder errors
[10:26:37] mpeg2video-decoder done: 530 frames, 0 decoder errors
[10:26:37] sync: got 353 frames, 383 expected
[10:26:37] sync: framerate min 23.976 fps, max 23.976 fps, avg 23.976 fps
x264 [info]: frame I:4     Avg QP:21.54  size: 19242
x264 [info]: frame P:94    Avg QP:23.31  size:  7560
x264 [info]: frame B:255   Avg QP:24.45  size:  3890
x264 [info]: consecutive B-frames:  3.4%  0.6%  0.8% 95.2%
x264 [info]: mb I  I16..4:  9.8% 74.6% 15.6%
x264 [info]: mb P  I16..4:  1.3%  6.9%  0.9%  P16..4: 55.2% 17.5% 11.8%  0.0%  0.0%    skip: 6.4%
x264 [info]: mb B  I16..4:  0.3%  1.1%  0.1%  B16..8: 61.0%  5.6%  0.8%  direct: 7.0%  skip:24.2%  L0:47.4% L1:49.4% BI: 3.2%
x264 [info]: 8x8 transform intra:75.8% inter:67.3%
x264 [info]: coded y,uvDC,uvAC intra: 78.4% 72.1% 20.6% inter: 36.3% 46.1% 0.1%
x264 [info]: i16 v,h,dc,p: 32% 33% 12% 22%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 17% 14% 33%  5%  5%  5%  7%  5%  9%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 40% 17% 16%  5%  4%  4%  5%  4%  5%
x264 [info]: i8c dc,h,v,p: 58% 24% 15%  2%
x264 [info]: Weighted P-Frames: Y:34.0% UV:16.0%
x264 [info]: ref P L0: 47.6% 13.9% 21.7% 13.1%  3.7%
x264 [info]: ref B L0: 75.7% 19.3%  4.9%
x264 [info]: ref B L1: 89.9% 10.1%
x264 [info]: kb/s:966.98
[10:26:37] mux: track 0, 353 frames, 1779424 bytes, 945.45 kbps, fifo 512
[10:26:37] mux: track 1, 706 frames, 302567 bytes, 160.76 kbps, fifo 1024
[10:26:37] mux: track 2, 469 frames, 360192 bytes, 191.38 kbps, fifo 512
[10:26:37] Finished work at: Mon Apr 27 10:26:37 2020

[10:26:37] libhb: work result = 0
[10:26:37] macgui: PreviewCore work done
[10:27:51] macgui: QueueCore scanning specifically for title: 1
[10:27:51] CPU: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
[10:27:51]  - Intel microarchitecture Kaby Lake
[10:27:51]  - logical processor count: 8
[10:27:51] hb_scan: path=/Volumes/Film Library 02/FILMS 2/RED_DESERT_990816, title_index=1
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
bluray.c:2585: nav_get_title_list(/Volumes/Film Library 02/FILMS 2/RED_DESERT_990816/) failed
[10:27:51] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Couldn't find device name.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: vm: dvd_read_name failed
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdread: Couldn't find device name.
[10:27:51] scan: DVD has 1 title(s)
[10:27:51] scan: scanning title 1
[10:27:51] scan: duration is 01:56:26 (6986033 ms)
[10:27:51] pgc_id: 1, pgn: 1: pgc: 0x7fe9c97028f0
[10:27:51] scan: checking audio 1
[10:27:51] scan: id=0x80bd, lang=Unknown (AC3), 3cc=und ext=0
[10:27:51] scan: checking subtitle 1
[10:27:51] scan: id=0x20bd, lang=Unknown (4:3) [VOBSUB], 3cc=und ext=0
[10:27:51] scan: title 1 has 16 chapters
[10:27:51] scan: chap 1, 185533 ms
[10:27:51] scan: chap 2, 297467 ms
[10:27:51] scan: chap 3, 412734 ms
[10:27:51] scan: chap 4, 258000 ms
[10:27:51] scan: chap 5, 569633 ms
[10:27:51] scan: chap 6, 504367 ms
[10:27:51] scan: chap 7, 429767 ms
[10:27:51] scan: chap 8, 496600 ms
[10:27:51] scan: chap 9, 526633 ms
[10:27:51] scan: chap 10, 579000 ms
[10:27:51] scan: chap 11, 499500 ms
[10:27:51] scan: chap 12, 649367 ms
[10:27:51] scan: chap 13, 933333 ms
[10:27:51] scan: chap 14, 181233 ms
[10:27:51] scan: chap 15, 338233 ms
[10:27:51] scan: chap 16, 124633 ms
[10:27:51] scan: aspect = 4:3
[10:27:51] scan: decoding previews for title 1
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
[10:27:51] scan: title angle(s) 1
[10:27:51] scan: audio 0x80bd: ac3, rate=48000Hz, bitrate=192000 Unknown (AC3) (1.0 ch) (192 kbps)
[10:27:51] scan: 10 previews, 720x480, 23.976 fps, autocrop = 64/62/4/2, aspect 4:3, PAR 8:9
[10:27:51] libhb: scan thread found 1 valid title(s)
[10:27:51] macgui: QueueCore scan done
[10:27:51] Starting work at: Mon Apr 27 10:27:51 2020

[10:27:51] macgui: QueueCore started encoding RED_DESERT.m4v
[10:27:51] macgui: QueueCore with preset Apple 1080p30 Surround
[10:27:51] 1 job(s) to process
[10:27:51] Starting Task: Encoding Pass
[10:27:51] job configuration:
[10:27:51]  * source
[10:27:51]    + /Volumes/Film Library 02/FILMS 2/RED_DESERT_990816
[10:27:51]    + title 1, chapter(s) 1 to 16
[10:27:51]  * destination
[10:27:51]    + /Volumes/Berkeley Films Music/Film Rips/Film Rips 02/RED_DESERT.m4v
[10:27:51]    + container: MPEG-4 (libavformat)
[10:27:51]      + chapter markers
[10:27:51]  * video track
[10:27:51]    + decoder: mpeg2video
[10:27:51]      + bitrate 200 kbps
[10:27:51]    + filters
[10:27:51]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[10:27:51]      + Decomb (mode=39)
[10:27:51]      + Framerate Shaper (mode=2:rate=27000000/900000)
[10:27:51]        + frame rate: 23.976 fps -> peak rate limited to 30.000 fps
[10:27:51]      + Subtitle renderer ()
[10:27:51]      + Crop and Scale (width=714:height=354:crop-top=64:crop-bottom=62:crop-left=4:crop-right=2)
[10:27:51]        + source: 720 * 480, crop (64/62/4/2): 714 * 354, scale: 714 * 354
[10:27:51]    + Output geometry
[10:27:51]      + storage dimensions: 714 x 354
[10:27:51]      + pixel aspect ratio: 8 : 9
[10:27:51]      + display dimensions: 634 x 354
[10:27:51]    + encoder: H.264 (libx264)
[10:27:51]      + preset:  medium
[10:27:51]      + profile: high
[10:27:51]      + level:   4.0
[10:27:51]      + quality: 22.00 (RF)
[10:27:51]      + color profile: 6-1-6
[10:27:51]  * subtitle track 1, Unknown (4:3) [VOBSUB] (track 0, id 0x20bd, Picture) -> Render/Burn-in, Forced Only
[10:27:51]  * audio track 1
[10:27:51]    + decoder: Unknown (AC3) (1.0 ch) (192 kbps) (track 1, id 0x80bd)
[10:27:51]      + bitrate: 192 kbps, samplerate: 48000 Hz
[10:27:51]    + mixdown: Mono
[10:27:51]    + dither: triangular
[10:27:51]    + encoder: AAC (Apple AudioToolbox)
[10:27:51]      + bitrate: 160 kbps, samplerate: 48000 Hz
[10:27:51]  * audio track 2
[10:27:51]    + decoder: Unknown (AC3) (1.0 ch) (192 kbps) (track 1, id 0x80bd)
[10:27:51]      + bitrate: 192 kbps, samplerate: 48000 Hz
[10:27:51]    + AC3 Passthru
libdvdnav: Using dvdnav version 6.0.1
libdvdread: Couldn't find device name.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: vm: dvd_read_name failed
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdread: Couldn't find device name.
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
[10:27:51] sync: expecting 167497 video frames
[10:27:51] encx264: min-keyint: 24, keyint: 240
[10:27:51] encx264: encoding at constant RF 22.000000
[10:27:51] encx264: unparsed options: level=4.0:vbv-bufsize=31250:vbv-maxrate=25000
x264 [info]: using SAR=8/9
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile High, level 4.0, 4:2:0, 8-bit
[10:27:52] sync: first pts audio 0x80bd is 0
[10:27:52] sync: first pts audio 0x80bd is 0
[10:27:52] sync: first pts video is 6006
[10:27:52] sync: "Chapter 1" (1) at frame 1 time 6006
[10:27:52] 1.451444s: Video -> Film
[10:28:12] sync: "Chapter 2" (2) at frame 4462 time 16719953
[10:28:55] sync: "Chapter 3" (3) at frame 11602 time 43520977
[10:29:58] sync: "Chapter 4" (4) at frame 21508 time 80705625
[10:30:41] sync: "Chapter 5" (5) at frame 27700 time 103948845
[10:32:26] sync: "Chapter 6" (6) at frame 41371 time 155266361
[10:33:56] sync: "Chapter 7" (7) at frame 53476 time 200705505
[10:35:10] sync: "Chapter 8" (8) at frame 63790 time 239421682
[10:36:30] sync: "Chapter 9" (9) at frame 75709 time 284162628
[10:37:57] sync: "Chapter 10" (10) at frame 88348 time 331606275
[10:39:46] sync: "Chapter 11" (11) at frame 102244 time 383768385
[10:41:16] sync: "Chapter 12" (12) at frame 114232 time 428768340
[10:43:27] sync: "Chapter 13" (13) at frame 129817 time 487270533
[10:46:12] sync: "Chapter 14" (14) at frame 152218 time 571354533
[10:46:39] 6502.395508s: Film -> Video
[10:46:39] 6502.579102s: Video -> Film
[10:46:44] sync: "Chapter 15" (15) at frame 156574 time 587679592
[10:47:33] sync: "Chapter 16" (16) at frame 164692 time 618152534
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
libdvdnav: Language 'en' not found, using 'eo' instead
libdvdnav: Menu Languages available: eo 
[10:47:55] reader: done. 1 scr changes
[10:47:55] work: average encoding speed for job is 139.239746 fps
[10:47:56] comb detect: heavy 1176 | light 24177 | uncombed 142370 | total 167723
[10:47:56] decomb: deinterlaced 1176 | blended 24177 | unfiltered 142370 | total 167723
[10:47:56] vfr: 167723 frames output, 0 dropped and 0 duped for CFR/PFR
[10:47:56] vfr: lost time: 0 (0 frames)
[10:47:56] vfr: gained time: 0 (0 frames) (0 not accounted for)
[10:47:56] ac3-decoder done: 218530 frames, 0 decoder errors
[10:47:56] ac3-decoder done: 218530 frames, 0 decoder errors
[10:47:56] mpeg2video-decoder done: 167725 frames, 0 decoder errors
[10:47:56] sync: got 167723 frames, 167497 expected
[10:47:56] sync: framerate min 23.976 fps, max 39.964 fps, avg 23.985 fps
x264 [info]: frame I:1217  Avg QP:20.09  size: 22905
x264 [info]: frame P:48675 Avg QP:23.02  size:  8037
x264 [info]: frame B:117831 Avg QP:24.88  size:  3011
x264 [info]: consecutive B-frames:  6.0%  0.5%  1.2% 92.3%
x264 [info]: mb I  I16..4: 10.9% 68.5% 20.5%
x264 [info]: mb P  I16..4:  2.0%  7.7%  1.7%  P16..4: 51.4% 16.7% 10.8%  0.0%  0.0%    skip: 9.8%
x264 [info]: mb B  I16..4:  0.5%  1.0%  0.2%  B16..8: 52.6%  5.5%  0.9%  direct: 4.9%  skip:34.4%  L0:45.3% L1:48.1% BI: 6.6%
x264 [info]: 8x8 transform intra:65.8% inter:70.7%
x264 [info]: coded y,uvDC,uvAC intra: 69.7% 74.6% 25.8% inter: 28.4% 38.1% 0.4%
x264 [info]: i16 v,h,dc,p: 26% 45% 10% 19%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 17% 20% 26%  5%  5%  5%  8%  5%  9%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 38% 21% 11%  4%  5%  4%  7%  4%  6%
x264 [info]: i8c dc,h,v,p: 52% 30% 14%  5%
x264 [info]: Weighted P-Frames: Y:19.3% UV:10.6%
x264 [info]: ref P L0: 47.6% 13.8% 24.4% 12.1%  2.1%
x264 [info]: ref B L0: 78.6% 17.1%  4.3%
x264 [info]: ref B L1: 91.5%  8.5%
x264 [info]: kb/s:885.28
[10:47:56] mux: track 0, 167723 frames, 773783077 bytes, 885.21 kbps, fifo 4096
[10:47:56] mux: track 1, 327798 frames, 143819299 bytes, 164.53 kbps, fifo 8192
[10:47:56] mux: track 2, 218530 frames, 167831040 bytes, 192.00 kbps, fifo 4096
[10:47:56] Finished work at: Mon Apr 27 10:47:56 2020

[10:47:56] libhb: work result = 0
[10:47:56] macgui: Queue Done, there are no more pending encodes
[10:47:56] macgui: QueueCore work done

Woodstock
Veteran User
Posts: 3760
Joined: Tue Aug 27, 2013 6:39 am

Re: Subtitles not transferring

Post by Woodstock »

Using actual ripping software would help in this situation (you would at least get the data transferred to your drive).

Code: Select all

[10:27:51]  * subtitle track 1, Unknown (4:3) [VOBSUB] (track 0, id 0x20bd, Picture) -> Render/Burn-in, Forced Only
Probably, there are no subtitles in that track that are flagged as forced, so you get no subtitles at all. VERY few DVDs and BDs use the forced flag on subtitles.

Using the Foreign Audio Scan might help here, because it will choose the TRACK that probably has the forced subtitles in it.
pbarker1701
Posts: 25
Joined: Sun May 17, 2020 7:59 am

Re: Subtitles not transferring

Post by pbarker1701 »

I've run into this problem when ripping 4K movies with a different software program. Sometimes it brings the subtitles over, sometimes it doesn't.
Once I've gotten my mkv file with MakeMKV, I will use one of various programs primarily designed for playback to let me select the subtitle file that actually works. Then I would which file to force either Handbrake or another program to use. Now if I can only get Handbrake to handle the video of 4K files properly, I'd be happy. Then I could justify the 4-6 day transcoding time.
Hervideo
Posts: 9
Joined: Wed Jun 27, 2007 4:59 pm

Re: Subtitles not transferring

Post by Hervideo »

Hi all,
Rather than starting a new thread, here is my somewhat similar issue:

Description of problem or question:
No subtitles even in the Preview, whatever subtitle track I choose, amongst:
  • Recherche audio étrangère (i.e. "Foreign Audio Scan" in English)
    0: Français (Wide Screen) [VOBSUB]
    1: Français (Letterbox) [VOBSUB]
    2: Français (Wide Screen) [VOBSUB]
    3: Français (Letterbox) [VOBSUB]
HandBrake version:
1.3.3

Operating system and version:
macOS 10.14.6 Mojave

HandBrake Activity Log ***required***
See https://www.dropbox.com/s/wdb3ze2h155hr ... 1.txt?dl=0

Thanks in advance for your help.
Woodstock
Veteran User
Posts: 3760
Joined: Tue Aug 27, 2013 6:39 am

Re: Subtitles not transferring

Post by Woodstock »

Hervideo, with no English track, Foreign audio scan found nothing to include as the first track, so it was dropped. You then have:
[09:07:46] * subtitle track 1, Francais (Wide Screen) [VOBSUB] (track 0, id 0x20bd, Picture) -> Render/Burn-in, Forced Only
Which will only burn in the non-existant flagged-as-FORCED subtitles.

Set the language to search for as FR, and FAS will probably choose no track, also, because the pairs of language tracks are the same, except for positioning.
Hervideo
Posts: 9
Joined: Wed Jun 27, 2007 4:59 pm

Re: Subtitles not transferring

Post by Hervideo »

Thanks Woodstock for your reply.
Woodstock wrote: Sun Jun 21, 2020 4:35 pmSet the language to search for as FR
Where can I set this?

For a better future understanding of mine, I might switch HB to its English version (which would not be an issue for me).
Can this be done internally, or should I download a non-translated version of HB?
Woodstock
Veteran User
Posts: 3760
Joined: Tue Aug 27, 2013 6:39 am

Re: Subtitles not transferring

Post by Woodstock »

In both the Audio and Subtitle tabs, you can set the "defaults" for language selection, and you can chose more than one language. The order of the languages in the "chosen" window determines what order they appear in the selections available on "tracks" part of the tab.

I believe for your usage you'd want French first, then English. Then the Foreign Audio Search will look at French subtitles as its preference.

I do not use FAS much myself, because I have too many sources that it won't work well for. I do test it every so often, when I'm doing a movie instead of a TV series.
Post Reply