Crashing when encoding with x265

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
StringSaber
Posts: 6
Joined: Thu Jul 11, 2019 5:10 am

Crashing when encoding with x265

Post by StringSaber » Thu Jul 11, 2019 5:16 am

Description of problem or question:
Handbrake crashes during encoding of .m2ts originating from blu ray .iso


Steps to reproduce the problem (If Applicable):
1. Load .m2ts file into handbrake
2. Select output to be .mp4 container
2. Encode with x265, variable frame rate, and fps = "Same as source"


HandBrake version (e.g., 1.0.0):
1.2.2


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Microsoft Windows NT 10.0.17763.0


HandBrake Activity Log ***required*** (see How-to get an activity log)

https://pastebin.com/VzYDnaLb

Woodstock
Veteran User
Posts: 3217
Joined: Tue Aug 27, 2013 6:39 am

Re: Crashing when encoding with x265

Post by Woodstock » Thu Jul 11, 2019 1:31 pm

Test it with the nightly build; there was an issue with x265 crashing in certain conditions that was resolved last moth.

StringSaber
Posts: 6
Joined: Thu Jul 11, 2019 5:10 am

Re: Crashing when encoding with x265

Post by StringSaber » Fri Jul 12, 2019 2:09 am

Thanks for the suggestion. The nightly build works for the .m2ts file!

However, the nightly build crashes when converting a .wmv file to .mp4 with x265.

Activity Log:
https://pastebin.com/SDUEAdLA

I'm new to these forums so let me know if I should make a separate post.

Woodstock
Veteran User
Posts: 3217
Joined: Tue Aug 27, 2013 6:39 am

Re: Crashing when encoding with x265

Post by Woodstock » Fri Jul 12, 2019 2:32 am

Since it has to do with x265, same topic is fine.

If you change the encoder to x264 (no other changes), do you still get the crash? Are there any errors reported in the Windows Event log about the encode?

We need to pin down whether it's the source (the WMV) or x265 itself.

StringSaber
Posts: 6
Joined: Thu Jul 11, 2019 5:10 am

Re: Crashing when encoding with x265

Post by StringSaber » Fri Jul 12, 2019 3:17 am

I still get the crash when I only change to x264

Handbrake activity log
https://pastebin.com/XXYYuMcL

Windows Event log
https://pastebin.com/5RyVkqgx

Woodstock
Veteran User
Posts: 3217
Joined: Tue Aug 27, 2013 6:39 am

Re: Crashing when encoding with x265

Post by Woodstock » Fri Jul 12, 2019 3:41 am

The only thing that stands out to me is the audio source...
[03:06:40] * audio track 1
[03:06:40] + decoder: Unknown (wmapro) (2.0 ch) (256 kbps) (track 1, id 0x0)
[03:06:40] + bitrate: 256 kbps, samplerate: 44100 Hz
I know it's not a solution, but... If you deselect the audio, does the encode finish?

StringSaber
Posts: 6
Joined: Thu Jul 11, 2019 5:10 am

Re: Crashing when encoding with x265

Post by StringSaber » Fri Jul 12, 2019 4:33 am

I deselected audio and handbrake nightly still crashes.
Activity log
https://pastebin.com/BhvtG7xd

StringSaber
Posts: 6
Joined: Thu Jul 11, 2019 5:10 am

Re: Crashing when encoding with x265

Post by StringSaber » Fri Jul 12, 2019 5:03 am

UPDATE

I tested again on nightly build with the .m2ts and encoding with x265 (same settings as original post except on nightly build).
Handbrake crashed. While troubleshooting, I used H.264 (Nvidia NVEnc) on the .m2ts and NOT the H.265 (x265) video codec. So the nightly build did not solve my original problem either. I apologize for the confusion.

Activity Log of .m2ts encoding with x265
https://pastebin.com/2vc61CBN

smitbret
New User
Posts: 1
Joined: Fri Aug 09, 2019 7:45 pm

Re: Crashing when encoding with x265

Post by smitbret » Fri Aug 09, 2019 8:13 pm

Having a similar problem myself. Handbrake would just fail when using NVENC encoding. I updated the nVIdia drivers and it completed succesfully with h264 (NVENC) but would crash with h265 (NVENC). I deleted all of the audio tracks except for a DTS audio track that I set to passthrough. Still failed.

Here is the log from the v1.2.2: https://pastebin.com/YstZdSFF

Installed the nightly build and the option for h265 (NVENC) doesn't even appear as choice in the <Video> tab in the nightly.

User avatar
s55
HandBrake Team
Posts: 9544
Joined: Sun Dec 24, 2006 1:05 pm

Re: Crashing when encoding with x265

Post by s55 » Fri Aug 09, 2019 8:21 pm

The log indicates it didn't crash, it simply failed the encode due to invalid settings.
The GTX 730 does not support H.265. We have an open ticket to hide the encoder option when it's not supported: https://github.com/HandBrake/HandBrake/issues/1666

Officially we only formally support 1050+, 1650+ and 2060+ cards although we don't restrict anything currently so your mileage may vary on older cards.

Note, with regards to the nightly, make sure the encoder is turned in in Preferences -> Video otherwise the h.264 encoder which may work, won't appear.

Post Reply