Is it possible to set default start time in a custom preset?

Discuss encoding for devices and presets.
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
ironsand
Posts: 2
Joined: Thu Jun 20, 2019 6:33 am

Is it possible to set default start time in a custom preset?

Post by ironsand » Thu Jun 20, 2019 8:11 am

Hi,

I have many recordings from TV and all videos start with unnecessary advertising that has same duration.
To delete the advertising part I need to change start time every time by manual.

Can I create a custom preset that set the specific start time?

I checked `presets.json` config file, but I could not find the option for it.

Code: Select all

          "AlignAVStart": true,
          "AudioCopyMask": [
            "copy:aac",
            "copy:ac3",
            "copy:dtshd",
            "copy:dts",
            "copy:mp3",
            "copy:truehd",
            "copy:flac",
            "copy:eac3"
          ],
          "AudioEncoderFallback": "ac3",
          "AudioLanguageList": [],
          "AudioList": [
            {
              "AudioBitrate": 128,
              "AudioCompressionLevel": 0.0,
              "AudioDitherMethod": null,
              "AudioEncoder": "av_aac",
              "AudioMixdown": "dpl2",
              "AudioNormalizeMixLevel": false,
              "AudioSamplerate": "48",
              "AudioTrackQualityEnable": false,
              "AudioTrackQuality": -1.0,
              "AudioTrackGainSlider": 0.0,
              "AudioTrackDRCSlider": 0.0
            }
          ],
          "AudioSecondaryEncoderMode": true,
          "AudioTrackSelectionBehavior": "first",
          "ChapterMarkers": true,
          "ChildrenArray": [],
          "Default": true,
          "FileFormat": "av_mp4",
          "Folder": false,
          "FolderOpen": false,
          "Mp4HttpOptimize": false,
          "Mp4iPodCompatible": false,
          "PictureAutoCrop": true,
          "PictureBottomCrop": 0,
          "PictureLeftCrop": 0,
          "PictureRightCrop": 0,
          "PictureTopCrop": 0,
          "PictureDARWidth": 704,
          "PictureDeblock": 4,
          "PictureDeinterlaceFilter": "off",
          "PictureCombDetectPreset": "default",
          "PictureCombDetectCustom": "",
          "PictureDeinterlacePreset": "",
          "PictureDeinterlaceCustom": "",
          "PictureDenoiseCustom": "",
          "PictureDenoiseFilter": "off",
          "PictureDenoisePreset": "light",
          "PictureDenoiseTune": "none",
          "PictureSharpenCustom": "",
          "PictureSharpenFilter": "off",
          "PictureSharpenPreset": "medium",
          "PictureSharpenTune": "none",
          "PictureDetelecine": "off",
          "PictureDetelecineCustom": "",
          "PictureItuPAR": false,
          "PictureKeepRatio": true,
          "PictureLooseCrop": false,
          "PictureModulus": 2,
          "PicturePAR": "auto",
          "PicturePARWidth": 1,
          "PicturePARHeight": 1,
          "PictureRotate": "0:0",
          "PictureWidth": 704,
          "PictureHeight": 396,
          "PictureForceHeight": 0,
          "PictureForceWidth": 0,
          "PresetDescription": null,
          "PresetName": "My Preset",
          "Type": 1,
          "UsesPictureFilters": false,
          "UsesPictureSettings": 1,
          "SubtitleAddCC": false,
          "SubtitleAddForeignAudioSearch": true,
          "SubtitleAddForeignAudioSubtitle": false,
          "SubtitleBurnBehavior": "foreign",
          "SubtitleBurnBDSub": false,
          "SubtitleBurnDVDSub": false,
          "SubtitleLanguageList": [],
          "SubtitleTrackSelectionBehavior": "none",
          "VideoAvgBitrate": 1200,
          "VideoColorMatrixCode": 0,
          "VideoEncoder": "x264",
          "VideoFramerate": "30",
          "VideoFramerateMode": "pfr",
          "VideoGrayScale": false,
          "VideoHWDecode": false,
          "VideoScaler": "swscale",
          "VideoPreset": "fast",
          "VideoTune": "",
          "VideoProfile": "main",
          "VideoLevel": "4.0",
          "VideoOptionExtra": "",
          "VideoQualityType": 1,
          "VideoQualitySlider": 22.0,
          "VideoQSVDecode": false,
          "VideoQSVAsyncDepth": 4,
          "VideoTwoPass": true,
          "VideoTurboTwoPass": true,
          "x264Option": "",
          "x264UseAdvancedOptions": false
        }
      ],
      "Folder": true,
      "PresetName": "Custom Presets",
      "PresetDescription": null,
      "Type": 1
    },

User avatar
s55
HandBrake Team
Posts: 9619
Joined: Sun Dec 24, 2006 1:05 pm

Re: Is it possible to set default start time in a custom preset?

Post by s55 » Thu Jun 20, 2019 6:16 pm

Nope. You could script the CLI but it's not something you can do with presets.

ironsand
Posts: 2
Joined: Thu Jun 20, 2019 6:33 am

Re: Is it possible to set default start time in a custom preset?

Post by ironsand » Thu Jun 20, 2019 11:15 pm

I see, thanks! I'll try with Handbrake CLI.

Post Reply