BUG : Batch encoding to H265 encodes to H264 instead

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Hanbrakeur
Posts: 60
Joined: Mon Jun 30, 2014 10:39 pm

BUG : Batch encoding to H265 encodes to H264 instead

Post by Hanbrakeur » Fri Mar 29, 2019 1:21 am

Description of problem or question:

Hello, when I select a folder of videos to encode to H265, they encode to H264 instead.


Steps to reproduce the problem :

- Open Source > Folder Batch Scan > Select a folder
- Add to queue > Add All
- Click on a custom H265 preset
- Start Encode

Steps to avoid the problem : Select the H265 custom Preset BEFORE adding files to queue

- Open Source > Folder Batch Scan > Select a folder
- Click on a custom H265 preset
- Add to queue > Add All
- Start Encode

HandBrake version (e.g., 1.0.0):

1.2.2 (2019022300)


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

Windows 7 64 bits SP1


HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

HandBrake 1.2.2 (2019022300)
OS: Microsoft Windows NT 6.1.7601 Service Pack 1
CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
Ram: 32728 MB, 
GPU Information:
  Radeon RX 580 Series - 24.20.13019.1008
Screen: 1920x1080
Temp Dir: D:\TEMP\
Install Dir: C:\Program Files\Handbrake
Data Dir: C:\Users\rio\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[02:08:34] hb_init: starting libhb thread
[02:08:34] 1 job(s) to process
[02:08:34] json job:
{
  "Audio": {
    "AudioList": [
      {
        "DRC": 0.0,
        "Encoder": "copy",
        "Gain": 0.0,
        "Mixdown": -1,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      "copy:aac",
      "copy:ac3",
      "copy:dtshd",
      "copy:dts",
      "copy:eac3",
      "copy:flac",
      "copy:mp3",
      "copy:truehd"
    ],
    "FallbackEncoder": "av_aac"
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "AlignAVStart": true,
    "File": "E:\\VIDEOS\\Gloryhole Swallow\\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": true
    },
    "Mux": "mp4"
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "1080",
          "width": "1920"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 1
    },
    "Title": 2,
    "Path": "E:\\VIDEOS\\_TELECHARGE\\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4"
  },
  "Subtitle": {
    "Search": {
      "Burn": true,
      "Default": false,
      "Enable": true,
      "Forced": true
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": "x265",
    "Level": "auto",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "fast",
    "Profile": "auto",
    "Quality": 22.0,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[02:08:34] CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
[02:08:34]  - Intel microarchitecture Ivy Bridge
[02:08:34]  - logical processor count: 8
[02:08:34] Intel Quick Sync Video support: no
[02:08:34] hb_scan: path=E:\VIDEOS\_TELECHARGE\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4, title_index=2
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image E:\VIDEOS\_TELECHARGE\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[02:08:34] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[02:08:34] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'E:\VIDEOS\_TELECHARGE\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4':
  Metadata:
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: mp42mp41isomiso2
    creation_time   : 2018-03-22T03:07:32.000000Z
  Duration: 00:58:34.05, start: 0.000000, bitrate: 10039 kb/s
    Stream #0:0(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 97 kb/s (default)
    Metadata:
      creation_time   : 2018-03-22T03:07:32.000000Z
      handler_name    : SoundHandler
    Stream #0:1(eng): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 9930 kb/s, 59.94 fps, 59.94 tbr, 60k tbn, 2000000000.00 tbc (default)
    Metadata:
      creation_time   : 2018-03-22T03:07:32.000000Z
      handler_name    : VideoHandler
[02:08:35] scan: decoding previews for title 2
[02:08:35] scan: audio 0x0: aac, rate=48000Hz, bitrate=97079 English (AAC LC) (2.0 ch)
[02:08:37] scan: 10 previews, 1920x1080, 59.940 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[02:08:37] scan: supported video decoders: avcodec qsv
[02:08:37] libhb: scan thread found 1 valid title(s)
[02:08:37] Skipping subtitle scan.  No suitable subtitle tracks.
[02:08:37] starting job
[02:08:37] Auto Passthru: allowed codecs are AAC, AC3, E-AC3, TrueHD, DTS, DTS-HD, MP3, FLAC
[02:08:37] Auto Passthru: fallback is AAC (avcodec)
[02:08:37] Auto Passthru: using AAC Passthru for track 1
[02:08:37] work: only 1 chapter, disabling chapter markers
[02:08:37] job configuration:
[02:08:37]  * source
[02:08:37]    + E:\VIDEOS\_TELECHARGE\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4
[02:08:37]    + title 2, chapter(s) 1 to 1
[02:08:37]    + container: mov,mp4,m4a,3gp,3g2,mj2
[02:08:37]    + data rate: 10039 kbps
[02:08:37]  * destination
[02:08:37]    + E:\VIDEOS\Gloryhole Swallow\Gloryhole Swallow  Renee 1st Visit (Mar 23, 2018).mp4
[02:08:37]    + container: MPEG-4 (libavformat)
[02:08:37]      + optimized for HTTP streaming (fast start)
[02:08:37]      + align initial A/V stream timestamps
[02:08:37]  * video track
[02:08:37]    + decoder: h264
[02:08:37]      + bitrate 9930 kbps
[02:08:37]    + filters
[02:08:37]      + Framerate Shaper (mode=1)
[02:08:37]        + frame rate: 59.940 fps -> constant 59.940 fps
[02:08:37]      + Crop and Scale (width=1920:height=1080:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[02:08:37]        + source: 1920 * 1080, crop (0/0/0/0): 1920 * 1080, scale: 1920 * 1080
[02:08:37]    + Output geometry
[02:08:37]      + storage dimensions: 1920 x 1080
[02:08:37]      + pixel aspect ratio: 1 : 1
[02:08:37]      + display dimensions: 1920 x 1080
[02:08:37]    + encoder: H.265 (libx265)
[02:08:37]      + preset:  fast
[02:08:37]      + profile: auto
[02:08:37]      + quality: 22.00 (RF)
[02:08:37]      + color profile: 1-1-1
[02:08:37]  * audio track 1
[02:08:37]    + decoder: English (AAC LC) (2.0 ch) (track 1, id 0x0)
[02:08:37]      + bitrate: 97 kbps, samplerate: 48000 Hz
[02:08:37]    + AAC Passthru
[02:08:37] sync: expecting 210632 video frames
x265 [info]: HEVC encoder version 2.9
x265 [info]: build info [Windows][GCC 8.2.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
x265 [info]: Main profile, Level-4.1 (Main tier)
x265 [info]: Thread pool created using 8 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 3 / wpp(17 rows)
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 60 / 600 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 15 / 4 / 0
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 1 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : CRF-22.0 / 0.60
x265 [info]: tools: rd=2 psy-rd=2.00 rskip signhide tmvp fast-intra
x265 [info]: tools: strong-intra-smoothing lslices=6 deblock sao
[02:08:37] sync: first pts video is 0
[02:08:37] sync: "Chapter 1" (1) at frame 1 time 0
[02:08:37] sync: first pts audio 0x0 is 1920

User avatar
Rodeo
HandBrake Team
Posts: 12141
Joined: Tue Mar 03, 2009 8:55 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by Rodeo » Fri Mar 29, 2019 6:09 am

Hanbrakeur wrote:
Fri Mar 29, 2019 1:21 am

Code: Select all

    "Encoder": "x265",

[…]

[02:08:37]    + encoder: H.265 (libx265)

[…]

x265 [info]: HEVC encoder version 2.9
x265 [info]: build info [Windows][GCC 8.2.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
x265 [info]: Main profile, Level-4.1 (Main tier)
x265 [info]: Thread pool created using 8 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 3 / wpp(17 rows)
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 60 / 600 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 15 / 4 / 0
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 1 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : CRF-22.0 / 0.60
x265 [info]: tools: rd=2 psy-rd=2.00 rskip signhide tmvp fast-intra
x265 [info]: tools: strong-intra-smoothing lslices=6 deblock sao

rollin_eng
Veteran User
Posts: 3129
Joined: Wed May 04, 2011 11:06 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by rollin_eng » Fri Mar 29, 2019 8:20 am

Hanbrakeur wrote:
Fri Mar 29, 2019 1:21 am


Steps to avoid the problem : Select the H265 custom Preset BEFORE adding files to queue
Your preset has to be selected before you add to queue.

Hanbrakeur
Posts: 60
Joined: Mon Jun 30, 2014 10:39 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by Hanbrakeur » Fri Mar 29, 2019 11:40 am

rollin_eng wrote:
Fri Mar 29, 2019 8:20 am
Hanbrakeur wrote:
Fri Mar 29, 2019 1:21 am


Steps to avoid the problem : Select the H265 custom Preset BEFORE adding files to queue
Your preset has to be selected before you add to queue.
Yes I know but it's a bug in my opinion. We sould be able to select the preset before or after. I lost literally 30 hours of encoding because I made that mistake.It took me a lot of time to find out why my videos were encoding to H264 even though H265 was selected. Hope the dev team fixes it, I'm sure a lot of people had the same problem but did not necessarily understand why it was doing that.

rollin_eng
Veteran User
Posts: 3129
Joined: Wed May 04, 2011 11:06 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by rollin_eng » Fri Mar 29, 2019 11:47 am

Items in the queue can have different settings thus the settings need to be applied before adding to the queue.

Hanbrakeur
Posts: 60
Joined: Mon Jun 30, 2014 10:39 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by Hanbrakeur » Fri Mar 29, 2019 11:51 am

Oh I understand, but maybe the dev team should put a warning like "Do you want to apply these settings to this file or the whole queue ?". Better be warned than waste hours of encoding.
Last edited by Hanbrakeur on Tue May 14, 2019 4:16 am, edited 1 time in total.

pitcher
Posts: 15
Joined: Sun May 12, 2019 11:41 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by pitcher » Tue May 14, 2019 3:54 am

Maybe I am confusing this but just want to be sure before I too waste my hours away.


In the old versions, as long as the preset was selected, then file is opened, the settings to be used are that of the already selected preset.

Are you saying the preset has to be selected *again* after the file has been opened to make sure?

Hanbrakeur
Posts: 60
Joined: Mon Jun 30, 2014 10:39 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by Hanbrakeur » Tue May 14, 2019 4:45 am

Hi Pitch,

Sorry if my explanations are confusing (english is not my first language) but for a safe batch encoding, the very first thing you must do after selecting the source folder is to select your preset (with single click). If you do this, you are guaranteed that all the files of your queue will be encoded with the selected preset.

The mistake I made was that I selected the Preset after clicking "Add to queue > Add all", which resulted in only the last file of the queue being encoded with the selected preset (and all the other ones with the default H264 preset).

Come back to me if you need more explanations.

pitcher
Posts: 15
Joined: Sun May 12, 2019 11:41 pm

Re: BUG : Batch encoding to H265 encodes to H264 instead

Post by pitcher » Tue May 14, 2019 2:39 pm

This makes sense and has always been the normal behavior for as long as I have been using it.

Post Reply