Sound delay on Android tablet

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
J Clement
Posts: 7
Joined: Thu Sep 23, 2010 6:13 pm

Sound delay on Android tablet

Post by J Clement » Sun Aug 26, 2018 9:51 pm

I created an MP4 with subtitles. It plays perfectly on my PC, but on my Commander/Freevi tablet there is a progressive delay in the sound.

The video was created from a large AVI with Lagarith/wave audio encoding. I always do complicated editing using lossless encoding. The AVI plays perfectly.

Handbrake 1.1.1 64bit

A copy of the video plays perfectly across the web from:
https://archive.org/details/LieutenantKizhe1934Restored
The cannon shots around 1:12:00 are obviously out of sync on my tablet. I tried 3 different players:
The default player, sView, TriDef Galler
sView played the best. Admittedly it is an old tablet, but other videos have played perfectly including HD 3D Side by Side MP4 rips.



Log: https://www.dropbox.com/s/8isqps6iam56d ... 6.txt?dl=0

Woodstock
Veteran User
Posts: 2759
Joined: Tue Aug 27, 2013 6:39 am

Re: Sound delay on Android tablet

Post by Woodstock » Mon Aug 27, 2018 12:47 am

First question, does encoded MP4 play with delayed audio on a PC or Mac? Isolating where the problem exists will help with fighting the problem.

One of my Android tablets (v3.something Android) always has unsynchronized audio on MKV files (MP4 plays fine), and it's worse with the higher the audio bitrate, the faster it becomes out of sync. The sync was fine on other devices.

Does it also go out of sync if you use, say, the AC3 encoder instead of AAC?

musicvid
Veteran User
Posts: 3121
Joined: Sat Jun 27, 2009 1:19 am

Re: Sound delay on Android tablet

Post by musicvid » Mon Aug 27, 2018 4:01 pm


The video was created from a large AVI with Lagarith/wave audio encoding. I always do complicated editing using lossless encoding. The AVI plays perfectly.
That's likely part of the problem, which has been reported with other AVI codecs as well.

Suggest you try XAVC-I, DNxHD, or ProRes for your digital intermediate rather than AVI.

I also understand Magic YUV is now supported in Handbrake, and may have fewer sync issues.

J Clement
Posts: 7
Joined: Thu Sep 23, 2010 6:13 pm

Re: Sound delay on Android tablet

Post by J Clement » Sun Sep 09, 2018 4:30 am

Thanks for the tips. But I had the same problem with Magix YUV, but on some players shorter delay. So I tried making a video with burned in subtitles and it worked perfectly. The problem is with the closed captioned subtitling. Even when the captions are not being displayed, there is a delay in the audio which is player dependent on an Android tablet, but not on my Win 10 PC.

musicvid
Veteran User
Posts: 3121
Joined: Sat Jun 27, 2009 1:19 am

Re: Sound delay on Android tablet

Post by musicvid » Sun Sep 09, 2018 8:35 pm

Related discussion on Vegas Pro forum
https://www.vegascreativesoftware.info/ ... /#ca687083

Post Reply