Error: invalid preset format

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
bjs.pdx
Posts: 2
Joined: Thu Aug 02, 2018 6:43 am

Error: invalid preset format

Post by bjs.pdx » Thu Aug 02, 2018 6:49 am

I just installed the current version on an Ubuntu 14.04 system and when I try to start it, handbrake starts and immediately stops. I see the following error in the log:

Code: Select all

[23:16:31] gtkgui: HandBrake 1.1.0 (2018041000) - Linux x86_64 - https://handbrake.fr
[23:16:31] Error: invalid preset format in presets_do()
[23:16:31] hb_init: starting libhb thread
[23:16:31] hb_init: starting libhb thread
[23:16:31] hb_init: starting libhb thread
[23:16:32] Plist parse error:  Start tag expected, '<' not found

[23:16:32] Error: invalid preset format in presets_do()
[23:16:32] Last error repeated 4 times
[23:16:32] Plist parse failed
[23:16:32] Error: invalid preset format in presets_do()

(ghb:16844): GLib-GIO-CRITICAL **: g_file_new_for_path: assertion 'path != NULL'
 failed

(ghb:16844): GLib-GIO-CRITICAL **: g_file_query_info: assertion 'G_IS_FILE (file
)' failed

(ghb:16844): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (o
bject)' failed

(ghb:16844): GLib-GIO-CRITICAL **: g_file_new_for_path: assertion 'path != NULL'

Any suggestions? I've tried removing and reinstalling. Have the same version running on 16.04 without issues.

mduell
Veteran User
Posts: 6106
Joined: Sat Apr 21, 2007 8:54 pm

Re: Error: invalid preset format

Post by mduell » Thu Aug 02, 2018 2:28 pm

Upgrade to the latest release, which may require updating your 4+ year old OS.

Woodstock
Veteran User
Posts: 2710
Joined: Tue Aug 27, 2013 6:39 am

Re: Error: invalid preset format

Post by Woodstock » Thu Aug 02, 2018 2:37 pm

What was your previous version? It may be that the presets from the old version are still being read in, and they're not in the current format.

bjs.pdx
Posts: 2
Joined: Thu Aug 02, 2018 6:43 am

Re: Error: invalid preset format

Post by bjs.pdx » Thu Aug 02, 2018 5:17 pm

I'm not ready to upgrade the OS at this point. I will eventually, but that doesn't really address the problem. I have since uninstalled handbrake using apt-get purge and then deleted the .config/ghb directory and reinstalled. Now I get the following error:

Code: Select all

(ghb:4347): Gtk-CRITICAL **: _gtk_cell_layout_buildable_add_child: assertion 'GTK_IS_CELL_RENDERER (child)' failed
Aborted (core dumped)
Handbrake never starts. Searching for the error didn't give me any results.

User avatar
BradleyS
Moderator
Posts: 1356
Joined: Thu Aug 09, 2007 12:16 pm

Re: Error: invalid preset format

Post by BradleyS » Sun Aug 12, 2018 4:35 am

Looks like your configuration data including presets may be corrupt. Instructions for clearing it are here: https://handbrake.fr/docs/en/1.1.0/help ... ssues.html

Post Reply