With upcoming changes to data protection and privacy laws in Europe coming into effect soon, we thought this would be a good time to remind everyone that we do have a privacy policy.
This applies to all users and visitors world-wide.

We have made a few changes to the language to make it clearer in relation to this new regulation but fundamentally, the terms and your rights are unchanged.

If you have any questions about this, please feel free to ask in the General Forum

Error after Finished Encoding

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
ekubo856
Posts: 2
Joined: Fri Jul 13, 2018 6:08 am

Error after Finished Encoding

Post by ekubo856 » Fri Jul 13, 2018 6:53 am

Description of problem or question:
I'm encoding a wmv with H264 codec to MP4 with H265 codec to save storage space. after it reach 100% it shows that there is an error in the encoding process but when i try to play the video it shows nothing wrong and i did skip the video to the end just to check and it play until the end
I have 3 WMV videos and all of them have the same problem



Steps to reproduce the problem (If Applicable):
I think it only happen with WMV files



HandBrake version (e.g., 1.1.0):
Version 1.1.0



Operating system and version (Windows 10 Creators Update):
Windows 10



HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

HandBrake 1.1.0 (2018040700) - 64bit
OS: Microsoft Windows NT 10.0.17134.0 - 64bit
CPU: Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz
Ram: 8102 MB, 
GPU Information:
  Intel(R) HD Graphics Family - 20.19.15.4531
Screen: 1920x1080
Temp Dir: C:\Users\Ekubo856\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\Ekubo856\AppData\Roaming\HandBrake Team\HandBrake\1.1.0.0

-------------------------------------------


# Starting Encode ...

[08:07:55] hb_init: starting libhb thread
[08:07:55] 1 job(s) to process
[08:07:55] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 160,
        "DRC": 0.0,
        "Encoder": 65536,
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 48000,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "AlignAVStart": false,
    "File": "C:\\Users\\Ekubo856\\Videos\\Handbrake\\VID-1.m4v",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "32",
          "crop-right": "16",
          "crop-top": "14",
          "height": "706",
          "width": "1232"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 1
    },
    "Title": 1,
    "Path": "D:\\New folder\\VID.wmv"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": false,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": 4096,
    "Level": "auto",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "medium",
    "Profile": "main",
    "Quality": 22.0,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[08:07:55] CPU: Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz
[08:07:55]  - Intel microarchitecture Haswell
[08:07:55]  - logical processor count: 4
[08:07:55] Intel Quick Sync Video support: yes
[08:07:55]  - Intel Media SDK hardware: API 1.19 (minimum: 1.3)
[08:07:55]  - H.264 encoder: yes
[08:07:55]     - preferred implementation: hardware (any) via D3D11
[08:07:55]     - capabilities (hardware):  breftype icq+la+i+downs vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[08:07:55]  - H.265 encoder: no
[08:07:55] hb_scan: path=D:\New folder\VID.wmv, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image D:\New folder\VID.wmv
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[08:07:55] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.3
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[08:07:55] dvd: not a dvd - trying as a stream/file instead
Input #0, asf, from 'D:\New folder\VID.wmv':
  Metadata:
    Title           : User
    Author          : User
    Copyright       : User
    creation_time   : 2015-05-13 01:34:17
  Duration: 01:57:19.17, start: 0.000000, bitrate: 5999 kb/s
    Stream #0:0: Audio: wmapro [b[1][0][0] / 0x0162]
      44100 Hz, stereo, fltp, 256 kb/s
    Metadata:
      IsVBR           : 0
      DeviceConformanceTemplate: M1
      WM/WMADRCPeakReference: 32767
      WM/WMADRCPeakTarget: 32767
      WM/WMADRCAverageReference: 2153
      WM/WMADRCAverageTarget: 2153
    Stream #0:1: Video: vc1 (Advanced) [WVC1 / 0x31435657]
      yuv420p, 1280x720
      29.97 fps, 1k tbn
    Metadata:
      IsVBR           : 0
      DeviceConformanceTemplate: AP@L2
[08:07:55] scan: decoding previews for title 1
[08:07:55] scan: audio 0x0: wmapro, rate=44100Hz, bitrate=256032 Unknown (wmapro) (2.0 ch)
av_read_frame error (-1052488119): Invalid data found when processing input
av_read_frame error (-1052488119): Invalid data found when processing input
[08:07:55] Warning: Could not read data for preview 10, skipped
[08:07:55] scan: 9 previews, 1280x720, 29.970 fps, autocrop = 14/0/32/16, aspect 16:9, PAR 1:1
[08:07:55] libhb: scan thread found 1 valid title(s)
[08:07:55] starting job
[08:07:55] work: track 1, dithering not supported by codec
[08:07:55] work: only 1 chapter, disabling chapter markers
[08:07:55] job configuration:
[08:07:55]  * source
[08:07:55]    + D:\New folder\VID.wmv
[08:07:55]    + title 1, chapter(s) 1 to 1
[08:07:55]    + container: asf
[08:07:55]    + data rate: 5999 kbps
[08:07:55]  * destination
[08:07:55]    + C:\Users\Ekubo856\Videos\Handbrake\VID-1.m4v
[08:07:55]    + container: MPEG-4 (libavformat)
[08:07:55]  * video track
[08:07:55]    + decoder: vc1
[08:07:55]    + filters
[08:07:55]      + Framerate Shaper (mode=1)
[08:07:55]        + frame rate: 29.970 fps -> constant 29.970 fps
[08:07:55]      + Crop and Scale (width=1232:height=706:crop-top=14:crop-bottom=0:crop-left=32:crop-right=16)
[08:07:55]        + source: 1280 * 720, crop (14/0/32/16): 1232 * 706, scale: 1232 * 706
[08:07:55]    + Output geometry
[08:07:55]      + storage dimensions: 1232 x 706
[08:07:55]      + pixel aspect ratio: 1 : 1
[08:07:55]      + display dimensions: 1232 x 706
[08:07:55]    + encoder: H.265 (libx265)
[08:07:55]      + preset:  medium
[08:07:55]      + profile: main
[08:07:55]      + quality: 22.00 (RF)
[08:07:55]  * audio track 1
[08:07:55]    + decoder: Unknown (wmapro) (2.0 ch) (track 1, id 0x0)
[08:07:55]      + bitrate: 256 kbps, samplerate: 44100 Hz
[08:07:55]    + mixdown: Stereo
[08:07:55]    + encoder: AAC (libavcodec)
[08:07:55]      + bitrate: 160 kbps, samplerate: 48000 Hz
[08:07:55] sync: expecting 210964 video frames
x265 [info]: HEVC encoder version 2.6
x265 [info]: build info [Windows][GCC 7.2.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x265 [info]: Main profile, Level-3.1 (Main tier)
x265 [info]: Thread pool created using 4 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 2 / wpp(12 rows)
x265 [warning]: Source height < 720p; disabling lookahead-slices
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 30 / 300 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 20 / 4 / 2
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 1 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : CRF-22.0 / 0.60
x265 [info]: tools: rd=3 psy-rd=2.00 rskip signhide tmvp strong-intra-smoothing
x265 [info]: tools: deblock sao
[08:07:55] sync: first pts video is 0
[08:07:55] sync: "Chapter 1" (1) at frame 1 time 0
[08:07:55] sync: first pts audio 0x0 is 0
[13:26:01] reader: done. 1 scr changes
[13:26:09] work: average encoding speed for job is 11.049600 fps
[13:26:09] vfr: 210964 frames output, 0 dropped and 0 duped for CFR/PFR
[13:26:09] vfr: lost time: 0 (0 frames)
[13:26:09] vfr: gained time: 0 (0 frames) (0 not accounted for)
[13:26:09] wmapro-decoder done: 151576 frames, 0 decoder errors
[13:26:09] vc1-decoder done: 210964 frames, 0 decoder errors
[13:26:09] sync: got 210964 frames, 210964 expected
[13:26:09] sync: framerate min 29.970 fps, max 30.303 fps, avg 29.970 fps
x265 [info]: frame I:    753, Avg QP:20.84  kb/s: 8326.17
x265 [info]: frame P:  50121, Avg QP:22.52  kb/s: 2734.91
x265 [info]: frame B: 160090, Avg QP:28.06  kb/s: 540.01
x265 [info]: Weighted P-Frames: Y:0.2% UV:0.1%
x265 [info]: consecutive B-frames: 1.0% 1.1% 4.8% 68.1% 24.9%
encoded 210964 frames in 19093.94s (11.05 fps), 1089.27 kb/s, Avg QP:26.72
[13:26:09] mux: track 0, 210964 frames, 959285673 bytes, 1090.21 kbps, fifo 8192
[13:26:09] mux: track 1, 329966 frames, 141085183 bytes, 160.34 kbps, fifo 8192
[13:26:09] libhb: work result = 5

# Encode Completed ...





User avatar
JohnAStebbins
HandBrake Team
Posts: 5125
Joined: Sat Feb 09, 2008 7:21 pm

Re: Error after Finished Encoding

Post by JohnAStebbins » Fri Jul 13, 2018 2:28 pm

Error 5 indicates a read error. Maybe the tail end of your file has some sort of problem.

ekubo856
Posts: 2
Joined: Fri Jul 13, 2018 6:08 am

Re: Error after Finished Encoding

Post by ekubo856 » Mon Jul 16, 2018 8:52 am

JohnAStebbins wrote:
Fri Jul 13, 2018 2:28 pm
Error 5 indicates a read error. Maybe the tail end of your file has some sort of problem.
You mean my file is corrupted??

Post Reply