Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Kurt Todoroff
Posts: 7
Joined: Sun Jan 30, 2011 1:09 am

Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by Kurt Todoroff » Tue Jun 12, 2018 3:33 pm

Handbrake 1.0.7 and libdcdcss 1.4.0 worked well transcoding my DVDs.

I updated Handbrake to 1.1.0. It scans DVDs, however, it does not recognize any content for transcoding. Handbrake 1.0.7 does recognize these same DVDs' content. As such, I continue to use this previous version instead of the most recent release.

1: Has anyone encountered this problem?

2: Does Handbrake 1.1.0 require libdvdcss, as did its predecessor?

iMac 17,1
Quad-Core i7 4GHz
8GB Memory
3TB SSD
macOS 10.13.5

Thank you.

Kurt

mduell
Veteran User
Posts: 6100
Joined: Sat Apr 21, 2007 8:54 pm

Re: Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by mduell » Tue Jun 12, 2018 3:38 pm

An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.

Best practice is to use an app intended for the purpose of ripping protected disks, HB plus third party hacks isn't great.

rollin_eng
Veteran User
Posts: 2848
Joined: Wed May 04, 2011 11:06 pm

Re: Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by rollin_eng » Tue Jun 12, 2018 3:51 pm

Libdvdcss is not supported thus results can be unpredictable.

Try ripping with makemkv first.

Kurt Todoroff
Posts: 7
Joined: Sun Jan 30, 2011 1:09 am

Re: Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by Kurt Todoroff » Fri Jun 15, 2018 10:37 am

Thank you for your responses.

I will continue using Handbrake 1.0.7.

Kurt

User avatar
Ritsuka
HandBrake Team
Posts: 988
Joined: Fri Jan 12, 2007 11:29 am

Re: Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by Ritsuka » Fri Jun 15, 2018 11:29 am

Try a newer version of Libdvdcss . You can install it from Homebrew for example.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5174
Joined: Sat Feb 09, 2008 7:21 pm

Re: Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by JohnAStebbins » Fri Jun 15, 2018 2:27 pm

libdvdcss isn't supported in 1.0.7 either. You just happened to get it working. It "works" in 1.1.0 as well. But we don't recommend it and don't provide assistance in setting it up.

Ronin
Posts: 23
Joined: Mon May 29, 2017 9:39 pm

Re: Handbrake 1.1.0 Issues And LIBDVDCSS Requirement

Post by Ronin » Wed Jun 20, 2018 7:57 pm

I'm not seeing any problem in 10.13.5 at all. I suggest that you remove Handbrake and everything associated with Handbrake, reboot then install a fresh copy of the latest version of everything and then it should work as expected.

Post Reply