With upcoming changes to data protection and privacy laws in Europe coming into effect soon, we thought this would be a good time to remind everyone that we do have a privacy policy.
This applies to all users and visitors world-wide.

We have made a few changes to the language to make it clearer in relation to this new regulation but fundamentally, the terms and your rights are unchanged.

If you have any questions about this, please feel free to ask in the General Forum

Segfault nearly every time during encode (Ubuntu 18.04)

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
hamakei
Posts: 5
Joined: Wed Jun 06, 2018 1:11 pm

Segfault nearly every time during encode (Ubuntu 18.04)

Post by hamakei » Wed Jun 06, 2018 8:48 pm

Description of problem or question:

Message to stderr: "Segmentation fault (core dumped)"

Handbrake now always crashes to desktop with a segmentation fault about 8 out of 10 times during encode. x264, x265...DVD or ISO...anything. Don't seem to be able to narrow it down. Sometimes when restarting the same encode after a crash it'll sail through with no problems.
Problem seems to be tied to recent upgrade to Ubuntu 18.04. This may just be a coincidence, though I encoded several files last week with no problems before the upgrade.

Steps to reproduce the problem:

Add an item. Start encoding. Crash happens at end of first pass
HandBrake version:

Tried:
Handbrake 1.0.4
Handbrake 1.1.0
20180605211348-2a2d334-master (x86_64)

All with same result.

Operating system and version:

Ubuntu 18.04 Kernel 4.15.0-22-generic from Wed May 16 12:15:17

HandBrake Activity Log

Activity Log up to point of crash: https://pastebin.com/TtC1Gkcf
Last edited by hamakei on Fri Jun 08, 2018 1:31 pm, edited 1 time in total.

mduell
Veteran User
Posts: 5943
Joined: Sat Apr 21, 2007 8:54 pm

Re: Segfault nearly every time during encode (Ubuntu 18.04)

Post by mduell » Wed Jun 06, 2018 9:35 pm

Did you get HB from the Ubuntu software center or the jstebbins PPA?

hamakei
Posts: 5
Joined: Wed Jun 06, 2018 1:11 pm

Re: Segfault nearly every time during encode (Ubuntu 18.04)

Post by hamakei » Wed Jun 06, 2018 11:06 pm

PPA

User avatar
BradleyS
Moderator
Posts: 1263
Joined: Thu Aug 09, 2007 12:16 pm

Re: Segfault nearly every time during encode (Ubuntu 18.04)

Post by BradleyS » Thu Jun 07, 2018 6:03 am

HandBrake does not work with copy protection. Please have a look at https://handbrake.fr/docs/en/latest/int ... about.html

hamakei
Posts: 5
Joined: Wed Jun 06, 2018 1:11 pm

Re: Segfault nearly every time during encode (Ubuntu 18.04)

Post by hamakei » Thu Jun 07, 2018 8:09 am

That's as maybe, but it's outside the scope of this problem. I'm also not sure why CSS is showing up in the Activity log, because if I pass the exact same ISO to "DVD Shrink", it reports that the disc is unencrypted. If I play the same ISO on a machine which doesn't have libdvdcss2 installed, it plays fine. Everything plays it like an unencrypted disc. Only Handbrake seems to think it is encrypted.

But if you notice, the key extraction always took a time of '0'

==

...I've just installed Handbrake on a completely fresh install of Ubuntu 18.04 on an independent laptop with a completely different CPU, GPU and hardware configuration....and it ALSO segfaults during encodes.

Is it something to do with the libraries Ubuntu 18.04 ships with?

The first couple of conversions worked fine...it wasn't until the one initialised at line 209 that it had problems...

https://pastebin.com/TV18tj7D

==

Aaanddd....I've installed Handbrake 1.1.0 on a Windows 7 64-bit machine and run it with the exact same settings on the same images...and it worked perfectly. This does suggest that either there is something wrong with the Ubuntu builds, or if there's something new with Ubuntu 18.04 which is causing it to have a fit...

==

I've just spent a couple of hours watching Handbrake (I don't recommend it as a way to pass the time) and the crash always seems to happen in between pass 1 and 2...pass 1 completes, the status bar changes to "Pass 2 0.0%" and then it segfaults.
Last edited by hamakei on Fri Jun 08, 2018 12:34 pm, edited 3 times in total.

hamakei
Posts: 5
Joined: Wed Jun 06, 2018 1:11 pm

Re: Segfault nearly every time during encode (Ubuntu 18.04)

Post by hamakei » Thu Jun 07, 2018 11:47 am

Hmm. There does seem to be a common pattern...

If I try and re-encode a DVD with a single main title, like a movie, 99% of the time it works fine.

But if I try and re-encode a DVD with multiple titles, like a TV show, it's almost always guaranteed to fail.
Last edited by hamakei on Tue Jun 12, 2018 10:40 am, edited 3 times in total.

hamakei
Posts: 5
Joined: Wed Jun 06, 2018 1:11 pm

Re: Segfault nearly every time during encode (Ubuntu 18.04)

Post by hamakei » Thu Jun 07, 2018 12:30 pm

[message removed]

Post Reply