Downsizing errors ?

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
karry299
Posts: 6
Joined: Fri Jun 06, 2014 1:56 pm

Downsizing errors ?

Post by karry299 »

I've been trying to convert 720p video to 480p, no filters enabled, and if i do a maximum, 4 minutes preview - it looks fine, but when i encode the whole video - it comes out looking extremely (and very uniformly) pixelized. No matter whether i use CRF or average bps. And what's more, within a 4-minute preview i dont detect anything wrong with the sound, but when i encode full video - i've tried many options, but it comes out with an immediately noticeable slight sound desync. How can that be ? Isnt the whole point of a preview to assess what will come out beforehand ? Why does it differ so much ?

TedJ
Veteran User
Posts: 5388
Joined: Wed Feb 20, 2008 11:25 pm

Re: Downsizing errors ?

Post by TedJ »

We have no idea, as you've failed to supply an activity log. Please see the big red box at the top of this, and nearly every other, page.

karry299
Posts: 6
Joined: Fri Jun 06, 2014 1:56 pm

Re: Downsizing errors ?

Post by karry299 »

Code: Select all

CLI Query:  -i "S:\29616.wmv" -t 1 --angle 1 -c 1 -o "S:\Video\29616.mp4"  -f mp4  --decomb -w 720 -l 400 --crop 0:0:0:0 --modulus 16 -e x264 -q 25 --cfr -a 1 -E mp3 -6 dpl2 -R Auto -B 32 -D 0 --gain 0 --audio-fallback ac3 --markers="C:\Users\****\AppData\Local\Temp\29616-1-chapters.csv" --encoder-preset=veryslow  --encoder-tune="film"  --encoder-level="5.1"  --encoder-profile=high  --verbose=1 -P  -U 

[13:35:13] hb_init: starting libhb thread
HandBrake svn6207 (2014053001) - MinGW x86_64 - http://handbrake.fr
4 CPUs detected
Opening S:\29616.wmv...
[13:35:13] CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
[13:35:13]  - Intel microarchitecture Ivy Bridge
[13:35:13]  - logical processor count: 4
[13:35:13] OpenCL device #1: Advanced Micro Devices, Inc. Pitcairn
[13:35:13]  - OpenCL version: 1.2 AMD-APP (1526.3)
[13:35:13]  - driver version: 1526.3 (VM)
[13:35:13]  - device type:    GPU
[13:35:13]  - supported:      YES
[13:35:13] Intel Quick Sync Video support: no
[13:35:13] hb_scan: path=S:\29616.wmv, title_index=1
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening S:\29616.wmv/BDMV/index.bdmv
libbluray/bdnav/index_parse.c:162: indx_parse(): error opening S:\29616.wmv/BDMV/BACKUP/index.bdmv
libbluray/bluray.c:2182: nav_get_title_list(S:\29616.wmv) failed
[13:35:13] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[13:35:13] dvd: not a dvd - trying as a stream/file instead
Input #0, asf, from 'S:\29616.wmv':
  Metadata:
    VBR Peak        : 200
    DeviceConformanceTemplate: MP@HL
    WMFSDKVersion   : 10.00.00.4005
    WMFSDKNeeded    : 0.0.0.0000
    IsVBR           : 1
    Buffer Average  : 370
  Duration: 01:13:03.95, start: 0.000000, bitrate: 1012 kb/s
    Stream #0.0: Audio: wmav2, 44100 Hz, 2 channels, fltp, 128 kb/s
    Stream #0.1: Video: wmv3 (Main), yuv420p, 1280x720, 856 kb/s, PAR 1:1 DAR 16:9, 29.97 fps, 1k tbn
[13:35:13] scan: decoding previews for title 1
[13:35:13] scan: audio 0x0: wmav2, rate=44100Hz, bitrate=128016 Unknown (wmav2) (2.0 ch)
[13:35:13] scan: 10 previews, 1280x720, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[13:35:13] libhb: scan thread found 1 valid title(s)
+ title 1:
  + stream: S:\29616.wmv
  + duration: 01:13:03
  + size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 29.970 fps
  + autocrop: 0/0/0/0
  + support opencl: yes
  + support hwd: yes
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 01:13:03
  + audio tracks:
    + 1, Unknown (wmav2) (2.0 ch) (iso639-2: und)
  + subtitle tracks:
Reading chapter markers from file C:\Users\****\AppData\Local\Temp\29616-1-chapters.csv
[13:35:13] 1 job(s) to process
[13:35:14] starting job
[13:35:14] yadif thread started for segment 0
[13:35:14] yadif thread started for segment 1
[13:35:14] yadif thread started for segment 3
[13:35:14] yadif thread started for segment 2
[13:35:14] decomb filter thread started for segment 0
[13:35:14] decomb filter thread started for segment 1
[13:35:14] decomb filter thread started for segment 2
[13:35:14] decomb filter thread started for segment 3
[13:35:14] decomb check thread started for segment 0
[13:35:14] decomb check thread started for segment 1
[13:35:14] decomb check thread started for segment 3
[13:35:14] decomb check thread started for segment 2
[13:35:14] mask filter thread started for segment 0
[13:35:14] mask filter thread started for segment 1
[13:35:14] mask filter thread started for segment 2
[13:35:14] mask filter thread started for segment 3
[13:35:14] mask erode thread started for segment 0
[13:35:14] mask erode thread started for segment 1
[13:35:14] mask erode thread started for segment 2
[13:35:14] mask erode thread started for segment 3
[13:35:14] mask dilate thread started for segment 0
[13:35:14] mask dilate thread started for segment 1
[13:35:14] mask dilate thread started for segment 2
[13:35:14] mask dilate thread started for segment 3
[13:35:14] work: sanitizing track 1 mixdown Dolby Pro Logic II to Stereo
[13:35:14] work: compression level not specified, track 1 setting compression level 2.00
[13:35:14] sync: expecting 131387 video frames
[13:35:14] work: only 1 chapter, disabling chapter markers
[13:35:14] job configuration:
[13:35:14]  * source
[13:35:14]    + S:\29616.wmv
[13:35:14]    + title 1, chapter(s) 1 to 1
[13:35:14]    + container: asf
[13:35:14]    + data rate: 1012 kbps
[13:35:14]  * destination
[13:35:14]    + S:\Video\29616 a.mp4
[13:35:14]    + container: MPEG-4 (libavformat)
[13:35:14]  * video track
[13:35:14]    + decoder: wmv3
[13:35:14]      + bitrate 856 kbps
[13:35:14]    + filters
[13:35:14]      + Decomb (default settings)
[13:35:14]      + Framerate Shaper (1:27000000:900900)
[13:35:14]        + frame rate: 29.970 fps -> constant 29.970 fps
[13:35:14]      + Crop and Scale (720:400:0:0:0:0)
[13:35:14]        + source: 1280 * 720, crop (0/0/0/0): 1280 * 720, scale: 720 * 400
[13:35:14]    + dimensions: 720 * 400, mod 16
[13:35:14]    + encoder: H.264 (libx264)
[13:35:14]      + preset:  veryslow
[13:35:14]      + tune:    film
[13:35:14]      + profile: high
[13:35:14]      + level:   5.1
[13:35:14]      + quality: 25.00 (RF)
[13:35:14]  * audio track 1
[13:35:14]    + decoder: Unknown (wmav2) (2.0 ch) (track 1, id 0x0)
[13:35:14]      + bitrate: 128 kbps, samplerate: 44100 Hz
[13:35:14]    + mixdown: Stereo
[13:35:14]    + encoder: MP3 (libmp3lame)
[13:35:14]      + bitrate: 32 kbps, samplerate: 44100 Hz
[13:35:14]      + compression level: 2.00
[13:35:14] reader: first SCR 0 id 0x1 DTS 0
[13:35:14] dxva2:CreateSurface succeed with 3, fmt (1280x720) surfaces (1280x720)
[13:35:14] dxva2:we got 2 decoder configurations
[13:35:14] dxva2:configuration[0] ConfigBitstreamRaw 1
[13:35:14] dxva2:configuration[1] ConfigBitstreamRaw 1
[13:35:14] dxva2:IDirectXVideoDecoderService_CreateVideoDecoder succeed
[13:35:14] dxva2:Using DXVA2 for hardware decoding
[13:35:14] dxva2:Available decoder output format 61 (AV_PIX_FMT_DXVA2_VLD)
[13:35:14] encx264: min-keyint: 30, keyint: 300
[13:35:14] encx264: encoding at constant RF 25.000000
[13:35:14] dxva2:Available decoder output format 61 (AV_PIX_FMT_DXVA2_VLD)
[13:35:14] encx264: unparsed options: level=5.1:ref=16:bframes=8:b-adapt=2:direct=auto:deblock=-1,-1:analyse=all:me=umh:merange=24:subme=10:trellis=2:psy-rd=1.00,0.15:vbv-bufsize=300000:vbv-maxrate=300000:rc-lookahead=60
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
x264 [info]: profile High, level 5.1
[13:35:14] enclame: opening libmp3lame
[13:35:14] sync: audio 0x0 time went backwards 68 ms, dropped 1 frames (start 27270, next 33436)
[13:35:14] sync: adding 256 ms of silence to audio 0x0  start 56520, next 33436
[13:35:14] Scaling With OpenCL
[13:35:14] Using Zero Copy
[14:50:44] reader: done. 1 scr changes
[14:50:45] work: average encoding speed for job is 28.957941 fps
[14:50:45] sync: got 131217 frames, 131387 expected
[14:50:45] decomb: deinterlaced 6 | blended 105 | unfiltered 131105 | total 131216
[14:50:45] render: 131216 frames output, 0 dropped and 0 duped for CFR/PFR
[14:50:45] render: lost time: 0 (0 frames)
[14:50:45] render: gained time: 0 (0 frames) (0 not accounted for)
[14:50:45] wmv3-decoder done: 131217 frames, 170 decoder errors, 0 drops
x264 [info]: frame I:577   Avg QP:23.74  size: 20135
x264 [info]: frame P:29797 Avg QP:27.84  size:  6105
x264 [info]: frame B:100842 Avg QP:32.44  size:  1515
x264 [info]: consecutive B-frames:  0.7%  0.6%  5.6% 48.1% 23.4% 19.5%  1.3%  0.3%  0.3%
x264 [info]: mb I  I16..4:  9.9% 63.4% 26.7%
x264 [info]: mb P  I16..4:  1.8%  7.0%  1.0%  P16..4: 42.9% 15.2%  9.4%  0.3%  0.0%    skip:22.2%
x264 [info]: mb B  I16..4:  0.1%  0.3%  0.0%  B16..8: 40.2%  5.9%  1.1%  direct: 1.5%  skip:50.8%  L0:43.6% L1:51.3% BI: 5.0%
x264 [info]: 8x8 transform intra:69.4% inter:59.7%
x264 [info]: direct mvs  spatial:100.0% temporal:0.0%
x264 [info]: coded y,uvDC,uvAC intra: 51.6% 46.4% 12.7% inter: 8.3% 3.8% 0.1%
x264 [info]: i16 v,h,dc,p: 33% 20% 14% 32%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu:  8%  8% 19%  7% 13% 11% 13%  9% 12%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 13%  8% 11%  8% 13% 11% 13% 10% 14%
x264 [info]: i8c dc,h,v,p: 45% 26% 18% 11%
x264 [info]: Weighted P-Frames: Y:1.0% UV:0.4%
x264 [info]: ref P L0: 51.0% 11.7% 15.8%  4.9%  3.9%  2.7%  2.3%  1.2%  1.1%  0.9%  0.9%  0.8%  0.7%  0.7%  0.7%  0.5%
x264 [info]: ref B L0: 82.8%  7.6%  3.3%  1.8%  1.2%  0.8%  0.6%  0.4%  0.3%  0.2%  0.2%  0.2%  0.2%  0.1%  0.1%
x264 [info]: ref B L1: 95.5%  4.5%
x264 [info]: kb/s:632.80
[14:50:45] wmav2-decoder done: 0 frames, 0 decoder errors, 0 drops
[14:50:45] mux: track 0, 131216 frames, 346294736 bytes, 631.93 kbps, fifo 16384
[14:50:45] mux: track 1, 167802 frames, 18915079 bytes, 34.52 kbps, fifo 16384
[14:50:45] libhb: work result = 0
Encode done!
HandBrake has exited.

User avatar
s55
HandBrake Team
Posts: 9709
Joined: Sun Dec 24, 2006 1:05 pm

Re: Downsizing errors ?

Post by s55 »

Try turning off DXVA

Post Reply