Apple TV AC3 Audio Out Of Sync

Discuss encoding for devices and presets.
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
nathug
Bright Spark User
Posts: 204
Joined: Fri Apr 11, 2008 10:21 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by nathug » Wed Apr 08, 2009 12:58 pm

fallapart13 wrote:As per my previous post, my Denon AVR-5800 receiver has no delay set to its optical timing and exhibits no issues with other my other devices (DirecTV HD DVR, Xbox 360, Playstation 3, Denon universal DVD player) all connected identically via HDMI (for video) directly to the tv and optical (for audio) connected to the receiver.

And none of my VisualHub encodes exhibit the sync issue with the AppleTV. I can see no possible way that my receiver is the cause of my woes.
I don't mean delay to optical timings you are talking about.

When you set up your surround system, to get correct delay settings for the Surround Speakers you either have to set individual delay times on each channel, or you use a tape measure and put in the distances from the listing position to each speaker. I would recommend reading your Denon manual on how to set this. If you have never done this, then you will for sure be hearing sync issues as the amp will think you are sitting the same distance from each speaker. Unless your room is built to DD specs, I very much doubt this is set correct.

Nate

fallapart13

Re: Apple TV AC3 Audio Out Of Sync

Post by fallapart13 » Wed Apr 08, 2009 5:02 pm

Nate - yes, the delay settings for each of the speakers is set identically for each input on my receiver. I used a tape measurer and a audio meter when I set up my surround system about 5 years ago. I just double-checked and no changes have been made to these settings. The center-channel (dialog) is where the sync issues are obviously most noticeable, but they occur across all speakers (I have a 7.1 system). As I have said before, VisualHub encoded videos do not exhibit this problem when being played back on this AppleTV system. And all other devices connected identically to my system do not have any sync issues. This is either an encoding problem or a firmware problem with AppleTV.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Wed Apr 08, 2009 6:13 pm

Okay, in further discussion on irc, it appears that just because your atv 2 setup is not connected to a dd 5.1 capable receiver does not mean the atv is sending the aac track. since your tv may be able to decode ac3 the atv may be sending the ac3 track.

In which case the same encode should show a delay on both of your setups if the problem lies in the encode itself.

Edit: upon further testing, it appears that if you are connected to the tv only via hdmi, the atv sends the aac track.
Last edited by dynaflash on Wed Apr 08, 2009 6:48 pm, edited 1 time in total.
Reason: original post disproved upon testing

belloq
Bright Spark User
Posts: 223
Joined: Sun Oct 12, 2008 5:09 am

Re: Apple TV AC3 Audio Out Of Sync

Post by belloq » Wed Apr 08, 2009 6:21 pm

How about swapping the aTV locations and see if the delay issues follow?

OCMike
Posts: 1
Joined: Wed Apr 08, 2009 7:15 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by OCMike » Wed Apr 08, 2009 7:29 pm

Hello,

I just registered so that I might add a bit more to the discussion (at least I hope so anyway.) I've noticed this as well on a recent encode with the latest version of Handbrake. The movie in question is "Scrooge" (I tried it first back in December and haven't had much time to play around with things lately.)

I recently tried re-encoding with both the ATV preset and the Universal (Apple) preset in Handbrake. Both times the audio is noticeably out of sync (for anyone who actually has the movie - see around the 6 min mark.) I can see this behavior on the AppleTV (like others) and also when viewing through iTunes on my computer (I haven't read of anyone looking at it from this perspective yet but it does remove the AV components from the equation.) The interesting thing is when I view the movie via the VLC Media player on my computer everything is in sync.

I'm wondering if this points to some kind of codec incompatability between the H.264 codec used in Handbrake (and possibly VLC Media player) and the iTunes/AppleTV H.264 codec.

Thanks for the great product and all the hard work you guys put in on this!

Mike

Hansel
Posts: 10
Joined: Thu Mar 05, 2009 10:07 am

Re: Apple TV AC3 Audio Out Of Sync

Post by Hansel » Thu Apr 09, 2009 7:24 am

Here are my findings:

Setup: Apple TV (2.3.1) connected with DVI to the TV and optical to the reciever.
Example of DVD's that causes out of sync: Boilerroom and Seinfeld (The problem occurs on all my Seinfeld DVD's - PAL version)

Test #1: Encoding Boilerroom and Seinfeld S3D1 - Episode 2 using latest SVN causes AC3-out of sync on both DVD's.
Test #2: Encoding Boilerroom and Seinfeld S3D1 - Episode 2 using ver. 0.92 (2008021900), the AC3 is in sync all the time.

I also own a PS3, and if I watch the files from test#1 using PS3 mediaserver (trascoding on the fly to mpeg2) the files
will play perfectly with no AC3-out of sync issues. So it doesn't seem like there's anything wrong with the HB-files from the latest SVN, it seems more like
some kind of compatibilty issue with the files from the latest SVN and the Apple TV (when using optical out)?

fallapart13

Re: Apple TV AC3 Audio Out Of Sync

Post by fallapart13 » Thu Apr 09, 2009 3:35 pm

dynaflash wrote:Edit: upon further testing, it appears that if you are connected to the tv only via hdmi, the atv sends the aac track.
DynaFlash, HDMI is able to carry 5.1 audio depending on the revision of HDMI on each end of the connection and the cable connecting the two. Older versions were only able to carry a stereo signal as you have suggested.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Thu Apr 09, 2009 7:33 pm

fallapart13 wrote:
dynaflash wrote:Edit: upon further testing, it appears that if you are connected to the tv only via hdmi, the atv sends the aac track.
DynaFlash, HDMI is able to carry 5.1 audio depending on the revision of HDMI on each end of the connection and the cable connecting the two. Older versions were only able to carry a stereo signal as you have suggested.
I understand that. however, the atv has to sense a sound device capable of *using* the 5.1 track (not just the right cable and connectors).

To test this, make a short one chapter hb encode and use a different language for the aac track than the ac3 track. Whichever one you hear is the track the atv is sending. our test showed that hdmi to a stereo capable tv only causes the atv to send the aac track. (in this case, we did the aac with the commentary source and the ac3 with the normal soundtrack). This is the only definitive way to determine which track the atv is sending in your particular setup.

Modular1
Posts: 7
Joined: Sat Dec 20, 2008 4:34 am

Re: Apple TV AC3 Audio Out Of Sync

Post by Modular1 » Sat Apr 11, 2009 12:11 pm

all my findings point to dolby digital over the optical output of the apple tv being the problem. if i turn off dolby digital, the apple tv outputs the aac track over the optical to my receiver and the sound is in sync. the sound is always in sync via hdmi to my tv no matter how i set the DD.

dolby digital 5.1 over the optical out of the apple tv is out of sync. everyone should bug report to apple and turn dolby digital off for the time being if it bothers you that much (which it does to me).

JVHB
Posts: 30
Joined: Thu Jan 08, 2009 6:03 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by JVHB » Tue Apr 14, 2009 3:49 pm

My Findings are as follows

ATV 2.3.1 Handbrake 0.93
HDMI for Video
Optical for audio - DD compatible receiver with no audio sync problems using XBOX 360, PS3, etc etc
Everything is sync'd via a wired network

Problem encodes are any that required de-interlacing or de-telecining - Mainly music videos from Ministry of Sound, Nirvana Unplugged, KISS Symphony, KISS unplugged

Re-tested using Component connections instead of HDMI - Out of sync
Re-encode same DVDs without DD passthru, AAC only - No sync problems
Changed order of Audio tracks to DD then AAC, and AAC then DD - Out of sync
Returned my ATV and exchanged for a new one - Still out of sync

Note : All encodes are in sync when using VLC. The out of synchronicity varies on ATV

lone_tree
Posts: 75
Joined: Mon May 05, 2008 10:23 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by lone_tree » Tue Apr 14, 2009 5:21 pm

JVHB wrote:My Findings are as follows

ATV 2.3.1 Handbrake 0.93
HDMI for Video
Optical for audio - DD compatible receiver with no audio sync problems using XBOX 360, PS3, etc etc
Everything is sync'd via a wired network

Problem encodes are any that required de-interlacing or de-telecining - Mainly music videos from Ministry of Sound, Nirvana Unplugged, KISS Symphony, KISS unplugged

Re-tested using Component connections instead of HDMI - Out of sync
Re-encode same DVDs without DD passthru, AAC only - No sync problems
Changed order of Audio tracks to DD then AAC, and AAC then DD - Out of sync
Returned my ATV and exchanged for a new one - Still out of sync

Note : All encodes are in sync when using VLC. The out of synchronicity varies on ATV
Any chance you can try these same results with the latest SVN build? I tried that on an encode yesterday (with another in processing) and it seems that it may have fixed the problem. It's interesting to see the results, however. Both encodes are nearly the same length (1:42:57.70 vs. 1:42:57.68 for the newer one) but there is a noticeable difference in one video track playing a few frames ahead of the other when played simultaneously in Quicktime.
If you don't have the latest build or can't compile for some reason, PM me and I will get it to you.

belloq
Bright Spark User
Posts: 223
Joined: Sun Oct 12, 2008 5:09 am

Re: Apple TV AC3 Audio Out Of Sync

Post by belloq » Tue Apr 14, 2009 6:28 pm

JVHB wrote:Re-tested using Component connections instead of HDMI - Out of sync
Re-encode same DVDs without DD passthru, AAC only - No sync problems
Changed order of Audio tracks to DD then AAC, and AAC then DD - Out of sync
Returned my ATV and exchanged for a new one - Still out of sync
Would be interested in the DD only option. (Possible once again with 2.3.1.)

lone_tree
Posts: 75
Joined: Mon May 05, 2008 10:23 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by lone_tree » Tue Apr 14, 2009 6:31 pm

Would be interesting, but HB 0.9.3 is old news; they're not going to fix it and rerelease the same version. Any fixes have and will go into 0.9.4. I read on another thread yesterday that someone thought this had been fixed in the current SVN release.
JVHB wrote:Problem encodes are any that required de-interlacing or de-telecining
I've been suspecting that for a while now. It would make sense if the video length is being changed at all.

nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Re: Apple TV AC3 Audio Out Of Sync

Post by nightstrm » Tue Apr 14, 2009 8:01 pm

lone_tree wrote:Would be interesting, but HB 0.9.3 is old news; they're not going to fix it and rerelease the same version. Any fixes have and will go into 0.9.4. I read on another thread yesterday that someone thought this had been fixed in the current SVN release.
JVHB wrote:Problem encodes are any that required de-interlacing or de-telecining
I've been suspecting that for a while now. It would make sense if the video length is being changed at all.
The problem is, I've been using detelecine + decomb since they were added (pre-9.3 release), and I have yet to come across an encode that exhibits this symptom that couldn't be explained otherwise. Maybe I've been lucky, or maybe I just haven't watched enough of my encodes, but I'm pretty sure I would have noticed it in my testing.

fallapart13

Re: Apple TV AC3 Audio Out Of Sync

Post by fallapart13 » Wed Apr 15, 2009 12:58 pm

Nightstrm: If I posted one of my encodes exhibiting the problem, could you download it and see how it plays back for you?

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Wed Apr 15, 2009 5:27 pm

Given This:
fallapart13 wrote:FINDINGS:
- Viewing the movie on AppleTV #1 (Living Room) the audio is always out of sync to varying degrees.
- Viewing the movie on AppleTV #2 (Bedroom) the audio and video are ALWAYS properly in sync with all content encoded with HB and VirtualHub.
I just do not understand how you can keep saying it is an issue with the HB encode itself. If the encode was bad it would exhibit it on any atv.

fallapart13

Re: Apple TV AC3 Audio Out Of Sync

Post by fallapart13 » Wed Apr 15, 2009 7:37 pm

Dynaflash: If I posted one of my encodes exhibiting the problem, could you download it and see how it plays back for you?

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Wed Apr 15, 2009 7:54 pm

if you want to post it, I can try it.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Wed Apr 15, 2009 7:58 pm

fallapart13 wrote:Dynaflash: If I posted one of my encodes exhibiting the problem, could you download it and see how it plays back for you?
However, my point is that according to your statement above you *do* have an atv setup that stays in sync. So I really do not see the point in trying it on my setup, it would be an erroneous test at best.

fallapart13

Re: Apple TV AC3 Audio Out Of Sync

Post by fallapart13 » Fri Apr 17, 2009 3:15 pm

DynaFlash: Here's a link to download one of the offending files. I am curious to see if the speech in this video plays back on in sync your system with AC3.

Additional testing by others NOT experiencing sync issues with their Dolby Digital setup, would be quite welcome.
Last edited by fallapart13 on Fri Apr 17, 2009 4:47 pm, edited 1 time in total.

lone_tree
Posts: 75
Joined: Mon May 05, 2008 10:23 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by lone_tree » Fri Apr 17, 2009 3:42 pm

This is getting to be a mess now. The problem is there are too many variables in each person's system to get a definitive answer as to what is going on. With my setup the only encode I've noticed that has been grossly out of sync was an encode of Run Fat Boy Run, which was my fault because I didn't let MTR finish it's processing before I popped the disc out to return it to Red Box in time. Other's that I've noticed out of sync are only by a few frames (fractions of a second), but still noticeable to the discerning eye. My out of sync encodes appear to be consistent from the ATV to the computer.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Fri Apr 17, 2009 4:10 pm

fallapart13 wrote:DynaFlash: Here's a link to download one of the offending files. I am curious to see if the speech in this video plays back on in sync your system with AC3.

Additional testing by others NOT experiencing sync issues with their Dolby Digital setup, would be quite welcome.
http://files.me.com/johnfinley/vewmy6
Okay, c'mon now you really expect me to eat up bandwidth and space downloading a 1.83 GB video file ?

I agree this is getting out of hand. I am very close to either locking this or moving it to tiki bar as all evidence point to an atv setup issue which means it is no longer an HB support issue.

Answer one question: Does this video work on one of your setups but not the other ?

For future reference, *if* you want to post test material. make sure its a short enough clip that it is sane to ask people to download it. As well distributing a copyrighted source even for testing is piracy any way you look at it. Especially a full length film.

User avatar
Rodeo
HandBrake Team
Posts: 12240
Joined: Tue Mar 03, 2009 8:55 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by Rodeo » Fri Apr 17, 2009 4:12 pm

dynaflash wrote:
fallapart13 wrote:Dynaflash: If I posted one of my encodes exhibiting the problem, could you download it and see how it plays back for you?
However, my point is that according to your statement above you *do* have an atv setup that stays in sync. So I really do not see the point in trying it on my setup, it would be an erroneous test at best.
Not my thread at all, but isn't fallapart13's second ATV setup connected via HDMI to what is most likely a stereo-capable TV (post #53872), which you said would cause the ATV to send the AAC track instead of AC-3 (post #54033)?

fallapart13

Re: Apple TV AC3 Audio Out Of Sync

Post by fallapart13 » Fri Apr 17, 2009 4:46 pm

The administrators, which have passively-aggressively commented throughout this thread, clearly don't want to hear any possible criticism or explore the possibility that there might be bugs in their crown jewel. And this thread is not unique - the tone that is taken throughout these forums is notoriously unfriendly and even hostile at times.

Why even provide forums if user issues are such a nuisance to you guys?

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Apple TV AC3 Audio Out Of Sync

Post by dynaflash » Fri Apr 17, 2009 5:05 pm

fwiw, I was downloading the entire file when you pulled it to try to assess what was wrong.

Having said that, since you do not need nor require developer, tester feedback (which has been provided in numerous posts in this thread) at the expense of their own time. I will leave this open for you and the other users to sort out.

It does seem a touch odd that the devs and testers have not had issues and you do. I would also note that comments regarding this thread being out of hand have come from other users, not just testers and devs. In any case, feel free to carry on since it was working so well for you.

Locked