Burn Subtitle

Discussion of the HandBrake command line interface (CLI)
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
colethegamer
Posts: 11
Joined: Wed Feb 07, 2024 8:35 am

Burn Subtitle

Post by colethegamer »

Description of problem or question:
I cannot Burn a subtitle, it always a simple added subtitle what can be disabled. I want to really burn it into the mkv file.



Steps to reproduce the problem (If Applicable):
flatpak run --command=HandBrakeCLI fr.handbrake.ghb --input "$video_file" --output "${subfolder}/tmp_video_file.mkv" --encoder x264 --quality 22 --rate 30 --audio 1 --aencoder av_ac3 --subtitle-default 1 --srt-codeset UTF-8 --srt-file "${subtitle_files[0]}" --subtitle-burned 1



HandBrake version (e.g., 1.0.0):
1.7.2


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Ubuntu 20.04
colethegamer
Posts: 11
Joined: Wed Feb 07, 2024 8:35 am

Re: Burn Subtitle

Post by colethegamer »

},
"Subtitle": {
"Search": {
"Burn": true,
"Default": false,
"Enable": false,
"Forced": false
},
"SubtitleList": [
{
"Burn": false,
"Default": false,
"Import": {
"Codeset": "UTF-8",
"Filename": "/home/data/automatedmovies/Into the Storm (2014)/Into the Storm (2014).srt",
"Format": "SRT",
"Language": "und"
},
"Offset": 0
}
mduell
Veteran User
Posts: 8271
Joined: Sat Apr 21, 2007 8:54 pm

Re: Burn Subtitle

Post by mduell »

Post the output to stderr.
Post Reply