Can;t update

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
sukayser
Posts: 3
Joined: Sat Oct 18, 2008 11:03 pm

Can;t update

Post by sukayser »

Description of problem or question:

When trying to update Handbrake from 1.0.7 to the current version, I get an error: "' Failed to change owner & group for Autoupdate with owner ID 602 and group ID 80." I have no idea where these IDs are set, and anyhow, I had Autoupdate unchecked.




Steps to reproduce the problem (If Applicable):
I get this error whether or not I have Autoupdate checked in Preferences.
In the Get Info window, changing the admin settings to "Read & Write" doesn't help.
I deleted the folder "Handbrake" in Library/Application Support. There was no Handbrake folder in "Library/Containers". No use (the Library/Application Support folder was replaced the next time I opened the old Handbrake).



HandBrake version (e.g., 1.0.0):
1.0.7



Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
macOS 10.16.7 (Catalina) on an iMac 27" i5 2020.



HandBrake Activity Log ***required*** (see How-to get an activity log)
This shows the contents of the activity window. The attempt to install does not seem to get saved.

Code: Select all

[11:46:48] macgui: Handbrake Version: 1.0.7  (2017040900)
[11:46:48] hb_init: starting libhb thread
[11:46:48] hb_init: starting libhb thread
rollin_eng
Veteran User
Posts: 4351
Joined: Wed May 04, 2011 11:06 pm

Re: Can;t update

Post by rollin_eng »

Can you download it from the website?
rollin_eng
Veteran User
Posts: 4351
Joined: Wed May 04, 2011 11:06 pm

Re: Can;t update

Post by rollin_eng »

This says in app update is not working:

viewtopic.php?t=42062
Woodstock
Veteran User
Posts: 4444
Joined: Tue Aug 27, 2013 6:39 am

Re: Can;t update

Post by Woodstock »

Version 1.0.x cannot even access the server, because the update checker does not use TLS 1.2.

It will have to be manually downloaded.
User avatar
s55
HandBrake Team
Posts: 10169
Joined: Sun Dec 24, 2006 1:05 pm

Re: Can;t update

Post by s55 »

The updater is actually live for the past few days but woodstock is right: 1.0.7 is simply too old and the security on the website is blocking it.
Post Reply