Leopard Catastrophic Headache

Random chit-chat and anything that doesn't belong elsewhere
Post Reply
Veteran User
Posts: 527
Joined: Sun Mar 18, 2007 2:11 am

Leopard Catastrophic Headache

Post by cvk_b »

Okay. Finally got Leopard. Installed to my sandbox
drive (this is my G5). I wanna play with the new
terminal, check out svn, see if my bash wrapper works, etc., etc.,

Well, since I'm booted out of my Tiger drive I thought
why not run disk utility to verify permissions, and check
disk structure…

Looks like the drive need repair. No big deal. Click
repair. BIG MISTAKE using Leopard disk repair on my
Tiger drive.

First disk repair looks normal but hangs "with under
a minute left". It was complaining about hard links
being zero instead of some number, perhaps TM related,
dunno. TM was never turned on, fwiw.

So repair fails with error suggesting formatting. Now
the drive is unmounted, unmountable repeating error,
and not selectable as bootable in system preferences.

At this point I realize I haven't ran SuperDuper in about
3 months because I'm stupid. Why did I turn off my
SD scheduling, why???

Try to repair again. No. Now I can't even verify without
error. I can't even fsck -y. The drive is invisible 'cept to disk
utility now. This is my primary work machine still–

Now I'm thinking Applecare, do I have it? Yes, but only
for my MBP. Can I use it, I wonder. Going through the docs
I find this AppleCare disc with TechToolPro Limited Edition on it.

Desperate… I install it. On first run it says "This software
is not fully tested on 10.5 Leopard". Well… at least the
software KNOWS about Leopard, right?

So TechTool sees the drive, even says there's files
on it… So I bite my nails and hit go.

TechToolPro AppleCare edition to the rescue, thank
goodness. I am posting from Tiger now and boy do I plan to
do some backing up soon.

So today's lesson is backup, and disk utility between
10.4 & 10.5 don't mix. I really thought installing Leopard to a
totally empty drive would cause me no troubles at all. I was wrong.

The funny thing is, I'm pretty anal about keeping my drive
repaired. I run fsck -y often and my Tiger install was from the
same day it came out, never once re-installed. My first
Leopard almost ate my first Tiger.


Posts: 1804
Joined: Mon Mar 26, 2007 12:07 am

Post by Cavalicious »

Ran into similar issue with my initial install on Friday. Maybe I should had posted it to help save some poor soul the trouble?! :wink:

I too had gotten the "Hard Link" errors during my initial install of Leopard. But after I tried doing an upgrade over my main partition. (Kids, always partition out you drives!)

Install crashed out - I ran Disk Utility (Verify then Repair)...Hard Link errors.

Next step, remove CD from Drive...had to reboot while holding down the mouse button...

Waiting...waiting....oh little Apple Logo...waiting...waiting...OK, where is that Data Rescue DVD...waiting...waiting....hey it booted.

OK...Copy all mailbox folder, photo library, bookmarks,iCals, and documents over to Storage Volume (Again Kids, always partition).

Now, lets try this again. Leopard Install boots and I go directly to Disk Util. Skip Verify, I dive straight to repair......? Partition clean ?

Hmm, ok, Upgrade...Agree...Install

<Cavalicious exits room in fear that his karma may crash install again>

45mins later...done.

I need a drink...Devil's handBrake maybe ? :twisted:

Posts: 23
Joined: Mon Apr 16, 2007 1:35 am

Post by remyhelsinki »

I always try booting off a Diskwarrior disc to see if I can fix crazy hd problems. That program has saved me a few times when everything else failed and I was pulling my hair out. It's worth a try if you know someone that has it or have access to it.

Glad you got everything working though. I do agree about backing up. I got a new iMac in Aug and after transferring over everything and double checking I still somehow forgot to transfer a folder over before I erased my backup called "archives." That was a very sad day. For some reason I was also anal and zero'd the drive so I lost photographs and quite a few of my freelance projects over the last 2 years... Luckily I had flattened copies of the most important things but it still sucks.

Posts: 886
Joined: Tue Jan 02, 2007 8:21 am

Post by baggss »

Sorry to hear about these issue.

I did 4 installs on my 4 machines, all Archive & Installs, and all worked fine.

Post Reply