Custom setting does not hold Audio Stting (Auto-Passthru)

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Posts: 1
Joined: Thu Apr 25, 2019 10:34 pm

Custom setting does not hold Audio Stting (Auto-Passthru)

Post by Ramses505 »

Description of problem or question:
Saving a custom setting does not seem to hold the Audio setting - I select Auto Passthru and 'update' my selected custom preset but loading a new file of clicking out of the custom preset and back in does not reflect the AutoPassthru setting chosen and saved.

Steps to reproduce the problem (If Applicable):
As above

HandBrake version (e.g., 1.0.0):

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Windows 7 SP1 pro

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

HandBrake 1.2.2 (2019022300)
OS: Microsoft Windows NT 6.1.7601 Service Pack 1
CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
Ram: 16258 MB, 
GPU Information:
  Intel(R) HD Graphics -
Screen: 1920x1080
Temp Dir: C:\Users\Ramses\AppData\Local\Temp\
Install Dir: C:\Program Files\Handbrake
Data Dir: C:\Users\Ramses\AppData\Roaming\HandBrake


Cannot load nvEncodeAPI64.dll
[23:35:53] hb_init: starting libhb thread

 # Starting Scan ...

[23:35:53] CPU: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
[23:35:53]  - Intel microarchitecture Ivy Bridge
[23:35:53]  - logical processor count: 4
[23:35:53] Intel Quick Sync Video support: yes
[23:35:53]  - Intel Media SDK hardware: API 1.11 (minimum: 1.3)
[23:35:53]  - H.264 encoder: yes
[23:35:53]     - preferred implementation: hardware (any) via D3D11
[23:35:53]     - capabilities (hardware):  vsinfo opt1 opt2+extbrc+ib_adapt+nmpslice
[23:35:53]  - H.265 encoder: no
[23:35:53] hb_scan: path=F:\Users\Ramses\Desktop\Bad Company 1972\Bad Company 1972.avi, title_index=0
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image F:\Users\Ramses\Desktop\Bad Company 1972\Bad Company 1972.avi
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[23:35:53] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[23:35:53] dvd: not a dvd - trying as a stream/file instead
Input #0, avi, from 'F:\Users\Ramses\Desktop\Bad Company 1972\Bad Company 1972.avi':
    encoder         : VirtualDubMod (build 2540/release)
  Duration: 01:28:49.00, start: 0.000000, bitrate: 1097 kb/s
    Stream #0:0: Video: mpeg4 (Advanced Simple Profile) (XVID / 0x44495658), yuv420p, 624x352 [SAR 1:1 DAR 39:22], 959 kb/s, 25 fps, 25 tbr, 25 tbn, 25 tbc
    Stream #0:1: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, fltp, 128 kb/s
[23:35:53] scan: decoding previews for title 1
[23:35:53] scan: audio 0x1: mp3float, rate=48000Hz, bitrate=128000 Unknown (MP3) (2.0 ch)
[23:35:53] scan: 10 previews, 624x352, 25.000 fps, autocrop = 0/0/0/0, aspect 1.77:1, PAR 1:1
[23:35:53] libhb: scan thread found 1 valid title(s)

 # Processing Scan Information ...

 # Scan Finished ...

Veteran User
Posts: 3614
Joined: Tue Aug 27, 2013 6:39 am

Re: Custom setting does not hold Audio Stting (Auto-Passthru)

Post by Woodstock »

In order for auto-pass through to work, the audio has to be in a codec that can be "passed through". I do not believe "mp3float" matches "MP3" for pass through.

Posts: 15
Joined: Sun May 12, 2019 11:41 pm

Re: Custom setting does not hold Audio Stting (Auto-Passthru)

Post by pitcher »

I am having a similar problem though not just with MP3.

I think possibly some of the audio settings are overriding each other, maybe this is a bug...

Post Reply