No audio track after encode

HandBrake for Windows support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
MyronAub
Posts: 5
Joined: Wed Jan 02, 2019 1:09 pm

No audio track after encode

Post by MyronAub » Wed Jan 02, 2019 1:28 pm

I'm using Handbrake to de-interlace a movie that was broadcast in two parts on the UK's ITV2 channel. Mediainfo reports that both raw .ts files have the exact same audio and video formats however one encodes perfectly while the other only outputs video with no audio track.

I've recaptured the raw .ts to eliminate a corrupt file and the problem re-occurs when encoded. The raw .ts plays audio without a problem.

In the logs I can see the following but have no idea if relevant or how to fix:
hb_audio_resample_update: avresample_open() failed (Error number -22 occurred)
[08:30:44] decavcodec: hb_audio_resample_update() failed

Any pointers would be really appreciated.

HandBrake 1.1.2

Windows 7 Pro SP1 64-bit

Code: Select all

HandBrake 1.1.2 (2018090500) - 64bit
OS: Microsoft Windows NT 6.1.7601 Service Pack 1 - 64bit
CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
Ram: 16265 MB, 
GPU Information:
  Intel(R) HD Graphics 530 - 21.20.16.4860
Screen: 1920x1080
Temp Dir: C:\Users\HB\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\HB\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[08:22:03] hb_init: starting libhb thread
[08:22:03] 1 job(s) to process
[08:22:03] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 160,
        "DRC": 0.0,
        "Encoder": 65536,
        "Gain": 0.0,
        "Mixdown": 6,
        "NormalizeMixLevel": false,
        "Samplerate": 48000,
        "Track": 0,
        "DitherMethod": 0
      },
      {
        "Bitrate": 640,
        "DRC": 0.0,
        "Encoder": 2048,
        "Gain": 0.0,
        "Mixdown": 6,
        "NormalizeMixLevel": false,
        "Samplerate": 48000,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "AlignAVStart": false,
    "File": "K:\\Videos5\\Captures\\HandBrake\\Elf part 1.m4v",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 4,
        "Settings": {
          "mode": "7"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "22",
          "crop-left": "2",
          "crop-right": "0",
          "crop-top": "18",
          "height": "1040",
          "width": "1918"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "0"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "time",
      "Start": 17100000,
      "End": 335970000
    },
    "Title": 1,
    "Path": "K:\\Videos5\\Captures\\Archive\\elf.ts"
  },
  "Subtitle": {
    "Search": {
      "Burn": true,
      "Default": false,
      "Enable": true,
      "Forced": true
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": 65536,
    "Level": "4.0",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "slower",
    "Profile": "high",
    "Quality": 18.0,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[08:22:03] CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
[08:22:03]  - Intel microarchitecture Skylake
[08:22:03]  - logical processor count: 8
[08:22:03] Intel Quick Sync Video support: yes
[08:22:03]  - Intel Media SDK hardware: API 1.23 (minimum: 1.3)
[08:22:03]  - H.264 encoder: yes
[08:22:03]     - preferred implementation: hardware (any) via D3D11
[08:22:03]     - capabilities (hardware):  breftype vsinfo opt1 opt2+mbbrc+extbrc+trellis+ib_adapt+nmpslice
[08:22:03]  - H.265 encoder: no
[08:22:03] hb_scan: path=K:\Videos5\Captures\Archive\elf.ts, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image K:\Videos5\Captures\Archive\elf.ts
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[08:22:03] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[08:22:03] dvd: not a dvd - trying as a stream/file instead
[08:22:03] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[08:22:03] Found the following PIDS
[08:22:03]     Video PIDS :
[08:22:03]       0x1011 type H.264 (0x1b) (PCR)
[08:22:03]     Audio PIDS :
[08:22:03]       0x1100 type AAC (0xf)
[08:22:03]     Subtitle PIDS :
[08:22:03]     Other PIDS :
[08:22:03] stream id 0x1100 (type 0xf substream 0x0) audio 0x1100
[08:22:03] scan: decoding previews for title 1
[08:22:03] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[08:22:21] scan: audio 0x1100: aac, rate=12000Hz, bitrate=109500 Unknown (AAC) (4.0 ch)
[08:22:22] stream: 91 good frames, 0 errors (0%)
[08:22:22] scan: 10 previews, 1920x1080, 25.000 fps, autocrop = 18/22/2/0, aspect 16:9, PAR 1:1
[08:22:22] scan: supported video decoders: avcodec qsv
[08:22:22] Title is likely interlaced or telecined (9 out of 10 previews). You should do something about that.
[08:22:22] libhb: scan thread found 1 valid title(s)
[08:22:22] Skipping subtitle scan.  No suitable subtitle tracks.
[08:22:22] starting job
[08:22:22] decomb filter thread started for segment 0
[08:22:22] decomb filter thread started for segment 2
[08:22:22] decomb filter thread started for segment 1
[08:22:22] decomb filter thread started for segment 3
[08:22:22] decomb filter thread started for segment 4
[08:22:22] decomb filter thread started for segment 5
[08:22:22] decomb filter thread started for segment 6
[08:22:22] decomb filter thread started for segment 7
[08:22:22] decomb check thread started for segment 0
[08:22:22] decomb check thread started for segment 1
[08:22:22] decomb check thread started for segment 2
[08:22:22] decomb check thread started for segment 3
[08:22:22] decomb check thread started for segment 4
[08:22:22] decomb check thread started for segment 5
[08:22:22] decomb check thread started for segment 6
[08:22:22] decomb check thread started for segment 7
[08:22:22] mask filter thread started for segment 0
[08:22:22] mask filter thread started for segment 1
[08:22:22] mask filter thread started for segment 2
[08:22:22] mask filter thread started for segment 3
[08:22:22] mask filter thread started for segment 4
[08:22:22] mask filter thread started for segment 5
[08:22:22] mask filter thread started for segment 6
[08:22:22] mask filter thread started for segment 7
[08:22:22] mask erode thread started for segment 0
[08:22:22] mask erode thread started for segment 1
[08:22:22] mask erode thread started for segment 2
[08:22:22] mask erode thread started for segment 3
[08:22:22] mask erode thread started for segment 4
[08:22:22] mask erode thread started for segment 5
[08:22:22] mask erode thread started for segment 6
[08:22:22] mask erode thread started for segment 7
[08:22:22] mask dilate thread started for segment 0
[08:22:22] mask dilate thread started for segment 1
[08:22:22] mask dilate thread started for segment 2
[08:22:22] mask dilate thread started for segment 3
[08:22:22] mask dilate thread started for segment 4
[08:22:22] mask dilate thread started for segment 5
[08:22:22] mask dilate thread started for segment 6
[08:22:22] mask dilate thread started for segment 7
[08:22:22] yadif thread started for segment 0
[08:22:22] yadif thread started for segment 1
[08:22:22] yadif thread started for segment 2
[08:22:22] yadif thread started for segment 3
[08:22:22] yadif thread started for segment 4
[08:22:22] yadif thread started for segment 5
[08:22:22] yadif thread started for segment 6
[08:22:22] yadif thread started for segment 7
[08:22:22] work: track 1, dithering not supported by codec
[08:22:22] work: track 2, dithering not supported by codec
[08:22:22] work: only 1 chapter, disabling chapter markers
[08:22:22] job configuration:
[08:22:22]  * source
[08:22:22]    + K:\Videos5\Captures\Archive\elf.ts
[08:22:22]    + title 1, start 00:03:10.00 stop 01:02:13.00
[08:22:22]  * destination
[08:22:22]    + K:\Videos5\Captures\HandBrake\Elf part 1.m4v
[08:22:22]    + container: MPEG-4 (libavformat)
[08:22:22]  * video track
[08:22:22]    + decoder: h264
[08:22:22]      + bitrate 200 kbps
[08:22:22]    + filters
[08:22:22]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[08:22:22]      + Decomb (mode=39)
[08:22:22]      + Framerate Shaper (mode=0)
[08:22:22]        + frame rate: same as source (around 25.000 fps)
[08:22:22]      + Crop and Scale (width=1918:height=1040:crop-top=18:crop-bottom=22:crop-left=2:crop-right=0)
[08:22:22]        + source: 1920 * 1080, crop (18/22/2/0): 1918 * 1040, scale: 1918 * 1040
[08:22:22]    + Output geometry
[08:22:22]      + storage dimensions: 1918 x 1040
[08:22:22]      + pixel aspect ratio: 1 : 1
[08:22:22]      + display dimensions: 1918 x 1040
[08:22:22]    + encoder: H.264 (libx264)
[08:22:22]      + preset:  slower
[08:22:22]      + profile: high
[08:22:22]      + level:   4.0
[08:22:22]      + quality: 18.00 (RF)
[08:22:22]  * audio track 1
[08:22:22]    + decoder: Unknown (AAC) (4.0 ch) (track 1, id 0x1100)
[08:22:22]      + bitrate: 109 kbps, samplerate: 12000 Hz
[08:22:22]    + mixdown: Dolby Pro Logic II
[08:22:22]    + encoder: AAC (libavcodec)
[08:22:22]      + bitrate: 160 kbps, samplerate: 48000 Hz
[08:22:22]  * audio track 2
[08:22:22]    + decoder: Unknown (AAC) (4.0 ch) (track 1, id 0x1100)
[08:22:22]      + bitrate: 109 kbps, samplerate: 12000 Hz
[08:22:22]    + mixdown: Dolby Pro Logic II
[08:22:22]    + encoder: AC3 (libavcodec)
[08:22:22]      + bitrate: 640 kbps, samplerate: 48000 Hz
[08:22:22] file is MPEG Transport Stream with 188 byte packets offset 0 bytes
[08:22:22] sync: expecting 88600 video frames
[08:22:22] encx264: encoding at constant RF 18.000000
[08:22:22] encx264: unparsed options: level=4.0:ref=4:b-adapt=2:direct=auto:analyse=all:me=umh:subme=9:trellis=2:vbv-bufsize=31250:vbv-maxrate=25000:rc-lookahead=60
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile High, level 4.0
[08:22:35] sync: first pts video is 0
hb_audio_resample_update: avresample_open() failed (Error number -22 occurred)
Last error repeated 1 times
hb_audio_resample_update: avresample_open() failed (Error number -22 occurred)
[08:30:44] decavcodec: hb_audio_resample_update() failed
[08:30:44] decavcodec: hb_audio_resample_update() failed
[09:14:58] stream: error near frame 83589: next_packet: sync lost @ 2843869044, regained after 44 bytes
[10:25:23] sync: reached video pts 318870000, exiting early
[10:25:40] stream: error near frame 196072: next_packet: sync lost @ 6684082108, regained after 96 bytes
[10:25:58] stream: error near frame 225969: next_packet: sync lost @ 7691436024, regained after 36 bytes
[10:30:23] hb_ts_stream_decode - eof
[10:30:23] reader: done. 5 scr changes
[10:30:24] work: average encoding speed for job is 12.020240 fps
[10:30:24] comb detect: heavy 86712 | light 452 | uncombed 1410 | total 88574
[10:30:24] decomb: deinterlaced 86712 | blended 452 | unfiltered 1410 | total 88574
[10:30:24] vfr: lost time: 0 (0 frames)
[10:30:24] vfr: gained time: 0 (0 frames) (0 not accounted for)
[10:30:24] stream: 419419 good frames, 5 errors (0%)
[10:30:24] aac-decoder done: 0 frames, 1073 decoder errors
[10:30:24] aac-decoder done: 0 frames, 1073 decoder errors
[10:30:24] h264-decoder done: 209675 frames, 0 decoder errors
[10:30:24] sync: got 88574 frames, 88600 expected
[10:30:24] sync: framerate min 12.500 fps, max 25.000 fps, avg 25.000 fps
x264 [info]: frame I:1002  Avg QP:14.37  size:188197
x264 [info]: frame P:24999 Avg QP:17.76  size: 74042
x264 [info]: frame B:62573 Avg QP:20.07  size: 22770
x264 [info]: consecutive B-frames:  3.2%  3.7% 12.4% 80.7%
x264 [info]: mb I  I16..4: 11.0% 69.3% 19.7%
x264 [info]: mb P  I16..4:  4.0% 13.8%  1.8%  P16..4: 44.0% 17.6%  9.9%  0.2%  0.0%    skip: 8.7%
x264 [info]: mb B  I16..4:  0.6%  1.5%  0.2%  B16..8: 45.6%  6.5%  1.2%  direct: 9.4%  skip:35.1%  L0:43.0% L1:50.7% BI: 6.3%
x264 [info]: 8x8 transform intra:69.2% inter:64.9%
x264 [info]: direct mvs  spatial:100.0% temporal:0.0%
x264 [info]: coded y,uvDC,uvAC intra: 67.2% 72.8% 45.2% inter: 27.6% 33.4% 2.1%
x264 [info]: i16 v,h,dc,p: 38% 29%  8% 24%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 16% 14% 11%  7% 10% 12% 10% 11% 10%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 18% 14%  7%  7% 11% 12% 11%  9% 10%
x264 [info]: i8c dc,h,v,p: 27% 34% 25% 14%
x264 [info]: Weighted P-Frames: Y:1.5% UV:0.9%
x264 [info]: ref P L0: 55.6% 12.8% 22.8%  8.6%  0.2%  0.0%
x264 [info]: ref B L0: 87.3% 10.7%  2.0%
x264 [info]: ref B L1: 94.6%  5.4%
x264 [info]: kb/s:7822.36
[10:30:24] mux: track 0, 88574 frames, 3464290009 bytes, 7822.19 kbps, fifo 2048
[10:30:24] mux: track 1, 0 frames, 0 bytes, 0.00 kbps, fifo 8
[10:30:24] mux: track 2, 0 frames, 0 bytes, 0.00 kbps, fifo 8
[10:30:24] libhb: work result = 0

# Encode Completed ...



mduell
Veteran User
Posts: 6547
Joined: Sat Apr 21, 2007 8:54 pm

Re: No audio track after encode

Post by mduell » Wed Jan 02, 2019 7:42 pm

1.1.2 is not supported, upgrade to the latest release (1.2.0) or try the nightly.

User avatar
Rodeo
HandBrake Team
Posts: 12116
Joined: Tue Mar 03, 2009 8:55 pm

Re: No audio track after encode

Post by Rodeo » Thu Jan 03, 2019 4:04 am

Also, the source track is AAC; so after updating to 1.2.0 try using AAC Passthru instead of an encoder.

Post Reply