[Invalid] Handbrake doesn't shutdown computer properly

Archive of historical bug reports.
Please use the GitHub link above to report issues.
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Post Reply
oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

[Invalid] Handbrake doesn't shutdown computer properly

Post by oRBIT2002 » Mon Jun 05, 2017 5:55 am

Please describe the problem in as much detail as possible:
Since the dawn of time (or atleast Windows XP), Handbrake doesn't shutdown the computer properly after an encode. If it encodes a file and I choose that it should shutdown computer after finished, it almost never does that when I leaves the computer idle (for the night for example). When I check my computer in the morning it's in power-saving mode (power-led flashing) and when I turn on the computer, THEN it shuts it down ("windows is shutting down"...). I don't think this problem ever occurs if I use my computer at the same time (=forgot to remove "shutdown computer after encoding"), then the computer shuts down correctly.
What are the steps to reproduce this problem:
Encode a file but make the que shutdown the computer when it's done.
What version of HandBrake you are running:
1.0.7
What operating system and version and you running (e.g. OSX 10.11, Windows 7, Ubuntu 14):
Windows 10 x64
Where did you download HandBrake from? handbrake.fr or somewhere else?
handbrake.fr
If there was any error, exception or crash report displayed, please copy it and paste it here:

Please include the scan or encode log:

Code: Select all

HandBrake 1.0.7 (2017040900) - 64bit
OS: Microsoft Windows NT 10.0.15063.0 - 64bit
CPU: Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz
Ram: 8131 MB, 
GPU Information:
  NVIDIA GeForce GTX 650 - 22.21.13.8205
Screen: 1920x1080
Temp Dir: C:\Users\Morgan\AppData\Local\Temp\
Install Dir: C:\Program Files\Handbrake
Data Dir: C:\Users\Morgan\AppData\Roaming\HandBrake Team\HandBrake\1.0.7.0

-------------------------------------------


# Starting Encode ...

[22:31:17] hb_init: starting libhb thread
[22:31:17] 1 job(s) to process
[22:31:17] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 192,
        "DRC": 0.0,
        "Encoder": 65536,
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [],
    "ChapterMarkers": false,
    "File": "M:\\Videokamera - klara\\2017\\2017-06-01 Legoland.mp4",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": true
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "1080",
          "width": "1920"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "chapter",
      "Start": 1,
      "End": 1
    },
    "Title": 1,
    "Path": "M:\\Videokamera - Rådata\\2017\\2017-06-01 - Legoland.mp4"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": true,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": 65536,
    "Level": "4.1",
    "Bitrate": 12000,
    "TwoPass": true,
    "Turbo": true,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "slow",
    "Profile": "high",
    "OpenCL": false,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[22:31:17] CPU: Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz
[22:31:17]  - Intel microarchitecture Haswell
[22:31:17]  - logical processor count: 4
[22:31:17] Intel Quick Sync Video support: no
[22:31:17] hb_scan: path=M:\Videokamera - Rådata\2017\2017-06-01 - Legoland.mp4, title_index=1
src/libbluray/disc/disc.c:274: failed opening UDF image M:\Videokamera - RÃ¥data\2017\2017-06-01 - Legoland.mp4
src/libbluray/disc/disc.c:352: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:352: error opening file BDMV\BACKUP\index.bdmv
[22:31:17] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[22:31:17] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'M:\Videokamera - RÃ¥data\2017\2017-06-01 - Legoland.mp4':
  Metadata:
    major_brand     : XAVC
    minor_version   : 16785407
    compatible_brands: XAVCmp42iso2
    creation_time   : 2017-06-04 20:20:22
  Duration: 00:13:27.10, start: 0.000000, bitrate: 58422 kb/s
    Stream #0:0(und): Video: h264 (High) [avc1 / 0x31637661]
      yuv420p, tv, bt709/bt709/iec61966-2-4
      3840x2160 [PAR 1:1 DAR 16:9], 56883 kb/s
      29.97 fps, 30k tbn (default)
    Metadata:
      creation_time   : 2017-06-04 20:20:22
      handler_name    : Video Media Handler
      encoder         : AVC Coding
    Stream #0:1(und): Audio: pcm_s16be [twos / 0x736F7774]
      48000 Hz, 2 channels, s16, 1536 kb/s (default)
    Metadata:
      creation_time   : 2017-06-04 20:20:22
      handler_name    : Non-Real Time Metadata
[22:31:18] scan: decoding previews for title 1
[22:31:19] scan: audio 0x1: pcm_s16be, rate=48000Hz, bitrate=1536000 Unknown (pcm_s16be) (2.0 ch)
[22:31:21] scan: 10 previews, 3840x2160, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[22:31:21] scan: supported video decoders: avcodec qsv
[22:31:21] libhb: scan thread found 1 valid title(s)
[22:31:21] Skipping subtitle scan.  No suitable subtitle tracks.
[22:31:21] starting job
[22:31:21] work: track 1, dithering not supported by codec
[22:31:21] job configuration:
[22:31:21]  * source
[22:31:21]    + M:\Videokamera - Rådata\2017\2017-06-01 - Legoland.mp4
[22:31:21]    + title 1, chapter(s) 1 to 1
[22:31:21]    + container: mov,mp4,m4a,3gp,3g2,mj2
[22:31:21]    + data rate: 58422 kbps
[22:31:21]  * destination
[22:31:21]    + M:\Videokamera - klara\2017\2017-06-01 Legoland.mp4
[22:31:21]    + container: MPEG-4 (libavformat)
[22:31:21]      + optimized for HTTP streaming (fast start)
[22:31:21]  * video track
[22:31:21]    + decoder: h264
[22:31:21]      + bitrate 56883 kbps
[22:31:21]    + filters
[22:31:21]      + Framerate Shaper (mode=1)
[22:31:21]        + frame rate: 29.970 fps -> constant 29.970 fps
[22:31:21]      + Crop and Scale (width=1920:height=1080:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[22:31:21]        + source: 3840 * 2160, crop (0/0/0/0): 3840 * 2160, scale: 1920 * 1080
[22:31:21]    + Output geometry
[22:31:21]      + storage dimensions: 1920 x 1080
[22:31:21]      + pixel aspect ratio: 1 : 1
[22:31:21]      + display dimensions: 1920 x 1080
[22:31:21]    + encoder: H.264 (libx264)
[22:31:21]      + preset:  slow
[22:31:21]      + profile: high
[22:31:21]      + level:   4.1
[22:31:21]      + bitrate: 12000 kbps, pass: 1
[22:31:21]      + fast first pass
[22:31:21]      + options: ref=1:8x8dct=0:me=dia:trellis=0
[22:31:21]                 analyse=i4x4 (if originally enabled, else analyse=none)
[22:31:21]                 subq=2 (if originally greater than 2, else subq unchanged)
[22:31:21]  * audio track 1
[22:31:21]    + decoder: Unknown (pcm_s16be) (2.0 ch) (track 1, id 0x1)
[22:31:21]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[22:31:21]    + mixdown: Stereo
[22:31:21]    + encoder: AAC (libavcodec)
[22:31:21]      + bitrate: 192 kbps, samplerate: 48000 Hz
[22:31:22] sync: expecting 24189 video frames
[22:31:22] encx264: min-keyint: 30, keyint: 300
[22:31:22] encx264: encoding at average bitrate 12000
[22:31:22] encx264: unparsed options: level=4.1:vbv-maxrate=62500:ref=4:b-adapt=2:subme=8:direct=auto:me=umh:vbv-bufsize=78125:rc-lookahead=50
x264 [info]: using SAR=1/1
x264 [warning]: VBV bitrate (62500) > level limit (50000)
x264 [warning]: VBV buffer (78125) > level limit (62500)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 AVX2 LZCNT BMI2
x264 [info]: profile Main, level 4.1
[22:31:23] sync: first pts video is 0
[22:31:23] sync: Chapter 1 at frame 1 time 0
[22:31:23] sync: first pts audio 0x1 is 0
[22:45:56] reader: done. 1 scr changes
[22:45:58] work: average encoding speed for job is 27.623253 fps
[22:45:59] vfr: 24189 frames output, 0 dropped and 0 duped for CFR/PFR
[22:45:59] vfr: lost time: 0 (0 frames)
[22:45:59] vfr: gained time: 0 (0 frames) (0 not accounted for)
[22:45:59] pcm_s16be-decoder done: 38725 frames, 0 decoder errors
[22:45:59] h264-decoder done: 24189 frames, 0 decoder errors
[22:45:59] sync: got 24189 frames, 24189 expected
[22:45:59] sync: framerate min 29.970 fps, max 29.970 fps, avg 29.970 fps
x264 [info]: frame I:88    Avg QP:22.27  size:289072
x264 [info]: frame P:8264  Avg QP:25.85  size: 93125
x264 [info]: frame B:15837 Avg QP:28.53  size: 23457
x264 [info]: consecutive B-frames:  6.4%  7.8% 33.4% 52.4%
x264 [info]: mb I  I16..4: 31.3%  0.0% 68.7%
x264 [info]: mb P  I16..4: 25.3%  0.0%  0.0%  P16..4: 63.1%  0.0%  0.0%  0.0%  0.0%    skip:11.6%
x264 [info]: mb B  I16..4:  5.0%  0.0%  0.0%  B16..8: 28.8%  0.0%  0.0%  direct:14.4%  skip:51.8%  L0:32.7% L1:40.0% BI:27.2%
x264 [info]: final ratefactor: 23.44
x264 [info]: direct mvs  spatial:100.0% temporal:0.0%
x264 [info]: coded y,uvDC,uvAC intra: 44.5% 55.4% 16.2% inter: 23.0% 16.0% 0.8%
x264 [info]: i16 v,h,dc,p: 31% 28% 30% 11%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 19% 20% 14%  7%  8%  7%  8%  7%  9%
x264 [info]: i8c dc,h,v,p: 57% 22% 18%  3%
x264 [info]: Weighted P-Frames: Y:13.1% UV:5.9%
x264 [info]: kb/s:11562.41
[22:45:59] starting job
[22:45:59] work: track 1, dithering not supported by codec
[22:45:59] job configuration:
[22:45:59]  * source
[22:45:59]    + M:\Videokamera - Rådata\2017\2017-06-01 - Legoland.mp4
[22:45:59]    + title 1, chapter(s) 1 to 1
[22:45:59]    + container: mov,mp4,m4a,3gp,3g2,mj2
[22:45:59]    + data rate: 58422 kbps
[22:45:59]  * destination
[22:45:59]    + M:\Videokamera - klara\2017\2017-06-01 Legoland.mp4
[22:45:59]    + container: MPEG-4 (libavformat)
[22:45:59]      + optimized for HTTP streaming (fast start)
[22:45:59]  * video track
[22:45:59]    + decoder: h264
[22:45:59]      + bitrate 56883 kbps
[22:45:59]    + filters
[22:45:59]      + Framerate Shaper (mode=1)
[22:45:59]        + frame rate: 29.970 fps -> constant 29.970 fps
[22:45:59]      + Crop and Scale (width=1920:height=1080:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[22:45:59]        + source: 3840 * 2160, crop (0/0/0/0): 3840 * 2160, scale: 1920 * 1080
[22:45:59]    + Output geometry
[22:45:59]      + storage dimensions: 1920 x 1080
[22:45:59]      + pixel aspect ratio: 1 : 1
[22:45:59]      + display dimensions: 1920 x 1080
[22:45:59]    + encoder: H.264 (libx264)
[22:45:59]      + preset:  slow
[22:45:59]      + profile: high
[22:45:59]      + level:   4.1
[22:45:59]      + bitrate: 12000 kbps, pass: 2
[22:45:59]  * audio track 1
[22:45:59]    + decoder: Unknown (pcm_s16be) (2.0 ch) (track 1, id 0x1)
[22:45:59]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[22:45:59]    + mixdown: Stereo
[22:45:59]    + encoder: AAC (libavcodec)
[22:45:59]      + bitrate: 192 kbps, samplerate: 48000 Hz
[22:46:00] sync: expecting 24189 video frames
[22:46:00] encx264: min-keyint: 30, keyint: 300
[22:46:00] encx264: encoding at average bitrate 12000
[22:46:00] encx264: unparsed options: level=4.1:vbv-maxrate=62500:ref=4:b-adapt=2:subme=8:direct=auto:me=umh:vbv-bufsize=78125:rc-lookahead=50
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 AVX2 LZCNT BMI2
x264 [info]: profile High, level 4.1
[22:46:01] sync: first pts video is 0
[22:46:01] sync: Chapter 1 at frame 1 time 0
[22:46:01] sync: first pts audio 0x1 is 0
[23:16:20] reader: done. 1 scr changes
[23:16:26] work: average encoding speed for job is 13.263161 fps
[23:16:27] vfr: 24189 frames output, 0 dropped and 0 duped for CFR/PFR
[23:16:27] vfr: lost time: 0 (0 frames)
[23:16:27] vfr: gained time: 0 (0 frames) (0 not accounted for)
[23:16:27] pcm_s16be-decoder done: 38725 frames, 0 decoder errors
[23:16:27] h264-decoder done: 24189 frames, 0 decoder errors
[23:16:27] sync: got 24189 frames, 24189 expected
[23:16:27] sync: framerate min 29.970 fps, max 29.970 fps, avg 29.970 fps
x264 [info]: frame I:88    Avg QP:23.08  size:298747
x264 [info]: frame P:8264  Avg QP:26.00  size: 97133
x264 [info]: frame B:15837 Avg QP:28.89  size: 23831
x264 [info]: consecutive B-frames:  6.4%  7.8% 33.4% 52.4%
x264 [info]: mb I  I16..4: 14.6% 53.2% 32.2%
x264 [info]: mb P  I16..4:  3.7%  7.8%  2.5%  P16..4: 39.7% 18.7% 15.2%  0.0%  0.0%    skip:12.3%
x264 [info]: mb B  I16..4:  0.3%  0.8%  0.4%  B16..8: 40.7%  8.3%  3.3%  direct: 4.3%  skip:41.8%  L0:42.3% L1:47.9% BI: 9.9%
x264 [info]: 8x8 transform intra:55.2% inter:62.3%
x264 [info]: direct mvs  spatial:99.9% temporal:0.1%
x264 [info]: coded y,uvDC,uvAC intra: 59.1% 63.1% 21.7% inter: 23.7% 20.0% 1.2%
x264 [info]: i16 v,h,dc,p: 33% 27% 11% 30%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 13% 10% 13%  8% 12% 11% 13%  9% 12%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 13% 11%  8%  8% 12% 11% 13% 10% 14%
x264 [info]: i8c dc,h,v,p: 47% 28% 16%  9%
x264 [info]: Weighted P-Frames: Y:13.2% UV:5.9%
x264 [info]: ref P L0: 64.1% 17.0% 12.2%  5.9%  0.7%  0.0%
x264 [info]: ref B L0: 88.0%  9.7%  2.2%
x264 [info]: ref B L1: 95.9%  4.1%
x264 [info]: kb/s:11957.89
[23:17:15] mux: track 0, 24189 frames, 1206407329 bytes, 11957.36 kbps, fifo 1024
[23:17:15] mux: track 1, 37834 frames, 19392415 bytes, 192.21 kbps, fifo 1024
[23:17:15] libhb: work result = 0

# Encode Completed ...


FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Handbrake doesn't shutdown computer properly

Post by FrostByte » Mon Jun 05, 2017 2:46 pm

I noticed the same thing with my computer, but I wasn't sure if the shutdown option was broke or just not using the forced option so I did a feature request. Or maybe there is some security setting since the Windows 10 Developers Update that is preventing it form shutting down. Either way I haven't figured out why it doesn't shutdown for me either lately after an encode is done. It used to shutdown fine for me awhile back I know.

viewtopic.php?f=26&t=36270

User avatar
BradleyS
Moderator
Posts: 1638
Joined: Thu Aug 09, 2007 12:16 pm

Re: Handbrake doesn't shutdown computer properly

Post by BradleyS » Mon Jun 05, 2017 5:37 pm

Since the dawn of time (or atleast Windows XP)...
You win the internet. :lol:

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: Handbrake doesn't shutdown computer properly

Post by FrostByte » Mon Jun 05, 2017 6:11 pm

Well, I know it's worked since then. I'm not thaaaaaaaaaat old :)

User avatar
s55
HandBrake Team
Posts: 9545
Joined: Sun Dec 24, 2006 1:05 pm

Re: Handbrake doesn't shutdown computer properly

Post by s55 » Mon Jun 05, 2017 6:25 pm

HandBrake requests that the OS shutdown. While in theory it should be forced, the OS can still reject the shutdown.

The feature is working as expected for me so there is probably something on your system that's interfering with it.

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: [Invalid] Handbrake doesn't shutdown computer properly

Post by oRBIT2002 » Thu Jun 08, 2017 5:30 am

It's annoying since when I wake the computer up from hibernation it immediately shuts down (as it should, sort of).
And I've had this issue for as long as I've used Handbrake (quite a few years now) and on multiple Windows OS's so...

Woodstock
Veteran User
Posts: 3220
Joined: Tue Aug 27, 2013 6:39 am

Re: [Invalid] Handbrake doesn't shutdown computer properly

Post by Woodstock » Thu Jun 08, 2017 4:51 pm

Do you have other tasks running? Shutdown can and will stop for tasks that refuse to acknowledge a shutdown request immediately.

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: [Invalid] Handbrake doesn't shutdown computer properly

Post by oRBIT2002 » Thu Jun 08, 2017 7:44 pm

I usually only have Handbrake running when I leave the computer on at night.

FrostByte
Posts: 61
Joined: Sat Dec 12, 2015 7:16 pm

Re: [Invalid] Handbrake doesn't shutdown computer properly

Post by FrostByte » Sat Jun 10, 2017 10:56 pm

Same here, just HB running when I go to bed. When I wake up there is a prompt and as soon as I click it the computer immediately shuts down. Very annoying :)

When I manually type in the command s55 posted it works perfect. For some reason Windows isn't allowing HB to do it though. Maybe it's Defender, or something else not allowing a third party app to do it.

Post Reply