Performance not as good as expected with Core i5-750

Post your testing results with HandBrake.
Post Reply
baljeet
Posts: 1
Joined: Wed Feb 03, 2010 1:16 am

Performance not as good as expected with Core i5-750

Post by baljeet » Wed Feb 03, 2010 1:54 am

Not sure if this needs to go under this section or tech support, but I figured I'd start here...

I just put together a new system and am not getting the FPS encoding that I would expect with Handbrake. If I run x264 Benchmark HD, I get around 75-80 FPS on Pass 1 and about 20-25 on Pass 2. This is on par with some of the results I've seen on sites doing benchmarks of comparable systems. If I take the same video file they use in that benchmark and process it in Handbrake, I get around 40-45 FPS in Pass 1.

I understand I may not be using the same exact settings they use in x264 Benchmark HD in Handbrake I guess I just thought I would get much better performance.

Motherboard: MSI P55-CD53
CPU: Core i5-750 overclocked to 3.4GHz (4 cores)
RAM: 4G DDR3 1600
OS: Windows 7 x64 Ultimate

Code: Select all

### Windows GUI 0.9.4 2009112300 
### Running: Microsoft Windows NT 6.1.7600.0 
###
### CPU: Intel(R) Core(TM) i5 CPU         750  @ 2.67GHz 
### Ram: 4087 MB 
### Screen: 1440x900 
### Temp Dir: C:\Users\Yostie\AppData\Local\Temp\ 
### Install Dir: C:\Program Files (x86)\Handbrake 
### Data Dir: C:\Users\Yostie\AppData\Roaming\HandBrake\HandBrake\0.9.4.0 
#########################################

[20:47:50] hb_init: checking cpu count
[20:47:50] hb_init: starting libhb thread
HandBrake 0.9.4 (2009112300) - MinGW i386 - http://handbrake.fr
4 CPUs detected
Opening C:\Users\Yostie\Downloads\x264_Benchmark_HD_v3.0\x264_Benchmark_HD_v3.0\test\test-720p.mpg...
[20:47:50] hb_scan: path=C:\Users\Yostie\Downloads\x264_Benchmark_HD_v3.0\x264_Benchmark_HD_v3.0\test\test-720p.mpg, title_index=1
[20:47:50] scan: trying to open with libdvdread
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[20:47:50] dvd: not a dvd - trying as a stream/file instead
[20:47:50] file is MPEG DVD Program Stream
[20:47:50] add_audio_to_title: added MPEG audio stream 0xc0
[20:47:50] scan: decoding previews for title 1
[20:47:50] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=384000 Unknown (MPEG) (2.0 ch)
Scanning title 1...
[20:47:50] scan: 10 previews, 1280x736, 23.976 fps, autocrop = 0/16/0/0, aspect 1.74:1, PAR 1:1
[20:47:50] scan: title (0) job->width:1280, job->height:720
[20:47:50] libhb: scan thread found 1 valid title(s)
+ title 1:
  + vts 0, ttn 0, cells 0->0 (0 blocks)
  + angle(s) 0
  + duration: 00:00:30
  + size: 1280x736, pixel aspect: 1/1, display aspect: 1.74, 23.976 fps
  + autocrop: 0/16/0/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:00:30
  + audio tracks:
    + 1, Unknown (MPEG) (2.0 ch) (iso639-2: und)
  + subtitle tracks:
[20:47:50] 2 job(s) to process
[20:47:50] starting job
[20:47:50] work: sanitizing track 0 mixdown Dolby Pro Logic II to Stereo
[20:47:50] job configuration:
[20:47:50]  * source
[20:47:50]    + C:\Users\Yostie\Downloads\x264_Benchmark_HD_v3.0\x264_Benchmark_HD_v3.0\test\test-720p.mpg
[20:47:50]    + title 1, chapter(s) 1 to 1
[20:47:50]  * destination
[20:47:50]    + C:\Users\Yostie\Desktop\test-720p-1.m4v
[20:47:50]    + container: MPEG-4 (.mp4 and .m4v)
[20:47:50]  * video track
[20:47:50]    + decoder: mpeg2
[20:47:50]      + bitrate 15000 kbps
[20:47:50]    + frame rate: same as source (around 23.976 fps)
[20:47:50]    + loose anamorphic
[20:47:50]      + modulus: 0
[20:47:50]      + storage dimensions: 1280 * 736 -> 1280 * 720, crop 0/16/0/0
[20:47:50]      + pixel aspect ratio: 1 / 1
[20:47:50]      + display dimensions: 1280 * 720
[20:47:50]    + filter
[20:47:50]      + Decomb (default settings)
[20:47:50]    + encoder: x264
[20:47:50]      + options: ref=3:bframes=4:subq=8:mixed-refs=0:8x8dct=0:trellis=1:analyse=all:deblock=-2,-1
[20:47:50]      + bitrate: 2000 kbps, pass: 1
[20:47:50]  * audio track 0
[20:47:50]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[20:47:50]    + mixdown: Stereo
[20:47:50]    + encoder: faac
[20:47:50]      + bitrate: 160 kbps, samplerate: 48000 Hz
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
[20:47:50] decomb thread started for segment 2
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[20:47:50] yadif thread started for segment 1
[20:47:50] yadif thread started for segment 2
[20:47:50] yadif thread started for segment 3
[20:47:50] decomb thread started for segment 3
[20:47:50] dvd: not a dvd - trying as a stream/file instead
[20:47:50] yadif thread started for segment 0
[20:47:50] decomb thread started for segment 1
[20:47:50] encx264: keyint-min: 24, keyint-max: 240
[20:47:50] decomb thread started for segment 0
[20:47:50] encx264: encoding with stored aspect 1/1
[20:47:50] reader: first SCR 0 id 192 DTS 21637
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
x264 [info]: profile Main, level 3.1
[20:47:50] mpeg2: "" (1) at frame 0 time -1
[20:47:50] sync: expecting 751 video frames
[20:47:50] sync: first pts is -1
[20:47:50] sync: video time didn't advance - dropped 2 frames (delta 0 ms, current 0, next 641, dur 641)
[20:48:08] reader: done. 0 scr changes
[20:48:09] sync: got 716 frames, 751 expected
[20:48:09] work: average encoding speed for job is 38.654705 fps
[20:48:12] mpeg2 done: 719 frames
[20:48:12] render: lost time: 0 (0 frames)
[20:48:12] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: frame I:20    Avg QP:19.05  size: 40486  PSNR Mean Y:47.59 U:52.18 V:52.53 Avg:48.65 Global:48.04
x264 [info]: frame P:368   Avg QP:23.16  size: 12626  PSNR Mean Y:44.91 U:50.71 V:50.82 Avg:46.11 Global:45.42
x264 [info]: frame B:327   Avg QP:23.79  size:  4989  PSNR Mean Y:45.11 U:51.33 V:51.76 Avg:46.38 Global:45.32
x264 [info]: consecutive B-frames: 25.8% 34.5% 11.2%  9.8% 18.7%
x264 [info]: mb I  I16..4: 49.2%  0.0% 50.8%
x264 [info]: mb P  I16..4:  9.0%  0.0%  5.2%  P16..4: 49.0%  5.1%  2.6%  0.0%  0.0%    skip:29.0%
x264 [info]: mb B  I16..4:  0.6%  0.0%  0.7%  B16..8: 35.1%  0.8%  1.0%  direct: 4.0%  skip:57.8%  L0:41.8% L1:54.7% BI: 3.5%
x264 [info]: final ratefactor: 21.75
x264 [info]: coded y,uvDC,uvAC intra: 44.4% 50.2% 11.5% inter: 12.0% 18.2% 0.2%
x264 [info]: i16 v,h,dc,p: 35% 19% 12% 35%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu:  8%  6%  8% 10% 15% 12% 15% 12% 15%
x264 [info]: Weighted P-Frames: Y:1.4%
x264 [info]: ref P L0: 52.9% 17.1% 20.5%  9.4%  0.1%
x264 [info]: ref B L0: 78.8% 21.2%
x264 [info]: SSIM Mean Y:0.9808567
x264 [info]: PSNR Mean Y:45.074 U:51.033 V:51.300 Avg:46.305 Global:45.426 kb/s:1901.35
[20:48:12] mp2-decoder done: 0 frames, 0 decoder errors, 0 drops
[20:48:12] decomb: deinterlaced 0 | blended 2 | unfiltered 713 | total 715
[20:48:12] starting job
[20:48:12] work: sanitizing track 0 mixdown Dolby Pro Logic II to Stereo
[20:48:12] job configuration:
[20:48:12]  * source
[20:48:12]    + C:\Users\Yostie\Downloads\x264_Benchmark_HD_v3.0\x264_Benchmark_HD_v3.0\test\test-720p.mpg
[20:48:12]    + title 1, chapter(s) 1 to 1
[20:48:12]  * destination
[20:48:12]    + C:\Users\Yostie\Desktop\test-720p-1.m4v
[20:48:12]    + container: MPEG-4 (.mp4 and .m4v)
[20:48:12]  * video track
[20:48:12]    + decoder: mpeg2
[20:48:12]      + bitrate 15000 kbps
[20:48:12]    + frame rate: same as source (around 23.976 fps)
[20:48:12]    + loose anamorphic
[20:48:12]      + modulus: 0
[20:48:12]      + storage dimensions: 1280 * 736 -> 1280 * 720, crop 0/16/0/0
[20:48:12]      + pixel aspect ratio: 1 / 1
[20:48:12]      + display dimensions: 1280 * 720
[20:48:12]    + filter
[20:48:12]      + Decomb (default settings)
[20:48:12]    + encoder: x264
[20:48:12]      + options: ref=3:bframes=4:subq=8:mixed-refs=0:8x8dct=0:trellis=1:analyse=all:deblock=-2,-1
[20:48:12]      + bitrate: 2000 kbps, pass: 2
[20:48:12]  * audio track 0
[20:48:12]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[20:48:12]    + mixdown: Stereo
[20:48:12]    + encoder: faac
[20:48:12]      + bitrate: 160 kbps, samplerate: 48000 Hz
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
[20:48:12] decomb thread started for segment 0
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
[20:48:12] yadif thread started for segment 1
libdvdnav: vm: failed to read VIDEO_TS.IFO
[20:48:12] yadif thread started for segment 2
[20:48:12] yadif thread started for segment 3
[20:48:12] yadif thread started for segment 0
[20:48:12] dvd: not a dvd - trying as a stream/file instead
[20:48:12] decomb thread started for segment 1
[20:48:12] decomb thread started for segment 2
[20:48:12] encx264: keyint-min: 24, keyint-max: 240
[20:48:12] decomb thread started for segment 3
[20:48:12] encx264: encoding with stored aspect 1/1
x264 [info]: using SAR=1/1
[20:48:12] reader: first SCR 0 id 192 DTS 21637
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
[20:48:12] mpeg2: "" (1) at frame 0 time -1
x264 [info]: profile Main, level 3.1
[20:48:12] sync: expecting 716 video frames
[20:48:12] sync: first pts is -1
[20:48:12] sync: video time didn't advance - dropped 2 frames (delta 0 ms, current 0, next 641, dur 641)
[20:48:29] reader: done. 0 scr changes
[20:48:30] sync: got 716 frames, 716 expected
[20:48:30] work: average encoding speed for job is 41.505558 fps
[20:48:12] sync: expecting 716 video frames
[20:48:12] sync: first pts is -1
[20:48:12] sync: video time didn't advance - dropped 2 frames (delta 0 ms, current 0, next 641, dur 641)
[20:48:29] reader: done. 0 scr changes
[20:48:30] sync: got 716 frames, 716 expected
[20:48:30] work: average encoding speed for job is 41.505558 fps
[20:48:31] mux: track 0, 715 frames, 7393181 bytes, 1977.32 kbps, fifo 16
[20:48:31] mux: track 1, 1403 frames, 597095 bytes, 159.69 kbps, fifo 256
[20:48:31] mpeg2 done: 719 frames
[20:48:31] render: lost time: 0 (0 frames)
[20:48:31] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: frame I:20    Avg QP:19.15  size: 39041  PSNR Mean Y:47.50 U:52.14 V:52.50 Avg:48.58 Global:48.08
x264 [info]: frame P:368   Avg QP:22.78  size: 13555  PSNR Mean Y:45.11 U:50.83 V:50.94 Avg:46.31 Global:45.80
x264 [info]: frame B:327   Avg QP:23.78  size:  4969  PSNR Mean Y:45.15 U:51.29 V:51.70 Avg:46.41 Global:45.57
x264 [info]: consecutive B-frames: 25.8% 34.5% 11.2%  9.8% 18.7%
x264 [info]: mb I  I16..4: 49.2%  0.0% 50.8%
x264 [info]: mb P  I16..4:  9.0%  0.0%  6.1%  P16..4: 48.4%  5.3%  2.7%  0.0%  0.0%    skip:28.4%
x264 [info]: mb B  I16..4:  0.6%  0.0%  0.9%  B16..8: 34.2%  0.9%  1.0%  direct: 3.5%  skip:58.9%  L0:41.3% L1:54.8% BI: 3.9%
x264 [info]: coded y,uvDC,uvAC intra: 47.5% 53.3% 11.6% inter: 12.2% 19.2% 0.1%
x264 [info]: i16 v,h,dc,p: 34% 19% 12% 36%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu:  8%  6%  8% 10% 15% 12% 15% 12% 15%
x264 [info]: Weighted P-Frames: Y:1.4%
x264 [info]: ref P L0: 51.5% 17.8% 21.7%  8.9%  0.1%
x264 [info]: ref B L0: 78.9% 21.1%
x264 [info]: SSIM Mean Y:0.9815151
x264 [info]: PSNR Mean Y:45.193 U:51.076 V:51.331 Avg:46.418 Global:45.741 kb/s:1985.80
[20:48:31] mp2-decoder done: 0 frames, 0 decoder errors, 0 drops
[20:48:31] decomb: deinterlaced 0 | blended 2 | unfiltered 713 | total 715
[20:48:32] libhb: work result = 0

Rip done!
HandBrake has exited.


 ############ End of Log ############## 

mduell
Veteran User
Posts: 6716
Joined: Sat Apr 21, 2007 8:54 pm

Re: Performance not as good as expected with Core i5-750

Post by mduell » Wed Feb 03, 2010 2:50 am

Likely because x264 Benchmark HD uses different encoding settings. Plenty of options you can change to increase framerate and decrease quality or increase filesize.

stmiller
Posts: 59
Joined: Thu Apr 12, 2007 8:16 pm

Re: Performance not as good as expected with Core i5-750

Post by stmiller » Fri Mar 05, 2010 5:07 pm

There are a zillion options with x264. It is overly complicated IMO.

So without knowing what options that Benchmark HD encoder is doing, what version of x264 they are using, how it was compiled, etc. even the slightest different x264 options will show a difference and not be a fair comparison.

(I'm not talking about frame rates and such. But the nitty gritty x264 options.)

[20:47:50] + encoder: x264
[20:47:50] + options: ref=3:bframes=4:subq=8:mixed-refs=0:8x8dct=0:trellis=1:analyse=all:deblock=-2,-1

User avatar
JohnAStebbins
HandBrake Team
Posts: 5464
Joined: Sat Feb 09, 2008 7:21 pm

Re: Performance not as good as expected with Core i5-750

Post by JohnAStebbins » Fri Mar 05, 2010 5:28 pm

He also didn't use the "turbo" first pass option which has a huge effect on the fist pass rate. And he failed to mention if the second pass was also slower.

Post Reply