093 -> 094 slow down

Post your testing results with HandBrake.
Post Reply
perwool
Posts: 10
Joined: Tue May 26, 2009 9:54 am

093 -> 094 slow down

Post by perwool »

Sorry about to tell that the speed of new version (0.9.4) significantly decreased on my PowerMac G5 Quad.

Machine Type: PowerMac G5 Quad/11GB/1000GB/ Mac OS X 10.5.8
CPU Speed: 4x 2.5 GHz
Number of CPUs 4
Rip Format: MP4
Encoder: x264
Video Size & settings: 480x368, deinterlace fast
Quality / Bit Rate: 600 kbps
1 or 2 Pass: 2 pass/turbo
Min/Max or Average Frames Per Second (FPS):

HB 0.9.3

[00:10:47] starting job
[00:10:47] + bitrate: 600 kbps, pass: 1
[00:16:36] work: average encoding speed for job is 89.607101 fps
[00:16:36] starting job
[00:16:36] + bitrate: 600 kbps, pass: 2
[00:24:50] work: average encoding speed for job is 63.514427 fps


HB 0.9.4

[23:09:22] starting job
[23:09:22] + bitrate: 600 kbps, pass: 1
[23:23:52] work: average encoding speed for job is 35.877914 fps
[23:23:53] starting job
[23:23:53] + bitrate: 600 kbps, pass: 2
[23:40:27] work: average encoding speed for job is 31.460678 fps

Ran at the same condition with the same input file, produced nearly the same size output file
(093: 109 307 286 bytes / 094: 109 850 664 bytes)

Looking at the Activity Monitor while encoding I noted the CPUs load was aproximately:
093: 375% / 094 250%

I used the precompiled binary files form downloaded disk images (.dmg)

Is there a chance to speed up the new v.0.9.4 by compiling myself?

A comment to GUI: it is more complicated to routine use and the Presets does not keep all the settings (e.g. the preset Deinterlace - fast always changes to Decomb)

I am going to compile the 0.9.4 CLI on my quad core Phenom to see if it is the common behavior. Than I give you a report.
User avatar
Rodeo
HandBrake Team
Posts: 12728
Joined: Tue Mar 03, 2009 8:55 pm

Re: 093 -> 094 slow down

Post by Rodeo »

Where are your logs in all this? You don't even specify which x264 settings you are using.

Regarding the deinterlace issue, there's a workaround: you have to make sure that Decomb is set to Off before you move the slider to Deinterlace. Otherwise, as you've noticed, the preset will save both the Decomb and Deinterlace settings, and Decomb will take precedence over Deinterlace.
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Re: 093 -> 094 slow down

Post by jbrjake »

0.9.4 is not slower than 0.9.3. Period. Don't make claims like this if you're not going to provide proof. The burden is on you.
perwool
Posts: 10
Joined: Tue May 26, 2009 9:54 am

Re: 093 -> 094 slow down

Post by perwool »

jbrjake wrote:0.9.4 is not slower than 0.9.3. Period. Don't make claims like this if you're not going to provide proof. The burden is on you.
I do not argue, I ask for help what am I doing wrong. As the time of encoding is aprox. two times longer and the CPUs load is about one half the result IS that the 0.9.4 is not slower measured by effitiency. I moved the source file onto a RAMdisk in ought to take out the measurement the disk operations. But why it does not use all CPU time available. Could it help to manually set the better nice? I do not run concurently any other application while encoding. I may try to kill some system called processes, but according the Application Monitor everything in active memory is nearly sleeping.

I am ready to help the developers with hard testing on my machine, which is now rather outdated but still powerful enough. I am ready to reinstal the Mac OS from the scratch to do tests on each system subversion available.

Do not account me as defamer, I am posting here (not elswere) to be helpful. In the other forums I recommend HandBrake more than 3 years and appreciate all its features as well as the continuity of CLI version.
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Re: 093 -> 094 slow down

Post by jbrjake »

if you were trying to be helpful you wouldn't be refusing requests for a complete activity log, as you promised to provide when you registered on this forum and been reminded to provide by a developer and a moderator. All you're doing is spreading FUD about the release because you can't be bothered to share your settings. You are just wasting time. Provide a log, and we can show how your testing is in error (hint: are you controlling for all the changes in default x264 settings between releases?).
perwool
Posts: 10
Joined: Tue May 26, 2009 9:54 am

Re: 093 -> 094 slow down

Post by perwool »

jbrjake wrote:... Provide a log, and we can show how your testing is in error (hint: are you controlling for all the changes in default x264 settings between releases?).
I prefere the CLI version on my Linux box, because in my bash script everything is clear. The GUI is helpful for cases when the video source has nonstandard dimensions and cropping. But on GUI the presets gave me nearly the same possibilities. I do not hide my logs, I simply do not want to waste space with them, in case there may be some primitive reason. As I tried to use the same presets, one could hope, the settings can be the same in both cases. In x264 params the only diference cna be found:

093:
[23:58:02] + options: ref=2:bframes=2:
subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0:ref=1:subme=1:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0

094:
[23:09:22] + options: ref=2:bframes=2:me=umh:
subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0:ref=1:subme=2:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0

Yes I cannot realize if it could have such heavy influence into CPU load and use. the whole logs are here:

094:

Code: Select all

[23:06:30] hb_init: checking cpu count
[23:06:30] hb_init: starting libhb thread
[23:06:30] macgui: Handbrake Version: 0.9.4 ppc (2009112300)
[23:06:30] hb_init: checking cpu count
[23:06:30] hb_init: starting libhb thread
[23:06:30] hb_init: checking cpu count
[23:06:30] hb_init: starting libhb thread
[23:07:30] macgui: trying to open video_ts folder (parent directory chosen)
[23:07:30] hb_scan: path=/Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg, title_index=0
[23:07:30] scan: trying to open with libdvdread
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[23:07:30] dvd: not a dvd - trying as a stream/file instead
[23:07:30] file is MPEG DVD Program Stream
[23:07:31] add_audio_to_title: added MPEG audio stream 0xc0
[23:07:32] scan: decoding previews for title 1
[23:07:32] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=192000 Unknown (MPEG) (2.0 ch)
[23:07:33] scan: 10 previews, 720x576, 25.000 fps, autocrop = 2/2/8/4, aspect 4:3, PAR 16:15
[23:07:33] scan: title (0) job->width:704, job->height:528
[23:07:33] libhb: scan thread found 1 valid title(s)
[23:09:18] macgui: Rip: Pending queue count is 1
[23:09:18] macgui: scanning specifically for title: 1
[23:09:18] macgui: performNewQueueScan currentQueueEncodeIndex is: 0
[23:09:18] hb_scan: path=/Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg, title_index=1
[23:09:18] scan: trying to open with libdvdread
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[23:09:18] dvd: not a dvd - trying as a stream/file instead
[23:09:19] file is MPEG DVD Program Stream
[23:09:20] add_audio_to_title: added MPEG audio stream 0xc0
[23:09:21] scan: decoding previews for title 1
[23:09:21] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=192000 Unknown (MPEG) (2.0 ch)
[23:09:22] scan: 10 previews, 720x576, 25.000 fps, autocrop = 2/2/8/4, aspect 4:3, PAR 16:15
[23:09:22] scan: title (0) job->width:704, job->height:528
[23:09:22] libhb: scan thread found 1 valid title(s)
[23:09:22] macgui: ScanDone state received from fQueueEncodeLibhb
[23:09:22] macgui: Preset: b 4:3 480x368
[23:09:22] macgui: processNewQueueEncode number of passes expected is: 2
[23:09:22] macgui: prepareJob exiting
[23:09:22] 2 job(s) to process
[23:09:22] starting job
[23:09:22] job configuration:
[23:09:22]  * source
[23:09:22]    + /Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg
[23:09:22]    + title 1, chapter(s) 1 to 1
[23:09:22]  * destination
[23:09:22]    + /Users/wr/Desktop/Ned a Stacey II (3) - pekařství.mp4
[23:09:22]    + container: MPEG-4 (.mp4 and .m4v)
[23:09:22]  * video track
[23:09:22]    + decoder: mpeg2
[23:09:22]      + bitrate 8200 kbps
[23:09:22]    + frame rate: same as source (around 25.000 fps)
[23:09:22]    + dimensions: 720 * 576 -> 480 * 368, crop 2/2/8/4
[23:09:22]    + filter
[23:09:22]      + Deinterlace (ffmpeg or yadif/mcdeint) (-1)
[23:09:22]    + encoder: x264
[23:09:22]      + options: ref=2:bframes=2:me=umh:subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0:ref=1:subme=2:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0
[23:09:22]      + bitrate: 600 kbps, pass: 1
[23:09:22]  * audio track 0
[23:09:22]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[23:09:22]    + mixdown: Stereo
[23:09:22]    + dynamic range compression: 1.000000
[23:09:22]    + encoder: ca_aac
[23:09:22]      + bitrate: 96 kbps, samplerate: 44100 Hz
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[23:09:22] dvd: not a dvd - trying as a stream/file instead
x264 [info]: using cpu capabilities: Altivec
x264 [info]: profile Main, level 2.1
[23:09:22] reader: first SCR 146 id 224 DTS 17757
[23:09:22] mpeg2: "" (1) at frame 0 time 10800
[23:09:23] sync: expecting 30914 video frames
[23:09:23] sync: first pts is 10800
[23:09:23] sync: adding 88 ms of silence to audio 0  start 14400, next 6480
[23:09:27] sync: audio 0 time went backwards 0 ms, dropped 1 frames (next 560880, current 560880)
[23:23:51] reader: done. 0 scr changes
[23:23:52] sync: got 31258 frames, 30914 expected
[23:23:52] work: average encoding speed for job is 35.877914 fps
[23:23:53] mpeg2 done: 31259 frames
[23:23:53] render: lost time: 0 (0 frames)
[23:23:53] render: gained time: 0 (0 frames) (0 not accounted for)
[23:23:53] encx264: 1 frames had to be split (31258 in, 31310 out)
x264 [info]: frame I:240   Avg QP:20.59  size: 25776  PSNR Mean Y:43.11 U:45.29 V:45.93 Avg:43.78 Global:43.36
x264 [info]: frame P:13585 Avg QP:23.30  size:  5510  PSNR Mean Y:40.29 U:43.03 V:43.61 Avg:41.07 Global:40.55
x264 [info]: frame B:17434 Avg QP:27.32  size:   719  PSNR Mean Y:39.62 U:42.90 V:43.67 Avg:40.52 Global:40.00
x264 [info]: consecutive B-frames:  3.3% 49.5% 47.2%
x264 [info]: mb I  I16..4: 15.8%  0.0% 84.2%
x264 [info]: mb P  I16..4:  8.5%  0.0%  0.0%  P16..4: 73.0%  0.0%  0.0%  0.0%  0.0%    skip:18.5%
x264 [info]: mb B  I16..4:  0.5%  0.0%  0.0%  B16..8: 14.2%  0.0%  0.0%  direct: 6.7%  skip:78.5%  L0:22.3% L1:45.1% BI:32.6%
x264 [info]: final ratefactor: 21.70
x264 [info]: coded y,uvDC,uvAC intra: 66.0% 65.4% 33.7% inter: 19.9% 14.9% 1.7%
x264 [info]: i16 v,h,dc,p: 49% 17% 19% 15%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 32% 15% 11%  6%  7%  9%  6%  8%  6%
x264 [info]: Weighted P-Frames: Y:0.0%
x264 [info]: SSIM Mean Y:0.9707554
x264 [info]: PSNR Mean Y:39.941 U:42.975 V:43.664 Avg:40.782 Global:40.254 kb/s:598.75
[23:23:53] mp2-decoder done: 0 frames, 0 decoder errors, 0 drops
[23:23:53] starting job
[23:23:53] job configuration:
[23:23:53]  * source
[23:23:53]    + /Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg
[23:23:53]    + title 1, chapter(s) 1 to 1
[23:23:53]  * destination
[23:23:53]    + /Users/wr/Desktop/Ned a Stacey II (3) - pekařství.mp4
[23:23:53]    + container: MPEG-4 (.mp4 and .m4v)
[23:23:53]  * video track
[23:23:53]    + decoder: mpeg2
[23:23:53]      + bitrate 8200 kbps
[23:23:53]    + frame rate: same as source (around 25.000 fps)
[23:23:53]    + dimensions: 720 * 576 -> 480 * 368, crop 2/2/8/4
[23:23:53]    + filter
[23:23:53]      + Deinterlace (ffmpeg or yadif/mcdeint) (-1)
[23:23:53]    + encoder: x264
[23:23:53]      + options: ref=2:bframes=2:me=umh:subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0
[23:23:53]      + bitrate: 600 kbps, pass: 2
[23:23:53]  * audio track 0
[23:23:53]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[23:23:53]    + mixdown: Stereo
[23:23:53]    + dynamic range compression: 1.000000
[23:23:53]    + encoder: ca_aac
[23:23:53]      + bitrate: 96 kbps, samplerate: 44100 Hz
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[23:23:53] dvd: not a dvd - trying as a stream/file instead
x264 [info]: using cpu capabilities: Altivec
[23:23:53] reader: first SCR 146 id 224 DTS 17757
[23:23:53] mpeg2: "" (1) at frame 0 time 10800
x264 [info]: profile Main, level 2.1
[23:23:55] sync: expecting 31258 video frames
[23:23:55] sync: first pts is 10800
[23:23:55] sync: adding 88 ms of silence to audio 0  start 14400, next 6480
[23:24:00] sync: audio 0 time went backwards 0 ms, dropped 1 frames (next 560880, current 560880)
[23:40:25] reader: done. 0 scr changes
[23:40:27] sync: got 31258 frames, 31258 expected
[23:40:27] work: average encoding speed for job is 31.460678 fps
[23:40:28] mux: track 0, 31259 frames, 93772189 bytes, 599.95 kbps, fifo 64
[23:40:28] mux: track 1, 53858 frames, 15443310 bytes, 98.81 kbps, fifo 256
[23:40:28] mpeg2 done: 31259 frames
[23:40:28] render: lost time: 0 (0 frames)
[23:40:28] render: gained time: 0 (0 frames) (0 not accounted for)
[23:40:28] encx264: 1 frames had to be split (31258 in, 31264 out)
x264 [info]: frame I:240   Avg QP:20.75  size: 26507  PSNR Mean Y:43.01 U:46.24 V:46.90 Avg:43.89 Global:43.58
x264 [info]: frame P:13585 Avg QP:23.12  size:  5483  PSNR Mean Y:40.64 U:43.91 V:44.66 Avg:41.53 Global:41.20
x264 [info]: frame B:17434 Avg QP:26.54  size:   742  PSNR Mean Y:39.90 U:43.55 V:44.55 Avg:40.88 Global:40.53
x264 [info]: consecutive B-frames:  3.3% 49.5% 47.2%
x264 [info]: mb I  I16..4: 11.1%  0.0% 88.9%
x264 [info]: mb P  I16..4:  0.7%  0.0%  3.3%  P16..4: 50.3% 19.1% 11.4%  0.0%  0.0%    skip:15.2%
x264 [info]: mb B  I16..4:  1.0%  0.0%  0.3%  B16..8: 13.2%  1.4%  0.8%  direct: 6.6%  skip:76.7%  L0:24.6% L1:47.2% BI:28.2%
x264 [info]: coded y,uvDC,uvAC intra: 75.4% 83.9% 58.2% inter: 16.9% 21.5% 3.1%
x264 [info]: i16 v,h,dc,p: 51% 14% 20% 16%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 32% 13% 14%  6%  7%  9%  5%  8%  5%
x264 [info]: Weighted P-Frames: Y:0.0%
x264 [info]: ref P L0: 64.2% 15.2% 20.6%
x264 [info]: SSIM Mean Y:0.9723431
x264 [info]: PSNR Mean Y:40.244 U:43.730 V:44.615 Avg:41.187 Global:40.825 kb/s:599.97
[23:40:28] mp2-decoder done: 0 frames, 0 decoder errors, 0 drops
[23:40:28] libhb: work result = 0
[23:40:28] macgui: incrementQueueItemDone currentQueueEncodeIndex is incremented to: 1
[23:40:28] macgui: incrementQueueItemDone the 0 item queue is complete

093:

Code: Select all

[23:52:45] macgui: Handbrake Version: 0.9.3 (2008112300)
[23:52:45] hb_init: checking cpu count
[23:52:45] hb_init: starting libhb thread
[23:52:45] hb_init: checking cpu count
[23:52:45] hb_init: starting libhb thread
[23:52:50] macgui: Rip: Pending queue count is 1
[23:52:50] macgui: scanning specifically for title: 1
[23:52:50] macgui: performNewQueueScan currentQueueEncodeIndex is: 0
[23:52:50] hb_scan: path=/Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg, title_index=1
[23:52:50] scan: trying to open with libdvdread
[23:52:50] dvd: not a dvd - trying as a stream/file instead
[23:52:50] file is MPEG DVD Program Stream
[23:52:51] add_audio_to_title: added MPEG audio stream 0xc0
[23:52:52] scan: decoding previews for title 1
[23:52:52] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=384000 Unknown (MPEG) (2.0 ch)
[23:52:52] scan: 10 previews, 720x576, 25.000 fps, autocrop = 2/2/8/4, aspect 4:3, PAR 16:15
[23:52:52] scan: title (0) job->width:704, job->height:528
[23:52:52] libhb: scan thread found 1 valid title(s)
[23:52:52] macgui: currentScanCount received from fQueueEncodeLibhb
[23:52:52] macgui: ScanDone state received from fQueueEncodeLibhb
[23:52:52] macgui: processNewQueueEncode title list is: 1
[23:52:52] macgui: Preset: b 4:3 480x368
[23:52:52] macgui: processNewQueueEncode number of passes expected is: 2
[23:52:52] macgui: prepareJob exiting
[23:52:52] 2 job(s) to process
[23:52:52] starting job
GUI ERROR dialog: Invalid audio codec: 0x10000
[23:52:52] libhb: work result = 0
[23:52:53] macgui: incrementQueueItemDone currentQueueEncodeIndex is incremented to: 1
[23:52:53] macgui: incrementQueueItemDone the 0 item queue is complete
[23:54:44] macgui: trying to open video_ts folder (parent directory chosen)
[23:54:44] hb_scan: path=/Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg, title_index=0
[23:54:44] scan: trying to open with libdvdread
[23:54:44] dvd: not a dvd - trying as a stream/file instead
[23:54:44] file is MPEG DVD Program Stream
[23:54:44] add_audio_to_title: added MPEG audio stream 0xc0
[23:54:45] scan: decoding previews for title 1
[23:54:45] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=384000 Unknown (MPEG) (2.0 ch)
[23:54:45] scan: 10 previews, 720x576, 25.000 fps, autocrop = 2/2/8/4, aspect 4:3, PAR 16:15
[23:54:45] scan: title (0) job->width:704, job->height:528
[23:54:45] libhb: scan thread found 1 valid title(s)
[23:54:46] macgui: ScanDone state received from fHandle
[23:57:18] macgui: Rip: Pending queue count is 0
[23:57:18] macgui: Rip: No pending jobs, so sending this one to doAddToQueue
[23:57:18] macgui: Rip: Going right to performNewQueueScan
[23:57:18] macgui: scanning specifically for title: 1
[23:57:18] macgui: performNewQueueScan currentQueueEncodeIndex is: 1
[23:57:18] hb_scan: path=/Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg, title_index=1
[23:57:18] scan: trying to open with libdvdread
[23:57:18] dvd: not a dvd - trying as a stream/file instead
[23:57:18] file is MPEG DVD Program Stream
[23:57:18] add_audio_to_title: added MPEG audio stream 0xc0
[23:57:19] scan: decoding previews for title 1
[23:57:19] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=384000 Unknown (MPEG) (2.0 ch)
[23:57:19] scan: 10 previews, 720x576, 25.000 fps, autocrop = 2/2/8/4, aspect 4:3, PAR 16:15
[23:57:19] scan: title (0) job->width:704, job->height:528
[23:57:19] libhb: scan thread found 1 valid title(s)
[23:57:19] macgui: currentScanCount received from fQueueEncodeLibhb
[23:57:19] macgui: ScanDone state received from fQueueEncodeLibhb
[23:57:19] macgui: processNewQueueEncode title list is: 1
[23:57:19] macgui: Preset: Custom
[23:57:19] macgui: processNewQueueEncode number of passes expected is: 2
[23:57:19] macgui: prepareJob exiting
[23:57:19] 3 job(s) to process
[23:57:19] starting job
GUI ERROR dialog: Invalid audio codec: 0x10000
[23:57:19] libhb: work result = 0
[23:57:20] macgui: incrementQueueItemDone currentQueueEncodeIndex is incremented to: 2
[23:57:20] macgui: incrementQueueItemDone the 1 item queue is complete
[23:57:37] macgui: removeQueueFileItem: Removing a cancelled/finished encode, decrement currentQueueEncodeIndex to 1
[23:57:38] macgui: removeQueueFileItem: Removing a cancelled/finished encode, decrement currentQueueEncodeIndex to 0
[23:58:01] macgui: Rip: Pending queue count is 1
[23:58:01] macgui: scanning specifically for title: 1
[23:58:01] macgui: performNewQueueScan currentQueueEncodeIndex is: 0
[23:58:01] hb_scan: path=/Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg, title_index=1
[23:58:01] scan: trying to open with libdvdread
[23:58:01] dvd: not a dvd - trying as a stream/file instead
[23:58:01] file is MPEG DVD Program Stream
[23:58:01] add_audio_to_title: added MPEG audio stream 0xc0
[23:58:02] scan: decoding previews for title 1
[23:58:02] scan: audio 0xc0: mp2, rate=48000Hz, bitrate=384000 Unknown (MPEG) (2.0 ch)
[23:58:02] scan: 10 previews, 720x576, 25.000 fps, autocrop = 2/2/8/4, aspect 4:3, PAR 16:15
[23:58:02] scan: title (0) job->width:704, job->height:528
[23:58:02] libhb: scan thread found 1 valid title(s)
[23:58:02] macgui: currentScanCount received from fQueueEncodeLibhb
[23:58:02] macgui: ScanDone state received from fQueueEncodeLibhb
[23:58:02] macgui: processNewQueueEncode title list is: 1
[23:58:02] macgui: Preset: Custom
[23:58:02] macgui: processNewQueueEncode number of passes expected is: 2
[23:58:02] macgui: prepareJob exiting
[23:58:02] 4 job(s) to process
[23:58:02] starting job
[23:58:02] job configuration:
[23:58:02]  * source
[23:58:02]    + /Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg
[23:58:02]    + title 1, chapter(s) 1 to 1
[23:58:02]  * destination
[23:58:02]    + /Users/wr/Desktop/Ned a Stacey II (3) - pekařství.mp4
[23:58:02]    + container: MPEG-4 (.mp4 and .m4v)
[23:58:02]  * video track
[23:58:02]    + decoder: mpeg2
[23:58:02]      + bitrate 8200 kbps
[23:58:02]    + frame rate: same as source (around 25.000 fps)
[23:58:02]    + dimensions: 720 * 576 -> 480 * 368, crop 2/2/8/4
[23:58:02]    + filter
[23:58:02]      + Deinterlace (ffmpeg or yadif/mcdeint) (-1)
[23:58:02]    + encoder: x264
[23:58:02]      + options: ref=2:bframes=2:subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0:ref=1:subme=1:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0
[23:58:02]      + bitrate: 600 kbps, pass: 1
[23:58:02]  * audio track 0
[23:58:02]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[23:58:02]    + mixdown: Stereo
[23:58:02]    + encoder: faac
[23:58:02]      + bitrate: 128 kbps, samplerate: 48000 Hz
[23:58:02] dvd: not a dvd - trying as a stream/file instead
[23:58:02] reader: first SCR 146
[23:58:02] mpeg2: "" (1) at frame 0 time 10800
x264 [info]: using cpu capabilities: Altivec
x264 [info]: profile Main, level 2.1
[23:58:02] sync: expecting 31523 video frames
[23:58:02] sync: first pts is 10800
[23:58:02] sync: adding 88 ms of silence to audio 0  start 14400, next 6480
[23:58:03] sync: audio 0 time went backwards 0 ms, dropped 1 frames (next 560880, current 560880)
[00:03:21] reader: done. 0 scr changes
[00:03:21] sync: got 31258 frames, 31523 expected
[00:03:21] work: average encoding speed for job is 98.034164 fps
[00:03:22] mpeg2 done: 31259 frames
[00:03:22] render: lost time: 0 (0 frames)
[00:03:22] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: slice I:239   Avg QP:21.53  size: 22488  PSNR Mean Y:41.93 U:44.47 V:45.00 Avg:42.67 Global:42.19
x264 [info]: slice P:11942 Avg QP:23.39  size:  5357  PSNR Mean Y:39.66 U:42.68 V:43.12 Avg:40.47 Global:39.82
x264 [info]: slice B:19080 Avg QP:25.93  size:  1289  PSNR Mean Y:38.92 U:42.35 V:42.86 Avg:39.82 Global:39.22
x264 [info]: consecutive B-frames:  5.4%  9.4% 85.2%
x264 [info]: mb I  I16..4: 12.4%  0.0% 87.6%
x264 [info]: mb P  I16..4:  9.0%  0.0%  0.0%  P16..4: 76.0%  0.0%  0.0%  0.0%  0.0%    skip:15.0%
x264 [info]: mb B  I16..4:  0.7%  0.0%  0.0%  B16..8: 20.3%  0.0%  0.0%  direct:15.7%  skip:63.2%  L0:29.8% L1:50.2% BI:20.0%
x264 [info]: final ratefactor: 23.44
x264 [info]: SSIM Mean Y:0.9671272
x264 [info]: PSNR Mean Y:39.227 U:42.494 V:42.974 Avg:40.091 Global:39.457 kb/s:600.98
[00:03:22] mp2-decoder done: 0 frames, 0 decoder errors, 0 drops
[00:03:22] starting job
[00:03:22] job configuration:
[00:03:22]  * source
[00:03:22]    + /Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg
[00:03:22]    + title 1, chapter(s) 1 to 1
[00:03:22]  * destination
[00:03:22]    + /Users/wr/Desktop/Ned a Stacey II (3) - pekařství.mp4
[00:03:22]    + container: MPEG-4 (.mp4 and .m4v)
[00:03:22]  * video track
[00:03:22]    + decoder: mpeg2
[00:03:22]      + bitrate 8200 kbps
[00:03:22]    + frame rate: same as source (around 25.000 fps)
[00:03:22]    + dimensions: 720 * 576 -> 480 * 368, crop 2/2/8/4
[00:03:22]    + filter
[00:03:22]      + Deinterlace (ffmpeg or yadif/mcdeint) (-1)
[00:03:22]    + encoder: x264
[00:03:22]      + options: ref=2:bframes=2:subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0
[00:03:22]      + bitrate: 600 kbps, pass: 2
[00:03:22]  * audio track 0
[00:03:22]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[00:03:22]    + mixdown: Stereo
[00:03:22]    + encoder: faac
[00:03:22]      + bitrate: 128 kbps, samplerate: 48000 Hz
[00:03:22] dvd: not a dvd - trying as a stream/file instead
x264 [info]: using cpu capabilities: Altivec
[00:03:22] reader: first SCR 146
[00:03:22] mpeg2: "" (1) at frame 0 time 10800
x264 [info]: profile Main, level 2.1
[00:03:24] sync: expecting 31523 video frames
[00:03:24] sync: first pts is 10800
[00:03:24] sync: adding 88 ms of silence to audio 0  start 14400, next 6480
[00:03:25] sync: audio 0 time went backwards 0 ms, dropped 1 frames (next 560880, current 560880)
[00:10:45] reader: done. 0 scr changes
[00:10:46] sync: got 31258 frames, 31523 expected
[00:10:46] work: average encoding speed for job is 70.636307 fps
[00:10:47] mpeg2 done: 31259 frames
[00:10:47] render: lost time: 0 (0 frames)
[00:10:47] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: slice I:239   Avg QP:20.83  size: 25040  PSNR Mean Y:42.50 U:45.90 V:46.47 Avg:43.41 Global:43.08
x264 [info]: slice P:11944 Avg QP:23.18  size:  5257  PSNR Mean Y:40.06 U:43.56 V:44.17 Avg:40.99 Global:40.55
x264 [info]: slice B:19078 Avg QP:25.00  size:  1310  PSNR Mean Y:39.42 U:43.19 V:43.90 Avg:40.40 Global:39.97
x264 [info]: consecutive B-frames:  5.4%  9.4% 85.2%
x264 [info]: mb I  I16..4:  7.8%  0.0% 92.2%
x264 [info]: mb P  I16..4:  0.7%  0.0%  4.2%  P16..4: 53.1% 17.1% 12.7%  0.0%  0.0%    skip:12.0%
x264 [info]: mb B  I16..4:  2.3%  0.0%  0.0%  B16..8: 23.6%  2.4%  1.4%  direct:12.0%  skip:58.4%  L0:26.2% L1:51.9% BI:21.9%
x264 [info]: ref P L0  77.2% 22.8%
x264 [info]: SSIM Mean Y:0.9705045
x264 [info]: PSNR Mean Y:39.690 U:43.350 V:44.022 Avg:40.646 Global:40.203 kb/s:599.96
[00:10:47] mp2-decoder done: 0 frames, 0 decoder errors, 0 drops
[00:10:47] starting job
[00:10:47] job configuration:
[00:10:47]  * source
[00:10:47]    + /Volumes/wr/film/macek/!vimky/mpg/Ned a Stacey II (3) - pekařství.mpg
[00:10:47]    + title 1, chapter(s) 1 to 1
[00:10:47]  * destination
[00:10:47]    + /Users/wr/Desktop/Ned a Stacey II (3) - pekařství.mp4
[00:10:47]    + container: MPEG-4 (.mp4 and .m4v)
[00:10:47]  * video track
[00:10:47]    + decoder: mpeg2
[00:10:47]      + bitrate 8200 kbps
[00:10:47]    + frame rate: same as source (around 25.000 fps)
[00:10:47]    + dimensions: 720 * 576 -> 480 * 368, crop 2/2/8/4
[00:10:47]    + filter
[00:10:47]      + Deinterlace (ffmpeg or yadif/mcdeint) (-1)
[00:10:47]    + encoder: x264
[00:10:47]      + options: ref=2:bframes=2:subq=6:mixed-refs=0:weightb=0:8x8dct=0:trellis=0:ref=1:subme=1:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0
[00:10:47]      + bitrate: 600 kbps, pass: 1
[00:10:47]  * audio track 0
[00:10:47]    + decoder: Unknown (MPEG) (2.0 ch) (track 1, id c0)
[00:10:47]    + mixdown: Stereo
[00:10:47]    + encoder: faac
[00:10:47]      + bitrate: 96 kbps, samplerate: 44100 Hz
[00:10:47] dvd: not a dvd - trying as a stream/file instead
x264 [info]: using cpu capabilities: Altivec
x264 [info]: profile Main, level 2.1
[00:10:47] sync: expecting 31523 video frames
[00:10:47] reader: first SCR 146
[00:10:47] mpeg2: "" (1) at frame 0 time 10800
[00:10:47] sync: adding 88 ms of silence to audio 0  start 14400, next 6480
[00:10:47] sync: first pts is 10800
[00:10:48] sync: audio 0 time went backwards 0 ms, dropped 1 frames (next 560880, current 560880)
Now I am going to restart the machine, clean up the preferences prepare the identical preferences (including decomb off as adviced by Rodeo-thanks), and then, after some quarters of an hour I will log again and tell you my results.

Thank for your your patiency
Last edited by Rodeo on Sun Nov 29, 2009 7:44 pm, edited 1 time in total.
Reason: Please enclose Activity Logs in [code] blocks
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Re: 093 -> 094 slow down

Post by jbrjake »

...as expected, you are *not* comparing equivalent settings. Why have you left weight-p enabled in 0.9.4?
perwool
Posts: 10
Joined: Tue May 26, 2009 9:54 am

Re: 093 -> 094 slow down

Post by perwool »

jbrjake wrote:...as expected, you are *not* comparing equivalent settings. Why have you left weight-p enabled in 0.9.4?
Yes, I am not such a gu-ru of x264 option, neither got an information about changes in default option settings. I simply supposed, that updating to new version does not destroy my presets.

The nicer and nicer GUI is very suitable for experimental work, x264 Advanced setting gives a nice preview of option string, but giving the option string does not set the parameters to those wanted, and it is hardly to find the default option string. I am not in doubt about your high qualification about the x264 encoder, but sorry for opinion based on my experience: the slow down was observed, weight-p enabled or not.

I always start to use the program with reading the available documentation, hence I read the NEWS. But warning about 50% slow down due to new defaults was not included.
Post Reply