With upcoming changes to data protection and privacy laws in Europe coming into effect soon, we thought this would be a good time to remind everyone that we do have a privacy policy.
This applies to all users and visitors world-wide.

We have made a few changes to the language to make it clearer in relation to this new regulation but fundamentally, the terms and your rights are unchanged.

If you have any questions about this, please feel free to ask in the General Forum

HandBrake freezing on HDML Cloner Box transcode

Discuss encoding for devices and presets.
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
discless
Regular User
Posts: 114
Joined: Tue Oct 21, 2008 4:47 am

HandBrake freezing on HDML Cloner Box transcode

Post by discless » Mon Feb 26, 2018 1:41 am

Description of problem or question
HDML Cloner Box is transcoding a 1 hour 53 minute 720p content to a mp4 file. I am attempting to transcode it to Apple 720p30 Surround with the 2nd audio track turned off, since it is only 2 channel audio

Steps to reproduce the problem (If Applicable)


HandBrake version (e.g., 1.0.0)
1.07

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.3 High Sierra, Windows 10 Creators Update)
High Sierra 10.13.3

Error message text or screenshot (If Applicable)
None; it just freezes at 2.8% however if I attempt a Force Quit, it does NOT say that HandBrake is frozen. I have left this going overnight and it just remains frozen at this step. Everything looks "normal" on HandBrake, but it just does not move to the next iteration. I have tried to regenerate the original HDML Cloner Box file and the problem repeats. And actually HandBrake can do a normal Quit.
Provide a URL from any image hosting site.

HandBrake Activity Log ***required*** (see How-to get an activity log)

Use any pastebin website and provide the URL it generates
- or -

Code: Select all

[17:12:16] macgui: Handbrake Version: 1.0.7  (2017040900)
[17:12:16] hb_init: starting libhb thread
[17:12:16] hb_init: starting libhb thread
[17:12:28] macgui: trying to open a folder or file
[17:12:28] macgui: ScanCore scanning titles with a duration of 10 seconds or more
[17:12:28] CPU: Intel(R) Core(TM) i5-2415M CPU @ 2.30GHz
[17:12:28]  - Intel microarchitecture Sandy Bridge
[17:12:28]  - logical processor count: 4
[17:12:28] hb_scan: path=/Users/michaelxxxxx/Desktop/Encode_26.mp4, title_index=0
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:274: failed opening UDF image /Users/michaelxxxxx/Desktop/Encode_26.mp4
disc.c:352: error opening file BDMV/index.bdmv
disc.c:352: error opening file BDMV/BACKUP/index.bdmv
[17:12:28] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[17:12:28] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Users/michaelxxxxx/Desktop/Encode_26.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: qt  
  Duration: 01:53:05.37, start: 0.000000, bitrate: 9585 kb/s
    Stream #0:0(eng): Audio: aac [mp4a / 0x6134706D]
      48000 Hz, stereo, fltp, 186 kb/s (default)
    Metadata:
      handler_name    : SoundHandler
    Stream #0:1(eng): Video: h264 (Constrained Baseline) [avc1 / 0x31637661]
      yuv420p, 1280x720, 9387 kb/s
      59.94 fps, 60k tbn (default)
    Metadata:
      handler_name    : VideoHandler
[17:12:28] scan: decoding previews for title 1
[17:12:28] scan: audio 0x0: aac, rate=48000Hz, bitrate=186573 English (AAC) (2.0 ch)
[17:12:31] scan: 10 previews, 1280x720, 59.663 fps, autocrop = 0/0/8/8, aspect 16:9, PAR 1:1
[17:12:31] libhb: scan thread found 1 valid title(s)
[17:12:31] macgui: ScanCore scan done
[17:13:01] macgui: QueueCore scanning specifically for title: 1
[17:13:01] CPU: Intel(R) Core(TM) i5-2415M CPU @ 2.30GHz
[17:13:01]  - Intel microarchitecture Sandy Bridge
[17:13:01]  - logical processor count: 4
[17:13:01] hb_scan: path=/Users/michaelxxxxx/Desktop/Encode_26.mp4, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:274: failed opening UDF image /Users/michaelxxxxx/Desktop/Encode_26.mp4
disc.c:352: error opening file BDMV/index.bdmv
disc.c:352: error opening file BDMV/BACKUP/index.bdmv
[17:13:01] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 5.0.1
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[17:13:01] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Users/michaelxxxxx/Desktop/Encode_26.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: qt  
  Duration: 01:53:05.37, start: 0.000000, bitrate: 9585 kb/s
    Stream #0:0(eng): Audio: aac [mp4a / 0x6134706D]
      48000 Hz, stereo, fltp, 186 kb/s (default)
    Metadata:
      handler_name    : SoundHandler
    Stream #0:1(eng): Video: h264 (Constrained Baseline) [avc1 / 0x31637661]
      yuv420p, 1280x720, 9387 kb/s
      59.94 fps, 60k tbn (default)
    Metadata:
      handler_name    : VideoHandler
[17:13:01] scan: decoding previews for title 1
[17:13:01] scan: audio 0x0: aac, rate=48000Hz, bitrate=186573 English (AAC) (2.0 ch)
[17:13:03] scan: 10 previews, 1280x720, 59.663 fps, autocrop = 0/0/8/8, aspect 16:9, PAR 1:1
[17:13:03] libhb: scan thread found 1 valid title(s)
[17:13:03] macgui: QueueCore scan done
[17:13:03] macgui: QueueCore started encoding [Classified].mp4
[17:13:03] 1 job(s) to process
[17:13:03] macgui: QueueCore with preset Apple 720p30 Surround
[17:13:03] starting job
[17:13:03] decomb filter thread started for segment 0
[17:13:03] decomb filter thread started for segment 1
[17:13:03] decomb filter thread started for segment 2
[17:13:03] decomb filter thread started for segment 3
[17:13:03] decomb check thread started for segment 0
[17:13:03] decomb check thread started for segment 1
[17:13:03] decomb check thread started for segment 2
[17:13:03] decomb check thread started for segment 3
[17:13:03] mask filter thread started for segment 0
[17:13:03] mask filter thread started for segment 1
[17:13:03] mask filter thread started for segment 2
[17:13:03] mask filter thread started for segment 3
[17:13:03] mask erode thread started for segment 0
[17:13:03] mask erode thread started for segment 1
[17:13:03] mask erode thread started for segment 2
[17:13:03] mask erode thread started for segment 3
[17:13:03] mask dilate thread started for segment 1
[17:13:03] mask dilate thread started for segment 0
[17:13:03] mask dilate thread started for segment 2
[17:13:03] mask dilate thread started for segment 3
[17:13:03] yadif thread started for segment 0
[17:13:03] yadif thread started for segment 1
[17:13:03] yadif thread started for segment 2
[17:13:03] yadif thread started for segment 3
[17:13:03] work: only 1 chapter, disabling chapter markers
[17:13:03] job configuration:
[17:13:03]  * source
[17:13:03]    + /Users/michaelxxxxx/Desktop/Encode_26.mp4
[17:13:03]    + title 1, chapter(s) 1 to 1
[17:13:03]    + container: mov,mp4,m4a,3gp,3g2,mj2
[17:13:03]    + data rate: 9585 kbps
[17:13:03]  * destination
[17:13:03]    + /Volumes/Macintosh HD/Videos/[Classified].mp4
[17:13:03]    + container: MPEG-4 (libavformat)
[17:13:03]  * video track
[17:13:03]    + decoder: h264
[17:13:03]      + bitrate 9387 kbps
[17:13:03]    + filters
[17:13:03]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[17:13:03]      + Decomb (mode=39)
[17:13:03]      + Framerate Shaper (mode=2:rate=27000000/900000)
[17:13:03]        + frame rate: 59.663 fps -> peak rate limited to 30.000 fps
[17:13:03]      + Crop and Scale (width=1264:height=720:crop-top=0:crop-bottom=0:crop-left=8:crop-right=8)
[17:13:03]        + source: 1280 * 720, crop (0/0/8/8): 1264 * 720, scale: 1264 * 720
[17:13:03]    + Output geometry
[17:13:03]      + storage dimensions: 1264 x 720
[17:13:03]      + pixel aspect ratio: 1 : 1
[17:13:03]      + display dimensions: 1264 x 720
[17:13:03]    + encoder: H.264 (libx264)
[17:13:03]      + preset:  medium
[17:13:03]      + profile: high
[17:13:03]      + level:   3.1
[17:13:03]      + quality: 21.00 (RF)
[17:13:03]  * audio track 1
[17:13:03]    + decoder: English (AAC) (2.0 ch) (track 1, id 0x0)
[17:13:03]      + bitrate: 186 kbps, samplerate: 48000 Hz
[17:13:03]    + mixdown: Stereo
[17:13:03]    + encoder: AAC (Apple AudioToolbox)
[17:13:03]      + bitrate: 160 kbps, samplerate: 48000 Hz
[17:13:03] sync: expecting 404833 video frames
[17:13:03] encx264: min-keyint: 30, keyint: 300
[17:13:03] encx264: encoding at constant RF 21.000000
[17:13:03] encx264: unparsed options: vbv-maxrate=17500:level=3.1:vbv-bufsize=17500
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
x264 [info]: profile High, level 3.1
[17:13:03] sync: first pts video is 0
[17:13:03] sync: "Chapter 1" (1) at frame 1 time 0
[17:13:03] sync: first pts audio 0x0 is 0

[code][/i]
Last edited by discless on Tue Feb 27, 2018 7:59 pm, edited 1 time in total.

Woodstock
Veteran User
Posts: 2561
Joined: Tue Aug 27, 2013 6:39 am

Re: HandBrake freezing on HDML Cloner Box transcode

Post by Woodstock » Mon Feb 26, 2018 2:36 pm

Does the same thing happen when you use the nightly build?

There are a LOT of things that change in the internals of the nightly builds, and it is very likely that your issue is fixed by one or more of them.

discless
Regular User
Posts: 114
Joined: Tue Oct 21, 2008 4:47 am

Re: HandBrake freezing on HDML Cloner Box transcode

Post by discless » Tue Feb 27, 2018 4:59 am

Could you explain to me the concept of the "nightly build" and how I would obtain it?

rollin_eng
Veteran User
Posts: 2755
Joined: Wed May 04, 2011 11:06 pm

Re: HandBrake freezing on HDML Cloner Box transcode

Post by rollin_eng » Tue Feb 27, 2018 8:13 am


discless
Regular User
Posts: 114
Joined: Tue Oct 21, 2008 4:47 am

Re: HandBrake freezing on HDML Cloner Box transcode

Post by discless » Tue Feb 27, 2018 8:02 pm

I tried the nightly and it froze at exactly the same point: 2.89%

I did the math and that means that something was suspect at 3 minutes 15 seconds into the video.

At that point I noticed a severe video and audio dropout from the digitization which was causing HandBrake to choke! I found two other such dropouts and am attempting to use HandBrake to transcode pieces from three separate "clean" files and then combine them back together.

Are there any good tools available on a Mac to combine the mp4 files back together? I also have access to Windows XP through Parallels.

Thank you for your help!

Woodstock
Veteran User
Posts: 2561
Joined: Tue Aug 27, 2013 6:39 am

Re: HandBrake freezing on HDML Cloner Box transcode

Post by Woodstock » Tue Feb 27, 2018 9:31 pm

You might try VideoRedo on Windows - there is a free trial and it is intended for fixing up damaged video streams.

discless
Regular User
Posts: 114
Joined: Tue Oct 21, 2008 4:47 am

Re: HandBrake freezing on HDML Cloner Box transcode

Post by discless » Tue Feb 27, 2018 9:50 pm

I will give it a shot, just to see what it can do, but perhaps it cannot recreate the missing damaged video/audio from the dropped out video/audio.

So what I have done is taken parts A, B & C from three digitizations that are partial but have these parts properly digitized.

Now I will use HandBrake to transcode all 3 of these parts and then I need to put them back together at the other end, so I have one complete file.

discless
Regular User
Posts: 114
Joined: Tue Oct 21, 2008 4:47 am

Re: HandBrake freezing on HDML Cloner Box transcode

Post by discless » Thu Mar 01, 2018 5:35 pm

HDML Cloner Box Customer Support also suggested I update the firmware and linked me to that process.

It would have been nice if they had suggested that two weeks ago when I purchased a replacement power supply from them!

We'll see how much this "smooth's out" the digitization process and removes the digital and audio glitches.

Their provided software did work to stitch together the three pieces into one (Windows) and HandBrake successfully transcoded for my AppleTV with about a half dozen glitches in the 1 hour 35 minute program.

Post Reply