Most complex settings to be used across iPod Touch & ATV

Discuss encoding for devices and presets.
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
iJoel
Regular User
Posts: 124
Joined: Sat Dec 20, 2008 7:25 am

Most complex settings to be used across iPod Touch & ATV

Post by iJoel »

-e x264 -q 20.0 -a 1 -E ca_aac -B 128 -6 dpl2 -R 48 -D 0.0 -f mp4 -X 720 --loose-anamorphic --decomb 1:2:6:9:80:16:16 --detelecine 1:1:4:4:0:0 -x cabac=1:ref=5:me=umh:b-adapt=2:weightb=0:trellis=1

I've been using these advanced settings for some time now.
Until now, I didn't realize that if the video was above a certain resolution
(I'm sure is a direct correlation to the bit rate, which I'm guessing is
problem) videos I encode get very distorted at certain parts, but only on the ATV.
The iPod Touch (3G 32GB) plays everything, perfectly. As does iTunes. And Front Row
plays some, and other's it just refuses to play the video (seems like a bug with Front Row,
since Quicktime X also plays everything perfectly).

So I was wondering what everyone else is using for their encodes to work across the iPod Touch 3G,
Apple TV, iTunes, Quicktime X, and Front Row.

I still can't believe that the iPod touch has become a better video player than the ATV, seriously.

Using: Handbrake - Version 0.9.4 x86_64, Snow Leopard. Latest ATV Software, iTunes 9.0.3




Update: I can't believe I missed this after all the reading up I did. I believe my problem
with the AppleTV is because I didn't add weightp=0 after the update as mentioned by Dynaflash.
I'll see if that will fix my Front Row problems as well ^_^.

SuperEricL
Posts: 39
Joined: Sat Jan 02, 2010 1:34 am

Re: Most complex settings to be used across iPod Touch & ATV

Post by SuperEricL »

I'm not sure why it would not work in Front Row. You may want to look here -> http://forum.handbrake.fr/viewtopic.php ... 4&start=50 it should give you some idea of what to use.

User avatar
Rodeo
HandBrake Team
Posts: 12401
Joined: Tue Mar 03, 2009 8:55 pm

Re: Most complex settings to be used across iPod Touch & ATV

Post by Rodeo »

iJoel wrote:--decomb 1:2:6:9:80:16:16

I've been using these advanced settings for some time now.
Just so you know, decomb defaults have changed. With this string, you're now using yadif only instead of alternating between yadif and blend based on combing intensity like in older versions (0.9.3).

The new defaults are detailed here:

http://trac.handbrake.fr/browser/tags/0 ... b/decomb.c

iJoel
Regular User
Posts: 124
Joined: Sat Dec 20, 2008 7:25 am

Re: Most complex settings to be used across iPod Touch & ATV

Post by iJoel »

SuperEricL wrote:I'm not sure why it would not work in Front Row. You may want to look here -> http://forum.handbrake.fr/viewtopic.php ... 4&start=50 it should give you some idea of what to use.
I believe my Front Row is very very corrupt. That's the only explanation. If I use settings from the post you mention. The video works on every device, except for, unfortunately, Front Row. It's not the biggest deal in the world. But it's a minor annoyance.
But my Front Row does a bunch of buggy things, like not syncing up with iTunes. I deleted three movies months ago, and yet they are all still there in Front Row lulz.
Rodeo wrote: Just so you know, decomb defaults have changed. With this string, you're now using yadif only instead of alternating between yadif and blend based on combing intensity like in older versions (0.9.3).
I replaced my values with the new defaults, dang, I'm so behind the times these days ;P.
Thank you very much ^_^.

SuperEricL
Posts: 39
Joined: Sat Jan 02, 2010 1:34 am

Re: Most complex settings to be used across iPod Touch & ATV

Post by SuperEricL »

Yeah. You may be able to figure out how to fix front row on google.

iJoel
Regular User
Posts: 124
Joined: Sat Dec 20, 2008 7:25 am

Re: Most complex settings to be used across iPod Touch & ATV

Post by iJoel »

SuperEricL wrote:Yeah. You may be able to figure out how to fix front row on google.

There was nothing on google about it. But I started messing around with settings
and the files. And it wasn't too hard to come up with the problem.
Front Row was/is playing the subtitle (closed captions) track that was
encoded along with the video in handbrake, instead of the video track.
It was a simple fix of opening the file in Subler and unchecking the enabled
check box. That allowed it to play in Front Row just fine, as well as allowed
iTunes to use the subtitle track if it wants to ^_^.

I guess now my main goal is to be able to accomplish a universal compatible file
without the need to manually edit it in Subler. So close.

Post Reply