Couldn't connect to accessibility bus

Discuss encoding for devices and presets.
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
darthshort
Posts: 1
Joined: Thu Mar 14, 2019 5:22 am

Couldn't connect to accessibility bus

Post by darthshort » Thu Mar 14, 2019 5:39 am

Description of problem or question:

[root@system7 sgi]# flatpak run fr.handbrake.ghb

** (ghb:2): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-j6SnrP6V15: Connection refused
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"

(ghb:2): GLib-GIO-CRITICAL **: g_dbus_proxy_new_sync: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

No source device available

Steps to reproduce the problem (If Applicable):

flatpak run fr.handbrake.ghb


HandBrake version (e.g., 1.0.0):

1.2.1 (x86_64


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

CentOS Linux release 7.6.1810 (Core)
Derived from Red Hat Enterprise Linux 7.6 (Source)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

CentOS Linux release 7.6.1810 (Core)
CentOS Linux release 7.6.1810 (Core)
cpe:/o:centos:centos:7



HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all


[root@system7 sgi]# cat /root/.var/app/fr.handbrake.ghb/config/ghb/Activity.log.2
[00:33:13] gtkgui: HandBrake 1.2.1 (2019021900) - Linux x86_64 - https://handbrake.fr
Cannot load libnvidia-encode.so.1
Cannot load libnvidia-encode.so.1
Cannot load libnvidia-encode.so.1
Cannot load libnvidia-encode.so.1
[00:33:13] hb_init: starting libhb thread
[00:33:13] hb_init: starting libhb thread
[00:33:13] hb_init: starting libhb thread

Please replace this text with the contents of your log file between the two code tags - OR -  provide a pastebin URL in place of these 3 lines.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5442
Joined: Sat Feb 09, 2008 7:21 pm

Re: Couldn't connect to accessibility bus

Post by JohnAStebbins » Fri Mar 15, 2019 10:10 pm

I'm not sure what that's all about. Are you able to run other flatpak apps on your system? I'm wondering if this is specific to HandBrake or if there is some other problem with flatpak in general on CentOS.

Post Reply