Bug on sound conversion

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Bug on sound conversion

Post by marinello56 »

I installed handbrake 0.9.2 and tried to convert a DVD movie in AVI: surprise, only the image is converted. No sound. I tried all sorts of settings, the result is always the same: there is no sound! I uninstalled version 0.9.2 to put the version 9.1: everything goes well, the sound is present. Do I have a BUG on version 9.2? Curious: nobody talks about them in the forum ! I have converted many films with version 9.1 and never have any problems. Too bad, because for me the 9.2 version has a big advantage: it keeps 2 tracks sound ... Can anyone help me?
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

have you tried another format ?
Cavalicious
Moderator
Posts: 1804
Joined: Mon Mar 26, 2007 12:07 am

Re: Bug on sound conversion

Post by Cavalicious »

How? What info are we suppose to by, other than fact that you think you have a bug?

Settings?
Source?
Activity Log?

Help us help you.

<moving from this forum to general...till proven otherwise>
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

no only AVI/MP3/stereo .
I selected a sound track of the DVD (VTS files extracted in a folder on hard-drive)
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

where is registred the LOG ? How can i post the "preset" file
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

Well, as we don't even know which platform you are on, if your on a mac the info you need is here:
http://trac.handbrake.fr/wiki/ActivityLog
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

Sorry. I work on Windows Xp
User avatar
s55
HandBrake Team
Posts: 9829
Joined: Sun Dec 24, 2006 1:05 pm

Re: Bug on sound conversion

Post by s55 »

Still an activity log window button on the toolbar.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

Code: Select all

[18:46:03] hb_init: checking cpu count
[18:46:03] hb_init: starting libhb thread
[18:46:03] thread ed2220 started ("libhb")
HandBrake 0.9.2 (2008022300) - http://handbrake.m0k.org/
1 CPU detected
Opening F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB...
[18:46:03] hb_scan: path=F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB, title_index=1
[18:46:03] scan: trying to open with libdvdread
ERROR: dvd: DVDOpen failed (F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB)[18:46:03] file is MPEG Program Stream
[18:46:03] hb_sample_pts: pts 370800 at 2328576
[18:46:03] hb_sample_pts: pts 950400 at 6569984
[18:46:03] hb_sample_pts: pts 1371600 at 10516480
[18:46:03] hb_sample_pts: pts 1897200 at 14503936
[18:46:03] thread ed23a8 started ("scan")
[18:46:03] hb_sample_pts: pts 2437200 at 18888704
[18:46:03] hb_sample_pts: pts 2908800 at 22767616
[18:46:03] hb_sample_pts: pts 3495600 at 27127808
[18:46:03] hb_sample_pts: pts 4035600 at 31158272
[18:46:03] hb_sample_pts: pts 4640400 at 35366912
[18:46:03] hb_sample_pts: pts 5173200 at 39485440
[18:46:03] hb_sample_pts: pts 5749200 at 43700224
[18:46:03] hb_sample_pts: pts 6256800 at 47718400
[18:46:03] hb_sample_pts: pts 6876000 at 51939328
[18:46:03] hb_sample_pts: pts 7423200 at 56160256
[18:46:03] hb_sample_pts: pts 7956000 at 60073984
[18:46:03] hb_sample_pts: pts 8506800 at 64385024
[18:46:03] add_audio_to_title: added AC3 audio stream 0x80bd
[18:46:03] scan: decoding previews for title 1
[18:46:03] scan: preview 1
[18:46:03] scan: AC3, rate=48000Hz, bitrate=192000
[18:46:03] scan: preview 2
[18:46:03] scan: preview 3
[18:46:03] scan: preview 4
[18:46:03] scan: preview 5
[18:46:03] scan: preview 6
[18:46:03] scan: preview 7
[18:46:04] scan: preview 8
[18:46:04] scan: preview 9
[18:46:04] scan: preview 10
[18:46:04] scan: 720x576, 25.000 fps, autocrop = 12/12/2/0
[18:46:04] hb_stream_update_audio: id=80bd, lang=Unknown (AC3) (2.0 ch), 3cc=und, rate = 48000, bitrate = 192000, flags = 0x2 (2)
[18:46:04] scan: title (0) job->width:720, job->height:512
[18:46:04] thread ed23a8 exited ("scan")
[18:46:04] thread ed23a8 joined ("scan")
[18:46:04] libhb: scan thread found 1 valid title(s)
+ title 1:
  + vts 0, ttn 0, cells 0->0 (0 blocks)
  + duration: 00:01:38
  + size: 720x576, aspect: 1.33, 25.000 fps
  + autocrop: 12/12/2/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:01:38
  + audio tracks:
    + 1, Unknown (AC3) (2.0 ch), 48000Hz, 192000bps
  + subtitle tracks:
[18:46:04] 1 job(s) to process
[18:46:04] starting job
[18:46:04]  + device F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB
[18:46:04]  + title 1, chapter(s) 1 to 1
[18:46:04]  + 720x576 -> 720x512, crop 12/12/2/0
[18:46:04]  + video frame rate: 25.000 fps
[18:46:04]  + video bitrate 1000 kbps, pass 0
[18:46:04]  + PixelRatio: 0, width:720, height: 512
[18:46:04]  + encoder x264
[18:46:04]  + audio 192 kbps, 48000 Hz
[18:46:04]  + encoder lame
[18:46:04]    + 80bd, Unknown (AC3) (2.0 ch)
[18:46:04]      + Requested mixdown: Stereo (HB_AMIXDOWN_STEREO)
[18:46:04]      + Actual mixdown: Stereo (HB_AMIXDOWN_STEREO)
[18:46:04] thread f07848 started ("work")
ERROR: dvd: DVDOpen failed (F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB)[18:46:04] thread f07df8 started ("reader")
[18:46:04]  + output: E:\VTS_03_1.VOB_T1_C1-1.avi
[18:46:04] thread f7cf08 started ("muxer")
[18:46:04] thread 130a2a8 started ("MPEG-2 decoder (libmpeg2)")
[18:46:04] thread 141a5d8 started ("Renderer")
[18:46:04] encx264: opening libx264 (pass 0)
x264 [info]: using cpu capabilities: MMX MMXEXT SSE SSE2 3DNow! 
[18:46:04] thread 1556238 started ("H.264/AVC encoder (libx264)")
No accelerated IMDCT transform found
[18:46:04] thread 155b410 started ("AC3 decoder")
[18:46:04] enclame: opening libmp3lame
[18:46:04] thread 15d7248 started ("MP3 encoder (libmp3lame)")
[18:46:04] sync: expecting 2476 video frames
[18:46:04] sync: first pts is 25200
[18:46:04] muxavi: opening E:\VTS_03_1.VOB_T1_C1-1.avi
[18:47:45] reader: done
[18:47:45] thread f07df8 exited ("reader")
[18:47:52] 96.680000s: Video -> Film
[18:47:53] sync: got 2421 frames, 2476 expected
[18:47:54] thread 141a5d8 exited ("Renderer")
[18:47:54] thread 155b410 exited ("AC3 decoder")
[18:47:54] thread 15d7248 exited ("MP3 encoder (libmp3lame)")
[18:47:54] thread 130a2a8 exited ("MPEG-2 decoder (libmpeg2)")
[18:47:54] thread 1556238 exited ("H.264/AVC encoder (libx264)")
[18:47:54] thread 130a2a8 joined ("MPEG-2 decoder (libmpeg2)")
[18:47:54] thread 141a5d8 joined ("Renderer")
[18:47:54] render: lost time: 0 (0 frames)
[18:47:54] render: gained time: 0 (0 frames) (0 not accounted for)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] thread 1556238 joined ("H.264/AVC encoder (libx264)")
x264 [info]: slice I:46    Avg QP:23.67  size: 29746  PSNR Mean Y:43.18 U:44.97 V:44.99 Avg:43.66 Global:42.75
x264 [info]: slice P:2375  Avg QP:26.10  size:  4495  PSNR Mean Y:40.86 U:42.87 V:42.88 Avg:41.36 Global:40.37
x264 [info]: mb I  I16..4: 41.6%  0.0% 58.4%
x264 [info]: mb P  I16..4:  5.9%  0.0%  4.6%  P16..4: 15.9%  6.4%  2.0%  0.0%  0.0%    skip:65.3%
x264 [info]: final ratefactor: 24.27
x264 [info]: SSIM Mean Y:0.9674807
x264 [info]: PSNR Mean Y:40.905 U:42.911 V:42.917 Avg:41.400 Global:40.405 kb/s:994.96
[18:47:54] thread 155b410 joined ("AC3 decoder")
[18:47:54] thread 15d7248 joined ("MP3 encoder (libmp3lame)")
[18:47:54] thread f07df8 joined ("reader")
[18:47:54] muxavi: writing index
[18:47:54] muxavi: closing E:\VTS_03_1.VOB_T1_C1-1.avi
[18:47:54] mux: file size, 12107568 bytes
[18:47:54] mux: track 0, 12046178 bytes, inf kbps
[18:47:54] mux: video bitrate error, +12046178 bytes
[18:47:54] mux: track 1, 0 bytes, nan kbps
[18:47:54] mux: overhead, 25.36 bytes per frame
[18:47:54] thread f7cf08 exited ("muxer")
[18:47:54] thread f7cf08 joined ("muxer")
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 1139 buffer(s)
[18:47:54] fifo_close: trashing 9 buffer(s)
[18:47:54] fifo_close: trashing 8 buffer(s)
[18:47:54] fifo_close: trashing 8 buffer(s)
[18:47:54] Freed 8 buffers of size 512
[18:47:54] Freed 2 buffers of size 1024
[18:47:54] Freed 2048 buffers of size 2048
[18:47:54] Freed 0 buffers of size 4096
[18:47:54] Freed 0 buffers of size 8192
[18:47:54] Freed 25 buffers of size 16384
[18:47:54] Freed 0 buffers of size 32768
[18:47:54] Freed 33 buffers of size 622080
[18:47:54] Freed 1 buffers of size 1048576
[18:47:54] Allocated 26220032 bytes of buffers on this pass and Freed 26187264 bytes, 32768 bytes leaked
[18:47:54] thread f07848 exited ("work")
[18:47:54] thread f07848 joined ("work")
[18:47:54] libhb: work result = 0

Rip done!
[18:47:54] thread ed2220 exited ("libhb")
[18:47:54] thread ed2220 joined ("libhb")
HandBrake has exited.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

The precedent Log this is the result of a test on a trailer
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

Um why are you trying to open one specific vob ? Why not just open the VIDEO_TS folder and let handbrake sort the source ?
At any rate, Handbrake obviously is having issues with the source as per

Code: Select all

[18:47:54] mux: track 0, 12046178 bytes, inf kbps
[18:47:54] mux: video bitrate error, +12046178 bytes
[18:47:54] mux: track 1, 0 bytes, nan kbps
Try opening the VIDEO_TS file and doing a one chapter encode to test it out.
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Re: Bug on sound conversion

Post by nightstrm »

Don't select and individual VOB file. Select the Video_TS folder and let Handbrake do a title scan.
marinello56 wrote:

Code: Select all

[18:46:03] hb_init: checking cpu count
[18:46:03] hb_init: starting libhb thread
[18:46:03] thread ed2220 started ("libhb")
HandBrake 0.9.2 (2008022300) - http://handbrake.m0k.org/
1 CPU detected
Opening F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB...
[18:46:03] hb_scan: path=F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB, title_index=1
[18:46:03] scan: trying to open with libdvdread
ERROR: dvd: DVDOpen failed (F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB)[18:46:03] file is MPEG Program Stream
[18:46:03] hb_sample_pts: pts 370800 at 2328576
[18:46:03] hb_sample_pts: pts 950400 at 6569984
[18:46:03] hb_sample_pts: pts 1371600 at 10516480
[18:46:03] hb_sample_pts: pts 1897200 at 14503936
[18:46:03] thread ed23a8 started ("scan")
[18:46:03] hb_sample_pts: pts 2437200 at 18888704
[18:46:03] hb_sample_pts: pts 2908800 at 22767616
[18:46:03] hb_sample_pts: pts 3495600 at 27127808
[18:46:03] hb_sample_pts: pts 4035600 at 31158272
[18:46:03] hb_sample_pts: pts 4640400 at 35366912
[18:46:03] hb_sample_pts: pts 5173200 at 39485440
[18:46:03] hb_sample_pts: pts 5749200 at 43700224
[18:46:03] hb_sample_pts: pts 6256800 at 47718400
[18:46:03] hb_sample_pts: pts 6876000 at 51939328
[18:46:03] hb_sample_pts: pts 7423200 at 56160256
[18:46:03] hb_sample_pts: pts 7956000 at 60073984
[18:46:03] hb_sample_pts: pts 8506800 at 64385024
[18:46:03] add_audio_to_title: added AC3 audio stream 0x80bd
[18:46:03] scan: decoding previews for title 1
[18:46:03] scan: preview 1
[18:46:03] scan: AC3, rate=48000Hz, bitrate=192000
[18:46:03] scan: preview 2
[18:46:03] scan: preview 3
[18:46:03] scan: preview 4
[18:46:03] scan: preview 5
[18:46:03] scan: preview 6
[18:46:03] scan: preview 7
[18:46:04] scan: preview 8
[18:46:04] scan: preview 9
[18:46:04] scan: preview 10
[18:46:04] scan: 720x576, 25.000 fps, autocrop = 12/12/2/0
[18:46:04] hb_stream_update_audio: id=80bd, lang=Unknown (AC3) (2.0 ch), 3cc=und, rate = 48000, bitrate = 192000, flags = 0x2 (2)
[18:46:04] scan: title (0) job->width:720, job->height:512
[18:46:04] thread ed23a8 exited ("scan")
[18:46:04] thread ed23a8 joined ("scan")
[18:46:04] libhb: scan thread found 1 valid title(s)
+ title 1:
  + vts 0, ttn 0, cells 0->0 (0 blocks)
  + duration: 00:01:38
  + size: 720x576, aspect: 1.33, 25.000 fps
  + autocrop: 12/12/2/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:01:38
  + audio tracks:
    + 1, Unknown (AC3) (2.0 ch), 48000Hz, 192000bps
  + subtitle tracks:
[18:46:04] 1 job(s) to process
[18:46:04] starting job
[18:46:04]  + device F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB
[18:46:04]  + title 1, chapter(s) 1 to 1
[18:46:04]  + 720x576 -> 720x512, crop 12/12/2/0
[18:46:04]  + video frame rate: 25.000 fps
[18:46:04]  + video bitrate 1000 kbps, pass 0
[18:46:04]  + PixelRatio: 0, width:720, height: 512
[18:46:04]  + encoder x264
[18:46:04]  + audio 192 kbps, 48000 Hz
[18:46:04]  + encoder lame
[18:46:04]    + 80bd, Unknown (AC3) (2.0 ch)
[18:46:04]      + Requested mixdown: Stereo (HB_AMIXDOWN_STEREO)
[18:46:04]      + Actual mixdown: Stereo (HB_AMIXDOWN_STEREO)
[18:46:04] thread f07848 started ("work")
ERROR: dvd: DVDOpen failed (F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS\VTS_03_1.VOB)[18:46:04] thread f07df8 started ("reader")
[18:46:04]  + output: E:\VTS_03_1.VOB_T1_C1-1.avi
[18:46:04] thread f7cf08 started ("muxer")
[18:46:04] thread 130a2a8 started ("MPEG-2 decoder (libmpeg2)")
[18:46:04] thread 141a5d8 started ("Renderer")
[18:46:04] encx264: opening libx264 (pass 0)
x264 [info]: using cpu capabilities: MMX MMXEXT SSE SSE2 3DNow! 
[18:46:04] thread 1556238 started ("H.264/AVC encoder (libx264)")
No accelerated IMDCT transform found
[18:46:04] thread 155b410 started ("AC3 decoder")
[18:46:04] enclame: opening libmp3lame
[18:46:04] thread 15d7248 started ("MP3 encoder (libmp3lame)")
[18:46:04] sync: expecting 2476 video frames
[18:46:04] sync: first pts is 25200
[18:46:04] muxavi: opening E:\VTS_03_1.VOB_T1_C1-1.avi
[18:47:45] reader: done
[18:47:45] thread f07df8 exited ("reader")
[18:47:52] 96.680000s: Video -> Film
[18:47:53] sync: got 2421 frames, 2476 expected
[18:47:54] thread 141a5d8 exited ("Renderer")
[18:47:54] thread 155b410 exited ("AC3 decoder")
[18:47:54] thread 15d7248 exited ("MP3 encoder (libmp3lame)")
[18:47:54] thread 130a2a8 exited ("MPEG-2 decoder (libmpeg2)")
[18:47:54] thread 1556238 exited ("H.264/AVC encoder (libx264)")
[18:47:54] thread 130a2a8 joined ("MPEG-2 decoder (libmpeg2)")
[18:47:54] thread 141a5d8 joined ("Renderer")
[18:47:54] render: lost time: 0 (0 frames)
[18:47:54] render: gained time: 0 (0 frames) (0 not accounted for)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] thread 1556238 joined ("H.264/AVC encoder (libx264)")
x264 [info]: slice I:46    Avg QP:23.67  size: 29746  PSNR Mean Y:43.18 U:44.97 V:44.99 Avg:43.66 Global:42.75
x264 [info]: slice P:2375  Avg QP:26.10  size:  4495  PSNR Mean Y:40.86 U:42.87 V:42.88 Avg:41.36 Global:40.37
x264 [info]: mb I  I16..4: 41.6%  0.0% 58.4%
x264 [info]: mb P  I16..4:  5.9%  0.0%  4.6%  P16..4: 15.9%  6.4%  2.0%  0.0%  0.0%    skip:65.3%
x264 [info]: final ratefactor: 24.27
x264 [info]: SSIM Mean Y:0.9674807
x264 [info]: PSNR Mean Y:40.905 U:42.911 V:42.917 Avg:41.400 Global:40.405 kb/s:994.96
[18:47:54] thread 155b410 joined ("AC3 decoder")
[18:47:54] thread 15d7248 joined ("MP3 encoder (libmp3lame)")
[18:47:54] thread f07df8 joined ("reader")
[18:47:54] muxavi: writing index
[18:47:54] muxavi: closing E:\VTS_03_1.VOB_T1_C1-1.avi
[18:47:54] mux: file size, 12107568 bytes
[18:47:54] mux: track 0, 12046178 bytes, inf kbps
[18:47:54] mux: video bitrate error, +12046178 bytes
[18:47:54] mux: track 1, 0 bytes, nan kbps
[18:47:54] mux: overhead, 25.36 bytes per frame
[18:47:54] thread f7cf08 exited ("muxer")
[18:47:54] thread f7cf08 joined ("muxer")
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 0 buffer(s)
[18:47:54] fifo_close: trashing 1139 buffer(s)
[18:47:54] fifo_close: trashing 9 buffer(s)
[18:47:54] fifo_close: trashing 8 buffer(s)
[18:47:54] fifo_close: trashing 8 buffer(s)
[18:47:54] Freed 8 buffers of size 512
[18:47:54] Freed 2 buffers of size 1024
[18:47:54] Freed 2048 buffers of size 2048
[18:47:54] Freed 0 buffers of size 4096
[18:47:54] Freed 0 buffers of size 8192
[18:47:54] Freed 25 buffers of size 16384
[18:47:54] Freed 0 buffers of size 32768
[18:47:54] Freed 33 buffers of size 622080
[18:47:54] Freed 1 buffers of size 1048576
[18:47:54] Allocated 26220032 bytes of buffers on this pass and Freed 26187264 bytes, 32768 bytes leaked
[18:47:54] thread f07848 exited ("work")
[18:47:54] thread f07848 joined ("work")
[18:47:54] libhb: work result = 0

Rip done!
[18:47:54] thread ed2220 exited ("libhb")
[18:47:54] thread ed2220 joined ("libhb")
HandBrake has exited.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

Sorry for my "poor english". I started using the folder then I lselect with "title" the same trailer. Allway no sound. I Make another test with the entire movie, it will be much longer. I will post the LOG tomorrow.

[19:08:51] hb_init: checking cpu count
[19:08:51] hb_init: starting libhb thread
[19:08:51] thread ed2200 started ("libhb")
HandBrake 0.9.2 (2008022300) - http://handbrake.m0k.org/
1 CPU detected
Opening F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS...
[19:08:51] hb_scan: path=F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS, title_index=3
[19:08:51] scan: trying to open with libdvdread
[19:08:51] thread ed23a8 started ("scan")
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
[19:08:51] scan: DVD has 7 title(s)
[19:08:51] scan: scanning title 3
[19:08:51] scan: opening IFO for VTS 3
[19:08:51] pgc_id: 1, pgn: 1: pgc: 0xed59c0
[19:08:51] scan: vts=3, ttn=1, cells=0->1, blocks=0->32339, 32340 blocks
[19:08:51] scan: duration is 00:01:36 (96100 ms)
[19:08:51] scan: checking audio 1
[19:08:51] scan: id=80bd, lang=Francais (AC3), 3cc=fra
[19:08:51] scan: title 3 has 2 chapters
[19:08:51] scan: chap 1 c=0->0, b=0->32075 (32076), 96010 ms
[19:08:51] scan: chap 2 c=1->1, b=32076->32339 (264), 90 ms
[19:08:51] scan: aspect = 16
[19:08:51] scan: decoding previews for title 3
[19:08:51] scan: preview 1
[19:08:51] scan: AC3, rate=48000Hz, bitrate=192000
[19:08:51] scan: preview 2
[19:08:51] scan: preview 3
[19:08:51] scan: preview 4
[19:08:51] scan: preview 5
[19:08:51] scan: preview 6
[19:08:51] scan: preview 7
[19:08:51] scan: preview 8
[19:08:51] scan: preview 9
[19:08:51] scan: preview 10
[19:08:51] scan: 720x576, 25.000 fps, autocrop = 12/12/2/0
[19:08:51] scan: title (0) job->width:720, job->height:384
[19:08:51] thread ed23a8 exited ("scan")
[19:08:51] thread ed23a8 joined ("scan")
[19:08:51] libhb: scan thread found 1 valid title(s)
+ title 3:
+ vts 3, ttn 1, cells 0->1 (32340 blocks)
+ duration: 00:01:36
+ size: 720x576, aspect: 1.78, 25.000 fps
+ autocrop: 12/12/2/0
+ chapters:
+ 1: cells 0->0, 32076 blocks, duration 00:01:36
+ 2: cells 1->1, 264 blocks, duration 00:00:00
+ audio tracks:
+ 1, Francais (AC3) (2.0 ch), 48000Hz, 192000bps
+ subtitle tracks:
[19:08:51] 1 job(s) to process
[19:08:51] starting job
[19:08:51] + device F:\FullDisc\MON MEILLEUR AMI LOC\VIDEO_TS
[19:08:51] + title 3, chapter(s) 1 to 2
[19:08:51] + 720x576 -> 720x384, crop 12/12/2/0
[19:08:51] + video frame rate: 25.000 fps
[19:08:51] + video bitrate 1000 kbps, pass 0
[19:08:51] + PixelRatio: 0, width:720, height: 384
[19:08:51] + encoder x264
[19:08:51] + audio 192 kbps, 48000 Hz
[19:08:51] + encoder lame
[19:08:51] + 80bd, Francais (AC3) (2.0 ch)
[19:08:51] + Requested mixdown: Stereo (HB_AMIXDOWN_STEREO)
[19:08:51] + Actual mixdown: Stereo (HB_AMIXDOWN_STEREO)
[19:08:51] thread ede7c0 started ("work")
[19:08:51] thread ededb8 started ("reader")
[19:08:51] + output: E:\VIDEO_TS_T3_C1-2.avi
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e65[19:08:51] thread edf0f0 started ("muxer")
00000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr[i] = 0x[19:08:51] thread edf778 started ("MPEG-2 decoder (libmpeg2)")
04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr[i] = 0x04c56e6500000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr[i] = 0x04c56e6500[19:08:51] thread ee2698 started ("Renderer")
[19:08:51] encx264: opening libx264 (pass 0)
x264 [info]: using cpu capabilities: MMX MMXEXT SSE SSE2 3DNow!
000000
*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr[i] = 0x04c56e6500000000
[19:08:51] thread 10b6680 started ("H.264/AVC encoder (libx264)")
No accelerated IMDCT transform found
[19:08:51] dvd: Beginning of Cell (0) at block 0
[19:08:51] thread 10bd640 started ("AC3 decoder")
[19:08:51] enclame: opening libmp3lame
[19:08:51] thread 11390d8 started ("MP3 encoder (libmp3lame)")
[19:08:51] sync: expecting 2427 video frames
[19:08:51] sync: first pts is 25200
[19:08:51] muxavi: opening E:\VIDEO_TS_T3_C1-2.avi
[19:10:22] dvd: End of Cell (0) at block 31874
[19:10:22] dvd: Beginning of Cell (1) at block 32076
[19:10:22] dvd: Chapter Break Cell Found
[19:10:22] dvd: End of Cell (1) at block 32076
[19:10:22] dvd: Skipping multi-angle cells 2-164
[19:10:24] reader: done
[19:10:24] thread ededb8 exited ("reader")
[19:10:24] MPEG2: Chapter Break Cell Found, searching for GOP
[19:10:24] MPEG2: Group of pictures found, searching for I-Frame
[19:10:24] MPEG2: I-Frame Found
[19:10:24] MPEG2: Chapter Break Inserted
[19:10:24] 96.680000s: Video -> Film
[19:10:25] work Renderer: Copying Chapter Break @ 8676000
[19:10:25] sync: got 2421 frames, 2427 expected
[19:10:25] thread ee2698 exited ("Renderer")
[19:10:25] thread edf778 exited ("MPEG-2 decoder (libmpeg2)")
[19:10:25] thread 10bd640 exited ("AC3 decoder")
[19:10:25] thread 11390d8 exited ("MP3 encoder (libmp3lame)")
[19:10:25] thread 10b6680 exited ("H.264/AVC encoder (libx264)")
[19:10:25] thread edf778 joined ("MPEG-2 decoder (libmpeg2)")
[19:10:25] thread ee2698 joined ("Renderer")
[19:10:25] render: lost time: 0 (0 frames)
[19:10:25] render: gained time: 0 (0 frames) (0 not accounted for)
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] thread 10b6680 joined ("H.264/AVC encoder (libx264)")
x264 [info]: slice I:45 Avg QP:22.27 size: 28815 PSNR Mean Y:43.61 U:45.39 V:45.42 Avg:44.08 Global:43.24
x264 [info]: slice P:2376 Avg QP:24.65 size: 4512 PSNR Mean Y:41.35 U:43.18 V:43.18 Avg:41.78 Global:40.84
x264 [info]: mb I I16..4: 34.5% 0.0% 65.5%
x264 [info]: mb P I16..4: 4.8% 0.0% 5.1% P16..4: 20.0% 7.3% 2.6% 0.0% 0.0% skip:60.3%
x264 [info]: final ratefactor: 22.68
x264 [info]: SSIM Mean Y:0.9712794
x264 [info]: PSNR Mean Y:41.393 U:43.216 V:43.226 Avg:41.827 Global:40.871 kb/s:992.72
[19:10:25] thread 10bd640 joined ("AC3 decoder")
[19:10:25] thread 11390d8 joined ("MP3 encoder (libmp3lame)")
[19:10:25] thread ededb8 joined ("reader")
[19:10:25] muxavi: writing index
[19:10:25] muxavi: closing E:\VIDEO_TS_T3_C1-2.avi
[19:10:25] mux: file size, 12080942 bytes
[19:10:25] mux: track 0, 12019543 bytes, inf kbps
[19:10:25] mux: video bitrate error, +12019543 bytes
[19:10:25] mux: track 1, 0 bytes, nan kbps
[19:10:25] mux: overhead, 25.36 bytes per frame
[19:10:25] thread edf0f0 exited ("muxer")
[19:10:25] thread edf0f0 joined ("muxer")
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] fifo_close: trashing 0 buffer(s)
[19:10:25] fifo_close: trashing 1139 buffer(s)
[19:10:25] fifo_close: trashing 9 buffer(s)
[19:10:25] fifo_close: trashing 8 buffer(s)
[19:10:25] fifo_close: trashing 8 buffer(s)
[19:10:25] Freed 6 buffers of size 512
[19:10:25] Freed 1 buffers of size 1024
[19:10:25] Freed 2048 buffers of size 2048
[19:10:25] Freed 0 buffers of size 4096
[19:10:25] Freed 0 buffers of size 8192
[19:10:25] Freed 25 buffers of size 16384
[19:10:25] Freed 0 buffers of size 32768
[19:10:25] Freed 33 buffers of size 622080
[19:10:25] Freed 1 buffers of size 1048576
[19:10:25] Allocated 26185216 bytes of buffers on this pass and Freed 26185216 bytes, 0 bytes leaked
[19:10:25] thread ede7c0 exited ("work")
[19:10:25] thread ede7c0 joined ("work")
[19:10:25] libhb: work result = 0

Rip done!
[19:10:26] thread ed2200 exited ("libhb")
[19:10:26] thread ed2200 joined ("libhb")
HandBrake has exited.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

I read the original VOB file of this trailer with VLC: The sound really exists
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

i am sure it is. VLC can read things HB can not. Its much more forgiving. Did you pre-rip this source, or what is it ?
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

Code: Select all

*** Zero check failed in ifo_read.c:2015
for vts_attributes->vtstt_audio_attr[i] = 0x[19:08:51] thread edf778 started ("MPEG-2 decoder (libmpeg2)")
04c56e6500000000
Tells me that HB cannot properly read the source you are choosing.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

I ripp the original DVD On my Hard-drive with DVDfabdecrypter . I do this many time with handbrake 9.1, and it allway works
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

Well, this title is giving your ripper a hard time then. Not sure what to say.
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Re: Bug on sound conversion

Post by jbrjake »

Not sure how you expect x264-in-avi to work when it's broken in 0.9.2

You're totally wrong when you say this bug hasn't been discussed on the forum.
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

ah, forgot about that one. :roll:
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

Thank you for your help. I ripp another DVD, contains trailers, with "DVDFabHDdecrypter". Then I test again with Handbrake 9.2 and 9.1. It will take a half-hour.
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

dont use x264 in an avi. Its broken like jbrjake said. use ffmpeg or maybe an mp4 format.
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

Ripped DVD "WALLACE AND GROMMIT" whith DVDfabdecrypter. Use Handbrake 9.2 to AVI. The software stop after 12.68% conversion 264/MP3/AVI. Same at the 2nd test. Try to MP4. It works. Problem: None of my readers installed can read MP4 files. Neither Mediaplayerclassic. Neither VLC. NERO ask me a license. I can neither controller result, neither read these conversion for my pleasure. You understand why I wanted to AVI format. Thank you for your response
marinello56
Posts: 14
Joined: Thu Mar 13, 2008 4:47 pm

Re: Bug on sound conversion

Post by marinello56 »

Neither Quictime, of course! Who can play MP4 file !!!!. Thanks for your help
dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Re: Bug on sound conversion

Post by dynaflash »

I am confused. afaik both vlc, and quicktime can easily read mp4 files. As well as any modern media player that I know of.
Post Reply