Encoding always changes color/brigthness ?

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
creizlein
Posts: 2
Joined: Fri Feb 28, 2020 11:32 pm

Encoding always changes color/brigthness ?

Post by creizlein »

Description of problem or question:
I am re-encoding general Action Camera Videos (GoPro, Yi Camera & Viofo), the problem is agnostic to the source of the video as it happens with all 3 sources, to either x264 and x265, using NVenc or CPU , all four codecs result in the same behaviour, despite the quality, CQ or settings I use, the destination videos appear with a super noticeable different in colour, like you apply a brighten effect to them, the original video is darker, like with more contrast, but the new video is brighter, you can tell this difference with any setting, of course quality might change but ignoring quality the color difference is always present, i tried with both x264 and x265 using both NVenc or CPU encoding.

Is this a normal behaviour or I am doing something wrong? not sure which details to include as this seems to be generic to all the settings i change
(And yes, I have make sure that no filters are turned on in the Filter tabs)

I am sharing 2 general screenshots which tells the difference, the top one is the original and the bottom the re-encoded in x264 with max settings (loseless).

As i cannot attach them here, I used WeTransfer, hope its ok: https://we.tl/t-V6KZ2PsG2d

Steps to reproduce the problem (If Applicable):
Encode any video with virtually any setting

HandBrake version (e.g., 1.0.0):
1.3.1

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Windows 10

HandBrake Activity Log ***required*** (see How-to get an activity log)

https://pastebin.com/cynvqZA1

mduell
Veteran User
Posts: 6933
Joined: Sat Apr 21, 2007 8:54 pm

Re: Encoding always changes color/brigthness ?

Post by mduell »

If you searched the forum before posting you might find other posts with exactly the same issue...

musicvid
Veteran User
Posts: 3455
Joined: Sat Jun 27, 2009 1:19 am

Re: Encoding always changes color/brigthness ?

Post by musicvid »

Turn off Dynamic Contrast (or whatever it's called) on your teevee or monitor. It isn't needed.

creizlein
Posts: 2
Joined: Fri Feb 28, 2020 11:32 pm

Re: Encoding always changes color/brigthness ?

Post by creizlein »

mduell wrote:
Sat Feb 29, 2020 2:32 pm
If you searched the forum before posting you might find other posts with exactly the same issue...
How does that helps the forum? at least spend the same time and same words providng a search filter or an actual link to a thread instead of assuming I didnt search, smartpants...

Post Reply