i9 9900K, HEVC @ 4K30 performance

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

i9 9900K, HEVC @ 4K30 performance

Post by oRBIT2002 » Sat Jul 27, 2019 7:39 pm

Just got myself a new computer with an Intel I9 9900K (running Windows 10) and was hoping for miracles in encoding 4K HEVC videos. However when encoding 4K30 HEVC with "medium" preset I get about 8-9fps encodingspeed.
Has anyone else tried 4K HEVC encoding with this CPU? Would be interesting if this is what to expect or if I'm doing something wrong..

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: i9 9900K, HEVC @ 4K30 performance

Post by oRBIT2002 » Sat Jul 27, 2019 7:42 pm

Forgot to mention (sorry, couldn't find a post-edit feature), I'm using Handbrake 1.2.2.. Intel QuickSync is btw disabled in preferences, this should be available for this CPU aswell?

User avatar
s55
HandBrake Team
Posts: 9523
Joined: Sun Dec 24, 2006 1:05 pm

Re: i9 9900K, HEVC @ 4K30 performance

Post by s55 » Sat Jul 27, 2019 7:52 pm

You know the drill with the logs ;) It's not particularly stand out as "slow" but it really depends on your settings.

I suspect there is room for optimisation but I'm not going to theorise until I see exactly what your actually doing.

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: i9 9900K, HEVC @ 4K30 performance

Post by oRBIT2002 » Sat Jul 27, 2019 8:05 pm

Here's a sample log.

Code: Select all

HandBrake 1.2.2 (2019022300)
OS: Microsoft Windows NT 10.0.18362.0
CPU: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz
Ram: 16316 MB, 
GPU Information:
  NVIDIA GeForce GTX 1050 Ti - 23.21.13.8813
Screen: 3840x2160
Temp Dir: C:\Users\morjo\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\morjo\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[22:00:46] hb_init: starting libhb thread
[22:00:46] 1 job(s) to process
[22:00:46] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 320,
        "DRC": 0.0,
        "Encoder": "av_aac",
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 0,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      "copy:aac",
      "copy:ac3",
      "copy:dtshd",
      "copy:dts",
      "copy:eac3",
      "copy:flac",
      "copy:mp3",
      "copy:truehd"
    ],
    "FallbackEncoder": "ac3"
  },
  "Destination": {
    "ChapterList": [],
    "ChapterMarkers": false,
    "AlignAVStart": false,
    "File": "C:\\temp\\test.mkv",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": "mkv"
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "2160",
          "width": "3840"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "time",
      "Start": 0,
      "End": 5400000
    },
    "Title": 1,
    "Path": "\\\\diskstation\\Media\\Videokamera\\2019\\2019-06-30 - Öland.mp4"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": false,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": "x265",
    "Level": "auto",
    "Bitrate": 20000,
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "",
    "Preset": "medium",
    "Profile": "auto",
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[22:00:46] CPU: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz
[22:00:46]  - Intel microarchitecture Kaby Lake
[22:00:46]  - logical processor count: 16
[22:00:46] Intel Quick Sync Video support: no
[22:00:46] hb_scan: path=\\diskstation\Media\Videokamera\2019\2019-06-30 - Öland.mp4, title_index=1
src/libbluray/disc/disc.c:323: failed opening UDF image \\diskstation\Media\Videokamera\2019\2019-06-30 - Öland.mp4
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[22:00:46] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[22:00:46] dvd: not a dvd - trying as a stream/file instead
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '\\diskstation\Media\Videokamera\2019\2019-06-30 - Öland.mp4':
  Metadata:
    major_brand     : XAVC
    minor_version   : 16785407
    compatible_brands: XAVCmp42iso2
    creation_time   : 2019-07-08T19:41:21.000000Z
  Duration: 00:14:44.15, start: 0.000000, bitrate: 58213 kb/s
    Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/iec61966-2-4), 3840x2160 [SAR 1:1 DAR 16:9], 56675 kb/s, 29.97 fps, 29.97 tbr, 30k tbn, 59.94 tbc (default)
    Metadata:
      creation_time   : 2019-07-08T19:41:21.000000Z
      handler_name    : Video Media Handler
      encoder         : AVC Coding
    Stream #0:1(und): Audio: pcm_s16be (twos / 0x736F7774), 48000 Hz, 2 channels, s16, 1536 kb/s (default)
    Metadata:
      creation_time   : 2019-07-08T19:41:21.000000Z
      handler_name    : Sound Media Handler
[22:00:46] scan: decoding previews for title 1
[22:00:47] scan: audio 0x1: pcm_s16be, rate=48000Hz, bitrate=1536000 Unknown (pcm_s16be) (2.0 ch)
[22:00:48] scan: 10 previews, 3840x2160, 29.970 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[22:00:48] scan: supported video decoders: avcodec qsv
[22:00:49] libhb: scan thread found 1 valid title(s)
[22:00:49] starting job
[22:00:49] job configuration:
[22:00:49]  * source
[22:00:49]    + \\diskstation\Media\Videokamera\2019\2019-06-30 - Öland.mp4
[22:00:49]    + title 1, start 00:00:0.00 stop 00:01:0.00
[22:00:49]    + container: mov,mp4,m4a,3gp,3g2,mj2
[22:00:49]    + data rate: 58213 kbps
[22:00:49]  * destination
[22:00:49]    + C:\temp\test.mkv
[22:00:49]    + container: Matroska (libavformat)
[22:00:49]  * video track
[22:00:49]    + decoder: h264
[22:00:49]      + bitrate 56675 kbps
[22:00:49]    + filters
[22:00:49]      + Framerate Shaper (mode=1)
[22:00:49]        + frame rate: 29.970 fps -> constant 29.970 fps
[22:00:49]      + Crop and Scale (width=3840:height=2160:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[22:00:49]        + source: 3840 * 2160, crop (0/0/0/0): 3840 * 2160, scale: 3840 * 2160
[22:00:49]    + Output geometry
[22:00:49]      + storage dimensions: 3840 x 2160
[22:00:49]      + pixel aspect ratio: 1 : 1
[22:00:49]      + display dimensions: 3840 x 2160
[22:00:49]    + encoder: H.265 (libx265)
[22:00:49]      + preset:  medium
[22:00:49]      + profile: auto
[22:00:49]      + bitrate: 20000 kbps, pass: 0
[22:00:49]      + color profile: 1-1-1
[22:00:49]  * audio track 1
[22:00:49]    + decoder: Unknown (pcm_s16be) (2.0 ch) (track 1, id 0x1)
[22:00:49]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[22:00:49]    + mixdown: Stereo
[22:00:49]    + dither: none
[22:00:49]    + encoder: AAC (libavcodec)
[22:00:49]      + bitrate: 320 kbps, samplerate: 48000 Hz
[22:00:49] sync: expecting 1828 video frames
x265 [info]: HEVC encoder version 2.9
x265 [info]: build info [Windows][GCC 8.2.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x265 [info]: Main profile, Level-5 (Main tier)
x265 [info]: Thread pool created using 16 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 4 / wpp(34 rows)
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 30 / 300 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 20 / 4 / 2
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 1 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : ABR-20000 kbps / 0.60
x265 [info]: tools: rd=3 psy-rd=2.00 rskip signhide tmvp strong-intra-smoothing
x265 [info]: tools: lslices=8 deblock sao
[22:00:49] sync: first pts video is 0
[22:00:49] sync: first pts audio 0x1 is 0
[22:00:49] sync: Chapter 1 at frame 3 time 6006
[22:04:23] sync: reached audio 0x1 pts 5401905, exiting early
[22:04:23] sync: reached video pts 5402397, exiting early
[22:04:29] work: average encoding speed for job is 8.381704 fps
[22:04:29] vfr: 1799 frames output, 0 dropped and 0 duped for CFR/PFR
[22:04:29] vfr: lost time: 0 (0 frames)
[22:04:29] vfr: gained time: 0 (0 frames) (0 not accounted for)
[22:04:30] pcm_s16be-decoder done: 4183 frames, 0 decoder errors
[22:04:30] h264-decoder done: 2598 frames, 0 decoder errors
[22:04:30] sync: got 1799 frames, 1828 expected
[22:04:30] sync: framerate min 29.970 fps, max 29.970 fps, avg 29.970 fps
x265 [info]: frame I:     12, Avg QP:27.79  kb/s: 50508.73
x265 [info]: frame P:    515, Avg QP:33.02  kb/s: 30330.69
x265 [info]: frame B:   1272, Avg QP:38.84  kb/s: 14006.66
x265 [info]: Weighted P-Frames: Y:6.8% UV:4.9%
x265 [info]: consecutive B-frames: 10.4% 6.1% 34.7% 29.2% 19.5%
encoded 1799 frames in 220.88s (8.14 fps), 18923.23 kb/s, Avg QP:37.10
[22:04:30] mux: track 0, 1799 frames, 141994397 bytes, 18913.67 kbps, fifo 512
[22:04:30] mux: track 1, 2814 frames, 2405726 bytes, 320.44 kbps, fifo 1024
[22:04:30] libhb: work result = 0

# Encode Completed ...



User avatar
s55
HandBrake Team
Posts: 9523
Joined: Sun Dec 24, 2006 1:05 pm

Re: i9 9900K, HEVC @ 4K30 performance

Post by s55 » Sat Jul 27, 2019 8:20 pm

Not much in the way of optimisations you can do there I'm afraid. I'd maybe choose a faster x265 preset.
I'd also avoid transcoding to/from network mounts. Particularly UNC one just as a general rule.

QuickSync isn't available since your on board GPU appears to be disabled. Guessing probably in the BIOS.

For reference, my 8700K is sub 9fps as well so you are there or there about in the ballpark of expectations with those settings.

oRBIT2002
Posts: 74
Joined: Sun Nov 01, 2009 11:22 am

Re: i9 9900K, HEVC @ 4K30 performance

Post by oRBIT2002 » Sat Jul 27, 2019 8:39 pm

I didn't see any noticable improvement with encoding a local file. But ok, I guess I have to live with <10fps, although, I expected alot more from this CPU, but I didn't do that much research about this so.. :)

razorback
Posts: 15
Joined: Wed Apr 25, 2018 7:47 am

Re: i9 9900K, HEVC @ 4K30 performance

Post by razorback » Wed Aug 14, 2019 5:32 am

Your log says that there is an Nvidia GTX 1050i present.
So you should be able to use this GPU.....
Codec H265 (Nvidia NVEnc)

Post Reply