General Question or Potential Bug: HB 1.2.2 - Prevent audio from incorrectly upmixing/upsampling?

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
pitcher
Posts: 15
Joined: Sun May 12, 2019 11:41 pm

General Question or Potential Bug: HB 1.2.2 - Prevent audio from incorrectly upmixing/upsampling?

Post by pitcher » Sun May 12, 2019 11:59 pm

First audio track is originally English DTS or AC-3 5.1 640kb/s but I want to encode this as AC-3 384kb/s - no issue with this, works fine.

However, 2nd audio track (and 3rd, 4th etc.) are usually also AC-3 often around 256kb/s but can also sometimes be as low as 96 kb/s.

I would prefer to encode e.g. Track 2, Track 3 etc. at AC-3 192kb/s (or just passthrough if it is less than this) because these are usually commentaries hence the lower quality, however I cannot figure out how to set this in the options - Handbrake keeps reverting itself to the original behavior that was being used on Track 1 i.e. AC-3 at 384kb/s.

So in some cases this is then incorrectly upmixing a 96kb/s or 192kb/s AC-3 to 384kb/s.

Is there some way I can set all tracks after Track 1 to AC-3 192kb/s and/or instead just passthrough if it is lower than this?

Extra Note:
Even if the 2nd (or 3rd or 4th) audio track is AAC (e.g. at 192kb/s), it is still not correctly passing through, but instead reverting to the behavior of converting to AC-3 384kb/s, again not the desired behavior.


Possible bug or oversight, is a fix required?


EDIT: This is when files are being originally opened, of course I can change the behavior manually, but having to do this across e.g. 50 files or more soon becomes very time consuming.

Post Reply