Deinterlacing doesn't work the same since v1.2.0

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
cufinnev
Posts: 4
Joined: Fri Dec 28, 2018 2:52 pm

Deinterlacing doesn't work the same since v1.2.0

Post by cufinnev » Fri Dec 28, 2018 3:18 pm

Description of problem or question:
Since upgrading to v1.2.0, deinterlacing does not work the same as it did in v1.1.2

Steps to reproduce the problem (If Applicable):
Link to a screenshot showing the setting used in v1.1.2. This properly deinterlaced my DVDs

Link to a screenshot showing the setting used in v1.2.0. This does not properly deinterlaced my DVDs.

HandBrake version (e.g., 1.0.0):
v1.1.2 - until the issue with v1.2.0 is resolved.

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Windows 10 64-bit

HandBrake Activity Log ***required*** (see How-to get an activity log)
Taken from v1.1.2 logs.

v1.1.2:

Code: Select all

HandBrake 1.1.2 (2018090500) - 64bit
OS: Microsoft Windows NT 10.0.16299.0 - 64bit
CPU: Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz
Ram: 16326 MB, 
GPU Information:
  NVIDIA GeForce GTX 1050 Ti - 25.21.14.1735
Screen: 1680x1050
Temp Dir: C:\Users\-\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\-\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[15:04:58] hb_init: starting libhb thread
[15:04:58] 1 job(s) to process
[15:04:58] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 192,
        "DRC": 0.0,
        "Encoder": 65536,
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 48000,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      1073807360,
      1073743872,
      1074003968,
      1073750016,
      1090519040,
      1074790400,
      1074266112,
      1107296256
    ],
    "FallbackEncoder": 2048
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "AlignAVStart": false,
    "File": "C:\\Users\\-\\AppData\\Local\\Temp\\tmp2DCB.mkv",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": 131072
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 5,
        "Settings": {
          "mode": "3"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 9,
        "Settings": {
          "cb-frame-count": 2,
          "cb-origin-tune": 0.9,
          "cb-patch-size": 7,
          "cb-prefilter": 0,
          "cb-range": 3,
          "cb-strength": 2.4,
          "y-frame-count": 2,
          "y-origin-tune": 0.9,
          "y-patch-size": 7,
          "y-prefilter": 0,
          "y-range": 3,
          "y-strength": 1.5
        }
      },
      {
        "ID": 12,
        "Settings": {
          "cb-kernel": "isolap",
          "cb-strength": 0.06,
          "y-kernel": "isolap",
          "y-strength": 0.1
        }
      },
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "576",
          "width": "720"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "preview",
      "Start": 2,
      "End": 900000,
      "SeekPoints": 60
    },
    "Title": 2,
    "Path": "D:\\DVD\\01 - Still Open All Hours\\Still Open All Hours - s01e00 - Pilot (Christmas Special)\\VTS_01_PGC_03_1.VOB"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": false,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": 4096,
    "Level": "auto",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "strong-intra-smoothing=0:rect=0",
    "Preset": "fast",
    "Profile": "main",
    "Quality": 25.0,
    "HWDecode": false,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[15:04:58] CPU: Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz
[15:04:58]  - Intel microarchitecture Kaby Lake
[15:04:58]  - logical processor count: 4
[15:04:58] Intel Quick Sync Video support: no
[15:04:58] hb_scan: path=D:\DVD\01 - Still Open All Hours\Still Open All Hours - s01e00 - Pilot (Christmas Special)\VTS_01_PGC_03_1.VOB, title_index=2
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image D:\DVD\01 - Still Open All Hours\Still Open All Hours - s01e00 - Pilot (Christmas Special)\VTS_01_PGC_03_1.VOB
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[15:04:58] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[15:04:58] dvd: not a dvd - trying as a stream/file instead
[15:04:58] file is MPEG Program Stream
[15:04:59] Probing 3 unknown streams
[15:04:59]     Probe: Found stream mpeg2video. stream id 0xe0-0x0
[15:04:59] Found the following streams
[15:04:59]     Video Streams :
[15:04:59]       0xe0-0x0 type MPEG2 (0x2)
[15:04:59]     Audio Streams :
[15:04:59]       0xbd-0x80 type AC3 (0x81)
[15:04:59]     Subtitle Streams :
[15:04:59]       0xbd-0x20 type DVD Subtitle (0x0)
[15:04:59]     Other Streams :
[15:04:59] stream id 0xbd (type 0x81 substream 0x80) audio 0x8000bd
[15:04:59] stream id 0xbd (type 0x0 substream 0x20) subtitle 0x2000bd
[15:04:59] scan: decoding previews for title 2
[15:04:59] file is MPEG Program Stream
[15:04:59] Probing 3 unknown streams
[15:04:59]     Probe: Found stream mpeg2video. stream id 0xe0-0x0
[15:04:59] scan: audio 0x8000bd: ac3, rate=48000Hz, bitrate=192000 Unknown (AC3) (2.0 ch)
[15:04:59] stream: 68 good frames, 0 errors (0%)
[15:04:59] scan: 10 previews, 720x576, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 64:45
[15:04:59] Title is likely interlaced or telecined (5 out of 10 previews). You should do something about that.
[15:04:59] libhb: scan thread found 1 valid title(s)
[15:04:59] starting job
[15:04:59] decomb filter thread started for segment 0
[15:04:59] decomb filter thread started for segment 1
[15:04:59] decomb filter thread started for segment 2
[15:04:59] decomb filter thread started for segment 3
[15:04:59] decomb check thread started for segment 0
[15:04:59] decomb check thread started for segment 1
[15:04:59] decomb check thread started for segment 2
[15:04:59] decomb check thread started for segment 3
[15:04:59] mask filter thread started for segment 0
[15:04:59] mask filter thread started for segment 1
[15:04:59] mask filter thread started for segment 2
[15:04:59] mask filter thread started for segment 3
[15:04:59] mask erode thread started for segment 0
[15:04:59] mask erode thread started for segment 1
[15:04:59] mask erode thread started for segment 2
[15:04:59] mask erode thread started for segment 3
[15:04:59] mask dilate thread started for segment 0
[15:04:59] mask dilate thread started for segment 1
[15:04:59] mask dilate thread started for segment 2
[15:04:59] mask dilate thread started for segment 3
[15:04:59] NLMeans using SSE2 optimizations
[15:04:59] NLMeans thread started for segment 0
[15:04:59] NLMeans thread started for segment 1
[15:04:59] NLMeans thread started for segment 2
[15:04:59] NLMeans thread started for segment 3
[15:04:59] MTFrame thread started for segment 0
[15:04:59] MTFrame thread started for segment 1
[15:04:59] work: track 1, dithering not supported by codec
[15:04:59] MTFrame thread started for segment 2
[15:04:59] MTFrame thread started for segment 3
[15:04:59] work: only 1 chapter, disabling chapter markers
[15:04:59] job configuration:
[15:04:59]  * source
[15:04:59]    + D:\DVD\01 - Still Open All Hours\Still Open All Hours - s01e00 - Pilot (Christmas Special)\VTS_01_PGC_03_1.VOB
[15:04:59]    + title 2, start 00:00:0.00 stop 00:00:10.00
[15:04:59]  * destination
[15:04:59]    + C:\Users\-\AppData\Local\Temp\tmp2DCB.mkv
[15:04:59]    + container: MPEG-4 (libavformat)
[15:04:59]  * video track
[15:04:59]    + decoder: mpeg2video
[15:04:59]      + bitrate 7500 kbps
[15:04:59]    + filters
[15:04:59]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[15:04:59]      + avfilter (yadif='mode=0:auto=1')
[15:04:59]        + yadif: mode=0, auto=1
[15:04:59]      + Framerate Shaper (mode=1)
[15:04:59]        + frame rate: 25.000 fps -> constant 25.000 fps
[15:04:59]      + Denoise (nlmeans) (y-strength=1.5:y-origin-tune=0.9:y-patch-size=7:y-range=3:y-frame-count=2:y-prefilter=0:cb-strength=2.4:cb-origin-tune=0.9:cb-patch-size=7:cb-range=3:cb-frame-count=2:cb-prefilter=0)
[15:04:59]      + Crop and Scale (width=720:height=576:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[15:04:59]        + source: 720 * 576, crop (0/0/0/0): 720 * 576, scale: 720 * 576
[15:04:59]      + Sharpen (lapsharp) (y-strength=0.1:y-kernel=isolap:cb-strength=0.06:cb-kernel=isolap)
[15:04:59]    + Output geometry
[15:04:59]      + storage dimensions: 720 x 576
[15:04:59]      + pixel aspect ratio: 1 : 1
[15:04:59]      + display dimensions: 720 x 576
[15:04:59]    + encoder: H.265 (libx265)
[15:04:59]      + preset:  fast
[15:04:59]      + options: strong-intra-smoothing=0:rect=0
[15:04:59]      + profile: main
[15:04:59]      + quality: 25.00 (RF)
[15:04:59]  * audio track 1
[15:04:59]    + decoder: Unknown (AC3) (2.0 ch) (track 1, id 0x8000bd)
[15:04:59]      + bitrate: 192 kbps, samplerate: 48000 Hz
[15:04:59]    + mixdown: Stereo
[15:04:59]    + encoder: AAC (libavcodec)
[15:04:59]      + bitrate: 192 kbps, samplerate: 48000 Hz
[15:04:59] file is MPEG Program Stream
[15:04:59] Probing 3 unknown streams
[15:04:59]     Probe: Found stream mpeg2video. stream id 0xe0-0x0
[15:04:59] sync: expecting 275 video frames
x265 [info]: HEVC encoder version 2.6
x265 [info]: build info [Windows][GCC 7.3.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x265 [info]: Main profile, Level-3 (Main tier)
x265 [info]: Thread pool created using 4 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 2 / wpp(9 rows)
x265 [warning]: Source height < 720p; disabling lookahead-slices
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 25 / 250 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 15 / 4 / 0
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 1 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : CRF-25.0 / 0.60
x265 [info]: tools: rd=2 psy-rd=2.00 rskip signhide tmvp fast-intra deblock sao
[15:04:59] sync: first pts audio 0x8000bd is 0
[15:04:59] sync: first pts video is 10080
[15:05:03] sync: reached audio 0x8000bd pts 901440, exiting early
[15:05:03] sync: reached video pts 902880, exiting early
[15:05:05] work: average encoding speed for job is 53.145336 fps
[15:05:05] comb detect: heavy 224 | light 14 | uncombed 10 | total 248
[15:05:05] vfr: 248 frames output, 0 dropped and 0 duped for CFR/PFR
[15:05:05] vfr: lost time: 0 (0 frames)
[15:05:05] vfr: gained time: 0 (0 frames) (0 not accounted for)
[15:05:05] stream: 10183 good frames, 0 errors (0%)
[15:05:05] ac3-decoder done: 1039 frames, 0 decoder errors
[15:05:05] mpeg2video-decoder done: 830 frames, 0 decoder errors
[15:05:05] sync: got 248 frames, 275 expected
[15:05:05] sync: framerate min 25.000 fps, max 25.000 fps, avg 25.000 fps
x265 [info]: frame I:      2, Avg QP:26.10  kb/s: 8696.40
x265 [info]: frame P:     50, Avg QP:27.22  kb/s: 2102.86
x265 [info]: frame B:    196, Avg QP:33.05  kb/s: 184.13
x265 [info]: Weighted P-Frames: Y:2.0% UV:2.0%
x265 [info]: consecutive B-frames: 3.8% 0.0% 3.8% 0.0% 92.3%
encoded 248 frames in 5.97s (41.54 fps), 639.62 kb/s, Avg QP:31.82
[15:05:05] mux: track 0, 248 frames, 794117 bytes, 632.76 kbps, fifo 256
[15:05:05] mux: track 1, 470 frames, 240879 bytes, 191.94 kbps, fifo 512
[15:05:05] libhb: work result = 0

# Encode Completed ...
v1.2.0:

Code: Select all

HandBrake 1.2.0 (2018121700)
OS: Microsoft Windows NT 10.0.16299.0
Ram: 16326 MB, 
GPU Information:
  NVIDIA GeForce GTX 1050 Ti - 25.21.14.1735
Screen: 1680x1050
Temp Dir: C:\Users\-\AppData\Local\Temp\
Install Dir: C:\Program Files\HandBrake
Data Dir: C:\Users\-\AppData\Roaming\HandBrake

-------------------------------------------


# Starting Encode ...

[15:14:51] hb_init: starting libhb thread
[15:14:51] 1 job(s) to process
[15:14:51] json job:
{
  "Audio": {
    "AudioList": [
      {
        "Bitrate": 192,
        "DRC": 0.0,
        "Encoder": "av_aac",
        "Gain": 0.0,
        "Mixdown": 4,
        "NormalizeMixLevel": false,
        "Samplerate": 48000,
        "Track": 0,
        "DitherMethod": 0
      }
    ],
    "CopyMask": [
      "copy:aac",
      "copy:ac3",
      "copy:dtshd",
      "copy:dts",
      "copy:eac3",
      "copy:flac",
      "copy:mp3",
      "copy:truehd"
    ],
    "FallbackEncoder": "ac3"
  },
  "Destination": {
    "ChapterList": [
      {
        "Name": "Chapter 1"
      }
    ],
    "ChapterMarkers": true,
    "AlignAVStart": false,
    "File": "C:\\Users\\-\\AppData\\Local\\Temp\\tmp37B3.mkv",
    "Mp4Options": {
      "IpodAtom": false,
      "Mp4Optimize": false
    },
    "Mux": "mp4"
  },
  "Filters": {
    "FilterList": [
      {
        "ID": 5,
        "Settings": {
          "mode": "3"
        }
      },
      {
        "ID": 3,
        "Settings": {
          "block-height": "16",
          "block-thresh": "40",
          "block-width": "16",
          "filter-mode": "2",
          "mode": "3",
          "motion-thresh": "1",
          "spatial-metric": "2",
          "spatial-thresh": "1"
        }
      },
      {
        "ID": 9,
        "Settings": {
          "cb-frame-count": 2,
          "cb-origin-tune": 0.9,
          "cb-patch-size": 7,
          "cb-prefilter": 0,
          "cb-range": 3,
          "cb-strength": 2.4,
          "y-frame-count": 2,
          "y-origin-tune": 0.9,
          "y-patch-size": 7,
          "y-prefilter": 0,
          "y-range": 3,
          "y-strength": 1.5
        }
      },
      {
        "ID": 12,
        "Settings": {
          "cb-kernel": "isolap",
          "cb-strength": 0.06,
          "y-kernel": "isolap",
          "y-strength": 0.1
        }
      },
      {
        "ID": 11,
        "Settings": {
          "crop-bottom": "0",
          "crop-left": "0",
          "crop-right": "0",
          "crop-top": "0",
          "height": "576",
          "width": "720"
        }
      },
      {
        "ID": 6,
        "Settings": {
          "mode": "1"
        }
      }
    ]
  },
  "PAR": {
    "Num": 1,
    "Den": 1
  },
  "Metadata": {},
  "SequenceID": 0,
  "Source": {
    "Angle": 1,
    "Range": {
      "Type": "preview",
      "Start": 2,
      "End": 900000,
      "SeekPoints": 60
    },
    "Title": 2,
    "Path": "D:\\DVD\\01 - Still Open All Hours\\Still Open All Hours - s01e00 - Pilot (Christmas Special)\\VTS_01_PGC_03_1.VOB"
  },
  "Subtitle": {
    "Search": {
      "Burn": false,
      "Default": false,
      "Enable": false,
      "Forced": false
    },
    "SubtitleList": []
  },
  "Video": {
    "Encoder": "x265",
    "Level": "auto",
    "TwoPass": false,
    "Turbo": false,
    "ColorMatrixCode": 0,
    "Options": "strong-intra-smoothing=0:rect=0",
    "Preset": "fast",
    "Profile": "main",
    "Quality": 25.0,
    "QSV": {
      "Decode": false,
      "AsyncDepth": 0
    }
  }
}
[15:14:51] CPU: Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz
[15:14:51]  - Intel microarchitecture Kaby Lake
[15:14:51]  - logical processor count: 4
[15:14:51] Intel Quick Sync Video support: no
[15:14:51] hb_scan: path=D:\DVD\01 - Still Open All Hours\Still Open All Hours - s01e00 - Pilot (Christmas Special)\VTS_01_PGC_03_1.VOB, title_index=2
udfread ERROR: ECMA 167 Volume Recognition failed
src/libbluray/disc/disc.c:323: failed opening UDF image D:\DVD\01 - Still Open All Hours\Still Open All Hours - s01e00 - Pilot (Christmas Special)\VTS_01_PGC_03_1.VOB
src/libbluray/disc/disc.c:424: error opening file BDMV\index.bdmv
src/libbluray/disc/disc.c:424: error opening file BDMV\BACKUP\index.bdmv
[15:14:51] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[15:14:51] dvd: not a dvd - trying as a stream/file instead
[15:14:51] file is MPEG Program Stream
[15:14:51] Probing 3 unknown streams
[15:14:51]     Probe: Found stream mpegvideo. stream id 0xe0-0x0
[15:14:51] Found the following streams
[15:14:51]     Video Streams :
[15:14:51]       0xe0-0x0 type MPEG2 (0x2)
[15:14:51]     Audio Streams :
[15:14:51]       0xbd-0x80 type AC3 (0x81)
[15:14:51]     Subtitle Streams :
[15:14:51]       0xbd-0x20 type DVD Subtitle (0x0)
[15:14:51]     Other Streams :
[15:14:51] stream id 0xbd (type 0x81 substream 0x80) audio 0x8000bd
[15:14:51] stream id 0xbd (type 0x0 substream 0x20) subtitle 0x2000bd
[15:14:51] scan: decoding previews for title 2
[15:14:51] file is MPEG Program Stream
[15:14:51] Probing 3 unknown streams
[15:14:51]     Probe: Found stream mpegvideo. stream id 0xe0-0x0
[15:14:51] scan: audio 0x8000bd: ac3, rate=48000Hz, bitrate=192000 Unknown (AC3) (2.0 ch)
[15:14:51] stream: 68 good frames, 0 errors (0%)
[15:14:51] scan: 10 previews, 720x576, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 64:45
[15:14:51] Title is likely interlaced or telecined (5 out of 10 previews). You should do something about that.
[15:14:51] libhb: scan thread found 1 valid title(s)
[15:14:51] starting job
[15:14:51] decomb filter thread started for segment 0
[15:14:51] decomb filter thread started for segment 1
[15:14:51] decomb filter thread started for segment 2
[15:14:51] mask filter thread started for segment 0
[15:14:51] mask filter thread started for segment 2
[15:14:51] decomb check thread started for segment 1
[15:14:51] mask erode thread started for segment 1
[15:14:51] decomb check thread started for segment 3
[15:14:51] decomb filter thread started for segment 3
[15:14:51] mask dilate thread started for segment 3
[15:14:51] decomb check thread started for segment 0
[15:14:51] mask filter thread started for segment 3
[15:14:51] mask erode thread started for segment 0
[15:14:51] decomb check thread started for segment 2
[15:14:51] mask erode thread started for segment 3
[15:14:51] mask erode thread started for segment 2
[15:14:51] mask dilate thread started for segment 0
[15:14:51] mask dilate thread started for segment 1
[15:14:51] mask dilate thread started for segment 2
[15:14:51] mask filter thread started for segment 1
[Parsed_yadif_0 @ 0000020f53687480] Option 'auto' not found
[AVFilterGraph @ 0000020f5364ac80] Error initializing filter 'yadif' with args 'mode=0:auto=1'
avfilter_init: avfilter_graph_parse2 failed (yadif='mode=0:auto=1')
[15:14:51] Failure to initialise filter 'avfilter', disabling
[15:14:51] NLMeans using SSE2 optimizations
[15:14:51] NLMeans thread started for segment 0
[15:14:51] NLMeans thread started for segment 1
[15:14:51] MTFrame thread started for segment 3
[15:14:51] NLMeans thread started for segment 3
[15:14:51] work: only 1 chapter, disabling chapter markers
[15:14:51] job configuration:
[15:14:51]  * source
[15:14:51]    + D:\DVD\01 - Still Open All Hours\Still Open All Hours - s01e00 - Pilot (Christmas Special)\VTS_01_PGC_03_1.VOB
[15:14:51]    + title 2, start 00:00:0.00 stop 00:00:10.00
[15:14:51]  * destination
[15:14:51] MTFrame thread started for segment 0
[15:14:51]    + C:\Users\-\AppData\Local\Temp\tmp37B3.mkv
[15:14:51]    + container: MPEG-4 (libavformat)
[15:14:51]  * video track
[15:14:51]    + decoder: mpeg2video
[15:14:51]      + bitrate 200 kbps
[15:14:51]    + filters
[15:14:51]      + Comb Detect (mode=3:spatial-metric=2:motion-thresh=1:spatial-thresh=1:filter-mode=2:block-thresh=40:block-width=16:block-height=16)
[15:14:51]      + Framerate Shaper (mode=1)
[15:14:51]        + frame rate: 25.000 fps -> constant 25.000 fps
[15:14:51] MTFrame thread started for segment 1
[15:14:51] MTFrame thread started for segment 2
[15:14:51]      + Denoise (nlmeans) (y-strength=1.5:y-origin-tune=0.9:y-patch-size=7:y-range=3:y-frame-count=2:y-prefilter=0:cb-strength=2.4:cb-origin-tune=0.9:cb-patch-size=7:cb-range=3:cb-frame-count=2:cb-prefilter=0)
[15:14:51]      + Crop and Scale (width=720:height=576:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[15:14:51] NLMeans thread started for segment 2
[15:14:51]        + source: 720 * 576, crop (0/0/0/0): 720 * 576, scale: 720 * 576
[15:14:51]      + Sharpen (lapsharp) (y-strength=0.1:y-kernel=isolap:cb-strength=0.06:cb-kernel=isolap)
[15:14:51]    + Output geometry
[15:14:51]      + storage dimensions: 720 x 576
[15:14:51]      + pixel aspect ratio: 1 : 1
[15:14:51]      + display dimensions: 720 x 576
[15:14:51]    + encoder: H.265 (libx265)
[15:14:51]      + preset:  fast
[15:14:51]      + options: strong-intra-smoothing=0:rect=0
[15:14:51]      + profile: main
[15:14:51]      + quality: 25.00 (RF)
[15:14:51]      + color profile: 5-1-6
[15:14:51]  * audio track 1
[15:14:51]    + decoder: Unknown (AC3) (2.0 ch) (track 1, id 0x8000bd)
[15:14:51]      + bitrate: 192 kbps, samplerate: 48000 Hz
[15:14:51]    + mixdown: Stereo
[15:14:51]    + dither: none
[15:14:51]    + encoder: AAC (libavcodec)
[15:14:51]      + bitrate: 192 kbps, samplerate: 48000 Hz
[15:14:51] file is MPEG Program Stream
[15:14:51] Probing 3 unknown streams
[15:14:51]     Probe: Found stream mpegvideo. stream id 0xe0-0x0
[15:14:51] sync: expecting 275 video frames
x265 [info]: HEVC encoder version 2.9
x265 [info]: build info [Windows][GCC 7.1.0][64 bit] 8bit+10bit+12bit
x265 [info]: using cpu capabilities: MMX2 SSE2Fast LZCNT SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x265 [info]: Main profile, Level-3 (Main tier)
x265 [info]: Thread pool created using 4 threads
x265 [info]: Slices                              : 1
x265 [info]: frame threads / pool features       : 2 / wpp(9 rows)
x265 [warning]: Source height < 720p; disabling lookahead-slices
x265 [info]: Coding QT: max CU size, min CU size : 64 / 8
x265 [info]: Residual QT: max TU size, max depth : 32 / 1 inter / 1 intra
x265 [info]: ME / range / subpel / merge         : hex / 57 / 2 / 2
x265 [info]: Keyframe min / max / scenecut / bias: 25 / 250 / 40 / 5.00
x265 [info]: Lookahead / bframes / badapt        : 15 / 4 / 0
x265 [info]: b-pyramid / weightp / weightb       : 1 / 1 / 0
x265 [info]: References / ref-limit  cu / depth  : 3 / on / on
x265 [info]: AQ: mode / str / qg-size / cu-tree  : 1 / 1.0 / 32 / 1
x265 [info]: Rate Control / qCompress            : CRF-25.0 / 0.60
x265 [info]: tools: rd=2 psy-rd=2.00 rskip signhide tmvp fast-intra deblock sao
[ac3 @ 0000020f53dfb940] frame sync error
[15:14:51] sync: first pts audio 0x8000bd is 0
[15:14:51] sync: first pts video is 10080
[15:14:56] sync: reached audio 0x8000bd pts 901440, exiting early
[15:14:56] sync: reached video pts 902880, exiting early
[15:14:58] work: average encoding speed for job is 49.337597 fps
[15:14:58] comb detect: heavy 224 | light 14 | uncombed 10 | total 248
[15:14:58] vfr: 248 frames output, 0 dropped and 0 duped for CFR/PFR
[15:14:58] vfr: lost time: 0 (0 frames)
[15:14:58] vfr: gained time: 0 (0 frames) (0 not accounted for)
[15:14:58] stream: 20201 good frames, 0 errors (0%)
[15:14:58] ac3-decoder done: 2012 frames, 0 decoder errors
[15:14:58] mpeg2video-decoder done: 1609 frames, 0 decoder errors
[15:14:58] sync: got 248 frames, 275 expected
[15:14:58] sync: framerate min 25.000 fps, max 25.000 fps, avg 25.000 fps
x265 [info]: frame I:      2, Avg QP:26.22  kb/s: 10947.90
x265 [info]: frame P:     50, Avg QP:27.32  kb/s: 2782.56
x265 [info]: frame B:    196, Avg QP:33.24  kb/s: 266.41
x265 [info]: Weighted P-Frames: Y:2.0% UV:2.0%
x265 [info]: consecutive B-frames: 3.8% 0.0% 3.8% 0.0% 92.3%
encoded 248 frames in 6.60s (37.58 fps), 859.84 kb/s, Avg QP:31.99
[15:14:58] mux: track 0, 248 frames, 1067193 bytes, 850.35 kbps, fifo 256
[15:14:58] mux: track 1, 470 frames, 240579 bytes, 191.70 kbps, fifo 512

# Encode Completed ...

[15:14:58] libhb: work result = 0

User avatar
BradleyS
Moderator
Posts: 1491
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by BradleyS » Fri Dec 28, 2018 4:18 pm

The position of some controls have changed, but the underlying settings are the same, and comparing the two logs reveals the same number of interlaced frames detected.

Can you be more specific about what isn't working properly? Is the Yadif interlacer working at all for you? Do the other deinterlacers work?

rollin_eng
Veteran User
Posts: 2990
Joined: Wed May 04, 2011 11:06 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by rollin_eng » Fri Dec 28, 2018 4:22 pm

15:14:51] mask filter thread started for segment 1
[Parsed_yadif_0 @ 0000020f53687480] Option 'auto' not found
[AVFilterGraph @ 0000020f5364ac80] Error initializing filter 'yadif' with args 'mode=0:auto=1'
avfilter_init: avfilter_graph_parse2 failed (yadif='mode=0:auto=1')
[15:14:51] Failure to initialise filter 'avfilter', disabling
[15:14:51]

You are getting this error in 1.2

Don’t know what it means, perhaps someone with more knowledge will.

User avatar
BradleyS
Moderator
Posts: 1491
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by BradleyS » Fri Dec 28, 2018 4:23 pm

Good spot. We'll look into this.

cufinnev
Posts: 4
Joined: Fri Dec 28, 2018 2:52 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by cufinnev » Fri Dec 28, 2018 4:43 pm

BradleyS wrote:
Fri Dec 28, 2018 4:18 pm
The position of some controls have changed, but the underlying settings are the same, and comparing the two logs reveals the same number of interlaced frames detected.

Can you be more specific about what isn't working properly? Is the Yadif interlacer working at all for you? Do the other deinterlacers work?
Basically I see interlaced frames with v1.2.0, but I do not with v1.1.2. I only know how to use some of the options for Handbrake - anything more technical is probably beyond me without Google.

The only way deinterlacing works is by changing the option Interlace Detection from Default to Off.

User avatar
s55
HandBrake Team
Posts: 9360
Joined: Sun Dec 24, 2006 1:05 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by s55 » Fri Dec 28, 2018 5:48 pm

John tracked it down and fixed this.
https://github.com/HandBrake/HandBrake/ ... c8576b2e7f

Will be in tomorrows nightly, or the upcoming 1.2.1 patch release sometime after the new year.

cufinnev
Posts: 4
Joined: Fri Dec 28, 2018 2:52 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by cufinnev » Fri Dec 28, 2018 7:42 pm

In the meantime, I will use v1.1.2 to encode my videos. I don't really see any reason to move to v1.2.0, as the encoding seems to take longer.

User avatar
JohnAStebbins
HandBrake Team
Posts: 5259
Joined: Sat Feb 09, 2008 7:21 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by JohnAStebbins » Sat Dec 29, 2018 3:29 pm

cufinnev wrote:
Fri Dec 28, 2018 7:42 pm
In the meantime, I will use v1.1.2 to encode my videos. I don't really see any reason to move to v1.2.0, as the encoding seems to take longer.
If you decide you want to use the new release, you could substitute the decomb filter for deinterlace. It has more options, but it also implements the same yadif modes as the deinterlace filter.

Looking at your logs, I do see that 1.2.0 was a little bit slower than 1.1.2. 49fps vs 53fps. I'm not sure what would cause that, but it could be internal changes in the x265 encoder caused your particular settings to be slightly slower.

cufinnev
Posts: 4
Joined: Fri Dec 28, 2018 2:52 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by cufinnev » Sun Dec 30, 2018 12:25 am

JohnAStebbins wrote:
Sat Dec 29, 2018 3:29 pm
cufinnev wrote:
Fri Dec 28, 2018 7:42 pm
In the meantime, I will use v1.1.2 to encode my videos. I don't really see any reason to move to v1.2.0, as the encoding seems to take longer.
If you decide you want to use the new release, you could substitute the decomb filter for deinterlace. It has more options, but it also implements the same yadif modes as the deinterlace filter.

Looking at your logs, I do see that 1.2.0 was a little bit slower than 1.1.2. 49fps vs 53fps. I'm not sure what would cause that, but it could be internal changes in the x265 encoder caused your particular settings to be slightly slower.
I can't remember why I chose yadif over decomb, I think it was to do with quality, but i can't be sure.

I don't want to preserve top quality and I can live with this. While I don't want to rush encoding, I have enough files that I don't want to spend an hour encoding each one. It takes me about 15-20 minutes to encode a 30 episode ripped from DVD and this is ideal for me. Each file averages around 165 MB (based on 69 x 30-minute episodes from DVD) - this is a good size for me, with good enough quality.

My problem is that a lot of my DVD material is old - some dating back from 1969, while some dates from this year. So my preset is a one for all - some is interlaced, some isn't and some seem to have partial (?) interlacing between frames, or even partial interlacing within the frame. I don't like to see interlacing, so choose to try and deinterlace.

Based on what I have said, what would be my best option to choose for deinterlacing in v1.2.0? I am more than happy to try out your suggestions, as I have nothing to lose.

User avatar
BradleyS
Moderator
Posts: 1491
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by BradleyS » Sun Dec 30, 2018 12:36 am

There are two components to deinterlacing in HandBrake, interlace detection which inspects each frame of your source for combing artifacts (the horizontal lines created by interlacing viewed progressive), and the actual filtering. It's a good idea when working with mixed sources to always enable interlacing detection so that interlaced frames are deinterlaced, and progressive frames are left alone. This is what the official presets do, except the production presets which are for professional use.

As far as which interlacing algorithm is best, this depends on the source and how much time you have to spend on filtering/encoding. EEDI2 provides a superior result in most cases but is terribly slow. HandBrake's decomb uses a combination of blend interpolation for frames with only a small amount of combing artifacts and yadif for heavily interlaced frames. Yadif uses yadif if any combing is detected. Bob is a different technique altogether that creates higher frame rates (smoother motion) and probably not what most people want for movies.

Decomb is the default, yadif is a good alternative. EEDI2 is best left for difficult sources that still look a bit jagged after deinterlacing. Bob is something experienced people may want in certain situations, but in my opinion is bad for movies.

ITgreybeard
Posts: 68
Joined: Tue Feb 11, 2014 3:47 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by ITgreybeard » Mon Jan 14, 2019 9:23 pm

'Twould be kind and productive to have this info included in the Handbrake documentation. Just saying...

User avatar
BradleyS
Moderator
Posts: 1491
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing doesn't work the same since v1.2.0

Post by BradleyS » Mon Jan 14, 2019 9:26 pm

Indeed. It's on my list but like most things, takes a back seat to income-earning activities. Patches are, of course, welcome.

Post Reply