Included subtitles of loaded mkv not shown up in Handbrake

General questions or discussion about HandBrake, Video and/or audio transcoding, trends etc.
Post Reply
dag0
Posts: 6
Joined: Sat Mar 12, 2011 2:13 pm

Included subtitles of loaded mkv not shown up in Handbrake

Post by dag0 »

Hello!

I am converting either mkv's or m2ts (both ripped from blue-ray) files to
mkv.
My problem is, that handbrake always offers me to select: "foreign audio search",
although there are subtitles in different languages included in the
original file. And: When I select to include "foreign audio search" whith
"forced only" selected or not: there do never appear subs in my resulting
mkv.
I have errors in my log (see beneath): "add_ffmpeg_subtitle: unknown subtitle stream type: 0x17006".
Do I understand correctly: "forced only" means that only subs in foreign
language passages are included?

Bye,
dag0

Code: Select all

# Windows GUI 0.9.5 2011010300
# Running: Microsoft Windows NT 5.1.2600 Service Pack 3
# CPU: Intel(R) Core(TM)2 Quad CPU    Q8400  @ 2.66GHz
# Ram: 3582 MB
# Screen: 1280x1024
# Temp Dir: C:\Documents and Settings\Patrice\Local Settings\Temp\
# Install Dir: D:\Program Files\Handbrake
# Data Dir: C:\Documents and Settings\Patrice\Application Data\HandBrake\HandBrake\0.9.5.3728

# CLI Query:  -i "N:\Shared Videos\Ice Age untouched_BR.mkv" -t 1 -c 1 -o "N:\Shared Videos\Ice Age untouched_BR-1.mkv"  -f mkv -w 1920 --loose-anamorphic  -e x264 -q 19 -a 1,2 -E copy:ac3,copy:ac3 -6 auto,auto -R Auto,Auto -B auto,auto -D 0.0,0.0 --subtitle scan -x b-adapt=2:rc-lookahead=50:level=41 --verbose=1
# User Query: False
-------------------------------------------

[02:58:53] hb_init: checking cpu count
[02:58:53] hb_init: starting libhb thread
HandBrake 0.9.5 (2011010300) - MinGW i386 - http://handbrake.fr
4 CPUs detected
Opening N:\Shared Videos\Ice Age untouched_BR.mkv...
[02:58:53] hb_scan: path=N:\Shared Videos\Ice Age untouched_BR.mkv, title_index=1
libbluray/bdnav/index_parse.c:157: indx_parse(): error opening N:\Shared Videos\Ice Age untouched_BR.mkv/BDMV/index.bdmv
libbluray/bluray.c:960: nav_get_title_list(N:\Shared Videos\Ice Age untouched_BR.mkv) failed (0x189b858)
[02:58:53] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 4.1.3
libdvdread: Encrypted DVD support unavailable.
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[02:58:53] dvd: not a dvd - trying as a stream/file instead
Input #0, matroska,webm, from 'N:\Shared Videos\Ice Age untouched_BR.mkv':
  Duration: 01:21:04.89, start: 0.000000, bitrate: 1280 kb/s
    Stream #0.0: Video: h264, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc
    Stream #0.1(ger): Audio: ac3, 48000 Hz, 5.1, s16, 640 kb/s
    Stream #0.2(eng): Audio: ac3, 48000 Hz, 5.1, s16, 640 kb/s
    Stream #0.3(ger): Subtitle: pgssub
    Stream #0.4(ger): Subtitle: pgssub
    Stream #0.5(ger): Subtitle: pgssub
[02:58:55] add_ffmpeg_subtitle: unknown subtitle stream type: 0x17006
[02:58:55] add_ffmpeg_subtitle: unknown subtitle stream type: 0x17006
[02:58:55] add_ffmpeg_subtitle: unknown subtitle stream type: 0x17006
[02:58:55] scan: decoding previews for title 1
Scanning title 1...
[02:58:55] scan: audio 0x1: AC-3, rate=48000Hz, bitrate=640000 Deutsch (AC3) (5.1 ch)
[02:58:55] scan: audio 0x2: AC-3, rate=48000Hz, bitrate=640000 English (AC3) (5.1 ch)
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
Scanning title 1...
[02:59:00] scan: 10 previews, 1920x1080, 23.976 fps, autocrop = 20/20/0/0, aspect 16:9, PAR 1:1
[02:59:00] scan: title (0) job->width:1920, job->height:1040
[02:59:00] libhb: scan thread found 1 valid title(s)
+ title 1:
  + stream: N:\Shared Videos\Ice Age untouched_BR.mkv
  + duration: 01:21:04
  + size: 1920x1080, pixel aspect: 1/1, display aspect: 1.78, 23.976 fps
  + autocrop: 20/20/0/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 01:21:04
  + audio tracks:
    + 1, Deutsch (AC3) (5.1 ch) (iso639-2: deu), 48000Hz, 640000bps
    + 2, English (AC3) (5.1 ch) (iso639-2: eng), 48000Hz, 640000bps
  + subtitle tracks:
Subtitle Scan Enabled - enabling subtitles if found for foreign language segments
[02:59:00] 2 job(s) to process
[02:59:00] starting job
[02:59:00] sync: expecting 116664 video frames
[02:59:00] job configuration:
[02:59:00]  * source
[02:59:00]    + N:\Shared Videos\Ice Age untouched_BR.mkv
[02:59:00]    + title 1, chapter(s) 1 to 1
[02:59:00]    + container: matroska,webm
[02:59:00]    + data rate: 1280 kbps
[02:59:00]  * destination
[02:59:00]    + N:\Shared Videos\Ice Age untouched_BR-1.mkv
[02:59:00]    + container: Matroska (.mkv)
[02:59:00]  * video track
[02:59:00]    + decoder: h264
[02:59:00]    + frame rate: same as source (around 23.976 fps)
[02:59:00]    + loose anamorphic
[02:59:00]      + storage dimensions: 1920 * 1080 -> 1920 * 1040, crop 20/20/0/0, mod 0
[02:59:00]      + pixel aspect ratio: 1 / 1
[02:59:00]      + display dimensions: 1920 * 1040
[03:46:21] reader: done. 1 scr changes
[03:46:22] work: average encoding speed for job is 0.000000 fps
[03:46:22] render: lost time: 0 (0 frames)
[03:46:22] render: gained time: 0 (0 frames) (0 not accounted for)
[03:46:22] starting job
[03:46:22] sync: expecting 116664 video frames
[03:46:22] job configuration:
[03:46:22]  * source
[03:46:22]    + N:\Shared Videos\Ice Age untouched_BR.mkv
[03:46:22]    + title 1, chapter(s) 1 to 1
[03:46:22]    + container: matroska,webm
[03:46:22]    + data rate: 1280 kbps
[03:46:22]  * destination
[03:46:22]    + N:\Shared Videos\Ice Age untouched_BR-1.mkv
[03:46:22]    + container: Matroska (.mkv)
[03:46:22]  * video track
[03:46:22]    + decoder: h264
[03:46:22]    + frame rate: same as source (around 23.976 fps)
[03:46:22]    + loose anamorphic
[03:46:22]      + storage dimensions: 1920 * 1080 -> 1920 * 1040, crop 20/20/0/0, mod 0
[03:46:22]      + pixel aspect ratio: 1 / 1
[03:46:22]      + display dimensions: 1920 * 1040
[03:46:22]    + encoder: x264
[03:46:22]      + options: b-adapt=2:rc-lookahead=50:level=41
[03:46:22]      + quality: 19.00 (RF)
[03:46:22]  * audio track 0
[03:46:22]    + decoder: Deutsch (AC3) (5.1 ch) (track 1, id 1)
[03:46:22]      + bitrate: 640 kbps, samplerate: 48000 Hz
[03:46:22]    + AC3 passthrough
[03:46:22]  * audio track 1
[03:46:22]    + decoder: English (AC3) (5.1 ch) (track 1, id 2)
[03:46:22]      + bitrate: 640 kbps, samplerate: 48000 Hz
[03:46:22]    + AC3 passthrough
[03:46:22] encx264: min-keyint: auto (23), keyint: 240
[03:46:22] encx264: encoding with stored aspect 1/1
[03:46:22] encx264: Encoding at constant RF 19.000000
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.1 Cache64
x264 [info]: profile High, level 4.1
No accelerated IMDCT transform found
No accelerated IMDCT transform found
[03:46:24] reader: first SCR 0 id 0 DTS 0
[06:25:06] reader: done. 1 scr changes
[06:25:08] work: average encoding speed for job is 12.247196 fps
[06:25:08] sync: got 116639 frames, 116664 expected
[06:25:08] h264-decoder done: 116639 frames, 0 decoder errors, 0 drops
[06:25:08] render: lost time: 0 (0 frames)
[06:25:08] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: frame I:1382  Avg QP:11.90  size:171130  PSNR Mean Y:51.69 U:54.99 V:55.45 Avg:52.53 Global:52.06
x264 [info]: frame P:38390 Avg QP:16.62  size: 34645  PSNR Mean Y:49.16 U:52.89 V:53.25 Avg:50.06 Global:49.47
x264 [info]: frame B:76867 Avg QP:21.30  size: 12948  PSNR Mean Y:48.03 U:52.35 V:52.67 Avg:49.03 Global:48.45
x264 [info]: consecutive B-frames:  3.2%  4.5% 57.8% 34.6%
x264 [info]: mb I  I16..4: 15.4% 61.2% 23.4%
x264 [info]: mb P  I16..4:  4.9% 12.6%  1.5%  P16..4: 26.7% 10.2%  5.3%  0.0%  0.0%    skip:38.9%
x264 [info]: mb B  I16..4:  0.7%  2.0%  0.2%  B16..8: 25.3%  4.1%  0.7%  direct: 3.9%  skip:63.1%  L0:43.0% L1:51.4% BI: 5.6%
x264 [info]: 8x8 transform intra:66.2% inter:72.4%
x264 [info]: coded y,uvDC,uvAC intra: 58.8% 62.0% 28.8% inter: 15.0% 12.7% 0.9%
x264 [info]: i16 v,h,dc,p: 39% 26%  8% 26%
x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 17% 19% 23%  6%  7%  7%  7%  7%  7%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 21% 22% 21%  5%  9%  7%  7%  5%  4%
x264 [info]: i8c dc,h,v,p: 54% 22% 18%  6%
x264 [info]: Weighted P-Frames: Y:2.7% UV:1.9%
x264 [info]: ref P L0: 62.4% 10.2% 18.8%  8.5%  0.2%
x264 [info]: ref B L0: 79.0% 16.9%  4.0%
x264 [info]: ref B L1: 89.4% 10.6%
x264 [info]: SSIM Mean Y:0.9903915 (20.173db)
x264 [info]: PSNR Mean Y:48.444 U:52.556 V:52.897 Avg:49.412 Global:48.793 kb/s:4212.72
[06:25:09] mux: track 0, 116639 frames, 2561711278 bytes, 4212.56 kbps, fifo 8
[06:25:09] mux: track 1, 152028 frames, 389191680 bytes, 640.00 kbps, fifo 256
[06:25:09] mux: track 2, 152028 frames, 389191680 bytes, 640.00 kbps, fifo 256
[06:25:09] libhb: work result = 0
Rip done!
HandBrake has exited.
User avatar
Rodeo
HandBrake Team
Posts: 12754
Joined: Tue Mar 03, 2009 8:55 pm

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by Rodeo »

HandBrake doesn't support Blu-Ray PGS Subtitles.
dag0
Posts: 6
Joined: Sat Mar 12, 2011 2:13 pm

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by dag0 »

Thanks for your answer, but is there any workaround? And: handbrake doesn't neither process chapters from my blue-ray-ripped m2ts - is that true? (it does whith mkv)
bye, dag0
TedJ
Veteran User
Posts: 5388
Joined: Wed Feb 20, 2008 11:25 pm

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by TedJ »

Use mkverge to copy the PGS subtitle stream from the source file into your encode.

MPEG2 Transport Stream (m2ts) files don't support chapters.
dag0
Posts: 6
Joined: Sat Mar 12, 2011 2:13 pm

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by dag0 »

You mean extract subs from the source, demux the encode and remux with subs? Puh...
Where are the blue-ray chapters located?
User avatar
Rodeo
HandBrake Team
Posts: 12754
Joined: Tue Mar 03, 2009 8:55 pm

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by Rodeo »

dag0 wrote:You mean extract subs from the source, demux the encode and remux with subs? Puh...
Where are the blue-ray chapters located?
Not sure. In any case, if you rip your BD to a file/folder structure or an ISO image and point HB to the folder above BDMV, it will find chapters. Note that libbluray doesn't support ISO images yet, so you'll have to mount it and point HB to the mounted image rather than the image file.
dag0
Posts: 6
Joined: Sat Mar 12, 2011 2:13 pm

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by dag0 »

Your right, that works! I only tried to load the BDMW-Folder which gave me an error. Thanks for the hint! A pity, that the subs are not supported...
MikeEckman
Posts: 10
Joined: Fri Sep 18, 2009 2:14 am

Re: Included subtitles of loaded mkv not shown up in Handbra

Post by MikeEckman »

A workaround I use is to search the internet for SRT subtitle files for the movies you are encoding.

I have found that www.subtitlesz.com is a good source. They're not all perfect (and it stinks to have to redo an encode just for the subtitles) but a tip Ive found is when downloading an SRT file for a Blu-Ray I ripped, I make sure to look at all the options I have in my language (English) and take only the ones that were sourced from a Blu-Ray. I know duuuh, right, but a lot of the ones out there are sourced from DVD or other sources, and they wont sync properly.

I really hope Handbrake one day can correct this as I miss the ease of getting subtitles right when ripping DVDs.
Post Reply