NO AUDIO?... Read Here! (Summary in First Post) **UPDATED**

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Locked
terabyteme
Posts: 9
Joined: Sun Apr 08, 2007 7:30 pm

Post by terabyteme »

Ok here's my list of problematic movies - if anyone can suggest any other ways of encoding please let me know and I can post back with results. I know these kinds of things aren't easy to figure out.

--"Rent" - Ripped full disc with DVD Decrypter windows xp, then copied to mac for processing.
Encoded with:
h.264 main
framerate: same as source
2-pass
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Average bitrate: 1500
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 192
Result: No audio about half way through the movie


I also attempted to encode this a second time with the following settings:

h.264 main
framerate: same as source
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Constant Quality: 70%
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 160
Result: No audio about half way through the movie

_________________


--"Howl's moving castle" - Ripped full disc with DVD Decrypter windows xp, then copied to mac for processing.
Encoded with:
h.264 main
framerate: same as source
2-pass
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Average bitrate: 1500
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 192
Result: No audio about half way through the movie

_________________


--"The Explorers" - Ripped full disc with MTR on mac
Encoded with:
h.264 main
framerate: same as source
2-pass
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Average bitrate: 1500
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 160
Result: No audio about half way through the movie

I also attempted to encode this a second time with the following settings:

h.264 main
framerate: same as source
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Constant Quality: 70%
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 128
Result: No audio about half way through the movie

_________________

System info:
Intel Macbook
MacTheRipper 2.6.6
Mediafork 0.8.0b1

Windows XP
DVD Decrypter 3.5.4.0
(no mediafork on this system)


I would also like to echo some previous comments made here - it seems when this problem happens the encoding frame rate drops drastically. Usually I will get about 28-30fps, but when doing a "problem movie" it will drop to 5-8fps. Imagine my surprise when I woke up after leaving my macbook on all night encoding, and I still had to wait until the afternoon for it to finish the queue.
cbud
Bright Spark User
Posts: 181
Joined: Thu Feb 22, 2007 2:24 am

Post by cbud »

petvas wrote:I had the exact same issue with The Rock and after DTOX it works...
The Rock (first edition) has a known mastering problem (read about it on the web years ago), something to do with the layer change. Some DVD players could not even play it. I could never get a good backup copy of it on DL disc. The first layer would play fine, but the second would not. The movie is great, I wish I had bought the Criterion version instead.
loyalty_anchored
Bright Spark User
Posts: 183
Joined: Wed Mar 14, 2007 1:49 pm

Post by loyalty_anchored »

ok guys, i just wanted to come back with more solid information, i had three DVDs that would consistantly give me dropped audio and hickups between chapters when encoding H.264 at full resolution and 3000 bitrate. it did not matter what i ripped the DVD with, what mode i ripped it in:

1- robocop
2- rocky3
3- the suicide kings

now that i am encoding in the CLI all three of these DVDs have encoded with no audio hickups and no dropped audio.

anyone who is experiencing audio drops and hickups, just give the CLI a try.

:D

by the way, why is this in support? isnt this clearly a bug?
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Post by jbrjake »

loyalty_anchored wrote:by the way, why is this in support? isnt this clearly a bug?
Because it's better to have one thread on the issue, and if we put it in bugs, rude people who refuse to search before posting will start new threads about it in support for each affected DVD. It's also not a single, consistently reproducible bug, or we wouldn't have this long of a thread.
terabyteme
Posts: 9
Joined: Sun Apr 08, 2007 7:30 pm

Post by terabyteme »

I decided to try the CLI on one of my "problem" movies (the explorers), but unfortunately this didn't help - in fact the entire movie is now without audio and it will only play in VLC, not quicktime("error opening movie: the movie could not be opened"). No errors or slowdowns occurred while the CLI version processed.

Here was the command I used:

/Volumes/MediaFork/MediaForkCLI -i /movies/THE_EXPLORERS/ -o /movies/the_explorers.mp4 -e x264 -b 1500 -E ac3 -R 44.1 -B 160 -2 -w 720 -l 416

terabyteme wrote:Ok here's my list of problematic movies - if anyone can suggest any other ways of encoding please let me know and I can post back with results. I know these kinds of things aren't easy to figure out.


--"The Explorers" - Ripped full disc with MTR on mac
Encoded with:
h.264 main
framerate: same as source
2-pass
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Average bitrate: 1500
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 160
Result: No audio about half way through the movie

I also attempted to encode this a second time with the following settings:

h.264 main
framerate: same as source
Keep AR: On
Anamorphic: Off
Deinterlace: Off
Constant Quality: 70%
Audio:
English AC3 5ch
Sample rate: 44.1
Bitrate: 128
Result: No audio about half way through the movie
loyalty_anchored
Bright Spark User
Posts: 183
Joined: Wed Mar 14, 2007 1:49 pm

Post by loyalty_anchored »

so it did not slow the encode down, yet there is no audio at all? i have not tried encoding and using AC3 pass through, so i cannot speak for it, but if you have no audio at all, i would say it is not related to the audio DROP that so many have been experiencing.

try not specifying an audio bitrate if your using AC3 passthrough, look at the GUI, i dont think you have the option to re-encode the AC3 stream. that is probably your issue, you are doing -E ac3 and -B 160. scratch out the -B 160 and the -R just let it use the source.

in any case, you should add a -v to your string (verbose) and you should see more log entries in the CLI, it might help you figure out what you are doing wrong. i do believe this to be user error.
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Post by jbrjake »

terabyteme wrote:/Volumes/MediaFork/MediaForkCLI -i /movies/THE_EXPLORERS/ -o /movies/the_explorers.mp4 -e x264 -b 1500 -E ac3 -R 44.1 -B 160 -2 -w 720 -l 416
You're trying to put AC3 in an .mp4 and you don't know why QuickTime won't open it?

Also: try setting the -R to 48. Helped NightStrm.

And Loyalty_Anchored -- if you don't know what the problem is, *don't respond*...your advice is just confusing. AC3 is not compatible with .mp4, it doesn't matter what the bitrate is.
Canucklehead
Posts: 2
Joined: Fri Mar 23, 2007 6:31 pm

Post by Canucklehead »

Although I am happy that I seem to be NOT alone with this problem (I am ripping 800 DVD's and have discovered about 11% so far loses sound after various times). I was wondering if one of the Moderators can post some srt of summary and what has been concluded so far. I have read all 9 pages but am a bit confused. Should I try an earlier version?.

I would like to also thank everyone involved for a stellar job done, it has been a tremendous value to the Apple TV purchase !.
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Post by nightstrm »

SUMMARY

For best results (but not necessarily 100%):
1. Use the command-line interface
2. Make sure your sample rate is the same as your input file (almost always 48kHz)
3. Do not go above 160kbps for audio bitrate if encoding to stereo (unnecessary anyways as the encoder will not do above that anyways)

Should also note, this list may not work for every title and that I am not a dev or a moderator, but it has solved 100% of the audio dropout problems I have experienced in the past.
loyalty_anchored
Bright Spark User
Posts: 183
Joined: Wed Mar 14, 2007 1:49 pm

Post by loyalty_anchored »

jbrjake wrote: And Loyalty_Anchored -- if you don't know what the problem is, *don't respond*...your advice is just confusing. AC3 is not compatible with .mp4, it doesn't matter what the bitrate is.
Sir yes sir! LOL.

Image
Loyalty_Anchored wrote: the -R just let it use the source
I did have some valuable recommendations in my post, as a matter of fact, the exact same as you gave. I am very well aware that I do not know as much as you when it comes to this application, I am only trying to help.
nightstrn wrote:SUMMARY

For best results (but not necessarily 100%):
1. Use the command-line interface
2. Make sure your sample rate is the same as your input file (almost always 48kHz)
3. Do not go above 160kbps for audio bitrate if encoding to stereo (unnecessary anyways as the encoder will not do above that anyways)

Should also note, this list may not work for every title and that I am not a dev or a moderator, but it has solved 100% of the audio dropout problems I have experienced in the past.
using the CLI has also solved 100% of my audio drop issues :D
petvas
Regular User
Posts: 82
Joined: Wed Feb 14, 2007 3:00 am

Post by petvas »

Is there a help file explaining the various command line options?
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Post by nightstrm »

http://handbrake.m0k.org/trac/wiki/CLIGuide

It's not complete, but will give you a pretty good idea.
terabyteme
Posts: 9
Joined: Sun Apr 08, 2007 7:30 pm

Post by terabyteme »

Doh! Thanks, you're right, I think I screwed that up. I must have been thinking about AAC and typed AC3 :) It's the first time I used the CLI so I'm sure I have some learning to do. I'll try it again later tonight and report back.


jbrjake wrote:
terabyteme wrote:/Volumes/MediaFork/MediaForkCLI -i /movies/THE_EXPLORERS/ -o /movies/the_explorers.mp4 -e x264 -b 1500 -E ac3 -R 44.1 -B 160 -2 -w 720 -l 416
You're trying to put AC3 in an .mp4 and you don't know why QuickTime won't open it?

Also: try setting the -R to 48. Helped NightStrm.

And Loyalty_Anchored -- if you don't know what the problem is, *don't respond*...your advice is just confusing. AC3 is not compatible with .mp4, it doesn't matter what the bitrate is.
terabyteme
Posts: 9
Joined: Sun Apr 08, 2007 7:30 pm

Post by terabyteme »

Ok, I tried the CLI again and no luck. The audio track cuts out at 1:10:47. I don't expect any magix fixes, I'm just posting this in the hope it has some useful data. This is the command line I used and the output from my terminal screen, however - I cut out all of the extraneous "adding 50 ms of silence" errors. There was over a thousand of them at least.


/Volumes/MediaFork/MediaForkCLI -i /movies/THE_EXPLORERS/ -o /movies/the_explorers.mp4 -e x264 -b 1500 -E faac -R 48 -B 160 -2 -w 720 -l 416 -v

[17:02:54] hb_init: checking cpu count
[17:02:54] hb_init: starting libhb thread
[17:02:54] thread 25182720 started ("libhb")
MediaFork 0.8.0b1 (2007021100) - http://mediafork.dynalias.com/
2 CPUs detected
Opening /movies/THE_EXPLORERS/...
[17:02:54] hb_scan: path=/movies/THE_EXPLORERS/, ti
[17:02:54] thread 25183744 started ("scan")
[17:02:54] scan: trying to open with libdvdread
[17:02:54] scan: DVD has 8 title(s)
[17:02:54] scan: scanning title 1
[17:02:54] scan: opening IFO for VTS 1
[17:02:54] scan: vts=1, ttn=1, cells=0->14, blocks=4->3007615, 3007612 blocks
[17:02:54] scan: duration is 01:46:25 (6385020 ms)
[17:02:54] scan: checking audio 1
[17:02:54] scan: id=80bd, lang=English (AC3)
[17:02:54] scan: checking audio 2
[17:02:54] scan: id=81bd, lang=English (AC3)
[17:02:54] scan: checking subtitle 1
[17:02:54] scan: id=20bd, lang=English
[17:02:54] scan: title 1 has 14 chapters
[17:02:54] scan: chap 1 c=0->0, b=4->137701 (137698), 315207 ms
[17:02:54] scan: chap 2 c=1->1, b=137702->273367 (135666), 275201 ms
[17:02:54] scan: chap 3 c=2->2, b=273368->460952 (187585), 383305 ms
[17:02:54] scan: chap 4 c=3->3, b=460953->621871 (160919), 349530 ms
[17:02:54] scan: chap 5 c=4->4, b=621872->881694 (259823), 521529 ms
[17:02:54] scan: chap 6 c=5->5, b=881695->1160226 (278532), 618407 ms
[17:02:54] scan: chap 7 c=6->6, b=1160227->1428933 (268707), 597393 ms
[17:02:54] scan: chap 8 c=7->7, b=1428934->1638669 (209736), 432304 ms
[17:02:54] scan: chap 9 c=8->8, b=1638670->1839832 (201163), 443335 ms
[17:02:54] scan: chap 10 c=9->10, b=1839833->1998369 (158537), 305730 ms
[17:02:54] scan: chap 11 c=11->11, b=1998370->2104610 (106241), 222456 ms
[17:02:54] scan: chap 12 c=12->12, b=2104611->2480310 (375700), 714646 ms
[17:02:54] scan: chap 13 c=13->13, b=2480311->2751034 (270724), 557543 ms
[17:02:54] scan: chap 14 c=14->14, b=2751035->3007615 (256581), 648427 ms
[17:02:54] scan: aspect = 16
[17:02:54] scan: decoding previews for title 1
Scanning title 1...
[17:02:55] scan: preview 1
[17:02:55] scan: rate=48000Hz, bitrate=448000
[17:02:55] scan: rate=48000Hz, bitrate=192000
[17:02:55] scan: preview 2
[17:02:55] scan: preview 3
[17:02:55] scan: preview 4
[17:02:55] scan: preview 5
[17:02:55] scan: preview 6
[17:02:55] scan: preview 7
[17:02:55] scan: preview 8
[17:02:55] scan: preview 9
[17:02:55] scan: preview 10
[17:02:55] scan: 720x480, 23.976 fps, autocrop = 0/0/6/6
[17:02:55] scan: title (0) job->width:704, job->height:400
[17:02:55] thread 25183744 exited ("scan")
[17:02:55] thread 25183744 joined ("scan")
[17:02:55] libhb: scan thread found 1 valid title(s)
+ title 1:
+ vts 1, ttn 1, cells 0->14 (3007612 blocks)
+ duration: 01:46:25
+ size: 720x480, aspect: 1.78, 23.976 fps
+ autocrop: 0/0/6/6
+ chapters:
+ 1: cells 0->0, 137698 blocks, duration 00:05:15
+ 2: cells 1->1, 135666 blocks, duration 00:04:35
+ 3: cells 2->2, 187585 blocks, duration 00:06:23
+ 4: cells 3->3, 160919 blocks, duration 00:05:50
+ 5: cells 4->4, 259823 blocks, duration 00:08:42
+ 6: cells 5->5, 278532 blocks, duration 00:10:18
+ 7: cells 6->6, 268707 blocks, duration 00:09:57
+ 8: cells 7->7, 209736 blocks, duration 00:07:12
+ 9: cells 8->8, 201163 blocks, duration 00:07:23
+ 10: cells 9->10, 158537 blocks, duration 00:05:06
+ 11: cells 11->11, 106241 blocks, duration 00:03:42
+ 12: cells 12->12, 375700 blocks, duration 00:11:55
+ 13: cells 13->13, 270724 blocks, duration 00:09:18
+ 14: cells 14->14, 256581 blocks, duration 00:10:48
+ audio tracks:
+ 80bd, English (AC3) (5 ch), 48000Hz, 448000bps
+ 81bd, English (AC3) (2 ch), 48000Hz, 192000bps
+ subtitle tracks:
+ 20bd, English
[17:02:55] thread 25183744 started ("work")
[17:02:55] 2 job(s) to process
[17:02:55] starting job
[17:02:55] + device /movies/THE_EXPLORERS/
[17:02:55] + title 1, chapter(s) 1 to 14
[17:02:55] + 720x480 -> 720x416, crop 0/0/6/6
[17:02:55] + deinterlace off
[17:02:55] + grayscale off
[17:02:55] + 23.976 fps, video bitrate 1500 kbps, pass 1
[17:02:55] + PixelRatio: 0, width:720, height: 416
[17:02:55] + encoder x264
[17:02:55] + audio 160 kbps, 48000 Hz
[17:02:55] + encoder faac
[17:02:55] thread 25202688 started ("reader")
[17:02:55] + output: /movies/the_explorers.mp4
[17:02:55] thread 25203712 started ("muxer")
[17:02:55] thread 25205760 started ("MPEG-2 decoder (libmpeg2)")
[17:02:55] thread 25187328 started ("Renderer")
[17:02:55] encx264: opening libx264 (pass 1)
[17:02:56] thread 26262016 started ("H.264/AVC encoder (libx264)")
[17:02:56] sync: expecting 153111 video frames
[17:02:56] sync: first pts is 25257
Encoding: task 1 of 2, 38.61 % (19.84 fps, avg 22.43 fps, ETA 01h09m51s)[17:46:52] PTS discontinuity (221957467, 26808)
Encoding: task 1 of 2, 66.51 % (21.72 fps, avg 22.25 fps, ETA 00h38m26s)[18:19:13] PTS discontinuity (160340459, 23977)
Encoding: task 1 of 2, 99.99 % (25.43 fps, avg 22.36 fps, ETA 00h00m01s)[18:57:02] reader: end of the title reached
[18:57:02] reader: done
[18:57:02] thread 25202688 exited ("reader")
Encoding: task 1 of 2, 100.00 % (25.00 fps, avg 22.36 fps, ETA 00h00m00s)[18:57:02] sync: got 153111 frames
Encoding: task 1 of 2, 100.00 % (25.00 fps, avg 22.36 fps, ETA 00h00m00s)[18:57:03] thread 25205760 exited ("MPEG-2 decoder (libmpeg2)")
[18:57:03] thread 25187328 exited ("Renderer")
[18:57:03] thread 25205760 joined ("MPEG-2 decoder (libmpeg2)")
[18:57:03] thread 25187328 joined ("Renderer")
[18:57:03] thread 26262016 exited ("H.264/AVC encoder (libx264)")
[18:57:03] thread 26262016 joined ("H.264/AVC encoder (libx264)")
[18:57:03] thread 25202688 joined ("reader")
[18:57:03] thread 25203712 exited ("muxer")
[18:57:03] thread 25203712 joined ("muxer")
[18:57:03] fifo_close: trashing 1798 buffer(s)
[18:57:03] fifo_close: trashing 8 buffer(s)
[18:57:03] fifo_close: trashing 0 buffer(s)
[18:57:03] fifo_close: trashing 0 buffer(s)
[18:57:03] fifo_close: trashing 2 buffer(s)
[18:57:03] starting job
[18:57:03] + device /movies/THE_EXPLORERS/
[18:57:03] + title 1, chapter(s) 1 to 14
[18:57:03] + 720x480 -> 720x416, crop 0/0/6/6
[18:57:03] + deinterlace off
[18:57:03] + grayscale off
[18:57:03] + 23.976 fps, video bitrate 1500 kbps, pass 2
[18:57:03] + PixelRatio: 0, width:720, height: 416
[18:57:03] + encoder x264
[18:57:03] + audio 160 kbps, 48000 Hz
[18:57:03] + encoder faac
[18:57:03] + 80bd, English (AC3) (5 ch)
[18:57:03] thread 25202688 started ("reader")
[18:57:03] + output: /movies/the_explorers.mp4
[18:57:03] thread 25203712 started ("muxer")
[18:57:03] thread 25204736 started ("MPEG-2 decoder (libmpeg2)")
[18:57:03] thread 25205760 started ("Renderer")
[18:57:03] encx264: opening libx264 (pass 2)
[18:57:19] thread 28683264 started ("H.264/AVC encoder (libx264)")
No accelerated IMDCT transform found
[18:57:19] thread 29547008 started ("AC3 decoder")
[18:57:19] thread 29065216 started ("AAC encoder (libfaac)")
[18:57:19] sync: expecting 153111 video frames
[18:57:19] sync: first pts is 25257
Encoding: task 2 of 2, 38.61 % (25.48 fps, avg 23.69 fps, ETA 01h06m08s)[19:38:56] PTS discontinuity (221957467, 26808)
Encoding: task 2 of 2, 66.51 % (22.09 fps, avg 23.69 fps, ETA 00h36m05s)[20:08:58] PTS discontinuity (160340459, 23977)
Encoding: task 2 of 2, 66.52 % (21.78 fps, avg 23.69 fps, ETA 00h36m04s)[20:09:00] sync: adding 50 ms of silence for track 80bd
[20:09:00] sync: adding 50 ms of silence for track 80bd
Encoding: task 2 of 2, 66.52 % (21.78 fps, avg 23.69 fps, ETA 00h36m04s)[20:09:00] sync: adding 50 ms of silence for track 80bd



[22:06:45] sync: adding 50 ms of silence for track 80bd
Encoding: task 2 of 2, 99.99 % (6.70 fps, avg 13.47 fps, ETA 00h00m01s)[22:06:45] sync: adding 50 ms of silence for track 80bd

[22:06:48] sync: adding 50 ms of silence for track 80bd
[22:06:48] sync: adding 50 ms of silence for track 80bd

[22:06:48] thread 25205760 exited ("Renderer")
[22:06:48] thread 25204736 exited ("MPEG-2 decoder (libmpeg2)")
[22:06:48] thread 28683264 exited ("H.264/AVC encoder (libx264)")
[22:06:48] thread 29547008 exited ("AC3 decoder")
[22:06:48] thread 25204736 joined ("MPEG-2 decoder (libmpeg2)")
[22:06:48] thread 25205760 joined ("Renderer")
[22:06:48] thread 28683264 joined ("H.264/AVC encoder (libx264)")
[22:06:48] thread 29065216 exited ("AAC encoder (libfaac)")
[22:06:48] thread 29547008 joined ("AC3 decoder")
[22:06:48] thread 29065216 joined ("AAC encoder (libfaac)")
[22:06:48] thread 25202688 joined ("reader")
Muxing: 0.00 %[22:06:48] mux: file size, 1286804986 bytes
[22:06:48] mux: track 0, 1198186049 bytes, 1501.02 kbps
[22:06:48] mux: video bitrate error, +814052 bytes
[22:06:48] mux: track 1, 85834637 bytes, 107.53 kbps
[22:06:48] mux: overhead, 6.15 bytes per frame
[22:06:48] thread 25203712 exited ("muxer")
[22:06:48] thread 25203712 joined ("muxer")
[22:06:48] fifo_close: trashing 1798 buffer(s)
[22:06:48] fifo_close: trashing 8 buffer(s)
[22:06:48] fifo_close: trashing 0 buffer(s)
[22:06:48] fifo_close: trashing 0 buffer(s)
[22:06:48] fifo_close: trashing 1 buffer(s)
[22:06:48] fifo_close: trashing 0 buffer(s)
[22:06:48] fifo_close: trashing 0 buffer(s)
[22:06:48] fifo_close: trashing 1 buffer(s)
[22:06:48] fifo_close: trashing 0 buffer(s)
[22:06:48] thread 25183744 exited ("work")
[22:06:48] thread 25183744 joined ("work")
[22:06:48] libhb: work result = 0

Rip done!
[22:06:48] thread 25182720 exited ("libhb")
[22:06:48] thread 25182720 joined ("libhb")
MediaFork has exited.
pmoc
Posts: 12
Joined: Mon Apr 09, 2007 10:54 am

Post by pmoc »

Same problem here: thousands of these lines during pass 2:
[07:09:17] sync: adding 50 ms of silence for track 80bd
Encoding: task 2 of 2, 80.10 % (7.49 fps, avg 7.36 fps, ETA 01h50m19s)

no luck with the CLI method...

Here is the command I used:
handbrakecli -v -i /users/philippe/desktop/ZO2/VIDEO_TS -o /users/philippe/desktop/zo2.mp4 -m -e x264 -b 1300 -r 25 -2 -d -p -E faac -R 44.1 -l 0:0:0:0

I'm now trying with -R 48

Cheers. Philippe.
pmoc
Posts: 12
Joined: Mon Apr 09, 2007 10:54 am

Post by pmoc »

same with -R 48 :-(
nightstrm
Veteran User
Posts: 1887
Joined: Fri Mar 23, 2007 5:43 am

Post by nightstrm »

What disc? They must have done some funky things with it...
pmoc
Posts: 12
Joined: Mon Apr 09, 2007 10:54 am

Post by pmoc »

about 95% of the DVD I try to rip (zone 2)... At this point, it would make more sense to list the DVD which actually went through :-(
Cavalicious
Moderator
Posts: 1804
Joined: Mon Mar 26, 2007 12:07 am

Post by Cavalicious »

pmoc wrote:At this point, it would make more sense to list the DVD which actually went through :-(
No, it would make more sense to let us know which are not working, so others can duplicate. There is nothing to fix on working DVDs.
incubowski
Posts: 20
Joined: Thu Mar 29, 2007 3:09 pm

Evidence

Post by incubowski »

Here is a little information that may or may not help anyone solve this. I ripped "Waking Life" full disc with MTR 2.6.6 using an iMac G5 and its stock drive. I then moved the VIDEO_TS folder to my macbook (Intel, obviously) laptop to encode with Handbrake SVN build 472. I had dropped audio about 50 minutes through the file. I moved the VIDEO_TS folder back to my iMac G5 and encoded using the same build of HandBrake and the same settings (listed below) and the file came out fine. I know people have said this isn't an Intel specific problem, as it has happened with non-Intel processors, but I just wanted to give an example of when encoding with the exact same source, using the same build of handbrake, with the same settings can result in the Intel generated file having dropped audio and the G5 generated file being just fine. I know using the CLI version may prevent problems but I thought this may be useful (or not) so solving the issue.

CRF at 74%
chapters used
192 AAC (to DPLI) at 48 from the 5.1 ac3 English AC3 track
23.9whatever for frame rate
x.264 main
.....dunno if I am leaving any settings out.
petvas
Regular User
Posts: 82
Joined: Wed Feb 14, 2007 3:00 am

Post by petvas »

I tried using the command line with all my problematic dvds and it worked 100% of the time!

The commandline I use is:
./HandBrakeCLI -i SOURCE -o TARGET -b 3000 -B 320 -e x264 -m -s 1 -R 48 -X RESOLUTION -Y RESOLUTION -p
Last edited by petvas on Thu Apr 12, 2007 4:59 pm, edited 1 time in total.
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Post by jbrjake »

petvas wrote:The commandline I use is:
./HandBrakeCLI -i SOURCE -o TARGET -b 2500 -B 320 -e x264 -m -s 1 -R 48 -X RESOLUTION -Y RESOLUTION -p
I'm glad it works for you, but you're misusing the CLI.

-X and -Y denote the maximum height and width for HandBrake to constrain the dimensions to, not the actual height and width you want to use. The idea is that someone might want to let HandBrake decide the dimensions and aspect ratio for them, but require the height to not exceed, say, 240 lines. If you want to actually give HB the specific dimensions to use, you should be using -h and -l (--height and --width).
petvas
Regular User
Posts: 82
Joined: Wed Feb 14, 2007 3:00 am

Post by petvas »

jbrjake wrote:
petvas wrote:The commandline I use is:
./HandBrakeCLI -i SOURCE -o TARGET -b 3000 -B 320 -e x264 -m -s 1 -R 48 -X RESOLUTION -Y RESOLUTION -p
I'm glad it works for you, but you're misusing the CLI.

-X and -Y denote the maximum height and width for HandBrake to constrain the dimensions to, not the actual height and width you want to use. The idea is that someone might want to let HandBrake decide the dimensions and aspect ratio for them, but require the height to not exceed, say, 240 lines. If you want to actually give HB the specific dimensions to use, you should be using -h and -l (--height and --width).
So, you mean I could just skip both options. What I did so far was to go to the GUI and see what the anamorphic output was and matched it in the cli. Now, I guess I can just use the -p option for anamorphic output.
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Post by jbrjake »

petvas wrote:Now, I guess I can just use the -p option for anamorphic output.
Yes...though I truly don't know why you'd have to guess:
http://handbrake.m0k.org/trac/wiki/AnamorphicGuide#cli
In the anamorphic guide I wrote: Anamorphic PAR in MediaForkCLI

This is even easier. Just add a "-p" like so:

Code: Select all

./MediaForkCLI -i dvd -o movie.mp4 -p
pmoc
Posts: 12
Joined: Mon Apr 09, 2007 10:54 am

Post by pmoc »

One interresting thing: I tried encoding MATRIX from a MTR rip (main feature only).

./HandBrakeCLI -i /users/philippe/desktop/MATRIX/VIDEO_TS -o /users/philippe/desktop/matrix.mp4 -b 2000 -e x264 -m -R 48 -p -v -s 1 -6 6ch
This first command gave a working result

./HandBrakeCLI -i /users/philippe/desktop/MATRIX/VIDEO_TS -o /users/philippe/desktop/matrix.mp4 -b 2000 -2 -d -e x264 -m -R 48 -p -v -s 1 -6 6ch
Doesn't work (No sound after 2 min 46s) adding 50ms of silence....

What do you think?

Cheers.
Locked