Error: cannot create compression session

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
GLF-MUC-WDY
New User
Posts: 1
Joined: Fri May 10, 2019 6:31 pm

Error: cannot create compression session

Post by GLF-MUC-WDY » Fri May 10, 2019 6:57 pm

VIDEOTOOLBOX not working on Skull Canyon Hackintosh with IrisPro580 ??

If I select VideoToolBox (either H.264 or H.265) Handbrake runs into Errors.
I am on a Hackintosh Intel NUC6i7KYK (Intel® Core™ i7-6770HQ with IrisPro580).
I assume it is Hardware related as on my NUC6i5SYH Hackintosh (i5 with IrisPlus) VideoToolBox works fine (H.264 & H.265).
Can anyone with a Skull Canyon Hackintosh confirm / refute this issue?

Best regards form Munich
Woody


Steps to reproduce the problem (If Applicable):
It is not related to any specific media or input format.

HandBrake version 1.2.2

Operating system: macOS HighSierra 10.13.6 (17G6030):

HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

H.264 (VideoToolBox)
[20:25:04] encavcodecInit: H.264 (VideoToolbox)
[20:25:04] encavcodec: encoding with stored aspect 1/1
[h264_videotoolbox @ 0x7fdf7f95ec00] Error: cannot create compression session: -12915
[h264_videotoolbox @ 0x7fdf7f95ec00] Try -allow_sw 1. The hardware encoder may be busy, or not supported.
[20:25:04] encavcodecInit: avcodec_open failed
error: Failure to initialise thread 'FFMPEG encoder (libavcodec)'
[20:25:04] comb detect: heavy 0 | light 0 | uncombed 0 | total 0
[20:25:04] decomb: deinterlaced 0 | blended 0 | unfiltered 0 | total 0
[20:25:04] vfr: lost time: 0 (0 frames)
[20:25:04] vfr: gained time: 0 (0 frames) (0 not accounted for)
[20:25:04] ac3-decoder done: 0 frames, 0 decoder errors
[20:25:04] ac3-decoder done: 0 frames, 0 decoder errors
[20:25:04] h264-decoder done: 0 frames, 0 decoder errors
[20:25:04] sync: got 0 frames, 69816 expected
[20:25:04] libhb: work result = 3
[20:25:05] macgui: QueueCore work failed
[20:25:05] macgui: Queue Done, there are no more pending encodes
[20:25:05] macgui: QueueCore stopped preventing sleep

H.265 (VideoToolBox)
20:34:12] encavcodecInit: H.265 (VideoToolbox)
[20:34:12] encavcodec: encoding with stored aspect 1/1
[hevc_videotoolbox @ 0x7fdf7fa15400] Error: cannot create compression session: -12903
[hevc_videotoolbox @ 0x7fdf7fa15400] Try -allow_sw 1. The hardware encoder may be busy, or not supported.
[20:34:12] encavcodecInit: avcodec_open failed
error: Failure to initialise thread 'FFMPEG encoder (libavcodec)'
error: Failure to initialise thread 'FFMPEG encoder (libavcodec)'
[20:34:12] comb detect: heavy 0 | light 0 | uncombed 0 | total 0
[20:34:12] decomb: deinterlaced 0 | blended 0 | unfiltered 0 | total 0
[20:34:12] vfr: lost time: 0 (0 frames)
[20:34:12] vfr: gained time: 0 (0 frames) (0 not accounted for)
[20:34:12] ac3-decoder done: 0 frames, 0 decoder errors
[20:34:12] ac3-decoder done: 0 frames, 0 decoder errors
[20:34:12] h264-decoder done: 0 frames, 0 decoder errors
[20:34:12] sync: got 0 frames, 69816 expected
[20:34:13] libhb: work result = 3
[20:34:13] macgui: QueueCore work failed
[20:34:13] macgui: Queue Done, there are no more pending encodes
[20:34:13] macgui: QueueCore stopped preventing sleep


User avatar
Rodeo
HandBrake Team
Posts: 12088
Joined: Tue Mar 03, 2009 8:55 pm

Re: Error: cannot create compression session

Post by Rodeo » Tue May 14, 2019 5:30 pm

Initializing the VT H.264 encoder with hardware acceleration fails for some reason. Not sure what the error code means, maybe Ritsuka would know, he spent a lot more time than me working with this API.

User avatar
s55
HandBrake Team
Posts: 9417
Joined: Sun Dec 24, 2006 1:05 pm

Re: Error: cannot create compression session

Post by s55 » Tue May 14, 2019 6:13 pm

You failed to include the entire log so I can't say for sure but in all likely hood, you're using settings that are invalid or beyond the capability of the hardware.

Post Reply