AVI previews but won't encode

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
maddog_uk_69
Posts: 5
Joined: Fri Jan 02, 2009 11:25 am

AVI previews but won't encode

Post by maddog_uk_69 » Fri Feb 08, 2019 1:23 pm

Description of problem or question:
I have an AVI file that a client supplied and I'm trying to encode it to MP4. The Live Preview works just fine, but every time I try to actually encode, HandBrake stops immediately with 'Encode Failed'.


HandBrake version (e.g., 1.0.0):
1.2.0


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
macOS 10.13.6 High Sierra


HandBrake Activity Log ***required*** (see How-to get an activity log)
I've included the successful preview stage of the log, in case that gives any additional clues as to the reason for failure.

Code: Select all

[13:21:22] hb_init: starting libhb thread
[13:21:22] macgui: PreviewCore started encoding preview_temp.m4v
[13:21:22] 1 job(s) to process
[13:21:22] macgui: PreviewCore with preset Very Fast 720p30
[13:21:22] starting job
[13:21:22] decomb filter thread started for segment 0
[13:21:22] decomb filter thread started for segment 1
[13:21:22] decomb filter thread started for segment 2
[13:21:22] decomb filter thread started for segment 3
[13:21:22] decomb filter thread started for segment 4
[13:21:22] decomb filter thread started for segment 5
[13:21:22] decomb filter thread started for segment 6
[13:21:22] decomb filter thread started for segment 7
[13:21:22] decomb filter thread started for segment 8
[13:21:22] decomb filter thread started for segment 9
[13:21:22] decomb filter thread started for segment 10
[13:21:22] decomb filter thread started for segment 11
[13:21:22] decomb check thread started for segment 0
[13:21:22] decomb check thread started for segment 1
[13:21:22] decomb check thread started for segment 2
[13:21:22] decomb check thread started for segment 3
[13:21:22] decomb check thread started for segment 4
[13:21:22] decomb check thread started for segment 5
[13:21:22] decomb check thread started for segment 6
[13:21:22] decomb check thread started for segment 7
[13:21:22] decomb check thread started for segment 8
[13:21:22] decomb check thread started for segment 9
[13:21:22] decomb check thread started for segment 10
[13:21:22] decomb check thread started for segment 11
[13:21:22] yadif thread started for segment 0
[13:21:22] yadif thread started for segment 1
[13:21:22] yadif thread started for segment 2
[13:21:22] yadif thread started for segment 3
[13:21:22] yadif thread started for segment 4
[13:21:22] yadif thread started for segment 5
[13:21:22] yadif thread started for segment 6
[13:21:22] yadif thread started for segment 7
[13:21:22] yadif thread started for segment 8
[13:21:22] yadif thread started for segment 9
[13:21:22] yadif thread started for segment 10
[13:21:22] yadif thread started for segment 11
[13:21:22] work: only 1 chapter, disabling chapter markers
[13:21:22] job configuration:
[13:21:22]  * source
[13:21:22]    + /Users/iand/Desktop/TESTIMONIALS.avi
[13:21:22]    + title 1, start 00:00:0.00 stop 00:00:15.00
[13:21:22]    + container: avi
[13:21:22]    + data rate: 3923 kbps
[13:21:22]  * destination
[13:21:22]    + /Users/iand/Library/Application Support/HandBrake//Previews/2941/preview_temp.m4v
[13:21:22]    + container: MPEG-4 (libavformat)
[13:21:22]      + align initial A/V stream timestamps
[13:21:22]  * video track
[13:21:22]    + decoder: msmpeg4v1
[13:21:22]      + bitrate 2379 kbps
[13:21:22]    + filters
[13:21:22]      + Comb Detect (mode=0:spatial-metric=2:motion-thresh=2:spatial-thresh=3:filter-mode=1:block-thresh=80:block-width=16:block-height=16)
[13:21:22]      + Decomb (mode=39)
[13:21:22]      + Framerate Shaper (mode=2:rate=27000000/900000)
[13:21:22]        + frame rate: 25.000 fps -> peak rate limited to 30.000 fps
[13:21:22]      + Crop and Scale (width=960:height=540:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[13:21:22]        + source: 960 * 540, crop (0/0/0/0): 960 * 540, scale: 960 * 540
[13:21:22]    + Output geometry
[13:21:22]      + storage dimensions: 960 x 540
[13:21:22]      + pixel aspect ratio: 1 : 1
[13:21:22]      + display dimensions: 960 x 540
[13:21:22]    + encoder: H.264 (libx264)
[13:21:22]      + preset:  veryfast
[13:21:22]      + profile: main
[13:21:22]      + level:   3.1
[13:21:22]      + quality: 23.00 (RF)
[13:21:22]      + color profile: 5-1-6
[13:21:22]  * audio track 1
[13:21:22]    + decoder: Unknown (pcm_s16le) (2.0 ch) (track 1, id 0x1)
[13:21:22]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[13:21:22]    + mixdown: Stereo
[13:21:22]    + dither: triangular
[13:21:22]    + encoder: AAC (Apple AudioToolbox)
[13:21:22]      + bitrate: 160 kbps, samplerate: 48000 Hz
[13:21:22] sync: expecting 400 video frames
[13:21:22] encx264: encoding at constant RF 23.000000
[13:21:22] encx264: unparsed options: level=3.1:ref=1:8x8dct=0:weightp=1:subme=2:mixed-refs=0:trellis=0:vbv-bufsize=14000:vbv-maxrate=14000:rc-lookahead=10
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
x264 [info]: profile Main, level 3.1, 4:2:0, 8-bit
[13:21:22] sync: first pts video is 0
[13:21:22] sync: "Chapter 1" (1) at frame 1 time 0
[13:21:22] sync: first pts audio 0x1 is 0
[13:21:23] sync: reached video pts 1350000, exiting early
[13:21:23] sync: reached audio 0x1 pts 1350120, exiting early
[13:21:23] work: average encoding speed for job is 0.000000 fps
[13:21:23] comb detect: heavy 0 | light 0 | uncombed 364 | total 364
[13:21:23] decomb: deinterlaced 0 | blended 0 | unfiltered 364 | total 364
[13:21:23] vfr: 364 frames output, 0 dropped and 0 duped for CFR/PFR
[13:21:23] vfr: lost time: 0 (0 frames)
[13:21:23] vfr: gained time: 0 (0 frames) (0 not accounted for)
[13:21:24] pcm_s16le-decoder done: 896 frames, 0 decoder errors
[13:21:24] msmpeg4v1-decoder done: 434 frames, 0 decoder errors
[13:21:24] sync: got 364 frames, 400 expected
[13:21:24] sync: framerate min 2.083 fps, max 25.000 fps, avg 24.267 fps
x264 [info]: frame I:3     Avg QP:13.88  size: 14378
x264 [info]: frame P:347   Avg QP:21.24  size:  3235
x264 [info]: frame B:14    Avg QP:22.38  size:  1279
x264 [info]: consecutive B-frames: 93.4%  3.8%  1.6%  1.1%
x264 [info]: mb I  I16..4: 74.0%  0.0% 26.0%
x264 [info]: mb P  I16..4:  5.6%  0.0%  0.4%  P16..4: 25.0%  8.9%  3.9%  0.0%  0.0%    skip:56.3%
x264 [info]: mb B  I16..4:  5.1%  0.0%  0.8%  B16..8:  7.0%  1.3%  0.1%  direct: 7.8%  skip:77.8%  L0:40.2% L1:48.1% BI:11.7%
x264 [info]: coded y,uvDC,uvAC intra: 22.1% 41.6% 3.0% inter: 6.9% 8.7% 0.0%
x264 [info]: i16 v,h,dc,p: 65% 17% 11%  6%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 33% 21% 17%  3%  6%  8%  4%  5%  3%
x264 [info]: i8c dc,h,v,p: 51% 18% 28%  2%
x264 [info]: Weighted P-Frames: Y:0.6% UV:0.6%
x264 [info]: kb/s:631.24
[13:21:24] mux: track 0, 364 frames, 1183501 bytes, 629.52 kbps, fifo 512
[13:21:24] mux: track 1, 706 frames, 307217 bytes, 163.41 kbps, fifo 1024
[13:21:24] libhb: work result = 0
[13:21:24] macgui: PreviewCore work done
[13:21:44] macgui: QueueCore prevented sleep
[13:21:44] macgui: QueueCore scanning specifically for title: 1
[13:21:44] CPU: Intel(R) Xeon(R) CPU           W3680  @ 3.33GHz
[13:21:44]  - logical processor count: 12
[13:21:44] hb_scan: path=/Users/iand/Desktop/TESTIMONIALS.avi, title_index=1
udfread ERROR: ECMA 167 Volume Recognition failed
disc.c:323: failed opening UDF image /Users/iand/Desktop/TESTIMONIALS.avi
disc.c:424: error opening file BDMV/index.bdmv
disc.c:424: error opening file BDMV/BACKUP/index.bdmv
[13:21:44] bd: not a bd - trying as a stream/file instead
libdvdnav: Using dvdnav version 6.0.0
libdvdread: Encrypted DVD support unavailable.
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
libdvdread:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
libdvdread: Can't open file VIDEO_TS.IFO.
libdvdnav: vm: failed to read VIDEO_TS.IFO
[13:21:44] dvd: not a dvd - trying as a stream/file instead
Input #0, avi, from '/Users/iand/Desktop/TESTIMONIALS.avi':
  Metadata:
    encoder         : VirtualDubMod 1.5.10.2 (build 2540/release)
  Duration: 00:05:41.20, start: 0.000000, bitrate: 3923 kb/s
    Stream #0:0: Video: msmpeg4v1 (MPG4 / 0x3447504D), yuv420p, 960x540, 2379 kb/s, 25 fps, 25 tbr, 25 tbn, 25 tbc
    Stream #0:1: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 48000 Hz, 2 channels, s16, 1536 kb/s
[13:21:44] scan: decoding previews for title 1
[13:21:44] scan: audio 0x1: pcm_s16le, rate=48000Hz, bitrate=1536000 Unknown (pcm_s16le) (2.0 ch)
[13:21:44] scan: 10 previews, 960x540, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
[13:21:44] libhb: scan thread found 1 valid title(s)
[13:21:44] macgui: QueueCore scan done
[13:21:44] 1 job(s) to process
[13:21:44] starting job
[13:21:44] macgui: QueueCore started encoding TESTIMONIALS.mp4
[13:21:44] macgui: QueueCore with preset Very Fast 720p30
[13:21:44] decomb filter thread started for segment 2
[13:21:44] decomb filter thread started for segment 0
[13:21:44] decomb filter thread started for segment 1
[13:21:44] decomb filter thread started for segment 3
[13:21:44] decomb filter thread started for segment 4
[13:21:44] decomb filter thread started for segment 5
[13:21:44] decomb filter thread started for segment 6
[13:21:44] decomb filter thread started for segment 7
[13:21:44] decomb filter thread started for segment 8
[13:21:44] decomb filter thread started for segment 9
[13:21:44] decomb filter thread started for segment 10
[13:21:44] decomb filter thread started for segment 11
[13:21:44] decomb check thread started for segment 0
[13:21:44] decomb check thread started for segment 1
[13:21:44] decomb check thread started for segment 2
[13:21:44] decomb check thread started for segment 3
[13:21:44] decomb check thread started for segment 4
[13:21:44] decomb check thread started for segment 5
[13:21:44] decomb check thread started for segment 6
[13:21:44] decomb check thread started for segment 7
[13:21:44] decomb check thread started for segment 8
[13:21:44] decomb check thread started for segment 9
[13:21:44] decomb check thread started for segment 10
[13:21:44] decomb check thread started for segment 11
[13:21:44] yadif thread started for segment 0
[13:21:44] yadif thread started for segment 1
[13:21:44] yadif thread started for segment 2
[13:21:44] yadif thread started for segment 3
[13:21:44] yadif thread started for segment 4
[13:21:44] yadif thread started for segment 5
[13:21:44] yadif thread started for segment 6
[13:21:44] yadif thread started for segment 7
[13:21:44] yadif thread started for segment 8
[13:21:44] yadif thread started for segment 9
[13:21:44] yadif thread started for segment 10
[13:21:44] yadif thread started for segment 11
[13:21:44] work: only 1 chapter, disabling chapter markers
[13:21:44] job configuration:
[13:21:44]  * source
[13:21:44]    + /Users/iand/Desktop/TESTIMONIALS.avi
[13:21:44]    + title 1, chapter(s) 1 to 1
[13:21:44]    + container: avi
[13:21:44]    + data rate: 3923 kbps
[13:21:44]  * destination
[13:21:44]    + /Volumes/Storage/Clients/CEM Cell Marketing/Toblerone Personalisation Awards Sumission/support/PIOTR TOB AWARD/TESTIMONIALS.avi/TESTIMONIALS.mp4
[13:21:44]    + container: MPEG-4 (libavformat)
[13:21:44]      + align initial A/V stream timestamps
[13:21:44]  * video track
[13:21:44]    + decoder: msmpeg4v1
[13:21:44]      + bitrate 2379 kbps
[13:21:44]    + filters
[13:21:44]      + Comb Detect (mode=0:spatial-metric=2:motion-thresh=2:spatial-thresh=3:filter-mode=1:block-thresh=80:block-width=16:block-height=16)
[13:21:44]      + Decomb (mode=39)
[13:21:44]      + Framerate Shaper (mode=2:rate=27000000/900000)
[13:21:44]        + frame rate: 25.000 fps -> peak rate limited to 30.000 fps
[13:21:44]      + Crop and Scale (width=960:height=540:crop-top=0:crop-bottom=0:crop-left=0:crop-right=0)
[13:21:44]        + source: 960 * 540, crop (0/0/0/0): 960 * 540, scale: 960 * 540
[13:21:44]    + Output geometry
[13:21:44]      + storage dimensions: 960 x 540
[13:21:44]      + pixel aspect ratio: 1 : 1
[13:21:44]      + display dimensions: 960 x 540
[13:21:44]    + encoder: H.264 (libx264)
[13:21:44]      + preset:  veryfast
[13:21:44]      + profile: main
[13:21:44]      + level:   3.1
[13:21:44]      + quality: 23.00 (RF)
[13:21:44]      + color profile: 5-1-6
[13:21:44]  * audio track 1
[13:21:44]    + decoder: Unknown (pcm_s16le) (2.0 ch) (track 1, id 0x1)
[13:21:44]      + bitrate: 1536 kbps, samplerate: 48000 Hz
[13:21:44]    + mixdown: Stereo
[13:21:44]    + dither: triangular
[13:21:44]    + encoder: AAC (Apple AudioToolbox)
[13:21:44]      + bitrate: 160 kbps, samplerate: 48000 Hz
[13:21:44] sync: expecting 8530 video frames
[13:21:44] encx264: encoding at constant RF 23.000000
[13:21:44] encx264: unparsed options: level=3.1:ref=1:8x8dct=0:weightp=1:subme=2:mixed-refs=0:trellis=0:vbv-bufsize=14000:vbv-maxrate=14000:rc-lookahead=10
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
x264 [info]: profile Main, level 3.1, 4:2:0, 8-bit
error: avio_open2 failed, errno -20
error: avio_open2 failed, errno -20
[13:21:44] work: average encoding speed for job is 0.000000 fps
[13:21:45] comb detect: heavy 0 | light 0 | uncombed 0 | total 0
[13:21:45] decomb: deinterlaced 0 | blended 0 | unfiltered 0 | total 0
[13:21:45] vfr: 0 frames output, 0 dropped and 0 duped for CFR/PFR
[13:21:45] vfr: lost time: 0 (0 frames)
[13:21:45] vfr: gained time: 0 (0 frames) (0 not accounted for)
[13:21:45] pcm_s16le-decoder done: 0 frames, 0 decoder errors
[13:21:45] msmpeg4v1-decoder done: 0 frames, 0 decoder errors
[13:21:45] sync: got 0 frames, 8530 expected
[13:21:45] libhb: work result = 3
[13:21:45] macgui: QueueCore work failed
[13:21:45] macgui: Queue Done, there are no more pending encodes
[13:21:45] macgui: QueueCore stopped preventing sleep

rollin_eng
Veteran User
Posts: 2990
Joined: Wed May 04, 2011 11:06 pm

Re: AVI previews but won't encode

Post by rollin_eng » Fri Feb 08, 2019 1:36 pm

Might be a write permission error, try writing to a different folder.

User avatar
s55
HandBrake Team
Posts: 9361
Joined: Sun Dec 24, 2006 1:05 pm

Re: AVI previews but won't encode

Post by s55 » Fri Feb 08, 2019 1:49 pm

[13:21:44] + /Volumes/Storage/Clients/CEM Cell Marketing/Toblerone Personalisation Awards Sumission/support/PIOTR TOB AWARD/TESTIMONIALS.avi/TESTIMONIALS.mp4

That looks suspicious

maddog_uk_69
Posts: 5
Joined: Fri Jan 02, 2009 11:25 am

Re: AVI previews but won't encode

Post by maddog_uk_69 » Fri Feb 08, 2019 3:41 pm

s55 wrote:
Fri Feb 08, 2019 1:49 pm
That looks suspicious
Argh!! Yes, thank you.

This is why, in my opinion, Handbrake needs an option to just save to the same folder as the source. I realise why it's like this, because historically the app was about ripping/encoding from a read-only source, and specifying a destination that maybe remained the same across many encodes made sense (encoding DVDs/images to the same "Movies" folder, for example). However I mainly use HB for encoding streams/files now, and I'd bet a good number (majority?) of users do the same. I end up encoding videos to the wrong folder more often than not these days, because I always forget to update the destination from the last time I used it.
As it was, this issue was caused by the use of Default Folder (a macOS essential in my book!) to quickly choose the destination folder, and somehow it included the source filename in the destination path.

Off to the feature request forum I go!

Woodstock
Veteran User
Posts: 2925
Joined: Tue Aug 27, 2013 6:39 am

Re: AVI previews but won't encode

Post by Woodstock » Fri Feb 08, 2019 11:47 pm

No, it's "like this" because so many people encode over their source file, and leave themselves with nothing. You have to work a bit at doing that in the GUI.

Take a look at Tools->Preferences->Output Files. Hover over the text boxes to see information about macros (aka "placeholders") you can use to put things in different directories.

Post Reply