Poor CPU utilization in Handbrake

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
truth1ness
Posts: 22
Joined: Fri Feb 14, 2014 11:02 pm

Poor CPU utilization in Handbrake

Post by truth1ness » Fri Dec 21, 2018 6:31 pm

Description of problem or question:
When I change the encoder speed (fast, faster, veryfast) Handbrake reduces my CPU usage so that the encode takes the same amount of time no matter what the setting. I can't figure out why it is doing this.



Steps to reproduce the problem (If Applicable):
Ran an encode on a video file with various speed settings. The faster I set it to the lower my CPU usage and the time to complete stayed about the same.

Below the first is the activity log of me starting an encode on Ultrafast and it stays at 40% of cpu. The second is the same preset except with the encode set to Placebo and it bounces between 60-80% cpu.

Strangely when I use HandBrakeBatch, which is basically a 3rd party wrapper tool to make batch processing easier, for some reason it runs at a constant 90% cpu and finishes much faster than the native Handbrake app. So it seems like there is some setting or something in my native version of the app that is causing the engine to not fully utilize my CPU. I've noticed this discrepancy for quite some time but this is the first time I tested the speed controls specifically and noticed there is a throttling in the HB app between speed settings as well. https://osomac.com/apps/osx/handbrake-batch/

Is there some rogue setting in the Handbrake app that is throttling my cpu that I can turn off? Why is it throttling down the speed as I turn up the speed setting? This is a huge performance hit.


HandBrake version (e.g., 1.0.0):

Version 1.1.2 (2018090500)


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):

10.14.2 (18C54) Mojave

2016 Macbook Pro
2.9 GHz Intel Core i7
16 GB 2133 MHz LPDDR3
SSD hard drive


HandBrake Activity Log ***required*** (see How-to get an activity log)

The file used in the test is EFT 120218.mp4


https://pastebin.com/Hswb8UMd Ultrafast and it stays at 40% of cpu
https://pastebin.com/E5Y3i86B Placebo and it bounces between 60-80% cpu

rollin_eng
Veteran User
Posts: 2942
Joined: Wed May 04, 2011 11:06 pm

Re: Poor CPU utilization in Handbrake

Post by rollin_eng » Fri Dec 21, 2018 7:01 pm

Turn off any filters and see if that helps.

truth1ness
Posts: 22
Joined: Fri Feb 14, 2014 11:02 pm

Re: Poor CPU utilization in Handbrake

Post by truth1ness » Fri Dec 21, 2018 7:30 pm

Ah, turning off the filter helped.

So I'm guessing when I ran Handbrake through Handbrakebatch it was bypassing the filter setting which is why it was able to get full cpu usage.

Now even though I've turned off all the filters it still says "x264 Unparse: ref=2:deblock=-1,-1:weightp=1:subme=6:psy-rd=1,0.15:rc-lookahead=30" in the encoder options area. The text is not editable and I don't see any way to remove these settings. Is there a way to get rid of this? Do these affect anything?

mduell
Veteran User
Posts: 6279
Joined: Sat Apr 21, 2007 8:54 pm

Re: Poor CPU utilization in Handbrake

Post by mduell » Fri Dec 21, 2018 7:46 pm

Those reflect the preset/tune you selected. Pick a different preset/tune to change them.

Post Reply