Don't get subtitles

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
dino
Posts: 2
Joined: Fri Oct 19, 2018 11:03 am

Don't get subtitles

Post by dino » Fri Oct 19, 2018 11:11 am

Description of problem or question:
I have a movie in an MKV container with two audio streams (German and English) and three subtitle streams (2 German and English). If I watch the movie with VLC, I can select any audio channels and subtitles, everything is perfect.

Now I want to create an AppleTV4-compatible m4v movie from the MKV with Handbreak, which contains both languages and at least the English subtitles (additionally German would be good, but not necessary). The two audio channels are no problem and the m4v movie looks great and sounds great in both languages. Only the subtitles don't work even after countless attempts with different settings. If I play the finished movie in VLC and select the English subtitles, I only get "Chapter" with the corresponding chapter number displayed.

Do you have a tip on how to make the settings in Handbreak so that the subtitles arrive in the m4v file and can be used?

Steps to reproduce the problem (If Applicable):
Countless attempts with different settings

HandBrake version (e.g., 1.0.0):
1.1.2

Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
macOS 10.14 Mojave

HandBrake Activity Log ***required*** (see How-to get an activity log)
There are too many!

Code: Select all

Please replace this text with the contents of your log file between the two code tags - OR -  provide a pastebin URL in place of these 3 lines.

Woodstock
Veteran User
Posts: 2753
Joined: Tue Aug 27, 2013 6:39 am

Re: Don't get subtitles

Post by Woodstock » Fri Oct 19, 2018 1:03 pm

Apple TV does not do well with MKV files, and MP4 files cannot have "switchable" subtitles from a Bluray source. The first is a deliberate choice by Apple, the second is a limitation of the container type.

The subtitle track you see is a special track to provide chapter markers, hence the "Chapter XX" displayed when you select it.

User avatar
BradleyS
Moderator
Posts: 1392
Joined: Thu Aug 09, 2007 12:16 pm

Re: Don't get subtitles

Post by BradleyS » Fri Oct 19, 2018 1:54 pm

Short version: On the subtitles tab, go to the selection behavior dialog and select English and related burn in options. After exiting the dialog, select reload on the subtitles tab and you should see a PGS format English subtitle track marked for burning into the video. These are unfortunately not able to be enabled/disabled in MP4 as Woodstock mentions.

dino
Posts: 2
Joined: Fri Oct 19, 2018 11:03 am

Re: Don't get subtitles

Post by dino » Fri Oct 19, 2018 3:33 pm

Thank you for the fast and competent answer! So I have to decide what I want to do without.

Post Reply