Deinterlacing quality on animation is very, very poor

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
Durendal
Posts: 28
Joined: Mon Feb 12, 2007 5:41 pm

Deinterlacing quality on animation is very, very poor

Post by Durendal »

This is with Handbrake 1.0.7, Mac OS 10.2.3, although I doubt that this is platform-specific. The issue I'm having is with the Futurama DVD sets, particularly earlier seasons. They're definitely interlaced. My understanding is that certain deinterlacing algorithms in Handbrake are supposed to be selective and only perform deinterlacing when visible combing is detected.. They aren't. At all. Any deinterlacer used with any settings causes the same problem: All lines become ragged whether they're moving or completely stationary. Gone are smooth lines throughout the video. Instead, everything looks like it's been run through a deinterlacer that simply discards a set of fields and does line doubling. Decomb, Yadif, Blend, Bob, tweak the interlace detection, doesn't matter. It deinterlaces the entire scene and does a very poor job of it. Has it always been this bad or were changes made that went unnoticed some time ago? How am I supposed to get a good encode when I'm stuck either with no deinterlacing and visible combing in points, or major destruction of detail but no combing? Should this be considered a bug?
Woodstock
Veteran User
Posts: 3797
Joined: Tue Aug 27, 2013 6:39 am

Re: Deinterlacing quality on animation is very, very poor

Post by Woodstock »

Gee, without logs to show what you're doing, it's really hard to say anything except, "Cool story."
mduell
Veteran User
Posts: 7222
Joined: Sat Apr 21, 2007 8:54 pm

Re: Deinterlacing quality on animation is very, very poor

Post by mduell »

The story isn't even that good.
Durendal
Posts: 28
Joined: Mon Feb 12, 2007 5:41 pm

Re: Deinterlacing quality on animation is very, very poor

Post by Durendal »

Logs won't help much in this case as it's common to the deinterlacing algorithms regardless of other compression settings. It's plainly visible in the preview window, no full compression needed, doesn't matter what codec, bitrate, quality level, or anything else is used. Any deinterlacing algorithm used shows the same issue with only slight variation. Turning deinterlacing off resolves the issue of ragged lines, but of course leaves combing in the video.

If it's helpful, a comparison can be seen here. The issue is obvious.
nhyone
Bright Spark User
Posts: 249
Joined: Fri Jul 24, 2015 4:13 am

Re: Deinterlacing quality on animation is very, very poor

Post by nhyone »

Durendal wrote: Thu Jun 29, 2017 3:37 am Logs won't help much in this case as it's common to the deinterlacing algorithms regardless of other compression settings.
No, the log will help.

From your image, it looks like you should enable just decombing (adaptive). Don't turn on deinterlacing.
User avatar
BradleyS
Moderator
Posts: 1859
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing quality on animation is very, very poor

Post by BradleyS »

Futurama is known to have been mastered extremely poorly in this regard. It's one of the most difficult sources to deal with due to an awful hard telecine. It's certainly not a HandBrake problem; it's the source.

Try turning on detelecine. Then add default interlacing detection and EEDI2 decomb preset. If this doesn't solve it, HandBrake can't fix the source.
Durendal
Posts: 28
Joined: Mon Feb 12, 2007 5:41 pm

Re: Deinterlacing quality on animation is very, very poor

Post by Durendal »

BradleyS wrote: Thu Jun 29, 2017 9:31 am Futurama is known to have been mastered extremely poorly in this regard. It's one of the most difficult sources to deal with due to an awful hard telecine. It's certainly not a HandBrake problem; it's the source.

Try turning on detelecine. Then add default interlacing detection and EEDI2 decomb preset. If this doesn't solve it, HandBrake can't fix the source.
I was afraid of that. The combs do look suspiciously thick in some areas.

Tried your suggestion, but it's still showing the jagged lines in the screenshot. Crap. Looks like I may be sunk without some seriously high-octane software deinterlacing. I do remember Apple Compressor having some insanely good (and insanely slow) deinterlacing algorithms in the frame controls settings, but that was ages ago. I wonder if that's still the case and if it might be able to handle this...
User avatar
BradleyS
Moderator
Posts: 1859
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing quality on animation is very, very poor

Post by BradleyS »

If I recall correctly, they took the progressive 23.976 fps source and baked in some non-standard telecine to 29.97. So most IVTC algorithms can't figure out how to undo it. There may even be some additional step in there making it worse; I forget. Shame, it's a great show.
Durendal
Posts: 28
Joined: Mon Feb 12, 2007 5:41 pm

Re: Deinterlacing quality on animation is very, very poor

Post by Durendal »

BradleyS wrote: Thu Jun 29, 2017 3:23 pm If I recall correctly, they took the progressive 23.976 fps source and baked in some non-standard telecine to 29.97. So most IVTC algorithms can't figure out how to undo it. There may even be some additional step in there making it worse; I forget. Shame, it's a great show.
Yeah, I found a writeup that a guy did comparing digital versions of Futurama. Netflix, Hulu, iTunes, Zune...the sad and strange thing is that the Zune file was nigh perfect on the deinterlacing while the others had serious issues with resolution loss during motion and jagged lines. I wonder what the heck Microsoft did or if they got a better source file to begin with.

Although looking at Netflix now, it seems they've fixed the issue on their end. My kingdom for either their video source or whatever software they used to deinterlace it...

EDIT: Using only detelecine seems to be the least-bad option. It removes some, but not all combing without major quality degradation. Some remains, but it's not horrible.
nhyone
Bright Spark User
Posts: 249
Joined: Fri Jul 24, 2015 4:13 am

Re: Deinterlacing quality on animation is very, very poor

Post by nhyone »

BradleyS wrote: Thu Jun 29, 2017 9:31 am Try turning on detelecine. Then add default interlacing detection and EEDI2 decomb preset. If this doesn't solve it, HandBrake can't fix the source.
I don't know about Durendal, but my Futurama DVDs are 23.976 fps, no IVTC needed.

According to HandBrake 0.10.5 help,

Code: Select all

    -d, --deinterlace       Unconditionally deinterlaces all frames
    -5, --decomb            Selectively deinterlaces when it detects combing
I would very much prefer to use decomb rather than deinterlace.

If the log is given, one of the things I would check is how interlaced the source is and how effective is the deinterlacing. Here is the line from Vol 1, ep 1 encoded with HB 0.10.2:

Code: Select all

[11:11:00] decomb: deinterlaced 2733 | blended 390 | unfiltered 31292 | total 34415
It didn't detect and fix all combing, but it is pretty watchable.


The syntax has changed for HandBrake 1.0.2 onwards:

Code: Select all

   --comb-detect[=string]  Detect interlace artifacts in frames.
                           If not accompanied by the decomb or deinterlace
                           filters, this filter only logs the interlaced
                           frame count to the activity log.
                           If accompanied by the decomb or deinterlace
                           filters, it causes these filters to selectively
                           deinterlace only those frames where interlacing
                           is detected.

   -d, --deinterlace[=string]
                           Deinterlace video using libav yadif.

   -5, --decomb[=string]   Deinterlace video using a combination of yadif,
                           blend, cubic, or EEDI2 interpolation.
I would still prefer to use decomb. :D
User avatar
BradleyS
Moderator
Posts: 1859
Joined: Thu Aug 09, 2007 12:16 pm

Re: Deinterlacing quality on animation is very, very poor

Post by BradleyS »

In HandBrake 1.0.0 and later, the interlacing/comb detection is a separate filter. Decomb is still available.
Post Reply