Severely Frustrated Noob with Disappearing Audio

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
chuckd62687
Posts: 3
Joined: Sun Apr 22, 2007 3:51 pm

Severely Frustrated Noob with Disappearing Audio

Post by chuckd62687 »

I am having audio issues with DVD video I have converted for my Apple TV. I have a G4 PPC 800GHz iMac. I am ripping the Main Feature from my DVD's using MTR 3.0r14d. This part works perfect. When I use handbrake 0.8.5b1 to convert the DVD to an mpeg4 I am almost always losing audio at some point in the feature. This has happened to me numerous times. This also happened with MediaFork 0.8.0b1. Is know there is already a lot of discussion on this forum about this subject, but I have so far seen no solution posted or any indication that there is a solution coming. Is there one? If not, I just wasted $300 on this AppleTV. Thanks, I would really appreciate any help I could get.
Last edited by chuckd62687 on Sun Apr 22, 2007 4:22 pm, edited 1 time in total.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Post by dynaflash »

Always, always use full Disk rip with the lastest mtr. Main Feauture never works in my experience.

In Main Feature, mtr rewrites some of the mastering and it causes nothing but trouble for HB.

chuckd62687
Posts: 3
Joined: Sun Apr 22, 2007 3:51 pm

Post by chuckd62687 »

So, in order for this to work, I have to convert an entire DVD to an mpeg4 for my Apple TV? Seems to miss the whole point of Apple TV, especially for TV shows on DVD.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Post by dynaflash »

No, HB will let you just pick the main title (which it defaults to). So, you will only be actually encoding the main title.

But, you have to use MTR full disk rip first.

baggss
Moderator
Posts: 886
Joined: Tue Jan 02, 2007 8:21 am

Post by baggss »

dynaflash wrote:Always, always use full Disk rip with the lastest mtr. Main Feauture never works in my experience.

In Main Feature, mtr rewrites some of the mastering and it causes nothing but trouble for HB.
This is interesting advice. The folks at MTR (geezerbuttz in particular) will tell you to do main feature extraction when ripping zero cell movies. IIRC the r14 documentation says specifically to use main feature and not full disc. My wife has been ripping movies with r14 and r14d using main feature extraction with no issues at all and I have used it successfully on a number of zero cell movies.

If this is the case, then zero cell movies are still going to be an issue for folks who are encountering the sound problem.

dynaflash
Veteran User
Posts: 3820
Joined: Thu Nov 02, 2006 8:19 pm

Post by dynaflash »

baggss, dont know what to day, since I went to full disk rips, everything has worked. But I guess whatever gets the job done ;)

kilofox
Posts: 15
Joined: Sat Feb 17, 2007 4:38 pm

Same Problem Brother....

Post by kilofox »

I am having the same issue ... everything I do:

Rip with MTR 2.6.6, MTR 3.0 r14, rip with HB, Main Feature, Full Extraction, DETOX etc etc

I have tried everything and in every combination.. 1 pass or 2 pass.

The end result is audio dropping out somewhere in the movie. I have tried dvds from many different studios... probably about 50. They all drop sound.

It always happens when the encoding rate drops from in the 20ish kbps to 8 or less kbps.

I can use the same ripped files with MPEG Streamclip or VisualHub and get a successful encode. I would much rather use HandBrake.

I am at a loss as to why this is happening to myself and a few others but does not appear to happen with everyone.

Could it be hardware related? My DVD/CD Drive?

I appreciate the teams effort, I hope down the road this "mystery" will be solved.

deckeda
Regular User
Posts: 138
Joined: Thu Feb 22, 2007 8:38 am

Post by deckeda »

I've had success with 3.0 r14 doing Main Extractions and using SVNs of Handbrake and Handbrake 0.8.5b1. BORAT, Casino Royale, Flipper, Good Night and Good Luck, Happy Feet Count me in as lucky so far, but I've converted those 5 movies so far (I'm knee-deep in other projects.)

I've never used MediaFork or earlier.

Seems what works for some doesn't work for everyone, but at least we know to try coming at it from some different angles.

chuckd62687, et al, if no matter what you do you just can't resolve this issue, try Visual Hub after MTR. Or Handbrake 0.71 as indicated in the main "no audio" thread.

Post Reply