Audio settings don't get saved when saving a customized preset

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
intellogo
Posts: 2
Joined: Sun May 02, 2021 12:52 pm

Audio settings don't get saved when saving a customized preset

Post by intellogo »

Description of problem or question:
Audio settings don't get saved when saving a customized preset.
After selecting a specific default preset and then customizing the audio encode settings and then saving it seems to have saved it.
But, after loading the new custom preset, the Audio settings tab shows me blank settings for the Audio encode settings. Why is this so?


Steps to reproduce the problem (If Applicable):




HandBrake version (e.g., 1.0.0):
1.3.3


Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
macOS Big Sur version 11.2.3



HandBrake Activity Log ***required*** (see How-to get an activity log)
Will submit log on receiving your response, if its needed, as I'm assuming my query is not really a bug with the app.
I'm with the opinion that this my query is already perhaps known by someone on how to solve it rather than being a bug.

Code: Select all

Please replace this text with the contents of your log file between the two code tags - OR -  provide a pastebin URL in place of these 3 lines.
If you are unable to do so, please state why so we can help you.
Woodstock
Veteran User
Posts: 4102
Joined: Tue Aug 27, 2013 6:39 am

Re: Audio settings don't get saved when saving a customized preset

Post by Woodstock »

Presets save audio selection rules set in the "Defaults" box, not specific settings. You cannot say, "Pick track 4 and encode it as AAC 5.1", and expect that to "stick" for all videos processed. Sources are far too diverse and the selection rules are rather simplistic.
intellogo
Posts: 2
Joined: Sun May 02, 2021 12:52 pm

Re: Audio settings don't get saved when saving a customized preset

Post by intellogo »

Thanks for your response.
But, why is it so that specific audio settings, for example MP3 with bitrate 128 KB at 44.1 KHz with Stereo output settings, cannot be saved to the custom preset which anyway saves specific Video settings?
User avatar
Ritsuka
HandBrake Team
Posts: 1251
Joined: Fri Jan 12, 2007 11:29 am

Re: Audio settings don't get saved when saving a customized preset

Post by Ritsuka »

Because there is only one video track, but there can be N audio tracks and a preset should be able to adapt to different source files with different numbers and types of audio tracks. You can set the preferred audio format in the "Selection Behaviour" panel.
Woodstock
Veteran User
Posts: 4102
Joined: Tue Aug 27, 2013 6:39 am

Re: Audio settings don't get saved when saving a customized preset

Post by Woodstock »

If you are dealing with things like "10 episodes of TV series XYZZY", which have tracks of the same type and will have the same encoding,I prefer using the command line.
Ramroumtx
Regular User
Posts: 100
Joined: Tue Sep 08, 2015 5:23 pm

Re: Audio settings don't get saved when saving a customized preset

Post by Ramroumtx »

Ritsuka wrote: Sun May 02, 2021 4:52 pm Because there is only one video track, but there can be N audio tracks and a preset should be able to adapt to different source files with different numbers and types of audio tracks. You can set the preferred audio format in the "Selection Behaviour" panel.
How can I do this in selection behavior? I am having the same problem. I have to set the audio every time and my audio come out blank if I don't go in there and change it.
Post Reply