Struggling with subtitles

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
jmalkows
Posts: 3
Joined: Fri Jan 08, 2021 9:35 pm

Struggling with subtitles

Post by jmalkows »

Description of problem or question:
I'm a longtime Handbrake for Mac user, but recently got a new Macbook Pro and redownloaded a newer version of the program. I'm attempting to burn from a DVD and burn in English subtitles, which I've done dozens of times with the previous Handbrake version I had. For some reason, none of the configurations of subtitle settings I've tried have actually produced visible subtitles on the video file Handbrake creates. It's essential that I be able to get subtitles on the file for accessibility reasons. To complicate matters, this DVD has about 15 subtitle tracks, including half a dozen in English (the language I need). Many thanks if you're able to help!



Steps to reproduce the problem (If Applicable):
I've tried about 6 or 7 different configurations of subtitle settings, Googled for an answer, read the Handbrake documentation on subtitles, and searched the community forum. (Hopefully the activity log I linked below works! That's a new process to me)



HandBrake version (e.g., 1.0.0):
Version 1.3.3 (2020061300)



Operating system and version (e.g., Ubuntu 16.04 LTS, macOS 10.13 High Sierra, Windows 10 Creators Update):
Mac OS Catalina version 10.15.7 (19H114)



HandBrake Activity Log ***required*** (see How-to get an activity log)

Code: Select all

https://pastebin.com/29gYy5DZ
Woodstock
Veteran User
Posts: 3937
Joined: Tue Aug 27, 2013 6:39 am

Re: Struggling with subtitles

Post by Woodstock »

Code: Select all

[15:56:03] Subtitle track 0 (id 0x20bd) 'English Closed Caption (Wide Screen) [VOBSUB]': 72 hits (0 forced)
[15:56:03] Subtitle track 1 (id 0x21bd) 'English Closed Caption (Letterbox) [VOBSUB]': 72 hits (0 forced)
[15:56:03] Subtitle track 6 (id 0x26bd) 'English Forced (Wide Screen) [VOBSUB]': 1 hits (0 forced)
[15:56:03] Subtitle track 7 (id 0x27bd) 'English Forced (Letterbox) [VOBSUB]': 1 hits (0 forced)
[15:56:03] Found a subtitle candidate with id 0x26bd
You've selected to do a foreign audio scan, forced only subtitles, and it found a track that had ONE subtitle in it. That track is being uses.

If you are not using English audio, you should not use the Foreign Audio Scan, and should select one of the English tracks manually.
User avatar
Rodeo
HandBrake Team
Posts: 12677
Joined: Tue Mar 03, 2009 8:55 pm

Re: Struggling with subtitles

Post by Rodeo »

Foreign Audio Search is also quite unreliable over a single chapter.
jmalkows
Posts: 3
Joined: Fri Jan 08, 2021 9:35 pm

Re: Struggling with subtitles

Post by jmalkows »

Thanks for these suggestions, all. I've tried removing the foreign audio search altogether and configuring the settings to just burn in the "English (Wide Screen)" track on a different disk for a chapter that I'm pretty sure has no foreign audio content, but I'm still getting a video file at the end without subtitles. Here's the activity log: https://pastebin.com/UmzN6xT3
User avatar
Rodeo
HandBrake Team
Posts: 12677
Joined: Tue Mar 03, 2009 8:55 pm

Re: Struggling with subtitles

Post by Rodeo »

Uncheck the forced-only box.
jmalkows
Posts: 3
Joined: Fri Jan 08, 2021 9:35 pm

Re: Struggling with subtitles

Post by jmalkows »

Ah, it was the "forced only" check that was the problem, you're right! Thanks so much for your help.
Post Reply