Subtitles not transferring

HandBrake for Mac support
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
bilitone
Posts: 2
Joined: Thu Jul 30, 2020 10:47 pm

Subtitles not transferring

Post by bilitone »

Hi
I should say up front that I’m not a very technical person, but I do get around Final Cut without much problem. Pastebin log below.
I’m doing some work for a theatre company, who wants me to extract some scenes from their DVDs in order to offer some visibility, promotion, and entertainment during this difficult time of sheltering-in-place (All theatre companies are suffering at this time, and are trying any way they can to stay alive.)

The recorded performances (DVDs and with more recent videos, Blu-Rays) have subtitles which we need to extract along with the video footage. Since I work on a Mac, I, of course, use the Mac version of Handbrake. In the subtitles tab of Handbrake, I see some features on posted screenshots of the Windows version which I do not see in the Mac version. Specifically, in the drop-down menu under Track, the options are

[None]
[Foreign audio search]
and [0 unknown (VOBSUB)]

There is no [1 English (4:3) (VOBSUB)
Over to the right, under Language, it is grayed out. There is not an option to choose a language there.
When I attempt to extract subtitles (choosing [0 unknown (VOBSUB)], since I cannot choose English), the results are unreadable.
I have read in these forums and others, that there may be an issue that should be rectified in the Char Code dropdown menu. However, the Mac version does not have a Char Code dropdown menu (not on my computer, anyway).
See screenshot below to illustrate, although the Track dropdown won’t stay dropped down in a screenshot, so you’ll have to take my word for the above).
Is there something I’m missing, or is there a current issue with the Mac version of Handbrake that I’ll have to wait to fix?
thanks for your patience,
bilitone

https://pastebin.com/6ZNWtkUm

https://www.dropbox.com/s/5p6pqb8fhfd7c ... 2.png?dl=0

User avatar
BradleyS
Moderator
Posts: 1859
Joined: Thu Aug 09, 2007 12:16 pm

Re: Subtitles not transferring

Post by BradleyS »

Split into new topic.

User avatar
BradleyS
Moderator
Posts: 1859
Joined: Thu Aug 09, 2007 12:16 pm

Re: Subtitles not transferring

Post by BradleyS »

At first glance it seems your settings files may be corrupted. See the section on clearing your HandBrake configuration data here: https://handbrake.fr/docs/en/1.3.0/help ... stem-macos

Note you will need to recreate any custom presets you have saved previously.

User avatar
Ritsuka
HandBrake Team
Posts: 1152
Joined: Fri Jan 12, 2007 11:29 am

Re: Subtitles not transferring

Post by Ritsuka »

Try to select the VIDEO_TS folder or the parent folder. A single VOB does not contain enough tracks info.

bilitone
Posts: 2
Joined: Thu Jul 30, 2020 10:47 pm

Re: Subtitles not transferring

Post by bilitone »

Hi Ritsuka,
This was the solution. I just assumed that if I extracted sections of the DVD, the subtitles would also be extracted,
but it was necessary to select the parent folder.
thanks much,
bilitone

Post Reply