faad2 fails to compile with libtool > 2.2 [comitted]

Archive of historical development discussions
Discussions / Development has moved to GitHub
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Post Reply
saintdev
Regular User
Posts: 146
Joined: Wed Dec 20, 2006 4:17 am

faad2 fails to compile with libtool > 2.2 [comitted]

Post by saintdev »

If you attempt to compile faad2 with libtool 2.2 you get the following:

Code: Select all

...found 353 target(s)...
...updating 2 target(s)...
LibFaad2 contrib/lib/libfaad.a
configure.in:14: installing `./config.guess'
configure.in:14: installing `./config.sub'
configure.in:12: installing `./install-sh'
configure.in:12: installing `./missing'
common/mp4ff/Makefile.am: installing `./depcomp'
/usr/share/automake-1.10/am/depend2.am: am__fastdepCXX does not appear in AM_CONDITIONAL
/usr/share/automake-1.10/am/depend2.am:   The usual way to define `am__fastdepCXX' is to add `AC_PROG_CXX'
/usr/share/automake-1.10/am/depend2.am:   to `configure.in' and run `aclocal' and `autoconf' again.
plugins/mpeg4ip/Makefile.am: C++ source seen but `CXX' is undefined
plugins/mpeg4ip/Makefile.am:   The usual way to define `CXX' is to add `AC_PROG_CXX'
plugins/mpeg4ip/Makefile.am:   to `configure.in' and run `autoconf' again.
Makefile.am: installing `./INSTALL'

    cd `dirname contrib/faad2.tar.gz` && CONTRIB=`pwd` &&
    rm -rf faad2 && (gzip -dc faad2.tar.gz | tar xf -) &&
    cd faad2 &&
    ./bootstrap && ./configure --prefix=$CONTRIB --cache-file=$CONTRIB/config.cache --disable-shared && make && make install

...failed LibFaad2 contrib/lib/libfaad.a ...
...skipped HandBrakeCLI for lack of contrib/lib/libfaad.a...
...failed updating 1 target(s)...
...skipped 1 target(s)...
Here's a patch to fix this. It uses the same patch that gentoo uses to build faad2. While it shouldn't hurt anything. As with any build system changes I would like to get OKs from all the arches before I commit.

Patch is here: http://handbrake.pastebin.ca/1045720
Last edited by saintdev on Wed Jun 18, 2008 1:15 am, edited 1 time in total.
User avatar
JohnAStebbins
HandBrake Team
Posts: 5583
Joined: Sat Feb 09, 2008 7:21 pm

Re: faad2 fails to compile with libtool > 2.2

Post by JohnAStebbins »

I've validated that this works for me. Using libtool 1.5.24. So you didn't break older stuff.
Post Reply