Linux build

Archive of historical development discussions
Discussions / Development has moved to GitHub
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Post Reply
woodmeister
Posts: 4
Joined: Tue Feb 20, 2007 1:08 pm

Linux build

Post by woodmeister »

I cannot get current svn versions of handbrake/mediafork to build correctly on linux. They always stop at the ipodutill.cpp file complaining that mp4.h cannot be found. I have tried both ./configure followed by jam, and followed by make. I realise that you prefer people to use binaries but I'm trying to encode x264b30 for my ipod, and i can't use beta 1 due to the aspect ratio bug.

thanks
mark
one01
Posts: 7
Joined: Thu Jan 11, 2007 3:18 am

Post by one01 »

I am also encountering the same problem. The issue is caused because libmp4v2 (located in contrib/mpeg4ip/) is not being built during compliation because of certain dependency issues.

First, I had to install the SDL development libraries. That solved one dependancy problem.

I now get:

Code: Select all

Error - we have detected a version of faac that has libmp4v2 support
and no copy of mpeg4ip-config.  This means faac was built with
faad2 and the libraries will be incompatible.
Please reinstall faac without mp4v2 support

    	cd `dirname contrib/mpeg4ip.tar.gz` && CONTRIB=`pwd` &&
    	rm -rf mpeg4ip && tar xzf mpeg4ip.tar.gz && cd mpeg4ip &&
    	./bootstrap && make -C lib/mp4v2 libmp4v2.la &&
    	cp lib/mp4v2/.libs/libmp4v2.a $CONTRIB/lib &&
    	cp mpeg4ip_config.h include/mpeg4ip.h include/mpeg4ip_version.h \
      	include/mpeg4ip_win32.h lib/mp4v2/*.h $CONTRIB/include &&
    	strip -S $CONTRIB/lib/libmp4v2.a
	
...failed LibMp4v2 contrib/lib/libmp4v2.a ...
I am using Fedora Core 6 and have the distribution's faac and faad packages installed. I noticed that MediaFork builds it's own version of the faac library. Could the faac package that I already have installed be overriding the library compiled by MediaFork and causing conflicts?
saintdev
Regular User
Posts: 146
Joined: Wed Dec 20, 2006 4:17 am

Post by saintdev »

one01 is correct. The check that mpeg4ip uses is amis. It ends up detecting your installed copy of faac instead of the copy that just got built by HandBrake's jam. I have a patch at home that removes the check all together, that I'll post for you to use. However, this could potentially break something (although I doubt it, as the Gentoo ebuild does the same thing when it builds libmp4v2), so apply it at your own discresion.
Last edited by saintdev on Mon Mar 05, 2007 1:39 am, edited 1 time in total.
saintdev
Regular User
Posts: 146
Joined: Wed Dec 20, 2006 4:17 am

Post by saintdev »

MaxB51
Posts: 2
Joined: Tue Sep 11, 2007 8:27 am

Post by MaxB51 »

Hi,

I have the same compile problem with v. 0.9.0


MaxB51
eddyg
Veteran User
Posts: 798
Joined: Mon Apr 23, 2007 3:34 am

Post by eddyg »

MaxB51 wrote:Hi,

I have the same compile problem with v. 0.9.0


MaxB51
It does compile fine on a fresh ubunto feisty install with just libz installed.

Therefore any issues are likely to be related to what libraries you have installed and whether HB is trying to use those instead of its own.

It's hard for us to debug that remotely, so maybe you could debug it and send us a patch for what is wrong in the Jamfile or makefiles?

Cheers, Ed.
MaxB51
Posts: 2
Joined: Tue Sep 11, 2007 8:27 am

Post by MaxB51 »

eddyg wrote:
MaxB51 wrote:Hi,

I have the same compile problem with v. 0.9.0


MaxB51
It does compile fine on a fresh ubunto feisty install with just libz installed.

Therefore any issues are likely to be related to what libraries you have installed and whether HB is trying to use those instead of its own.

It's hard for us to debug that remotely, so maybe you could debug it and send us a patch for what is wrong in the Jamfile or makefiles?

Cheers, Ed.

Hi,

I followed the same path of precedent patch...

1) apply the patch handbrake-svn417-libmp4v2-configure.patch that produce the patch_mpeg4ip_faac.patch file.

2) change the line 205 of contrib/Jamfile from:

patch -p1 < ../patch-mpeg4ip.patch && patch -p0 < ../patch-mpeg4ip-pascal-str.patch &&

to:

patch -p1 < ../patch-mpeg4ip.patch && patch -p1 < patch_mpeg4ip_faac.patch && patch -p0 < ../patch-mpeg4ip-pascal-str.patch &&


so it's works...

Bye,

Max
th3rmite
Posts: 27
Joined: Sun Sep 16, 2007 6:27 pm

stderr

Post by th3rmite »

The linux binary on the download page outputs on stderr instead of stdout. If I compiled the svn version would it do the same?
saintdev
Regular User
Posts: 146
Joined: Wed Dec 20, 2006 4:17 am

Re: stderr

Post by saintdev »

th3rmite wrote:The linux binary on the download page outputs on stderr instead of stdout. If I compiled the svn version would it do the same?
yes
th3rmite
Posts: 27
Joined: Sun Sep 16, 2007 6:27 pm

Post by th3rmite »

@saintdev

Any reason why?
saintdev
Regular User
Posts: 146
Joined: Wed Dec 20, 2006 4:17 am

Post by saintdev »

th3rmite wrote:@saintdev

Any reason why?
Because that's the way titer coded it, and we haven't wanted to change it.
th3rmite
Posts: 27
Joined: Sun Sep 16, 2007 6:27 pm

Post by th3rmite »

okey dokey
Post Reply