pkg-config lying to me?

Archive of historical development discussions
Discussions / Development has moved to GitHub
Post Reply
augy
Posts: 1
Joined: Wed Feb 03, 2016 5:02 pm

pkg-config lying to me?

Post by augy » Wed Feb 03, 2016 5:13 pm

Trying to get handbrake building on my raspberry pi:

Code: Select all

HandBrake@pi $ uname -a
Linux raspberrypi 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux
When I run this:

Code: Select all

./configure --launch --disable-gtk --force --enable-local-autotools
or this (note no local-autotools):

Code: Select all

./configure --launch --disable-gtk --force
... i get...

Code: Select all

   ....
  : checking pkg-config is at least version 0.9.0... yes
  : checking for LIBXML2... no
  : configure: error: Package requirements (libxml-2.0 >= 2.6) were not met:
  : 
  : No package 'libxml-2.0' found
  : 
  : Consider adjusting the PKG_CONFIG_PATH environment variable if you
  : installed software in a non-standard prefix.
  : 
  : Alternatively, you may set the environment variables LIBXML2_CFLAGS
  : and LIBXML2_LIBS to avoid the need to call pkg-config.
  : See the pkg-config man page for more details.
  : ../contrib/libbluray/module.rules:2: recipe for target 'contrib/libbluray/.stamp.configure' failed
  : make: *** [contrib/libbluray/.stamp.configure] Error 1
-------------------------------------------------------------------------------
time end: Wed Feb  3 08:56:24 2016
duration: 19 seconds (19.82s)
result: FAILURE (code 2)
-------------------------------------------------------------------------------
Build is finished!
You may now cd into ./build and examine the output.
HandBrake@pi $ if pkg-config --exists 'libxml-2.0 >= 2.6'; then echo OK ; else echo NOK ; fi
OK
HandBrake@pi $ 
As you can see from the pkg-config command issued above, I DO have a libxml-2.0 that is recent enough, yet the configure script complains anyway.

I've tried adding the path to the package directly:

Code: Select all

PKG_CONFIG_PATH="/usr/lib/arm-linux-gnueabihf/pkgconfig" bash -c "./configure --launch --disable-gtk --force"
no joy. I don't need bluray support. I'm happy to disable it if there's a config flag for it, though I think I'd rather figure out what's really going on with pkg-config. Any help appreciated.

Thanks!

Post Reply