Page 1 of 1

Missing libdts in latest cygwin contribbin?

Posted: Sun Sep 02, 2007 10:31 pm
by Lant
I was trying to build the latest version of handbrake and after my usual changes of "CYGWIN_NT-5.1" to "CYGWIN_NT-6.0-WOW64", I got the following error:

ranlib: 'lib/libdts.a': No such file
make: *** [app] Error 1

in \contrib\lib\ there was a libdts.a but it was a shortcut to "/home/Scott/pack/contrib/lib/libdca.a"

So I'm just assuming that libdts is missing from this contribbin.

Posted: Tue Sep 04, 2007 7:51 pm
by s55
libdts is not used anymore, should compile just fine. libdts.a shortcut will be removed from the next pack.

Just out of interest, where exactly did you get cygwin 6 from?

Posted: Tue Sep 04, 2007 8:48 pm
by Lant
Theres not a version change :D .On Vista x64 it identifies as 6.0-WOW64 instead of 5.1 so for it to properly detect that I am using windows I need to change that.

Anyway the reason I posed this in the first place was because I got an error when running "make HandbrakeCLI":

$ make HandbrakeCLI
Getting contribs ()...
--21:45:13-- ... 011.tar.gz
=> `contribbin-cygwin-0011.tar.gz'
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2,686,501 (2.6M) [application/octet-stream]

100%[============================================================================>] 2,686,501 453.02K/s ETA 00:00

21:45:22 (432.65 KB/s) - `contribbin-cygwin-0011.tar.gz' saved [2686501/2686501]

ranlib: 'lib/libdts.a': No such file
make: *** [app] Error 1

Although after finally compiling jam I was able to jam HB.

Posted: Tue Sep 04, 2007 8:58 pm
by s55
yeh, jam would work. Do you still get the error now with make?

Needs to be a clean checkout.

Posted: Tue Sep 04, 2007 9:21 pm
by Lant
Nope did a clean checkout and I'm still getting the error.

Posted: Tue Sep 04, 2007 10:03 pm
by s55
Ok will look into it when I get a chance.

Posted: Wed Sep 05, 2007 9:34 am
by Lant

Posted: Fri Sep 14, 2007 7:09 pm
by Lant
Just like to point out that I still have this problem on rev 964

Posted: Fri Sep 14, 2007 11:29 pm
by s55
yes, its not been fixed yet.

A new contrib pack is needing built due to updated libaries but i'm on holiday atm so it'll be 2 weeks b4 i get a chance to update it.

If you have a dualcore system you can use jam -j 2
to speed up the compile as it is.

Posted: Sat Sep 15, 2007 7:39 am
by Lant
Thanks for that tip. And enjoy your holiday.

Posted: Sat Sep 22, 2007 4:25 pm
by s55
Should be fixed in rev 978
Let me know if that new contrib pack works. Make sure you test on a clean checkout

Posted: Sat Sep 22, 2007 7:56 pm
by Lant
Worked fine - on updating an existing checkout as well.
Thanks a lot for this.