HB compile fails until libfaac.a is resolved

Archive of historical development discussions
Discussions / Development has moved to GitHub
Forum rules
*******************************
Please be aware we are now using GitHub for issue tracking and feature requests.
- This section of the forum is now closed to new topics.

*******************************
Post Reply
thrasher
Posts: 1
Joined: Thu Oct 26, 2006 12:10 am

HB compile fails until libfaac.a is resolved

Post by thrasher »

Guys, thanks for picking this project up, and hosting the forums. While doing a fresh compile from SVN today I ran into a compile bug, and resolution that I thought would be helpful for others.

Got this message at the end of clean v70 SVN checkout and build:

<snip>
...skipped HBTest for lack of contrib/lib/libfaac.a...
...failed updating 1 target(s)...
...skipped 1 target(s)...
...updated 55 target(s)...

So, I copied my local version used for ffmpeg builds to HandBrake/contrib/lib as:

cp /usr/lib/libfaac.a contrib/lib/.

Then when I ran 'configure && jam' it worked:

[root@***** HandBrake]# ./configure && jam
System: Linux
Endian: little
To build HandBrake, run 'jam'.
...found 254 target(s)...
...updating 1 target(s)...
Link HBTest
Chmod1 HBTest
...updated 1 target(s)...
[root@***** HandBrake]# find . -name HBTest
./HBTest

Hopefully someone will find this useful.
-Jason

Post Reply