Encode in Full Range

Archive of historical feature requests.
Please use the GitHub link above to report issues.
Forum rules
*******************************

Please be aware we are now using GitHub for issue tracking and feature requests.

- This forum is now closed to new topics.
- Existing topics will remain open for a short while as the transition over occurs.
*******************************
Post Reply
Bryman
Posts: 2
Joined: Mon Jan 23, 2017 5:57 pm

Encode in Full Range

Post by Bryman » Mon Jan 23, 2017 6:08 pm

Please describe what you would like to see added to HandBrake:

The option to encode in Full Range, because currently it encodes in limited range (blacks aren't truly black and whites aren't truly white)
Why would you like to see this added:

Because the videos I encode don't look great in limited range colors... I would like to be able to encode in real-time with a different program with ultrafast so the video is smooth (which has the option to encode in full range) and then reencode with a stronger compression (like veryfast-medium) with Handbrake in full range... there's probably a x264 command for that (which I don't know) But it would be nice to have an option to just tick "Encode in full range"
What version of HandBrake are you currently running:
1.0.2
What operating system and version and you currently running (e.g. OSX 10.11, Windows 7, Ubuntu 14):

Windows 7 Home Premium SP1

musicvid
Veteran User
Posts: 3165
Joined: Sat Jun 27, 2009 1:19 am

Re: Encode in Full Range

Post by musicvid » Tue Jan 24, 2017 1:16 pm

Handbrake codecs are 709 not RGB
If the output plays flat, turn OFF Dynamic Contrast at your video drivers, monitor, teevee, and hardware players and leave them off. The levels are correct, contingent on correct source input levels and decoding flags, of course.

Here's some common mistakes for you to chew on:
viewtopic.php?f=14&t=33111

If you want support for your issue, post full logs in the relevant forum.

Bryman
Posts: 2
Joined: Mon Jan 23, 2017 5:57 pm

Re: Encode in Full Range

Post by Bryman » Tue Jan 24, 2017 9:33 pm

Thank you very much

I disabled "Use hardware YUV>RGB conversions" in VLC and it fixed it

musicvid
Veteran User
Posts: 3165
Joined: Sat Jun 27, 2009 1:19 am

Re: Encode in Full Range

Post by musicvid » Fri Jan 27, 2017 11:06 am

Yup.

Post Reply