HandbrakeCLI 0.9.8 PowerPC Mac OS X Leopard 10.5.8

Random chit-chat and anything that doesn't belong elsewhere
Post Reply
cvk_b
Veteran User
Posts: 527
Joined: Sun Mar 18, 2007 2:11 am

HandbrakeCLI 0.9.8 PowerPC Mac OS X Leopard 10.5.8

Post by cvk_b »

Posted in Tiki Bar because this is just silly.
    Obviously, not official, not supported, not tested. Build log included.

    SHA1:

    Code: Select all

    60b68885b417f07c96e8ed5332bf8ba166489be0
    Here's a log file from a quick run showing modern CLI features...

    Code: Select all

    [14:44:58] hb_init: starting libhb thread
    HandBrake 0.9.8 (2012080800) - Darwin ppc - http://handbrake.fr
    2 CPUs detected
    Opening /Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv...
    [14:44:58] hb_scan: path=/Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv, title_index=1
    libbluray/bdnav/index_parse.c:157: indx_parse(): error opening /Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv/BDMV/index.bdmv
    libbluray/bluray.c:1471: nav_get_title_list(/Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv) failed (0x1807a00)
    [14:44:58] bd: not a bd - trying as a stream/file instead
    libdvdnav: Using dvdnav version 4.1.3
    libdvdread: Encrypted DVD support unavailable.
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
    libdvdread: Can't open file VIDEO_TS.IFO.
    libdvdnav: vm: failed to read VIDEO_TS.IFO
    [14:44:58] dvd: not a dvd - trying as a stream/file instead
    Input #0, matroska,webm, from '/Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv':
      Duration: 01:50:46.65, start: 0.000000, bitrate: 896 kb/s
        Stream #0.0(eng): Video: h264 (High), yuv420p, 1280x720, PAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
        Stream #0.1: Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s (default)
        Stream #0.2: Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s
        Stream #0.3: Subtitle: [0][0][0][0] / 0x0000 (default)
    [14:44:58] scan: decoding previews for title 1
    [14:44:58] scan: audio 0x1: AC-3, rate=48000Hz, bitrate=448000 Unknown (AC3) (5.1 ch)
    [14:44:58] scan: audio 0x2: AC-3, rate=48000Hz, bitrate=448000 Unknown (AC3) (5.1 ch)
    Scanning title 1...
    Scanning title 1...
    Scanning title 1...
    Scanning title 1...
    [14:44:59] scan: 10 previews, 1280x720, 23.976 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
    [14:44:59] scan: title (0) job->width:1280, job->height:720
    [14:44:59] libhb: scan thread found 1 valid title(s)
    + title 1:
      + stream: /Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv
      + duration: 01:50:46
      + size: 1280x720, pixel aspect: 1/1, display aspect: 1.78, 23.976 fps
      + autocrop: 0/0/0/0
      + chapters:
        + 1: cells 0->0, 0 blocks, duration 01:50:46
      + audio tracks:
        + 1, Unknown (AC3) (5.1 ch) (iso639-2: und), 48000Hz, 448000bps
        + 2, Unknown (AC3) (5.1 ch) (iso639-2: und), 48000Hz, 448000bps
      + subtitle tracks:
        + 1, Unknown (iso639-2: und) (Text)(UTF-8)
    [14:44:59] 1 job(s) to process
    [14:44:59] starting job
    [14:44:59] Width out of bounds, scaling down to 624
    [14:44:59] New dimensions 624 * 352
    [14:44:59] work: mixdown not specified, track 1 setting mixdown Dolby Pro Logic II
    [14:44:59] work: bitrate not specified, track 1 setting bitrate 64
    [14:44:59] sync: expecting 311 video frames
    [14:44:59] job configuration:
    [14:44:59]  * source
    [14:44:59]    + /Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv
    [14:44:59]    + title 1, frames 0 to 300
    [14:44:59]    + container: matroska,webm
    [14:44:59]    + data rate: 896 kbps
    [14:44:59]  * destination
    [14:44:59]    + /Volumes/c1bin330avi/xbmc-new/sample.HE-AAC.mkv
    [14:44:59]    + container: Matroska (.mkv)
    [14:44:59]  * video track
    [14:44:59]    + decoder: h264
    [14:44:59]    + frame rate: same as source (around 23.976 fps)
    [14:44:59]    + dimensions: 1280 * 720 -> 624 * 352, crop 0/0/0/0, mod 0
    [14:44:59]    + encoder: H.264 (x264)
    [14:44:59]      + x264 preset: ultrafast
    [14:44:59]      + x264 tune: animation,fastdecode
    [14:44:59]      + options: vbv-maxrate=9500:vbv-bufsize=9500:stats=/Volumes/c2bin90mkv/cli.x264:pass=1
    [14:44:59]      + quality: 20.00 (RF)
    [14:44:59]  * subtitle track 3, Unknown (id 0x3) Text [UTF-8] -> Pass-Through
    [14:44:59]  * audio track 1
    [14:44:59]    + decoder: Unknown (AC3) (5.1 ch) (track 1, id 0x1)
    [14:44:59]      + bitrate: 448 kbps, samplerate: 48000 Hz
    [14:44:59]    + mixdown: Dolby Pro Logic II
    [14:44:59]    + encoder: HE-AAC (CoreAudio)
    [14:44:59]      + bitrate: 64 kbps, samplerate: 48000 Hz
    [14:45:00] reader: first SCR 54080280 id 0x0 DTS 54080280
    [14:45:00] encx264: min-keyint: 24, keyint: 240
    [14:45:00] encx264: Encoding at constant RF 20.000000
    x264 [warning]: --psnr used with psy on: results will be invalid!
    x264 [warning]: --tune psnr should be used if attempting to benchmark psnr!
    x264 [info]: using cpu capabilities: Altivec
    x264 [info]: profile Main, level 3.0
    [14:45:10] sync: reached 301 frames, exiting early
    [14:45:10] work: average encoding speed for job is 30.769230 fps
    [14:45:10] reader: done. 1 scr changes
    [14:45:10] sync: got 301 frames, 311 expected
    [14:45:10] h264-decoder done: 330 frames, 0 decoder errors, 0 drops
    [14:45:10] render: lost time: 0 (0 frames)
    [14:45:10] render: gained time: 0 (0 frames) (0 not accounted for)
    x264 [info]: frame I:2     Avg QP:17.50  size: 53467  PSNR Mean Y:46.03 U:49.84 V:49.36 Avg:46.90 Global:46.65
    x264 [info]: frame P:100   Avg QP:16.72  size: 15767  PSNR Mean Y:46.06 U:49.32 V:48.81 Avg:46.79 Global:45.54
    x264 [info]: frame B:199   Avg QP:18.61  size:  1325  PSNR Mean Y:46.13 U:49.41 V:48.92 Avg:46.87 Global:45.63
    x264 [info]: consecutive B-frames:  0.7%  0.7% 98.7%
    x264 [info]: mb I  I16..4: 100.0%  0.0%  0.0%
    x264 [info]: mb P  I16..4:  3.5%  0.0%  0.0%  P16..4: 62.3%  0.0%  0.0%  0.0%  0.0%    skip:34.2%
    x264 [info]: mb B  I16..4:  0.0%  0.0%  0.0%  B16..8: 10.0%  0.0%  0.0%  direct:11.3%  skip:78.6%  L0:23.1% L1:63.6% BI:13.3%
    x264 [info]: coded y,uvDC,uvAC intra: 74.2% 58.6% 38.9% inter: 17.8% 10.7% 3.6%
    x264 [info]: i16 v,h,dc,p: 33% 27% 26% 14%
    x264 [info]: i8c dc,h,v,p: 47% 24% 25%  5%
    x264 [info]: SSIM Mean Y:0.9882956 (19.316db)
    x264 [info]: PSNR Mean Y:46.105 U:49.381 V:48.887 Avg:46.841 Global:45.604 kb/s:1241.48
    [14:45:10] mux: track 0, 301 frames, 1947333 bytes, 1095.35 kbps, fifo 512
    [14:45:10] mux: track 1, 334 frames, 119667 bytes, 67.31 kbps, fifo 512
    [14:45:10] mux: track 2, 4 frames, 187 bytes, 0.11 kbps, fifo 8
    [14:45:10] libhb: work result = 0
    
    Encode done!
    HandBrake has exited.
    
    real	0m12.713s
    user	0m19.402s
    sys	0m1.099s
    
    /Users/areLosers/pineapplecli/workingcopies/98/./HandBrakeCLI -i /Volumes/c1bin330avi/xbmc-new/TestFolder/SomethingWorthWatching.mkv -o /Volumes/c1bin330avi/xbmc-new/sample.HE-AAC.mkv --start-at-preview=3 --stop-at=frame:300 --verbose=1 --aencoder=ca_haac -s 1 --x264-preset=ultrafast --x264-tune=animation,fastdecode --maxWidth=624 --encoder=x264 --quality=20 -x vbv-maxrate=9500:vbv-bufsize=9500:stats=/Volumes/c2bin90mkv/cli.x264:pass=1
    Last edited by cvk_b on Wed Aug 08, 2012 10:02 pm, edited 1 time in total.
    Reason: As suggested by a dev, a correctly tagged 0.9.8 version.
    Smithcraft
    Veteran User
    Posts: 2693
    Joined: Thu Jan 22, 2009 8:04 pm

    Re: HandbrakeCLI 0.9.8 PowerPC Mac OS X Leopard 10.5.8

    Post by Smithcraft »

    I'm gonna have to try this!

    SC
    Post Reply