Known list of dependencies for 9.3?

Support for HandBrake on Linux, Solaris, and other Unix-like platforms
Forum rules
An Activity Log is required for support requests. Please read How-to get an activity log? for details on how and why this should be provided.
Post Reply
jeffcobb
Posts: 31
Joined: Thu Jan 15, 2009 3:33 am

Known list of dependencies for 9.3?

Post by jeffcobb »

I am building HandBrake from source on a few different Nix platforms and while it is building nicely on some, libxvidcore is failing on others and I have not yet sorted out why. I have noted a few other new dependencies since 9.2 so I wondered if there were any known lists of 9.2-9.3 dependency changes...

Jeff
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Re: Known list of dependencies for 9.3?

Post by jbrjake »

Every single time someone has claimed libxvid is not building they have been wrong.

You are almost certainly not thoroughly reading the build log....which you have, inexplicably, not shared.
jeffcobb
Posts: 31
Joined: Thu Jan 15, 2009 3:33 am

Re: Known list of dependencies for 9.3?

Post by jeffcobb »

Forgive me for not being clearer; I was not really looking for tech support, only advisory data; for example from 9.2->9.3 we also acquired a dependency on libbz2-dev; I was simply asking if there was a list of known external dependencies not satisfied by some stage of the Jam file execution. Since I provision a number of machines for HandBrake its handy to have a script to make sure all external tools and libraries are satisfied before building HandBrake itself.

Hope this clears things up.

Jeff
jbrjake
Veteran User
Posts: 4805
Joined: Wed Dec 13, 2006 1:38 am

Re: Known list of dependencies for 9.3?

Post by jbrjake »

...still waiting for a build log...
jeffcobb
Posts: 31
Joined: Thu Jan 15, 2009 3:33 am

Re: Known list of dependencies for 9.3?

Post by jeffcobb »

This is not a tech support request only a build dependency list request but if you want to see 9.3 failing to build thats not hard at all. Here is Debian Etch failing because it could not find a qualified assembler even though one is demonstrated to be there by the log:
jeff@cobb1:~/dev/svntest/dvdmetabase/HandBrake-0.9.3$ make
echo "#ifndef HB_BUILD" > libhb/hbversion.h
echo "#define HB_BUILD 2009011901" >> libhb/hbversion.h
echo "#endif" >> libhb/hbversion.h
echo "#ifndef HB_VERSION" >> libhb/hbversion.h
echo "#define HB_VERSION \"svnexported\"" >> libhb/hbversion.h
echo "#endif" >> libhb/hbversion.h
echo "#ifndef HB_APPCAST_URL" >> libhb/hbversion.h
echo "#define APPCAST_URL \"http://handbrake.fr/appcast_unstable.xml\"" >> libhb/hbversion.h
echo "#endif" >> libhb/hbversion.h
( cd .. ; ./configure ; cd contrib ; cp -f ../config.jam . ; jam )

System: Linux
Endian: little

Don't run configure by hand, make runs it automatically.

No, really. That's it. Just type 'make' and hit return.

You're supposed to be building with make, not jam.
If you were going to use jam--which you shouldn't--you'd run:
'./jam' on a Mac, or
'jam' on Linux or Windows

To make jam, boil fruit with sugar and an acid until pectins are released.

...found 59 target(s)...
...updating 1 target(s)...
LibX264 ./lib/libx264.a
patching file encoder/slicetype.c
Hunk #1 succeeded at 487 (offset 108 lines).
Found no assembler
Minimum version is yasm-0.6.1 or nasm-2.0
If you really want to compile without asm, configure with --disable-asm.

cd `dirname ./x264.tar.gz` && CONTRIB=`pwd` &&
rm -rf x264 && (gzip -dc x264.tar.gz | tar xf - ) &&
cd x264 && patch -p0 < ../patch-x264-idr.patch &&
bash ./configure --prefix=$CONTRIB --enable-pthread &&
make libx264.a && cp libx264.a $CONTRIB/lib/ && cp x264.h $CONTRIB/include/ && strip -S $CONTRIB/lib/libx264.a

...failed LibX264 ./lib/libx264.a ...
...failed updating 1 target(s)...
make[1]: *** [.contrib] Error 1
make: *** [contrib/.contrib] Error 2
jeff@cobb1:~/dev/svntest/dvdmetabase/HandBrake-0.9.3$ nasm -v
NASM version 2.06rc1 compiled on Jan 18 2009
jeff@cobb1:~/dev/svntest/dvdmetabase/HandBrake-0.9.3$

Leaving that aside though is there a list of dependencies that changed from 9.2 to 9.3? Thats what would be helpful.

Thanks!

Jeff
User avatar
s55
HandBrake Team
Posts: 9829
Joined: Sun Dec 24, 2006 1:05 pm

Re: Known list of dependencies for 9.3?

Post by s55 »

Found no assembler
x264 requires yasm 0.7 or above, not yasm 0.6 or nasm

Everything you need to know is in the compile guide.
User avatar
JohnAStebbins
HandBrake Team
Posts: 5583
Joined: Sat Feb 09, 2008 7:21 pm

Re: Known list of dependencies for 9.3?

Post by JohnAStebbins »

I thought I had already pointed you at our compile guide.
http://trac.handbrake.fr/wiki/CompileGu ... KUIonLinux

All the dependencies are there. There's no list of changed dependencies since none of us has had a need for such a list.
jeffcobb
Posts: 31
Joined: Thu Jan 15, 2009 3:33 am

Re: Known list of dependencies for 9.3?

Post by jeffcobb »

John, things are a little confusing here; please allow me to try to clear things up. First this has nothing at *all* to do with the GUI build which on my main development machine built without a hitch and I am having a ball with it.

My situation is this: I have 3 different machines here that I tend to run HandBrake on, a Debian Etch box, an Ubuntu 8.04 box and a bleeding-edge 8.10. The Etch box is basically just a scrap server, the 8.04 is a basic desktop and the 8.10 being my main dev box has just about every development library I can think of on it already for the other work I do. Last thing to note is all machines had HandBrake-0.9.2 installed via a provisioning script I have which assumes an APT-based box with no build tools at all pre-installed. The script installs the toolchain, jam and other things needed by HandBrake, then pulls the source and configures and builds that.

When I tried to build 0.9.3 with the same deps on the 8.10 box, the build failed because it needed libbz2-dev installed. Since 0.9.2 had built on this box within the past 2 weeks, this had to be a new dependency that 0.9.2 did not need. This is the kind of dependency I was referring to; now having added that to my script, at least on some machines it does a soup-to-nuts pull and build of handbrake for me. I made the leap that if there was one dependency there might be more, hence the question. I wasn't trying to get anyone to troubleshoot my install; thats my job or I will never learn anything.

But the GUI builds fine and I am not only using it to learn about some new HandBrake features but also learning the GtkBuilder stuff from the links you sent. Cheers.

Jeff
jeffcobb
Posts: 31
Joined: Thu Jan 15, 2009 3:33 am

Re: Known list of dependencies for 9.3?

Post by jeffcobb »

s55 wrote:
Found no assembler
x264 requires yasm 0.7 or above, not yasm 0.6 or nasm

Everything you need to know is in the compile guide.
Look at the bottom of the build log:nasm -v shows version 2.06.
TedJ
Veteran User
Posts: 5388
Joined: Wed Feb 20, 2008 11:25 pm

Re: Known list of dependencies for 9.3?

Post by TedJ »

Um, that should be yasm 0.7+ not nasm, as has already been pointed out.
jeffcobb
Posts: 31
Joined: Thu Jan 15, 2009 3:33 am

Re: Known list of dependencies for 9.3?

Post by jeffcobb »

My mistake; I went by this output:
Minimum version is yasm-0.6.1 or nasm-2.0

Will correct my install. Thank you for your patience.

Jeff
Post Reply